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Preface
Welcome to the Genesys Agent Scripting 7 Deployment Guide. This guide 
describes system requirements, installation of the Genesys Agent Scripting 
application, installation of supporting applications, and Genesys Agent 
Scripting Collaboration mode.

This guide is valid only for the 7.x release of this product. 

This chapter provides an overview of this guide, identifies the primary 
audience, introduces document conventions, lists related reference 
information, and so on: 
 “Intended Audience” on page 8
 “Document Conventions” on page 8
 “Chapter Summaries” on page 10
 “Related Resources” on page 10
 “Making Comments on This Document” on page 11
 “Contacting Genesys Technical Support” on page 12
 “Document Change History” on page 12

Genesys Agent Scripting is a development tool that enables you to create and 
maintain browser-based web applications called “agent scripts.” An agent 
script guides agents through an effective customer interaction flow and helps 
them complete a structured business process. 

Agent scripts provide many benefits. A script ensures the quality of the 
interaction, adds structure and clarity to the definition of the process, integrates 
data access and data entry capabilities, maximizes the probability of success, 
and minimizes the training required by the agent. Genesys Agent Scripting 
assists in constructing the interfaces to other back office systems.
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Preface Intended Audience

Intended Audience
This guide is primarily intended for system administrators or script developers. 
It is also intended for contact center agents who will install and use Genesys 
Agent Scripting. The guide assumes that you have a basic understanding of:

• CTI concepts, processes, terminology, and applications.

• Network design and operation.

• Your own network configurations.

You should also be familiar with:

• Scripting using Active Server Pages (ASPs) or Java Server Pages (JSPs).

• Apache Tomcat 4.1, 5.0, 5.5; or Microsoft IIS 5.0 or 6.0 web servers.

• HTML editing.

Document Conventions
This document uses certain stylistic and typographical conventions—
introduced here—that serve as shorthands for particular kinds of information.

Document Version Number

A version number appears at the bottom of the inside front cover of this 
document. Version numbers change as new information is added to this 
document. Here is a sample version number:

80fr_ref_06-2008_v8.0.001.00 

You will need this number when you are talking with Genesys Technical 
Support about this product.

Screen Captures Used in This Document

Screen captures from the product graphical user interface (GUI), as used in this 
document, may sometimes contain minor spelling, capitalization, or 
grammatical errors. The text accompanying and explaining the screen captures 
corrects such errors except when such a correction would prevent you from 
installing, configuring, or successfully using the product. For example, if the 
name of an option contains a usage error, the name would be presented exactly 
as it appears in the product GUI; the error would not be corrected in any 
accompanying text.
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Type Styles

Table 1 describes and illustrates the type conventions that are used in this 
document.

Table 1: Type Styles

Type Style Used For Examples

Italic • Document titles

• Emphasis

• Definitions of (or first references to) 
unfamiliar terms

• Mathematical variables

Also used to indicate placeholder text within 
code samples or commands, in the special case 
where angle brackets are a required part of the 
syntax (see the note about angle brackets on 
page 10).

Please consult the Genesys Migration 
Guide for more information.

Do not use this value for this option.

A customary and usual practice is one 
that is widely accepted and used within a 
particular industry or profession.

The formula, x +1 = 7 
where x stands for . . .

Monospace 
font

(Looks like 
teletype or 
typewriter 
text)

All programming identifiers and GUI 
elements. This convention includes:

• The names of directories, files, folders, 
configuration objects, paths, scripts, dialog 
boxes, options, fields, text and list boxes, 
operational modes, all buttons (including 
radio buttons), check boxes, commands, 
tabs, CTI events, and error messages.

• The values of options.

• Logical arguments and command syntax.

• Code samples.

Also used for any text that users must 
manually enter during a configuration or 
installation procedure, or on a command line.

Select the Show variables on screen 
check box.

In the Operand text box, enter your 
formula.

Click OK to exit the Properties dialog 
box.

T-Server distributes the error messages in 
EventError events.

If you select true for the inbound-bsns-
calls option, all established inbound 
calls on a local agent are considered 
business calls.

Enter exit on the command line.

Square 
brackets ([ ])

A particular parameter or value that is optional 
within a logical argument, a command, or 
some programming syntax. That is, the 
presence of the parameter or value is not 
required to resolve the argument, command, or 
block of code. The user decides whether to 
include this optional information.

smcp_server -host [/flags]
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Preface Chapter Summaries

Chapter Summaries
In addition to this opening chapter, this guide contains these chapters:

• Chapter 1, “Overview of Genesys Agent Scripting” on page 13, introduces 
the major components, key features, and benefits of this release of the 
Genesys Agent Scripting application.

• Chapter 2, “System Requirements” on page 17, describes the minimum 
system and software requirements for installing and using this product.

• Chapter 3, “Installing Genesys Agent Scripting” on page 29, provides 
basic installation instructions for this product.

• Chapter 4, “Installing Supporting Applications” on page 35, describes how 
to obtain and install the applications that the product requires, and how to 
set up the appropriate environment.

• Chapter 5, “Installing Genesys Agent Scripting for Use with Genesys 
Agent Interaction Layer” on page 43, provides instructions for Genesys 
software administrators who will be integrating agent scripts generated by 
Genesys Agent Scripting into their Agent Desktop workflow.

• Chapter 6, “Using Genesys Agent Scripting in Collaboration Mode” on 
page 49, provides information for system administrators on how to set up 
Genesys Agent Scripting in a multiple-user environment, and how to set up 
and manage users and Project Books.

• The Appendix, “Genesys Integration with the ASP.NET (ASPX) Platform” 
on page 83, provides information for Genesys software administrators who 
will support Genesys Agent Scripting on the ASP.NET platform.

Related Resources
Consult these additional resources as necessary:

Angle 
brackets 
(< >)

A placeholder for a value that the user must 
specify. This might be a DN or a port number 
specific to your enterprise.

Note: In some cases, angle brackets are 
required characters in code syntax (for 
example, in XML schemas). In these cases, 
italic text is used for placeholder values.

smcp_server -host <confighost>

Table 1: Type Styles (Continued) 

Type Style Used For Examples
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Preface Making Comments on This Document

• Genesys Agent Scripting 7.2 Help, which provides details on the features 
and functionality of the Genesys Agent Scripting application. This Help 
file is available from within the Genesys Agent Scripting Development 
Environment and provides reference material for the graphical user 
interface (GUI).

• Genesys Agent Scripting 7.2 User Guide, which describes how to use the 
installed software to create new projects; compile, test, and deploy existing 
projects; and integrate projects with Genesys Outbound software.

• Genesys Technical Publications Glossary, which ships on the Genesys 
Documentation Library CD and which provides a comprehensive list of the 
Genesys and CTI terminology and acronyms used in this document.

Release Notes and Product Advisories for this product, which are available on 
the Genesys Technical Support website at http://genesyslab.com/support.

Information on supported hardware and third-party software is available on the 
Genesys Technical Support website in the following documents:

• Genesys Desktop 7.6 Deployment Guide, which ships on the Genesys 
Documentation Library CD and outlines Genesys Desktop configuration 
and installation procedures.

• Genesys Desktop 7.6 Developer’s Guide, which ships on the Genesys 
Documentation Library CD and describes how to customize Genesys 
Desktop with buttons, menus, and other features.

• Genesys Supported Operating Systems and Databases

• Genesys Supported Media Interfaces

• Interaction SDK (Java) Deployment Guide

• Genesys Integration Server Deployment Guide

• Genesys 7.6 Desktop .NET Toolkit Developer's Guide

• Genesys 7.6 Desktop Developer's Guide

• Framework 8.0 Deployment Guide, which provides reference to the SOAP 
options in the Genesys Configuration Server.

• Outbound Contact 8.0 Reference Manual, which provides information 
needed for the Outbound Script objects.

Genesys product documentation is available on the:

• Genesys Technical Support website at http://genesyslab.com/support.

• Genesys Documentation Library DVD, which you can order by e-mail 
from Genesys Order Management at orderman@genesyslab.com.

Making Comments on This Document
If you especially like or dislike anything about this document, feel free to 
e-mail your comments to Techpubs.webadmin@genesyslab.com. 

mailto:techpubs.webadmin@genesyslab.com
http://genesyslab.com/support
mailto:orderman@genesyslab.com
http://genesyslab.com/support
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Preface Contacting Genesys Technical Support

You can comment on what you regard as specific errors or omissions, and on 
the accuracy, organization, subject matter, or completeness of this document. 
Please limit your comments to the scope of this document only and to the way 
in which the information is presented. Contact your Genesys Account 
Representative or Genesys Technical Support if you have suggestions about 
the product itself.

When you send us comments, you grant Genesys a nonexclusive right to use or 
distribute your comments in any way it believes appropriate, without incurring 
any obligation to you.

Contacting Genesys Technical Support
If you have purchased support directly from Genesys, contact Genesys 
Technical Support at the following regional numbers:

Document Change History
This document has been updated for new and changed functionality in the 
7.2.002.15 release of Genesys Agent Scripting (GAS), as described in the 
Release Notes and online help.

Region Telephone E-Mail

North America and 
Latin America

+888-369-5555 (toll-free)
+506-674-6767

support@genesyslab.com

Europe, Middle East, and 
Africa

+44-(0)-1276-45-7002 support@genesyslab.co.uk

Asia Pacific +61-7-3368-6868 support@genesyslab.com.au

Malaysia 1-800-814-472 (toll-free)
+61-7-3368-6868

support@genesyslab.com.au

India 000-800-100-7136 (toll-free)
+91-(022)-3918-0537

support@genesyslab.com.au

Japan +81-3-6361-8950 support@genesyslab.co.jp

Before contacting technical support, refer to the Genesys Technical Support Guide for complete contact 
information and procedures.

mailto:support@genesyslab.com
mailto:support@genesyslab.co.uk
mailto:support@genesyslab.com.au
mailto:support@genesyslab.com.au
mailto:support@genesyslab.com.au
mailto:support@genesyslab.co.jp
http://genesyslab.com/support/dl/retrieve/default.asp?item=B3BFC6DABE22B62AAE32A6D31E6396E3&view=item
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Chapter

1 Overview of Genesys Agent 
Scripting
Genesys Agent Scripting is a development tool that enables you to create and 
maintain browser-based web applications called “agent scripts.” An agent 
script guides contact center agents through an interaction with a contact and 
helps them complete a structured business process. Typical business processes 
include filling out an application, identifying the right type of expert contact to 
handle an inquiry, troubleshooting a system, and so on.

An agent script enables a contact center agent to work with the contact to 
complete a task. The script provides text (such as well-pointed questions) and 
data that help the agent deliver a consistently high level of service to the 
contact. 

In addition to providing a simple linear flow of script text and related controls, 
a Genesys agent script can react dynamically to information from a customer. 
This means that, using Genesys Agent Scripting, you can design an agent 
script to handle normal variations in a structured business process. As 
necessary, the script can respond dynamically to the answers to scripted 
questions. Depending on the feedback, the flow of the script may change from 
one course to another. If the default flow is not correct for the contact's 
circumstances, the script may adjust by displaying a different page of text to 
the agent. 

Agent scripts provide many benefits. A script ensures the quality of the 
interaction, adds structure and clarity to the definition of the process, integrates 
data access and data entry capabilities, maximizes the probability of success, 
and minimizes the training required by the agent. Genesys Agent Scripting 
assists in constructing the interfaces to other back office systems.

The information in this chapter is divided between the following topics:
 Genesys Agent Scripting Components, page 14
 New in This Release, page 15
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Chapter 1: Overview of Genesys Agent Scripting Genesys Agent Scripting Components

Genesys Agent Scripting Components
This section describes the components that make up the Genesys Agent 
Scripting application. 

The Agent Scripting Editor

The Agent Scripting Editor is a Windows-based, call-flow designer that script 
developers use to write and edit complex scripts for business processes.

It provides two design modes:

• Graphical requires the installation of Microsoft Visio 2003 Professional 
software. This design mode employs customized flowchart elements to 
create, edit, or display the individual components of a call flow.

• Tree-Structured is the default design mode if you do not install Microsoft 
Visio 2003 Professional. This design mode employs a standard tree 
structure to create, edit, or display pages, streams, process flows, and 
projects.

Genesys Agent Scripting contains a compiler that script developers use to 
compile their newly created scripts and generate source files. The source files 
are one of the following types:

• Active Server Page (ASP) or ASP.NET (ASPX) source files that run on a 
Microsoft IIS 5.0 or IIS 6.0 web server.

• Java Server Page (JSP) source files that run on an Apache Tomcat 4.1, 5.0, 
or 5.5 web server, version 4.1, 5.0, or 5.5, or on the WebSphere 
Application Server, version 5.1 or 6.0.

Agent Scripting provides two code-generation modes:

• Incremental (generates only what has changed since the last compile)

• Full (compiles all elements)

Developers can use the Simulate action in Genesys Agent Scripting to start an 
Internet Explorer browser, and test scripts before actual deployment. 

The Runtime Engine

The runtime engine provides agents access to the developed business processes 
(deployed scripts), which reside on a web server and which the agent accesses 
and uses through a web browser.

The agent carries out an interaction with a customer. The runtime engine 
provides:

• An intuitive display within the web browser.

• Automatic and transparent script updates.
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• Data-entry validation.

• Navigation capabilities for the agent.

These features facilitate the agent’s use of the designed script and guide the 
agent to a smooth interaction with the customer.

Collaboration Mode

Collaboration mode allows you to: convert Project Books to a multi-user 
format; check in and check out files; lock and unlock Project Books; and 
access the administration function to manage users and servers (for system 
administrators only). 

The following functions are available in Collaboration mode:

• Conversion of Project Books for multiple users

• A Collaboration Check In / Check Out feature to manage multiple-user 
Project Books

• Login with password protection for system-administrator access to 
Collaboration Administration

• The ability to add, delete, activate, or deactivate user accounts and to 
update user information

• The ability to lock and unlock multiple-user Project Books and to change 
the Lock mode

In many cases, it may be necessary for several script developers to combine 
their efforts, or collaborate, on a large script design/development project. After 
conversion to Collaboration mode, the Project Book remains in this mode. It 
cannot be restored to a single user mode.

New in This Release
This section describes the new features in Genesys Agent Scripting release 
7.2.0.

• Support for custom integration with the Genesys .NET Desktop Toolkit. 
See the new Appendix, “Genesys Integration with the ASP.NET (ASPX) 
Platform” on page 83.

• Support for custom desktops and other applications created with Genesys 
6.x and 7.x SDKs.

• Mapping of asynchronous events to regular fields, and dynamic updating 
of regular fields while an agent is on the page. See the help topic Define > 
Async Interfaces.

Catalog enhancements that dynamically reflect your addition, deletion, and 
moving of pages in the editor. See the help topic Define > Catalogs > Catalog 
Properties.
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• Support in the Assignment Rules dialog for wildcards, and for comparing 
two Genesys fields to each other in assignment rules. See the help topic 
Compile > Assignment Rules.

• Separate environment and compiler settings for design and run-time 
environments. See the help topic Compile > Target Environment.

• Support for listener field values in branching operations.

The following feature was removed from this release:

• The Function tab is removed from the Field Properties dialog box.
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Chapter

2 System Requirements
This chapter outlines the software requirements for the Genesys Agent 
Scripting 7 application.

The information in this chapter is divided among the following topics:
 Requirements for Running the Agent Scripting Editor, page 17
 Requirements for Deploying Generated Scripts, page 18
 Web Archive Deployment in a Web Server, page 23
 Requirements for Collaboration Mode, page 23
 Requirements for Using Deployed Business Processes, page 25
 Migration of Database Interfaces that Use Stored Procedures, page 25

Requirements for Running the Agent 
Scripting Editor

This section outlines the operating system and software requirements for 
running the Genesys Agent Scripting application’s Agent Scripting Editor. 
Review these requirements before installing Genesys Agent Scripting.

• One of these following operating systems:
 Windows 2000 Professional with Service Pack 4 
 Windows 2000 Server running on a 32-bit Intel processor 
 Windows 2000 Professional SP4
 Windows XP Professional 
 Windows 2003 Server running on a 32-bit Intel processor 

• Microsoft Visio 2003 Professional (required only for Graphical design 
mode showing process flow and stream diagrams within Genesys Agent 
Scripting).
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Requirements for Deploying 
Generated Scripts

This section outlines the operating system and software requirements for 
compiling and running scripts created or modified within Genesys Agent 
Scripting.

The requirements depend on the nature of the web server that will host the 
generated source files.

Please review these requirements before installing Genesys Agent Scripting.

Deploying Applications

Web pages generated by Genesys Agent Scripting require write access to their 
target directory. When deploying Genesys Agent Scripting applications, please 
ensure that the web server has write authority to the target directory.

Deploying Applications Under Microsoft IIS

Use a Microsoft IIS web server if you are working with one of the following 
combinations:

• ASP or ASP.NET without Asynchronous (Async)

• ASP.NET with Async* (see additional step)

For either of the above combinations, complete these additional steps for 
deployment:

1. From the Windows Start Menu, go to the Control Panel and select 
Administrative Tools. 

2. Select Internet Information Services (IIS) Manager. 

3. In the Internet Information Services (IIS) Manager window, navigate to the 
target directory folder under (computer name) > Web Sites > Default Web 
Site > (target directory).

Genesys Agent Scripting must be deployed as a separate application. To set 
this up:

1. Right-click the folder and select Properties.

2. On the Home Directory tab, click the Create button next to the Application 
name.
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ASP.NET with Async*

If you are using ASP.NET with Async, complete these additional steps:

1. Right-click the Async sub-directory folder and select Properties.

2. Click the Create button next to the Application name.

Deploying Applications Under Tomcat

When using an Apache Tomcat web server, the generated script created by the 
Genesys Agent Scripting editor is deployed as a separate application. During 
deployment, context information (folder WEB-INF) is automatically included, 
enabling Tomcat to recognize the application. If the generated Agent Scripting 
Web Application is deployed in the webapps folder of Tomcat, then Tomcat 
must be restarted to make the application available. 

If you are using Tomcat 5.0 or 5.5 and you are not deploying the generated 
Agent Scripting Web Application in the Tomcat’s webapps folder, then you 
need to use Tomcat Web Application Manager to tell Tomcat where the 
application is deployed.

You can start the Tomcat Web Application Manager and begin the deployment 
by performing the following steps:

1. Open a Web browser.

2. Go to http://machineName:8080/manager/html (machineName is the name of 
the machine on which Tomcat is installed). 

3. In the Tomcat Web Application Manager, specify the sub-directory folder 
of the generated Web application you wish to deploy.

Improving Performance

To improve the performance of Genesys Agent Scripting applications, set 
Tomcat's Maximum Memory Pool value to 1024 MB., as follows:

1. Run: <Tomcat Installation Directory>/bin/TomcatW.exe.

2. Click the Java Properties tab.

3. Set Maximum Memory Pool to 1024 MB.

Deploying Applications Under WebSphere

See the section “Web Archive Deployment in a Web Server” on page 23 for 
instructions on how to generate a Web Archive (.WAR) file suitable for 
deploying in WebSphere 5.1 or 6.0.
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Active Server Pages

If you want to deploy Active Server Pages (.asp) or Active Server Pages for 
.NET (.aspx) pages, you will need to compile the script and deploy the 
generated .asp or .aspx source files on a Microsoft IIS web server.

The required operating system and web server software consists of either of the 
following:

• Microsoft Windows 2000 Server with Microsoft IIS 5.0 web server.

• Microsoft Windows 2003 Server with Microsoft IIS 6.0 web server.

Upon installation of (or upgrade to) the Microsoft Windows 2000 Server, 
Microsoft IIS 5.0 web server is installed automatically. Upon installation of (or 
upgrade to) the Microsoft Windows 2003 Server, Microsoft IIS 6.0 web server 
is installed automatically.

When you are ready to compile and deploy scripts, you will need to identify 
the path to the Microsoft IIS web server within Genesys Agent Scripting.

Figure 1 on page 21 shows an example of the Genesys Agent Scripting Target 
Environment dialog box as it might be set up for ASP deployment:
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Figure 1: Setting Target Environment for ASP Deployment

Java Server Pages

If you want to deploy Java Server Pages (JSP), you will need to compile the 
script and deploy the generated JSP source files on an Apache Tomcat web 
server, or WebSphere.

The required operating system and software consists of:

• Microsoft Windows 2000 Server, Microsoft Windows 2003 Server, or 
Microsoft Windows 2000 Professional SP4.

• Apache Tomcat 4.1, 5.0, or 5.5 web server, or WebSphere Application 
Server, Version 5.1 or 6.0.

• Sun’s Java 2 Enterprise Edition (J2EE) v1.4 SDK or Java 2 SDK, 
Enterprise Edition, v1.3.1.
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To set up the Apache Tomcat web server, or WebSphere, you must first 
download and install both the J2EE SDK and Apache Tomcat, or WebSphere. 
See “Installing Supporting Applications for JSP” on page 38 for details.

The Apache Tomcat web server, or WebSphere, may reside on the same 
computer as the Genesys Agent Scripting application, or may reside on a 
networked host. When you are ready to compile and deploy scripts, you will 
need to identify the path to the web server within Genesys Agent Scripting.

Figure 2 on page 22 shows an example of the Genesys Agent Scripting Target 
Environment Properties dialog box as it might be set up for JSP deployment:

Figure 2: Setting Target Environment for JSP Deployment

One additional step is necessary at the Java Web Server. The Genesys Agent 
Scripting library wwg.jar must be installed in a directory that is accessible by 
the Java Web Server. This file are shipped with Genesys Agent Scripting and is 
located in its installed path ...\GenesysIntegration\lib.

For example, in Tomcat, you might put it in the ...\shared\lib directory.
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Web Archive Deployment in a Web Server
Genesys Agent Scripting provides the capability to generate Web Archive 
(.WAR) files for deployment to Java-based web servers, such as Tomcat or 
WebSphere. When a Project Book is compiled with the “Create Target as a 
.WAR File” option selected, a file will be placed into the target directory that 
has the form ProjectBookName.WAR. This file can then be deployed as a Web 
application using the administration utilities available for the desired web 
server. 

Figure 3: Setting Target Environment for JSP Deployment - Creating the 
Target as a .WAR File

Figure 3 shows the Advanced Tab, with the option checked to Create Target as 
a .WAR File.

Requirements for Collaboration Mode
This section outlines the operating system and software requirements for using 
Collaboration mode.

The requirements depend on the type of collaboration server that you will be 
using.
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Review these requirements before installing Genesys Agent Scripting.

Note: It is not necessary for the collaboration server to be running on the 
same server, or have the same target language, as the generated scripts.

Microsoft IIS Collaboration Server

If you are setting up a Microsoft IIS Collaboration Server, the operating system 
and software requirements include either of the following:

• Microsoft Windows 2000 Server with Microsoft IIS 5.0 web server.

• Microsoft Windows 2003 Server with Microsoft IIS 6.0 web server.

Upon installation of (or upgrade to) the Microsoft Windows 2000 Server, 
Microsoft IIS 5.0 web server is installed automatically. Upon installation of (or 
upgrade to) the Microsoft Windows 2003 Server, Microsoft IIS 6.0 web server 
is installed automatically.

When you are ready to set up a Microsoft IIS Collaboration Server, see 
“Microsoft IIS Collaboration Server” on page 37 for instructions.

Apache Tomcat Collaboration Server

If you are setting up an Apache Tomcat 4.1, 5.0, or 5.5 Collaboration Server, 
the operating system and software requirements are:

• One of the following:
 Microsoft Windows 2000 Server
 Microsoft Windows 2003 Server

• Apache Tomcat 4.1, 5.0, or 5.5 web server

• Sun’s Java 2 Enterprise Edition v1.4 SDK or Java 2 SDK, Enterprise 
Edition, v1.3.1

• MySQL Database Server and a properly configured MySQL database

The Apache Tomcat may reside on the same computer as the Genesys Agent 
Scripting application, or it may reside on a networked host. When you are 
ready to set up an Apache Tomcat Collaboration Server, see “Apache Tomcat 
4.1, 5.0, 5.5 or WebSphere 5.1, 6.0 Collaboration Server” on page 37 for 
instructions.

WebSphere Collaboration Server

If you are setting up a WebSphere Application Server, Version 5.1 or 6.0, the 
operating system and software requirements are:

• Microsoft Windows 2000 Server or Microsoft Windows 2003 Server

• WebSphere Application Server, Version 5.1 or 6.0

• MySQL Database Server and a properly configured MySQL database
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The WebSphere Application Server may reside on the same computer as the 
Genesys Agent Scripting application, or it may reside on a networked host. 
When you are ready to set up a WebSphere Application Server, see “Apache 
Tomcat 4.1, 5.0, 5.5 or WebSphere 5.1, 6.0 Collaboration Server” on page 37 
for instructions.

Requirements for Using Deployed 
Business Processes

One of the following web browsers is required for running deployed business 
processes (scripts): 

• Internet Explorer 6.x or 7.x

• Netscape Navigator 6.2, 7.0, 7.1, or 7.2.

Migration of Database Interfaces that Use 
Stored Procedures

Note: The information in this section applies only to Project Books 
containing Database Interfaces that use Stored Procedures from 
Releases 7.0 and 7.0.1, and that you are upgrading to 7.0.101 or higher. 

After migrating a project book to the new version of Genesys Agent Scripting 
7.0.101 or higher, some special considerations exist.

If the project book contains the Database Interface for Stored Procedures, you 
will need to perform some manual changes, using the Genesys Agent Scripting 
Editor. This section explains how to make these changes.

Genesys Agent Scripting versions 7.0.101 or higher support output parameters 
and return values for Stored Procedures. 

Defining Specific Parameters 

To support this feature, you must define the Stored Procedures parameters that 
have the following directions and SQL Types.

Directions:
 Input 
 Output 
 Input/Output
 Return Value
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SQL Types: 
 INTEGER 
 FLOAT 
 VARCHAR
 DATE
 TIMESTAMP
 CURSOR 
 REAL
 SMALLINT
 BIGINT
 DOUBLE
 DECIMAL
 TIME

For existing project books that contain Stored Procedures parameters, Genesys 
Agent Scripting automatically migrates the parameter definitions. It defines 
them with a direction of Input and a SQL Type of VARCHAR. This automatic 
migration might cause a discrepancy of types during runtime if the input 
parameter is not supposed to be of the type VARCHAR. Therefore, we recommend 
that you check all of the parameter definitions for all of the Database 
Interfaces. 

Special Considerations for Oracle Databases

Genesys Agent Scripting version 7.0.101 or higher performs additional 
migration of all parameter definitions for the Oracle Database. In previous 
versions of Genesys Agent Scripting, a Stored Procedure Database Interface 
could only call Stored Procedures that contained output parameters that 
matched the columns defined in the Database Interface. The call to the Stored 
Procedure would result in data being returned in these columns. The columns 
are mapped to the Table Field defined in the Database Interface. The result was 
the return of one table row. This restricted the stored procedure from returning 
multiple rows for a table. This restriction was the result of the Oracle Database 
forcing all outputs from a stored procedure to be returned as output parameters, 
including SQL query results. 

Now, with the support of CURSOR output parameters, Genesys Agent Scripting is 
no longer forced to treat the defined columns as output parameters. The 
migration of Database Interfaces now results in defining new Output 
parameters of the type VARCHAR. This parameter applies to each of the defined 
columns whose output values are mapped to the Table Fields previously 
associated with the columns. 

The execution of the migrated Database Interface results in the associated 
fields being updated with the values from each output parameter. However, it 
does not force the defined Table Field associated with these fields to be 
updated. So, you must perform manual changes to force the Table Field to be 
reloaded. Or, you can change the Stored Procedure to remove the output 
parameter for each column, and to define an output parameter of the SQL Type 
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CURSOR. This will save the results of a SQL query into the Table Field defined 
for the Database Interface.
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3 Installing Genesys Agent 
Scripting
This chapter describes how to install the Genesys Agent Scripting application.

The Genesys Agent Scripting installation process uses an InstallShield Wizard.

If you have a previously installed version of Genesys Agent Scripting on your 
computer, this version must be uninstalled before proceeding with the 
installation of the current version.

To install Genesys Agent Scripting:

1. Insert the CD in the CD drive.

The CD should begin the installation automatically. If it doesn’t start, go to 
the CD drive from Windows Explorer and double-click setup.exe.

This should begin the installation procedure. Figure 4 appears, informing 
you that the system is preparing for installation. 

Figure 4: InstallShield Prepares the Genesys Installation Wizard
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Once the application is ready to be installed, the screen shown in Figure 5 
appears, welcoming you to the installation for Genesys Agent Scripting.

Figure 5: Welcome to the Installation of Genesys Agent Scripting

2. Click Next to continue. 

At any point in the install, you may quit by clicking Cancel or the X in the 
upper-right corner of any screen. When canceling, the following 
confirmation screen shown in Figure 6 appears.

Figure 6: Confirm Cancellation of Genesys Agent Scripting Installation

To confirm cancellation, click Yes.

To return to the screen in Figure 5, click No, then click Next to continue the 
installation.
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Figure 7: Choose Destination Location

Figure 7 shows the Choose Destination Location screen.

The default installation directory is C:\Program Files\GCTI\Genesys Agent 
Scripting\. You can change the installation directory by clicking the 
Browse button and selecting or creating a new directory.

Note: Genesys recommends using the default directory. Instructions later 
in the guide assume that Genesys Agent Scripting is installed in the 
default directory.

3. Click Next to continue with the installation.

The screen shown in Figure 8 on page 32 appears, indicating that the 
Wizard is ready to install the Scripting application.
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Figure 8: Ready to Install

4. Click the Install button to start the installation process and to open the 
screen shown in Figure 9.

Figure 9: Installing Genesys Agent Scripting

This screen displays installation status. When the application has finished 
installing, the screen shown in Figure 10 on page 33 appears. 
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Figure 10: Installation Complete

5. When Genesys Agent Scripting has completed its installation, click Finish 
to close the Installation Wizard.

Genesys Agent Scripting is installed.

To run Genesys Agent Scripting, select Start > Programs > Genesys Solutions 
> Genesys Agent Scripting > Start Agent Scripting from the main taskbar.

Genesys Agent Scripting contains a Help system that provides reference 
information on all the elements of the graphical user interface (GUI). Once you 
have started the Genesys Agent Scripting application, access the Help system 
in one of the following ways:

• Press F1.

• Select Help > Genesys Agent Scripting Help.

Help information is organized in a structure similar to the menu structure 
within Genesys Agent Scripting.
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4 Installing Supporting 
Applications
This chapter describes how to install the supporting applications that Genesys 
Agent Scripting needs to run properly.

The information in this chapter is divided amongst the following topics:
 Preparing to Install, page 35
 Installing Microsoft Visio 2003 Professional, page 37
 Installing HTMLDOC, page 38
 Installing Supporting Applications for ASP, page 38
 Installing Supporting Applications for JSP, page 38

Preparing to Install
Genesys Agent Scripting requires the presence of certain supporting 
applications to ensure smooth operation of all of its features and functions. The 
type of environment you will be using and the level of functionality you 
require from Genesys Agent Scripting determine which supporting 
applications you must install, as well as other configuration changes that may 
be required.

For system administrators wishing to use a Genesys Agent Scripting JSP 
Collaboration Server, additional software installations are required. See 
“Apache Tomcat 4.1, 5.0, 5.5 or WebSphere 5.1, 6.0 Collaboration Server” on 
page 37 for details.
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Microsoft Visio 2003 Professional

Process flows and streams are two of the building blocks used to build 
scripting applications for end users. If agents intend to use process flow or 
stream diagrams to conceptualize and/or build process flows or streams, you 
must install Microsoft Visio 2003 Professional on any system running Genesys 
Agent Scripting.

Obtain Microsoft Visio 2003 Professional from any software retailer/vendor.

Easy Software Product’s HTMLDOC

If you intend to use the HTML to PDF file generation capabilities of Genesys 
Agent Scripting, you must install an additional supporting application called 
HTMLDOC from Easy Software Products. This application is downloadable 
for free from their website http://www.easysw.com/htmldoc.

Compiling and Running Scripts: ASP

If you intend to build Agent Scripting applications with Active Server Pages 
(ASPs), you will need access to a Microsoft IIS 5.0 or 6.0 web server to 
successfully compile, simulate, and run the script pages.

Upon installation of (or upgrade to) the Microsoft Windows 2000 Server 
operating system, Microsoft IIS 5.0 web server is installed automatically.

Upon installation of (or upgrade to) the Microsoft Windows 2003 Server 
operating system, Microsoft IIS 6.0 web server is installed automatically.

Agent Scripting Applications with Active Server Pages.NET (ASPXs)

If you intend to build Agent Scripting applications with Active Server 
Pages.NET (ASPXs), you must have Microsoft.NET Framework Version 1.1 
installed on your IIS server.

• IIS 5.0—available to download for free from Microsoft’s website.

• IIS 6.0—comes with Microsoft.NET Framework version 1.1 already 
installed.

Compiling and Running Scripts: JSP

If you intend to build Agent Scripting applications with Java Server Pages 
(JSPs), you must install or have access to:

• The Java 2 Enterprise Edition (J2EE) v1.4 SDK.

• An Apache Tomcat 4.1, 5.0, or 5.5 web server, or WebSphere Application 
Server, Version 5.1 or 6.0, to successfully compile and run script pages.
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J2EE SDK

The Java 2 Enterprise Edition v1.4 SDK is required to enable Apache Tomcat 
4.1, 5.0, or 5.5 to compile Java Server Pages (JSPs).

Obtain this SDK at no cost from Sun’s Java website at 
http://java.sun.com/j2ee/1.4/download.html.

Microsoft IIS Collaboration Server

You do not need to install any additional software on your Microsoft Windows 
2000 or 2003 Server to build and use a Microsoft IIS Collaboration Server 
(ASP environment).

When running on Microsoft IIS, the Microsoft IIS 5.0 or 6.0 Collaboration 
Server database is set up automatically.

When running Genesys Agent Scripting applications as ASPs, the Microsoft 
XML Parser Version 3.0 or higher must be installed on the Server system.

• IIS 5.0: available to download from Microsoft's website.

• IIS 6.0: the appropriate version is already installed with the operating 
system.

Apache Tomcat 4.1, 5.0, 5.5 or WebSphere 5.1, 6.0 
Collaboration Server

There are special requirements to build and use an Apache Tomcat or 
WebSphere web server as the Collaboration Server (JSP environment).

A MySQL database is required to run in Collaboration mode on a Tomcat 
server. This database server must be installed and started. Genesys Agent 
Scripting provides a SQL file to create the tables and fields that the 
Collaboration Server requires.

These steps must precede the conversion of a Project Book to Collaboration 
mode within Genesys Agent Scripting.

See “Installing MySQL for JSP Collaboration Mode” on page 39 for more 
details.

Installing Microsoft Visio 2003 
Professional

Genesys Agent Scripting looks for the presence of Microsoft Visio 2003 
Professional. If found, process flow and stream diagrams, as well as diagram- 
creation features, become available.
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If Genesys Agent Scripting does not find Microsoft Visio 2003 Professional, 
the application functions normally, but without process flow and stream 
diagramming. 

Install Microsoft Visio 2003 Professional as you would any other Windows-
based application. Follow the instructions throughout the installation process.

After installation is completed, activate Microsoft Visio 2003 Professional. To 
activate, start Microsoft Visio 2003 Professional and click Activate Product on 
the Help menu. This launches the Activation Wizard, and activates the 
application.

Installing HTMLDOC
After you obtain the correct version of HTMLDOC for the Windows platform 
you use, extract the application and run its installation routine (setup.exe). The 
HTMLDOC executable must be installed in a location that is accessible from 
the Web Server that is hosting the deployed Agent Scripts.

Installing Supporting Applications for ASP
For Active Server Pages, you must have a Microsoft IIS 5.0 or 6.0 web server 
on your system, or have network access to a server that is running Microsoft 
IIS 5.0 or 6.0. To deploy scripts, you will need remote access to the Microsoft 
IIS server that will host the scripts.

For ASP.NET, the Microsoft.NET Framework Version 1.1 and the latest 
available Service Packs must be installed on the IIS Server.

When running Genesys Agent Scripting applications as ASPs, the Microsoft 
XML Parser Version 3.0 or higher must be installed on the Server system for 
either of the following:

• IIS 5.0 - available to download from Microsoft's website.

• IIS 6.0 - the appropriate version is already installed with the operating 
system.

Installing Supporting Applications for JSP
For Java Server Pages, you will need to install either the Java 2 Enterprise 
Edition v1.4 SDK or v1.3.1. In addition, you must install the Apache Tomcat 
web server or the WebSphere 5.1 or 6.0 application server on your system or 
have network access to a server running an Apache Tomcat web server or a 
WebSphere 5.1 or 6.0 application web server.
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Note: To correctly set up with Tomcat in Collaboration mode under JSP, it is 
necessary to download the activation.jar and mail.jar files needed 
by Tomcat. They are not deployed by default. You can download these 
from http://java.sun.com/products/javamail/. Put them in 
...\common\lib directory under Tomcat.

Finally, if you will be using Collaboration mode for JSP, you must have a 
MySQL database available and you must install the open source MySQL 
Database Server on the computer running Genesys Agent Scripting.

Installing the Java 2 Enterprise Edition v1.4 SDK

Download the Java 2 Enterprise Edition v1.4 SDK from Sun’s Java website at 
http://java.sun.com/j2ee/1.4/download.html. You will obtain a self-
extracting archive such as j2eesdk-1_4-dr-windows-eval.exe (the name of the 
file you obtain may differ).

Double-click the self-extracting archive file and follow the instructions to 
install the SDK.

Installing Apache Tomcat

Download the Apache Tomcat 4.1, 5.0, or 5.5 binary files at no cost from the 
Apache website at http://jakarta.apache.org/tomcat/. You will obtain a 
self-extracting archive such as jakarta-tomcat-4.1.29.exe (the name of the 
file you obtain may differ). 

Note: Install the Java 2 Enterprise Edition v1.4 SDK before installing 
Tomcat. The Apache Tomcat 4.1, 5.0, or 5.5 installation looks for an 
installed Java Development Kit.

Double-click the self-extracting archive file and follow the instructions to 
install Apache Tomcat 4.1, 5.0, or 5.5.

Installing IBM WebSphere 5.1 or 6.0 Application Server

Install WebSphere Application Server as you would any other Windows-based 
application. Follow the instructions throughout the installation process.

Installing MySQL for JSP Collaboration Mode

The 7.0 release of Genesys Agent Scripting requires the presence of a MySQL 
database to convert a Project Book from single-user to multiple-user 
(Collaboration) mode within a JSP environment.
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To use Collaboration mode for JSP, you must have a MySQL database 
available and you must install the open source MySQL Database Server on the 
computer that is running Genesys Agent Scripting.

For instructions on setting up a MySQL database, see “Creating and Setting 
Up a MySQL Database” on page 40.

Installing MySQL Database Server

Download the open source MySQL Database Server at no cost from 
http://www.mysql.com/downloads/index.html. You will obtain a ZIP file such 
as mysql-4.0.18-win.zip (the name of the file you obtain may differ).

Extract the installation files from the ZIP file, double-click setup.exe, and 
follow the instructions to install MySQL Database Server.

You now need to create a MySQL database if you intend to use the Genesys 
Agent Scripting Collaboration Module with JSP. See the next section for more 
details.

Creating and Setting Up a MySQL Database

To create and set up a MySQL database, run MySQL Database Server from a 
command line and perform the following steps:

Note: This procedure assumes that MySQL Database Server was installed 
into the default directory: c:\mysql.

1. Copy the SQL command file SQL_WWC_NEW_7-0-1.sql from the Genesys 
Agent Scripting JSP Collaboration folder (by default c:\Program 
Files\GCTI\Genesys Agent Scripting\Collaborate jsp Web Folder\) to 
the mysql\bin directory.

2. Access a Command Prompt in Windows, and change to the MySQL server 
directory:
cd \mysql\bin

3. Start the MySQL Database Server administrator tool if it is not already 
running:
c:\mysql\bin>winmysqladmin

4. Log in as administrator:
c:\mysql\bin>mysql --user=root mysql

5. Create a user called wwc for Genesys Agent Scripting Collaboration:
mysql> GRANT ALL PRIVILEGES ON *.* TO ‘wwc’@‘hostname’ IDENTIFIED BY 
‘wwc’ WITH GRANT OPTION;

You may substitute other values for the user (‘wwc’) and the password 
(‘wwc’). If you do, however, you will need to change the default values in 
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the connection string file. See “Copying the Connection String File for the 
JSP Collaboration Server” on page 50.

hostname: This is the hostname from which the user 'wwc' will access the 
MySQL database. The hostname must be a fully qualified name, or can be 
set to % to indicate that the user can access this database from any host. 

6. Create a database called WWC to use for Genesys Agent Scripting 
Collaboration:
mysql> CREATE DATABASE WWC;

You may substitute another value for the database name (WWC). If you do, 
however, you will need to change the default value in the connection string 
file. See “Copying the Connection String File for the JSP Collaboration 
Server” on page 50.

7. Select this database (make it active):
mysql> USE WWC;

8. Invoke the SQL command file (SQL_WWC_NEW_7-0-1.sql) to create the tables 
needed for Genesys Agent Scripting Collaboration: 
mysql > SOURCE SQL_WWC_NEW_7-0-1.sql

9. Exit MySQL Administration:
mysql> EXIT

10. Close the Command Prompt window. 

The database is now set up properly.

Installing the MySQL Connector/J Driver

Download the MySQL Connector/J Driver from 
http://www.mysql.com/downloads/index.html. (This is open-source software, 
available at no cost.) You will obtain a ZIP file whose name has the following 
form:
mysql-connector-java-3.0.11-stable.zip

The name of the file you obtain may differ. After downloading the file, install 
it as follows:

1. Extract the installation files from the ZIP file.

2. Locate the file mysql-connector-java-3.0.11-stable-bin.jar (the name of 
the .jar may differ), and copy it to the following location:

For Tomcat: <TOMCAT>\shared\lib

...where <TOMCAT> is the path to the Tomcat directory.

The procedure above assumes that Apache Tomcat 4.1, 5.0, or 5.5 was 
installed in its default directory.

Note: No action is necessary when running on WebSphere Application 
Server version 5.1 or 6.0.
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You have now installed all the supporting applications and drivers you need to 
run in Genesys Agent Scripting JSP Collaboration mode.

See Chapter 6 to continue the steps required to use Collaboration mode for JSP.

Upgrading a MySQL Database from Genesys Agent 
Scripting Version 7.0.0

If you are upgrading from Genesys Agent Scripting version 7.0.0 to version 
7.0.1 or higher, the MySQL Collaboration database must be upgraded. This is 
accomplished by running the SQL command file SQL_WWC_UPDATE_7-0-1.sql 
against your current Genesys Agent Scripting 7.0.0 Collaboration database.



Deployment Guide 43

Chapter

5 Installing Genesys Agent 
Scripting for Use with
Genesys Agent Interaction 
Layer
This chapter is intended for Genesys software administrators. It describes how 
to install Genesys Agent Scripting (GAS) for use with the Genesys Agent 
Interaction layer, which is implemented in Java®.

Genesys Agent Scripting provides a Java Servlet that can be integrated with 
the Agent Desktop’s software to provide access to Genesys Agent Interaction 
Layer. Data from an interaction can be used to determine the server location 
and the starting point of the Agent Script to be used to process the interaction.

The information in this chapter is divided among the following topics:
 Agent Desktop Integration with Genesys Agent Scripting, page 44
 Genesys Agent Desktop Integration with Genesys Agent Scripting, 

page 44
 Creating the Genesys Application for Genesys Agent Scripting, page 46
 Configuring Genesys Configuration Server for Outbound Operations, 

page 47
 Genesys Agent Scripting Server, page 47
 Genesys Agent Scripting Project Book, page 47
 T-Server Configuration, page 48
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Agent Desktop Integration with Genesys 
Agent Scripting

Note: If you are using the Genesys Agent Desktop (version 7.0.1 or higher), 
skip this section and proceed to the section entitled “Genesys Agent 
Desktop Integration with Genesys Agent Scripting” on page 44. 

To integrate an Agent Desktop using Genesys Agent Scripting with Genesys 
Agent Interaction Layer, perform the following steps:

1. Install the file containing the Java Servlet from the Agent Scripting install 
path ...\GenesysIntegration\lib\WWG.jar into a directory of the Java Web 
Server that is accessible by the Agent Desktop application.

2. Ensure that the Genesys Interaction SDK (version 7.1) has been installed 
and is accessible to the Java Web Server. For more detailed information, 
refer to the Interaction SDK (Java) Deployment Guide.

3. Update the web.xml file in the Java Server's Web Application directory 
...\WEB-INF to identify the Genesys Agent Scripting integration 
components. Code snippets are provided in web.xml.Sample in the Genesys 
Agent Scripting Install directory ...\GenesysIntegration\.

a. Add the GASAssignerServlet definition.

b. Add the GASAssignerServlet mapping section.

The Genesys Agent Scripting servlet provides a public method with the 
signature:
public String getAssignedPFURL(String interactionID) throws Exception

This method may be used to determine where a particular Interaction should be 
directed. This method returns a string that provides the URL used to invoke the 
desired Agent Script. It is based on data referenced by the Interaction. The 
URL may be used unmodified, since it contains the location and all required 
Query parameters; or additional Query parameters may be appended, as 
determined by the needs of the deployed Agent Script. Refer to 
...\GenesysIntegration\gdesktop\custom\AgentScripting.jsp for sample 
usage.

Genesys Agent Desktop Integration with 
Genesys Agent Scripting

To integrate the Genesys Agent Desktop (version 7.0.1 or higher) with 
Genesys Agent Scripting using Genesys Agent Interaction Layer, perform the 
steps listed below. Use these instructions instead of the instructions in the 
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previous section entitled “Agent Desktop Integration with Genesys Agent 
Scripting”.

Note: These instructions assume that you have a basic Genesys Agent 
Desktop (GAD) installation. If the GAD has already been customized, 
these instructions must be modified accordingly. 

For detailed information about the Genesys Agent Desktop application, refer to 
the Genesys Desktop 7 Deployment Guide and the Genesys Desktop 7 
Developer's Guide.

Note: Genesys requires you to run the Genesys Agent Desktop on its own 
dedicated Java web server. Therefore the Genesys Agent Scripting 
scripts should be deployed to a separate Java web server. 

1. If Genesys Agent Desktop has NOT been previously customized:

a. Copy the entire directory from the GAS Install path 
...\GenesysIntegration\gdesktop\custom directly to the GAD Java 
Server's Web Application path ...\gdesktop\custom.

b. Copy the file custom.properties from the GAS Install path 
...\GenesysIntegration\gdesktop to the GAD Java Server's Web 
Application path ...\gdesktop\WEB-INF\classes. The string “Agent 
Scripting” may be changed to any value that you want to use as a label 
on the AgentScripting tab.

2. If Genesys Agent Desktop HAS been customized, you must update the 
customization files to include the Genesys Agent Scripting customization, 
as follows:

a. Modify ...\gdesktop\custom\custom.xml, which is located in the GAD 
Java Server's Web Application directory, to include the AgentScripting 
Tab information from the supplied sample AgentScripting.xml file 
from the ...\GenesysIntegration\gdesktop\custom directory.

b. Include the javascript-onload section for the GAD window in the 
custom.xml file.

c. Put AgentScripting.jsp in the GAD Java Server's Web Application 
directory ...\gdesktop\custom.   AgentScripting.jsp is located in the 
Genesys Agent Scripting Install directory 
...\GenesysIntegration\gdesktop\custom.

d. Add the following line 
AgentScripting=<Agent Scripting>

to this file

...\WEBINF\classes\custom.properties

where <Agent Scripting> is the name displayed on the AgentScripting 
tab.

3. Put the WWG.jar file in the ...\WEB-INF\lib directory. 



46 Genesys Agent Scripting 7.2

Chapter 5: Installing Genesys Agent Scripting for Use with Genesys Agent Interaction Layer Creating the Genesys 

This file is in the Agent Scripting install directory: 
...\GenesysIntegration\lib\WWG.jar.

4. Update the web.xml file in the Java Server's Web Application directory 
...\gdesktop\WEB-INF to identify the Genesys Agent Scripting integration 
components. Code snippets are provided in web.xml.Sample in the Genesys 
Agent Scripting Install directory ...\GenesysIntegration\.

a. Add the GASAssignerServlet definition

b. Add the GASAssignerServlet mapping section

c. Add the <init-param> for AgentScripting.xml to the <initUAD> 
servlet definition.

Creating the Genesys Application for 
Genesys Agent Scripting

In order for Genesys Agent Scripting to access other Genesys components, you 
must set up an application for Genesys Agent Scripting in Genesys 
Configuration Manager 7. To do this, complete the following steps: 

1. In Configuration Manager, open the Environment folder, then the 
Application Templates folder. If Genesys_Agent_Scripting templates are 
absent, import them from the Template folder on the Genesys Agent 
Scripting CD at: //templates/Genesys_Agent_Scripting_702.apd

2. Create a new application from Configuration Manager using the 
Genesys_Agent_Scripting_702 template.

3. On the General tab, enter an Application Name. This name will be used by 
the GAS Server and should be supplied to the parameter 
G_Config_ApplName located in the Target Environment Properties dialog 
box, Configuration File tab.

4. In a multi-tenant environment, select the tenant tab and add the tenant with 
which this application will interact. Choose only one tenant.

5. On the Start Info tab enter a period “.” for the Working Directory and the 
Command line sections. This Start Info tab is not used.

6. On the Connections tab add a connection to the Premise T-Servers that 
your Agent Desktop application uses. Also, if your Agent Desktop 
application uses Contact Server, add this Contact Server.

7. On the Options tab fill in the license section with your appropriate 
information.

For more detailed information, refer to the Interaction SDK (Java) Deployment 
Guide.
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Configuring Genesys Configuration Server 
for Outbound Operations

If you are using Outbound Contact Solution (requires version 7.0.100.08 or 
higher) with Genesys Agent Scripting, then an additional section must be 
added to your Configuration Server's config file. The section name and options 
are below:
[soap]

port =

debug =

client_lifespan =

For more information on these options, please refer to the Framework 7 
Configuration Options Reference Manual, Chapter 4, and particularly the 
section on SOAP.

Note: Restarting any web server—GAD or GAS Tomcats, GAS IIS, or 
Genesys Integration Server—requires that you also restart all 
Outbound campaigns.

Genesys Agent Scripting Server
When using deployed Agent Scripts integrated with Genesys Agent Interaction 
software, one additional step is necessary at the Java web server. The Genesys 
Agent Interaction software Java files must be installed in a directory that is 
accessible by the Java Web Server. These files are shipped with Genesys Agent 
Scripting and are located in its installed path ...\GenesysIntegration\lib.

For example, in Tomcat, you might put them in the ...\shared\lib directory.

Genesys Agent Scripting Project Book
Genesys Agent Scripting provides built-in Agent Scripting objects that can be 
used by scripts to display Genesys information and perform actions on 
Genesys Interactions. To create Agent Scripts that operate in this “Genesys 
Integrated” mode, follow these steps: 

1. When creating a new Project Book, select the base toolkit “Genesys Agent 
Interaction toolkit” from the Project Book Properties panel.

2. In Compile->Assignment Rules, on the Deployment Settings tab, set the 
“Genesys Agent Scripting Assigner Servlet URL” to the URL used to 
access the application hosting this servlet. 
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 This URL must end in the name of the servlet and match the 
appropriate mapping, which is specified in either “Agent Desktop 
Integration with Genesys Agent Scripting” in Step 3b, or “Genesys 
Agent Desktop Integration with Genesys Agent Scripting” in Step 4b. 
The default is GASAssigner. 

3. In Compile->Assignment Rules, set the Default URL to the deployed 
location of this Project Book.

4. Deploy the Assignment rules (even if empty, the Default URL must be set). 
Please note, the Agent Desktop Web Server needs to be running since the 
GAS Assigner Servlet from Step 2 will actually be invoked.

5. For each Target environment, the Configuration file parameters must be set 
(including the CME Application name created from the procedure in the 
topic “Creating the Genesys Application for Genesys Agent Scripting” on 
page 46). 

T-Server Configuration
GAS will attach interaction data to the call when a transfer with data is issued. 
In order for this data to be properly propagated to the new interaction an option 
in T-Server must be checked. Open the T-Server application and go to the 
Options tab. Select the T-Server section and check the value of consult-user-
data. This value must be inherited or joint for the GAS transfer to work 
properly. For more information on these options please consult your T-Server 
deployment guide.
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Chapter

6 Using Genesys Agent 
Scripting in Collaboration 
Mode
This chapter is intended for system administrators or script developers. It 
describes how to convert Genesys Agent Scripting Project Books for use in a 
multiple-user environment, and how to set up and manage users and Project 
Books in Collaboration mode.

The information in this chapter is divided among the following topics:
 Preparing for the Conversion, page 49
 Converting a Project Book to Collaboration Mode, page 51
 Managing Users and Project Books, page 63
 Using Genesys Agent Scripting Collaboration Administration, page 70

Preparing for the Conversion
To use Genesys Agent Scripting in a multiple-user environment, databases - 
(called Project Books), must be converted to a format that allows for multiple 
users. Genesys refers to these converted Project Books as multiple-user or 
Collaboration mode Project Books.

You should have already completed the following:

1. Installed the Genesys Agent Scripting application.

2. Installed the appropriate supporting applications.
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Backing Up Your Project Book

Before attempting to convert a Project Book to Collaboration mode, Genesys 
strongly recommends that you create a backup copy of the Project Book and 
store it in a safe location. 

This is recommended for two reasons:

• Converted Project Book files cannot be restored to Single-User mode.

• Should a Project Book file be damaged during or subsequent to 
conversion, your backup assures that the original file is intact.

Example: Backing Up WWGDemo.mdb

Genesys Agent Scripting first opens with a Project Book called WWGDemo (file 
name WWGDemo.mdb). You can assume this will be the candidate Project Book to 
convert to Collaboration mode. To back up this Project Book file:

1. Locate the WWGDemo.mdb file in C:\Program Files\GCTI\Genesys Agent 
Scripting (assuming the default installation path).

2. Make a copy of this file and store it in the same folder.

Copying the Connection String File for the JSP 
Collaboration Server

The steps in this section apply only when you are setting up a JSP 
Collaboration Server.

Note: If you plan to convert additional Project Books to Collaboration mode: 
If the additional Project Books do not use the same Collaboration 
Server as your initial converted Project Book, do not carry out this 
procedure at this time! 
Instead, carry out this procedure before performing Step 8 in the 
section “Converting the Project Book” on page 53.

1. Navigate the following path:
C:\Program Files\GCTI\Genesys Agent Scripting\Collaborate jsp Web 
Folder

2. Select the file WWCConfigExample.inc.jsp and copy it.

3. Rename the copy to WWCConfig.inc.jsp.

4. Double-click WWCConfig.inc.jsp to open it.

Notepad opens with the file information shown in Figure 11 on page 51.
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Figure 11: WWCConfig.inc.jsp file

5. If you set up the MySQL database and user information as described 
earlier, the information in this connection string should be correct 
(hostname = localhost, database = wwc, user = wwc, password = wwc).

6. If you created a different database, user, or password, then update the 
connection string with your values:
 /wwc? is replaced with /<your database name>?
 user=<your user name>
 password=<your password>

7. If you installed MySQL on a different machine, you need to change 
localhost to the machine name where the MySQL database resides.

8. If you make any changes to this file, select File > Save.

9. Exit from Notepad.

Converting a Project Book to 
Collaboration Mode

You are now ready to convert Project Books to Collaboration mode in Genesys 
Agent Scripting.

Creating a Folder for the Collaboration Server

You must create a folder for the Collaboration Server:

• For a Microsoft IIS server (serving ASPs), create a WWC folder inside 
C:\Inetpub\wwwroot\.

• For an Apache Tomcat 4.1, 5.0, or 5.5 server (serving JSPs), create a WWC 
folder inside:

For Tomcat: <TOMCAT>\webapps
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...where <TOMCAT> is the path to the Tomcat directory.

The procedure above assumes that Apache Tomcat 4.1, 5.0, or 5.5 was 
installed in its default directory.

The Collaboration Server folder is populated automatically during the Project 
Book conversion when you click the Test button on Step 8, page 55. Also, the 
WEB-INF folder will be deployed telling Tomcat that this is a runnable 
application. After the Collaboration Server folder has been populated, you 
must restart Tomcat to enable Tomcat to detect the application. 

Starting the Web Server

Before running Genesys Agent Scripting to convert Project Books to 
Collaboration mode, you should start the web server you will be using for 
collaboration as follows:

• For ASP, start the Microsoft IIS 5.0 or 6.0 web server.

• For JSP, start the Apache Tomcat 4.1, 5.0, or 5.5 web server, or WebSphere 
5.1 or 6.0.

• For JSP, when you are using WebSphere as a collaboration server. See 
“Using a WebSphere Application Server for the Collaboration Server” on 
page 58.

Starting Genesys Agent Scripting

You can start Agent scripting after you have completed the following:

• Installed the supporting applications

• Installed the Genesys Agent Scripting application

• Created the Collaboration Server folder

• For JSP, after you have created and set up a MySQL Database for running 
a JSP Collaboration Server

After these have been completed, perform the following steps:

1. Start Genesys Agent Scripting from the main taskbar by selecting Start > 
Programs > Genesys Solutions > Genesys Agent Scripting > Start Agent 
Scripting.

2. You may see a message to set up a path called 
C:\Inetpub\wwwroot\WWGDemo. This is for Microsoft IIS web servers and 
ASP. 
 If you will be using ASP, click Yes.
 If you will be using JSP, click No.

3. You may see an information box for Genesys Agent Scripting. Click Close 
(or wait for the box to close on its own).

When starting Genesys Agent Scripting for the first time, the WWGDemo Project 
Book opens by default and is displayed in the main window.
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The WWGDemo Project Book (file name WWGDemo.mdb) is the file to use as an 
example for conversion.

Note: If you have not backed up the WWGDemo.mdb file, see “Backing Up Your 
Project Book” on page 50 and follow the instructions. Genesys 
strongly recommends that you back up any Project Book file that you 
intend to convert to Collaboration mode.

Converting the Project Book

Carry out the following steps to convert a Project Book to Collaboration mode. 
Again, the WWGDemo.mdb file is the example.

Note: You must convert a Project Book to Collaboration mode before any of 
the multiple-user options (such as Administrate or Lock/Unlock 
Database) become available.

1. From the Genesys Agent Scripting main menu, select File > Convert to 
Collaborate Mode.

This opens the first screen of the conversion wizard as shown in Figure 12. 
This first screen warns you to back up your Project Book file before 
carrying out the conversion.

Figure 12: Convert to Collaborate Wizard, Backup Warning
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2. Click Next to proceed to the next screen of the wizard shown in Figure 13.

Figure 13: Convert to Collaborate Wizard, Find Server

3. Select asp or jsp as desired in the Server Language field.

4. Click Find Server to locate the server that will populate the Server 
Location field.

The Select Target Directory for Collaborate Server dialog box opens 
as shown in Figure 14.

Figure 14: Convert to Collaborate Wizard, Navigate to WWC
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5. In this dialog box, navigate to the folder you set up in “Creating a Folder 
for the Collaboration Server” on page 51 and click Open.

6. Click OK if you see a JSP Environment message.

The Server Location and Server URL fields are now populated in the 
conversion wizard as shown in Figure 15 on page 55.

Figure 15: Convert to Collaborate Wizard, Fields Populated

7. Replace the host string in the Server URL field with the fully qualified host 
name and port used to access the Collaboration Server. This is the URL 
string that designers of this Project Book will use to address this 
Collaboration Server.

The default port for Apache Tomcat is 8080. The modified Server URL 
string is shown in Figure 15.

Note: Before proceeding to the next step, be sure to carry out the instructions 
detailed in “Copying the Connection String File for the JSP 
Collaboration Server” on page 50, if you have not already done so. The 
Test step will not work correctly unless you have copied (and updated) 
this connection string file.

8. Click Test to test the connection to the Collaboration Server.

If successful, the screen shown in Figure 16 appears.

Note: Clicking Test deploys the Collaboration Server, populating the WWC 
folder. For JSP, this includes the creation of a WEB-INF subfolder, 
which tells Tomcat that you have a runnable server. You must 
restart Tomcat to pick up this change.
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Figure 16: Convert to Collaborate Wizard, Server Installed/Connected

9. Click Next to proceed to the screen shown in Figure 17.

Figure 17: Convert to Collaborate Wizard, Provide Login Information

10. Enter admin in the UserID field.

11. Enter admin in the Password field.

12. Click Login.
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You are now logged in as shown in Figure 18.

Figure 18: Convert to Collaborate Wizard, Login Successful

13. Click Next to open the dialog box shown in Figure 19.

Figure 19: Convert to Collaborate Wizard, Start Conversion

14. Start the conversion of your Project Book to Collaboration mode by 
clicking Check In.

Warning! Depending on the size of the Project Book, this conversion process 
may require a lot of time. Once you start it, you cannot stop it 
without destroying the Project Book file.
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The conversion process proceeds as shown in Figure 20. Allow the 
conversion process to complete.

Figure 20: Convert to Collaborate Wizard, Converting Project Book

Figure 21: Convert to Collaborate Wizard - Conversion Complete

15. Click Finish when you see the screen shown in Figure 21.

Using a WebSphere Application Server for the Collaboration 
Server

The Genesys Agent Scripting install directory contains a file called WWC.war. 
This file is suitable for deployment on the WebSphere Application Server. To 
use a WebSphere Application Server, follow these steps: 

1. After WWC.war has been installed as a Web Application on the WebSphere 
Application Server, update the WWCConfig.inc.jsp file to use the 
appropriate configuration string for accessing the mySQL database (see 
Figure 11).
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2. Update the XMLServer tag in the WWGConfig.xml file to contain the correct 
URL specification for the WebSphere Server (the default port number for 
WebSphere is 9080).

3. Once these changes are complete, start the Web Application using the 
WebSphere Administration utility.

Converting a Project Book to Collaboration Mode 
using WebSphere for the Collaboration Server

Carry out the following steps to convert a Project Book to Collaboration mode 
for WebSphere as the Collaboration Server. Again, the WWGDemo.mdb file is the 
example.

Note: You must convert a Project Book to Collaboration mode before any of 
the multiple-user options (such as Administrate or Lock/Unlock 
Database) become available.

1. From the Genesys Agent Scripting main menu, select File > Convert to 
Collaborate Mode.

This opens the first screen of the conversion wizard as shown in Figure 22. 
This first screen warns you to back up your Project Book file before 
carrying out the conversion.

Figure 22: Convert to Collaborate Wizard, Backup Warning
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2. Click Next to proceed to the next screen of the wizard shown in Figure 23.

Figure 23: Convert to Collaborate Wizard, Find Server

3. Select jsp in the Server Language field.

Figure 24: Convert to Collaborate Wizard, Fields Populated: WebSphere

4. Replace the host string in the Server URL field with the fully qualified host 
name and port used to access the Collaboration Server. This is the URL 
string that designers of this Project Book will use to address this 
Collaboration Server.

The default port for WebSphere Application Server is 9080. The modified 
Server URL string is shown in Figure 24.

5. Click Test to test the connection to the Collaboration Server.

If successful, the screen shown in Figure 25 appears.
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Figure 25: Convert to Collaborate Wizard, Server Installed/Connected

6. Click Next to proceed to the screen shown in Figure 26.

Figure 26: Convert to Collaborate Wizard, Provide Login Information

7. Enter admin in the UserID field.

8. Enter admin in the Password field.

9. Click Login.
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You are now logged in as shown in Figure 27.

Figure 27: Convert to Collaborate Wizard, Login Successful

10. Click Next to open the dialog box shown in Figure 28.

Figure 28: Convert to Collaborate Wizard, Start Conversion

11. Start the conversion of your Project Book to Collaboration mode by 
clicking Check In.

Warning! Depending on the size of the Project Book, this conversion process 
may require a lot of time. Once you start it, you cannot stop it 
without destroying the Project Book file.
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The conversion process proceeds as shown in Figure 29. Allow the 
conversion process to complete.

Figure 29: Convert to Collaborate Wizard, Converting Project Book

Figure 30: Convert to Collaborate Wizard - Conversion Complete

12. Click Finish when you see the screen shown in Figure 30.

Managing Users and Project Books
Once you have converted a Project Book to Collaboration mode, you can 
access the tools that enable you to manage users and Project Books.
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For example, the File menu changes when you are in multiple-user 
(Collaboration) mode, as shown in Figure 31.

Figure 31: File Menu for Collaboration Mode

The Collaborate option on the File menu opens a submenu with several 
options. The following subsections provide descriptions of the options. Also, 
note that the File menu items called Lock Exclusive and Unlock Exclusive are 
available only in a multiple-user environment.

Lock Exclusive/Unlock Exclusive

In Collaboration mode, you can lock the Project Book for your exclusive use, 
and release the lock after you have made changes and checked in all objects.

Lock Exclusive

The Lock Exclusive feature enables you to lock the Project Book for your 
exclusive use. Lock Exclusive appears in the File menu only when Genesys 
Agent Scripting is in Collaboration mode. 

In this operational mode, you do not need to check out individual records to 
make changes. However, you must check in all changes prior to releasing the 
exclusive lock. If a Project Book is locked exclusively, another user cannot 
modify any objects until the exclusive lock is released. 
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When you select File > Lock Exclusive, the dialog box shown in Figure 32 
opens (Database means Project Book).

Figure 32: Lock Exclusive

Click OK to confirm the message. The current Project Book is now locked for 
your exclusive use.

Unlock Exclusive
If you have been working with an exclusively locked Project Book, you can 
use the Unlock Exclusive option to release the exclusive lock. 

• When a Project Book is locked, the Unlock Exclusive option appears in the 
File menu, replacing the Lock Exclusive option that appears when you are 
in Collaboration mode. You can use this option to release the exclusive 
lock. 

• Before releasing the lock, you must check in all objects as described in 
“Check In” on page 66. 

• When you select File > Unlock Exclusive, the dialog box shown in 
Figure 33 opens (database means Project Book).

Figure 33: Unlock Exclusive

• Click OK to confirm the message. If you have checked in all objects, the 
current Project Book is now unlocked and available to other users.
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Check In

The Check In option checks in changes that you or another user has made to 
objects, updating the collaboration database and making the objects available 
for other users to modify. When you select this option, the dialog box shown in 
Figure 34 opens.

Figure 34: Collaboration Check In

The Object column in this dialog box lists all objects in the Project Book that 
are currently checked out. Other columns provide the name of each object that 
has been checked out, a description of the object, and the date the object was 
checked out.

• To select an object for check in, select the box to the left of the object 
under the Object column.

• Before checking in changes to the Admin database, you must provide a 
comment describing the changes that you have made.

• Click Check In to check in the selected objects. Once objects are checked 
in, other users can view the changes.
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Check Out

Use the Check Out option to lock Project Book objects so they can be safely 
updated without affecting the work of other users. When you select this option, 
the dialog box shown in Figure 35 opens.

Figure 35: Collaboration Check Out

Note: By default, objects are automatically checked out when you edit them. 
However, you can turn off this automatic check out by going to File > 
Settings > Collaborate tab and deselecting the box labelled 
Automatically Lock Pages When the User Clicks on the Page in the 

Script View. 

This is useful when you are simply looking at a Project Book and don’t 
want to be required to check in all the Process Flows/Streams and 
pages just because you looked at them. 

However, if you attempt to edit a page which is not checked out, you 
will get a warning dialog box, This page cannot be edited at this 
time. You will need to check out the page before editing it.

• Use the Show Objects of Type drop-down list to filter the Object list to 
only show objects of a certain type. Valid types are [ALL], Projects, 
Process Flows, Streams, Pages, Fields, Actions, Database Interfaces, 

XML Interfaces, Functions, and API Interface.
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• The Object column lists all objects in the Project Book that are currently 
not checked out. Objects are described under the Description column. To 
check out an object, select the check box next to it.

Note: Objects are automatically checked out when you edit them from any 
Genesys Agent Scripting dialog box.

• Click Check Out to check out the selected objects. Until an object is 
checked back in, other users cannot modify or delete it.

• The Progress pane at the bottom of the Collaboration Check Out dialog 
box shows the progress as each object is checked out. 

Apply Updates

The Apply Updates option applies all changes checked in by other users to the 
local copy of the Project Book.

Note: Before checking out an object, Genesys Agent Scripting automatically 
updates the local copy.

• When you select File > Collaborate > Apply Updates, the dialog box 
shown in Figure 36 opens (Build database means Rebuild Project Book).

Figure 36: Apply Updates

• Click Apply Updates to rebuild the local Project Book with all changes that 
you have checked in.

Build Project Book

The option to build a Project Book builds a new copy of a Collaboration 
Server-controlled, Genesys Agent Scripting Project Book. You will need to 
build a copy of the Project Book for each user of the project and they will be 
required to log onto the server before doing any editing with that Project Book. 
While users will have their own Project Books, all changes are stored in the 
common Collaboration Server. 
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Note: The assigned Admin user should not be a script editor. This Admin 
user is responsible for maintaining users and building Collaboration 
mode Project Books. 

• When you select File > Collaborate > Build Project Book, the dialog 
box shown in Figure 37 opens. (Note that Build database means Build 
Project Book).

Figure 37: Build Project Book

• Click Setup New Database to create a new copy of the Project Book.

Warning! Make sure that you regularly back up your Project Book files to a 
secure location. If you do not make backup copies of your Project 
Book files, you will not be able to recover any lost information.

Scan for Errors

Genesys Agent Scripting Project Books can run in either of two modes:

• Pessimistic mode

• Optimistic mode

In Pessimistic mode, the Project Book assumes that users are going to do 
things that conflict with each other, so the Project Book prevents this from 
happening. For example, this mode prevents a user from adding a new 
reference to an object that a different user is currently attempting to delete.

In Optimistic mode, the Project Book assumes that users are not going to do 
things that conflict with each other. It operates as if these situations are very 
rare and not worth the cycle time. 

Use the Scan for Errors option to scan the Project Book for any errors that 
may occur when the Project Book is running in Optimistic mode.
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• When you select File > Collaborate > Scan for Errors, the dialog box 
shown in Figure 38 opens.

Figure 38: Scan for Errors

• Click Scan to check for errors in the Project Book.

Administrate

Use this option to launch Genesys Agent Scripting Collaboration 
Administration, which is described in detail in the next section.

Using Genesys Agent Scripting 
Collaboration Administration

As a system administrator or script developer in a multiple-user Genesys 
Agent Scripting environment, you can set up, update, and manage users and 
Project Books.

Select File > Collaborate > Administrate to run Collaboration Administration.

Note: You must be running in Collaboration mode in order to access 
Collaboration Administration.
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Login Screen

The Login screen as shown in Figure 39 opens in a web browser when you 
launch Collaboration Administration.

Figure 39: Collaboration Administration Login Screen

The first time you open Collaboration Administration, the UserID and Password 
are both set to admin. You can change these values later when you update user 
information. See “Updating Users” on page 76. For now:

1. Enter admin in the UserID field.

2. Enter admin in the Password field.

3. Click Login.

The Home screen opens in the web browser as shown in Figure 40 on page 72.

Home Screen

Figure 40 on page 72 shows the Collaboration Administration Home Screen. 
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Figure 40: Collaboration Administration Home Screen

Genesys Agent Scripting 7 Collaboration Administration has two main 
functions:

• User maintenance

• Project Book maintenance

You will click Update Users or Update Servers (Update Servers means Update 
Project Books) from the Home screen’s left panel depending on which type of 
maintenance function you wish to run.
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Setting Up and Managing Users (Update Users)

Overview
This section describes how to set up and manage Genesys Agent Scripting 
users who will be sharing Project Books that are converted to Collaboration 
mode.

The user maintenance function enables you to add new users or to modify and 
deactivate existing ones.

Click Update Users on the left panel to open the screen shown in Figure 41 in a 
web browser.

Figure 41: Update Users
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Adding Users

The Insert User function enables an Admin user to add new users to the Admin 
database.

1. Click Insert User to open the screen shown in Figure 42 in the web 
browser:

Figure 42: Insert User

2. Enter a value in the UserID field.

This is the UserID to log into Genesys Agent Scripting in Collaboration 
mode, or into Genesys Agent Scripting Collaboration Administration. You 
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can enter up to 100 characters in this field. The value you enter must be 
unique.

3. Enter the user’s name in the User Name field.

You can enter up to 200 characters in this field.

4. Enter a password for this user in the Password field.

This is the password to log into Genesys Agent Scripting in Collaboration 
mode, or into Genesys Agent Scripting Collaboration Administration. You 
can enter up to 100 characters in this field. Any text you enter will be 
hidden.

5. If you want this user to have access to Genesys Agent Scripting 
Collaboration Administration, select the Admin User check box.

If the check box is not selected, this user can run Genesys Agent Scripting 
in Collaboration mode, but will be unable to access Collaboration 
Administration.

6. Click Insert User to add the new user to the Genesys Agent Scripting 
Admin database.

Your new user is added to the list of user records in the User Table. In the 
example shown in Figure 43 on page 76, UserID = 2004, User Name= Sal 
Thomas, and the user is active but is not an Admin user.
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Figure 43: New User Added

Updating Users

The User Table shown in Figure 43 lists all user accounts. Use the radio button 
next to each user to select a specific user account to update, delete, or activate.

1. Click Show All Users to display all active and inactive user accounts.
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Inactive user accounts are accounts that were deactivated or deleted. They 
are maintained in the Admin database, but the user is unable to log in. See 
Figure 44.

Figure 44: Show All Users

2. Select the radio button beside a user record in the User Table that you want 
to update.

When you do this, the user record fields on the screen are populated with 
the user’s information, as shown in Figure 45 on page 78.
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Figure 45: Update User Information

3. Change any information that you want to update about this user.
 To change the UserID, User Name, or Password: edit the appropriate 

field.
 To give this user administration rights: select the Admin User check 

box.
 To remove administration rights: clear the Admin User check box.
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4. Complete your update by doing one of the following:
 Click Update User to register the changes you made into the Admin 

database.
 Click Delete User to deactivate this user account. The user record 

remains in the Admin database, but the user is unable to log in unless 
reactivated.

 Click Activate User to activate or reactivate a user account that is 
currently inactive. In the example shown in Figure 45 on page 78, 
clicking Activate User adds a check mark to the Active User check 
box and allows this user to regain login rights.

Setting Up and Managing Project Books (Update Servers)

Overview
This section describes how to manage Genesys Agent Scripting Project Books 
that users will share.

Admin users can lock and unlock Project Books using the Project Book 
maintenance portion of Genesys Agent Scripting Collaboration 
Administration.

Click Update Servers in the left panel to open the screen shown in Figure 46 
on page 80 in a web browser.



80 Genesys Agent Scripting 7.2

Chapter 6: Using Genesys Agent Scripting in Collaboration Mode Using Genesys Agent Scripting Collaboration 

Figure 46: Update Servers (Project Books)

As you can see in Figure 46, the Server Table contains a list of Project Book 
files that have been converted to Collaboration mode; the column Database 
Name contains the list of Project Book files. The following characteristics of the 
Project Book are provided in the table:

• Project Book file name

• Lock mode (Pessimistic or Optimistic)

• Whether the Project Book is currently locked

• Whether the Project Book has an exclusive lock (achieved by selecting 
File > Lock Exclusive as described earlier)

• If locked, the user name of the user who has locked the Project Book

Changing the Lock Mode

The Project Book can be locked in one of two ways:

In Pessimistic mode, the Project Book assumes that users are going to do 
things that conflict with each other, so the Project Book prevents this from 
happening. 
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For example, this mode prevents a user from adding a new reference to an 
object that a different user is currently attempting to delete.

In Optimistic mode, the Project Book assumes that conflict situations are very 
rare and not worth the cycle time.

Note: You cannot change the lock mode if the Project Book is currently 
locked or if it has an exclusive lock. You must unlock the Project Book 
or release the exclusive lock (select File > Unlock Exclusive) before 
you can change the lock mode.

1. Select the radio button beside the Project Book file in the Server Table 
whose properties you want to modify.

2. Click Change Lock Mode.

You must check in all objects before you can change the lock mode. If you 
have objects that are checked out, check them in as described in “Check 
In” on page 66. If other users have checked out objects, these users must 
also check in their items before you can change the lock mode.

Once all items have been checked in, Change Lock Mode will change the Project 
Book from Pessimistic mode to Optimistic mode, or vice versa.

Unlocking the Project Book

Selecting the Locked? check box for a Project Book record in the Server Table 
places a database-wide lock on that Project Book.

As system administrator or script developer with Admin rights, you can clear 
this check box. If the Project Book also has an exclusive lock placed on it, you 
must release the exclusive lock before you can unlock the Project Book. 
Exclusive- lock maintenance is handled from within the Genesys Agent 
Scripting application.

1. Select the radio button beside the Project Book file in the Server Table 
whose properties you want to modify.

2. Click Unlock Database to clear the database-wide lock on the currently 
selected Project Book.

Why Unlock a Project Book?

When Genesys Agent Scripting is in the process of checking in or checking out 
components, it places a lock on the entire Project Book so that no one else can 
make changes to the project book during its operation. Under normal 
conditions, this lock is acquired and released automatically. However, if a 
user’s machine crashes or the network goes down during the course of a check 
in or check out, this global lock might not be released. In these instances, use 
Collaboration Administration to manually clear this lock.



82 Genesys Agent Scripting 7.2

Chapter 6: Using Genesys Agent Scripting in Collaboration Mode Using Genesys Agent Scripting Collaboration 

Notes: You should only clear a lock manually if it is apparent that the last 
check in or check out failed and is no longer processing. 

Only Project Book-level locks are displayed in the Server Table. You 
must administer more specific locks, such as locks on individual 
Scripts, Pages, Fields, and so on, through the Genesys Agent Scripting 
application.

Exclusive Lock

Selecting the Locked Exclusive? check box for a Project Book record in the 
Server Table locks a Project Book for a user’s exclusive use. In this mode, the 
user does not have to check out individual records to make changes. However, 
the user must check in all changes before releasing the exclusive lock.
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Genesys Integration with 
the ASP.NET (ASPX) 
Platform
Genesys Agent Scripting 7.2 supports Genesys integration with the ASP.NET 
(ASPX) platform. You can create an ASPX target environment for a Project 
Book with the Genesys Agent Interaction Toolkit. 

Please note these requirements:

• To work within the Genesys environment, ASPX Scripts created with the 
Genesys Agent Interaction Toolkit require Genesys Integration Server 
version 7.2 or later.

• For release 7.2, new configuration fields for ASPX target environments 
were added:
 G_NETServer_PrimaryHost
 G_NETServer_PrimaryPort
 G_NETServer_BackupHost
 G_NETServer_BackupPort

To compile a Project Book for the ASPX target environment, you must 
populate these fields with the appropriate information about Genesys 
Integration Server, which is used by ASPX Agent Scripts. 

These fields appear on the Configuration File tab. To access them, choose 
Target Environment from the Compile menu, then select (or create) an 
ASPX target environment, and click on the Configuration File tab.

For detailed information about Genesys Integration Server, refer to the 
Genesys Integration Server Deployment Guide.
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