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Preface
Welcome to the Voice Platform Solution 8.1 Integration Guide. This document 
provides an overview of the Voice Platform Solution (VPS), with an aim to 
integrating the various components that make up the solution—in other words, 
to get the components working together.

What this guide does not cover:

• Deployment procedures—This guide provides step-by-step instructions of 
the changes that need to be made to make the solution work, but not how to 
install or initially configure the individual components. For deployment 
information, consult the respective product Deployment Guides.

• Network integration—Although the call flow scenarios in this guide may 
include third-party components external to the solution, such as gateways 
or a PBX (Private Branch Exchange), this guide does not explain in detail 
the integration of those components with the solution. SIP Server is mostly 
responsible for these network connections, and so for more information 
you should consult the Framework 8.1 SIP Server Deployment Guide.

This document applies to the following solution component versions:

• Genesys Media Server 8.1.6

• SIP Server 8.1.0

• Management Framework 8.1.2

• Genesys Administrator / Genesys Administrator Extension 8.1.3

• Composer 8.1.1

• IVR Server 8.1.0

• Genesys Security Pack 8.1.1

• Genesys Voice Platform (GVP) 8.1.7

This preface contains the following sections:
 About Voice Platform Solution 8.1, page 12

Note: For versions of this document created for other releases of this 
product, visit the Genesys Technical Support website, or request the 
Documentation Library DVD, which you can order by e-mail from 
Genesys Order Management at orderman@genesyslab.com.

mailto:orderman@genesyslab.com
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 Intended Audience, page 12
 Making Comments on This Document, page 13
 Contacting Genesys Technical Support, page 13
 Document Change History, page 13

For information about related resources and about the conventions that are 
used in this document, see the supplementary material starting on page 233.

About Voice Platform Solution 8.1
The Voice Platform Solution 8.1 combines voice self-service, agent-assisted 
service, and application management functions into a single, IP-based contact 
center solution.

Using Voice over Internet Protocol (VoIP) technology, the VPS can process 
incoming IP calls and decide with a high degree of flexibility where and when 
in the call flow to launch voice self-service applications, and when to transfer 
calls to an available agent for customer assistance, using several available 
transfer methods.

The solution combines components from three main Genesys products—
Genesys Voice Platform (GVP) 8.1, SIP Server 8.1, and Management 
Framework 8.1—into one integrated product that supports a variety of call 
flow scenarios. The procedures in this guide include the basic configuration 
steps required to get the various components working together. After the 
components have been integrated, application developers can design the 
routing strategies, voice dialog applications, and call control applications for 
the various call flow scenarios.

Intended Audience
This document is primarily intended for system administrators and system 
integrators. It has been written with the assumption that you have a basic 
understanding of:

• Computer-telephony integration (CTI) concepts, processes, terminology, 
and applications.

• The Session Initiation Protocol (SIP) generally, as well as the integration of 
SIP messaging into the Genesys environment: SIP Server and related 
components.

• Network design and operation.

• Your own network configurations.

This guide also assumes that you:

• Are familiar with the Genesys Management Framework architecture and 
functions that support SIP Server 8.1 and Genesys Voice Platform 8.1.
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• Have already installed and are familiar with SIP Server and related 
components, as well as GVP and its related components.

Making Comments on This Document
If you especially like or dislike anything about this document, feel free to 
e-mail your comments to Techpubs.webadmin@genesyslab.com. 

You can comment on what you regard as specific errors or omissions, and on 
the accuracy, organization, subject matter, or completeness of this document. 
Please limit your comments to the scope of this document only and to the way 
in which the information is presented. Contact your Genesys Account 
Representative or Genesys Technical Support if you have suggestions about 
the product itself.

When you send us comments, you grant Genesys a nonexclusive right to use or 
distribute your comments in any way it believes appropriate, without incurring 
any obligation to you.

Contacting Genesys Technical Support
If you have purchased support directly from Genesys, please contact Genesys 
Customer Care.

Before contacting technical support, please refer to the Genesys Care Program 
Guide for complete contact information and procedures.

Document Change History
This is the first release of the Voice Platform Solution 8.1 Integration Guide 
that contains this section. This section lists content that is new or that has 
changed significantly since the first release of this document. The most recent 
changes appear first.

New in This Document

8.1.7 Chapter 13, “Integrating with SSG,” on page 195:

• Added a warning about Legacy GVPi applications that use attached data to 
the section “Task Summary: SSG Integration, Routing Point Call Flow” on 
page 201.

Appendix B, “Configuration Options,” on page 225:

• Added a note to the option Appendix B, “RPDN,” on page 232.

8.1.6 Chapter 1, “About the Voice Platform Solution,” on page 17:

http://genesyslab.com/support/contact
http://genesyslab.com/support/contact
http://genesyslab.com/support/dl/retrieve/default.asp?item=B3BFC6DABE22B62AAE32A6D31E6396E3&view=item
http://genesyslab.com/support/dl/retrieve/default.asp?item=B3BFC6DABE22B62AAE32A6D31E6396E3&view=item
mailto:techpubs.webadmin@genesyslab.com
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• Modified a Note about REFER limitations on page 20.

Chapter 4, “Supported Call Flow Scenarios,” on page 47:

• Modified a paragraph about REFER limitations on page 55.

Chapter 6, “High Availability,” on page 77:

• Added to the section “HA In Scaled Deployment” on page 81:
 “Solution Level Components and Interfaces” on page 78
 “Configuration, Reporting and Development Tools” on page 78

Chapter 13, “Integrating with SSG,” on page 195:

• Added a note about Paraxip media gateway testing to Table Task Summary:, 
“Integrating the SSG for Outbound Calls,” on page 195.

• Added a note about Paraxip media gateway testing to Table 9, “SIP Server 
Options—TServer Section,” on page 206.

• Added a note about Paraxip media gateway testing to page 209.

Appendix B, “Configuration Options,” on page 225

• Removed section describing SIP Server configuration options. These 
options are described in SIP Server documentation.
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Part

1 Solution Overview
For an overview of the Voice Platform Solution and its various components, as 
well as the kinds of architecture configurations and call flow scenarios that the 
solution supports, see the following chapters:

• Chapter 1, “About the Voice Platform Solution,” on page 17

• Chapter 2, “Supported CTI Through SIP Server Configurations,” on 
page 31

• Chapter 3, “Supported CTI Through IVR Server Configurations,” on 
page 39

• Chapter 4, “Supported Call Flow Scenarios,” on page 47

• Chapter 5, “Hierarchical Multi-Tenant Environments,” on page 63

• Chapter 6, “High Availability,” on page 77

• Chapter 7, “Support for IVR Server,” on page 89

• Chapter 8, “PSTN Connector,” on page 101
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Chapter

1 About the Voice Platform 
Solution
This chapter provides an overview of the Voice Platform Solution (VPS) 8.1 
components, basic component and system architecture, supported call 
scenarios, as well as the steps required to integrate the various components into 
a functioning solution.

This chapter includes the following sections:
 What Is the Voice Platform Solution? page 17
 Features and Benefits, page 19
 About the Components, page 21
 How It Works—The Basic Inbound Call Flow, page 23
 How It Works—The Basic Outbound Call Flow, page 26
 How It Works—CTI in the Solution, page 27
 About Genesys Administrator, page 29

What Is the Voice Platform Solution?
The Voice Platform Solution 8.1 combines voice self-service, agent-assisted 
service, and application management functions into a single, IP-based contact 
center solution.

Using Voice over Internet Protocol (VoIP) technology, the VPS can process 
incoming IP calls and decide with a high degree of flexibility where and when 
in the call flow to launch voice self-service applications, and when to transfer 
calls to an available agent for customer assistance, using several available 
transfer methods.

The solution combines components from three main Genesys products—
Genesys Voice Platform (GVP) 8.1, SIP Server 8.1, and Management 
Framework 8.1—into one integrated product that supports a variety of call 
flow scenarios. The procedures in this guide include the basic configuration 
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steps required to get the various components working together. After the 
components have been integrated, application developers can design the 
routing strategies, voice dialog applications, and call control applications for 
the various call flow scenarios.

Functional Overview

Figure 1 shows the overall VPS functionality. This figure shows functions 
only, not components.

Figure 1: General Functioning of the VPS

The three major functions shown in Figure 1 are:

• SIP Interface—SIP Server provides this function, connecting the solution 
to the external network, and providing call setup and tear down between 
customer and agent endpoints, as well as between the solution components 
themselves. 

• Voice Self-Service—The GVP components provide this function, which 
can include VoiceXML applications, CCXML applications, Speech 
Recognition, Text-to-Speech conversion, and other features during the 
voice dialog portion of the interaction between the calling customer and 
the contact center.

• Assisted-Service—Although not a mandatory part of the solution, 
Universal Routing Server (URS) is used in most supported call flow 
scenarios to provide this function. URS controls the routing strategies that 
deliver the call to an available agent for the assisted-service portion of the 
call, after the voice dialog portion is completed. URS can also launch 
self-service applications on GVP directly from the routing strategy.

• Outbound Calls—GVP can be used as the media server to provide 
services such as call progress detection and media bridging to outbound 
VoiceXML applications. The Supplementary Services Gateway (SSG) 
provides the HTTP interface used to make the outbound call to the 
customer, and connect the customer to the VoiceXML application.

Customer
Endpoint

SIP Interface

Voice Self-
Service

Assisted 
Service

Agent Endpoint
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Features and Benefits
The following lists include the new features for the latest release, as well as the 
main features and benefits of the solution.

What‘s New In VPS 8.1.2

The following list includes the specific high-level features and benefits that are 
new to VPS in release 8.1.2.

• PSTN Connector—For VPS integration with traditional telephony 
environments using Dialog hardware and software. For a sample 
deployment, see “PSTN Connector” on page 101.

• Hierarchical Multi-Tenancy (HMT)—Supports HMT configurations for 
service providers, enabling them to apportion a select number of inbound 
ports for each customer, which provides greater flexibility when enforcing 
policies during service selection. See “Hierarchical Multi-Tenant 
Environments” on page 63.

• Genesys Media Server—Supports the same set of features that were 
previously provided by Genesys Stream Manager (7.x), along with several 
new codec formats for voice delivery associated with outbound calling, 
call parking, call recording, conferencing, and IVR prompting.

• Resource Manager in Active Cluster Configuration—Support for high 
availability (HA) deployments of Resource Manager instances as a pair of 
active servers, for use in HA networks with certain restrictions. See “High 
Availability” on page 77.

Main Features and Benefits

This following list includes the specific high-level features and benefits offered 
by an integrated Voice Platform Solution 8.1.

• Flexible CTI through SIP Server integration—For CTI through SIP Server, 
a single set of integration procedures supports a variety of inbound call 
flow scenarios.

• Flexible CTI through IVR Server integration—For VPS integration with 
IVR Server, an additional set of integration procedures supports inbound 
call flows for IVR-centric voice applications. The CTI Connector provides 
the integration point between the solution and the IVR Server.

• Two methods for launching VoiceXML applications:
 Play Application treatments in the routing strategy (CTI through SIP 

Server only).

Note: For more information, consult the Genesys Media Server 8.1 
Deployment Guide.
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 IVR Profile mapping on the Resource Manager

• Outbound calling through the Supplementary Services Gateway (SSG)—
Independent from the inbound call flow configuration, the VPS with SSG 
provides an HTTP interface for initiating applications with functions 
outside of what is available in VoiceXML and CCXML applications. For 
example, placing a batch of outbound calls using an IVR Profile.

• Multiple methods for transferring calls between the self-service portion of 
the call to the assisted-service portion. These transfer methods include:
 SIP REFER requests
 Bridged transfers
 Media redirect transfers
 Consultation transfers using the SIP REFER with replaces method 

• In CTI through IVR Server configurations, CTI Connector with IVR 
Server provides support for the following:
 Legacy 7.6 GVP voice applications (also called GVPi applications)
 Next Generation Interpreter (NGI) applications with proprietary 

VoiceXML <send> and <receive> tags for direct CTI functionality 
from the voice application.

• CCXML Conferencing

• Speech Recognition—The VPS supports Media Resource Control Protocol 
(MRCP) sessions for speech recognition. This feature requires a third-party 
speech server.

• Text-To-Speech (TTS) technology

• Real-Time Debugging

• High Availability to ensure that services are not interrupted in the event of 
a failure or process restart. For a basic overview of this feature, see 
Chapter 6, “High Availability,” on page 77.

For features and benefits offered by individual components, see the respective 
product Deployment Guide.

Notes: Consultation transfers using the SIP REFER with replaces method 
are not completely supported.

REFER is not supported if the inbound leg is originally pinned on 
a route point (e.g., GVP is configured as a VOIP service DN).

Depending on the design of your VoiceXML application, media 
redirect transfers may require some additional configuration on 
the Media Control Platform. For more information, see 
“Configuring the Solution for Media Redirect Transfers” on 
page 125.
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About the Components
Figure 2 shows the component architecture of the Voice Platform Solution 8.1.

Figure 2: Component Architecture

As shown in Figure 2, the Voice Platform Solution 8.1 includes the following 
components:

• SIP Server—SIP Server provides the network interface for the solution. It 
also provides the CTI link to the T-Library applications used by the 
solution, such as URS and Agent Desktop.

• Media Control Platform (MCP)—This is the core component used to 
deliver the VoiceXML applications that control the voice self-service 
portion of the call. It includes a legacy VoiceXML interpreter (GVPi) and 
a Next Generation Interpreter (NGI). MCP can also be used as the Genesys 
Media Server, replacing Stream Manager to support media streaming 
through the media server markup language (MSML) interface. For more 
information, see the Genesys Media Server 8.1 Deployment Guide.

• Call Control Platform (CCP)—This SIP-based call controller is used to 
deliver CCXML applications. It is an optional component, required only if 
you intend to use CCXML applications in your deployment.
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• Resource Manager (RM)—The Resource Manager controls access and 
routing between the various GVP components. It also acts as a proxy for 
SIP messaging between the GVP components.

• Supplementary Services Gateway (SSG)—The SSG provides an HTTP 
interface for initiating outbound calls to customers, and connecting the 
customer to an outbound VoiceXML application.

• Voice Platform Reporting Server—The Reporting Server collects and 
provides access to data and statistics submitted by VPS components. You 
can also use Reporting Web Services to make the raw data available for 
third-party report generation. 

• Genesys Composer—Composer is an application development tool that 
developers can use to author the VoiceXML applications (design and edit) 
or edit the CCXML applications (edit only, design for CCXML 
applications is unavailable) used by the solution. Although not mandatory 
to the deployment, it is recommended.

• CTI Connector—The CTI Connector provides VPS integration with IVR 
Server in order to support IVR-centric voice applications—including 
legacy GVPi applications and NGI applications with CTI extensions—as 
well as certain switch configurations that require a CTI through IVR 
Server architecture.

• PSTN Connector—The PSTN Connector enables the VPS to integrate 
with Dialogic hardware and software for legacy TDM environments.

• Genesys Media Server—The Genesys Media Server, provided through 
GVP, is used to stream media files in order to provide announcements and 
music to callers queued on Routing Points or ACD queues. This is an 
optional component, required for SIP Server control over the playing of 
announcements or music. For details, see the Genesys Media Server 8.1 
Deployment Guide.

• Management Layer—A number of service components are used to 
provide management capability. You can access the Management Layer 
using either the Solution Control Interface, or Genesys Administrator, a 
web-based interface that lets you start and stop components in the solution, 
monitor their activity, or make configuration changes as required. Where 
possible, the integration procedures in this guide use Genesys 
Administrator. For more information, see “About Genesys Administrator” 
on page 29.

Note: The Voice Platform Solution 8.1 does not require either the Speech 
Server or the Application Server in the deployment. The MCP and 
CCP can execute simple applications that use locally stored 
pre-recorded audio files, instead of the third-party speech or 
application servers.
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How It Works—The Basic Inbound Call 
Flow

In a typical pure-IP deployment, contact center agents are registered on the SIP 
Server (or on a separate T-Server for a hybrid switch). Incoming calls come in 
to SIP Server from the Public Switched Telephony Network (PSTN) through a 
third-party media gateway. Voice self-service is provided to the customer 
through one of three kinds of VoiceXML applications:

• Standard VoiceXML applications—These applications provide voice 
self-service using standard VoiceXML tags. Transfers to the 
assisted-service part of the call can be initiated from the application, using 
the <transfer> tag. Both GVPi and NGI applications are supported.

• URS-centric applications—In these applications, an inbound call arrives at 
a routing strategy first, where the strategy initiates the VoiceXML 
application. After the voice interaction, call control returns to the routing 
strategy for delivery to an agent or other DN. Only NGI applications are 
supported.

• IVR-centric applications—In these applications, the application itself 
controls CTI actions through VPS integration with the IVR Server. These 
mid-call CTI actions can include routing, getting statistics, or attaching 
data. Both GVPi and NGI applications are supported.

Call Delivery to GVP

Depending on how your deployment selects the voice application, the caller is 
connected to the voice self-service application in different ways:

• GVP configured as a Trunk DN—The call arrives on the Trunk DN, where 
GVP is immediately given call control in order to start a standard 
VoiceXML application.

• GVP configured as a Voice Over IP Service DN—The call arrives at a 
Routing Point DN, where a routing strategy uses a Play Application 
treatment to launch a URS-centric voice application, in CTI through SIP 
Server configurations.

• GVP is configured as a series of Voice Treatment Port DNs—The call 
arrives at a Routing Point DN, where a strategy selects a Voice Treatment 
Port DN that the solution uses to launch an IVR-centric voice application. 
This option is only available in CTI through IVR Server configurations.

• GVP is configured as a Trunk DN with port number—In station-side 
connected configurations, the call arrives on the Trunk DN with the port 
number from the PBX that GVP requires to perform DNIS lookup, in CTI 
through IVR Server configurations.
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Call Flow for Standard VoiceXML Applications

For Standard VoiceXML applications, the call reaches GVP through a SIP 
Server Trunk DN, and the MCP launches a VoiceXML application as mapped 
on the Resource Manager through IVR Profiles. Several transfer methods are 
available to transfer the call from GVP to the Routing Point, where the routing 
strategy can instruct URS to launch additional VoiceXML applications or 
deliver the call to an available agent.

Figure 3 shows the basic call flow for a standard VoiceXML application.

Figure 3: Basic Standard VoiceXML Application Call Flow

Call Flow for URS-centric Applications

In CTI through SIP Server configurations, you can design URS-centric voice 
applications, where the call reaches the routing point first, and the URS 
(according to the routing strategy) can initiate a simple VoiceXML application 
on GVP as follows:

1. URS sends a TApplyTreatment request of the type 
TreatmentPlayApplication to SIP Server.

2. SIP Server sends an INVITE to GVP—specifically to the Resource 
Manager.

3. MCP launches the actual VoiceXML application.

In this case, the VoiceXML application does not initiate call transfers. After 
the voice self-service interaction is completed, control of the call returns to the 
URS, where the routing strategy can then determine where to route the call.

Figure 4 on page 25 shows the basic call flow for a URS-centric application.
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Figure 4: Basic URS-centric Application Call Flow

Note: This method for initiating applications is only available for CTI 
through SIP Server configurations. This method is not available for 
VPS integrations with CTI Connector and IVR Server.

Call Flow for IVR-centric Applications

In CTI through IVR Server configurations, the incoming call arrives at a 
Routing Point DN, where the strategy selects an IVR port configured as a 
Voice Treatment Port DN. SIP Server sends this port number to the Resource 
Manager, so that it can then send this info to CTI Connector and IVR Server to 
obtain call information (for example, ANI, DNIS, and UUID). After the CTI 
Connector receives the call details, it sends an INVITE to the Resource Manager 
with the DNIS required to map the IVR Profile and launch the voice 
application.

An exception is in a station side-connected configuration, where the PBX 
sends the port number through the Media Gateway as the DN (requires 
configuration on the Media Gateway). The call arrives on a Trunk DN 
configured for the port number provided by the PBX. This port number is 
forwarded to the CTI Connector for DNIS lookup before IVR Profile mapping 
can take place. Figure 5 on page 26 shows the basic call flow for a typical 
IVR-centric application.
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Figure 5: Basic IVR-Centric Application Call Flow

How It Works—The Basic Outbound Call 
Flow

To support outbound dialing, the VPS includes the Supplementary Services 
Gateway (SSG), an HTTP interface that can manage the initiation of outbound 
calls, either singly or in bulk, and connect the called number to a Standard 
VoiceXML application.

To initiate a call, a third-party “trigger” application (TA) sends CreateCall 
attributes in an HTTP POST request to the SSG. The SSG translates certain 
required parameters into Extensions attributes that it then includes in the 
TMakePredictiveCall request that it sends to SIP Server. These attributes can 
include Call Progress Detection (CPD) control parameters, used to determine 
the status of the called number—answering machine, fax, or voice—before 
connecting the called number with a particular voice application, as identified 
in the IVR Profile included in the HTTP POST.

Figure 6 on page 27 shows the basic call flow for a TA-initiated outbound call.
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Figure 6: Basic Outbound Call Flow

Some key considerations about this call flow:

• For outbound calls, GVP is configured as a Trunk Group DN. SIP Server 
sends the INVITE to the outbound customer from this DN.

Starting in 812, outbound calls can also be configured to go through a 
Routing Point DN (as an alternative to the Trunk Group configuration), for 
legacy deployments where GVP is configured as a series of Voice 
Treatment Ports.

• If CPD parameters are not specified in the HTTP POST request, the default 
parameters in the SIP Server application are used instead.

• If CPD is configured on both the media gateway and the MCP, then the 
media gateway will be used.

How It Works—CTI in the Solution
Depending on the needs of your deployment, the Voice Platform Solution 
provides computer-telephony integration (CTI) with the larger Genesys suite 
either through the SIP Server or through the IVR Server. 

The three basic configurations as they relate to CTI in the solution are:
 Voice Platform Only (no CTI), page 28
 CTI Through SIP Server, page 28
 CTI Through IVR Server, page 28
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Voice Platform Only (no CTI)

Suitable for small or medium Enterprise deployments that do not have any 
agents to service, and so do not require a full computer-telephony integration 
with the larger Genesys suite. SIP Server is still included in the deployment, 
though its CTI capability is not in use. In this case, you do not need to include 
CTI Connector or IVR Server in the deployment.

Voice platform-only configurations support only standard VoiceXML 
applications.

Note: For most switch configurations, SIP Server is able to provide CTI 
functionality should your deployment later require the addition of, for 
example, Universal Routing Server for VPS transfers to agents or 
workstations within the enterprise.

CTI Through SIP Server

Suitable for most IP-only contact center deployments, CTI through SIP Server 
configurations support the following types of applications:

• Standard VoiceXML applications

• URS-controlled applications

In deployments that use SIP Server for the CTI link to the larger Genesys suite, 
Genesys recommends that you develop your applications for voice self-service 
only, with all CTI functionality provided by the URS routing strategy. 
IVR-centric applications are not available in this configuration.

For detailed descriptions and call flow diagrams, see the following chapter:

• Chapter 2, “Supported CTI Through SIP Server Configurations,” on 
page 31

CTI Through IVR Server

Suitable for deployments that require backwards compatibility for legacy voice 
applications, or in switch configurations where SIP Server cannot provide the 
CTI connection to the larger suite, CTI through IVR Server configurations 
support the following types of applications:

• Standard VoiceXML applications

• IVR-centric applications

URS-controlled applications are not available in this configuration.

For detailed descriptions and call flow diagrams, see the following chapter:

• Chapter 3, “Supported CTI Through IVR Server Configurations,” on 
page 39.
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About Genesys Administrator
Genesys Administrator is a Web-based user interface for the management and 
configuration of Genesys components.

Use Genesys Administrator to deploy, configure, provision, and monitor the 
solution.

To access Genesys Administrator in your Genesys deployment, go to the 
following URL:

http://<Genesys Administrator host>/wcm

For more information about deploying or using Genesys Administrator, consult 
the following:

• Framework 8.1 Genesys Administrator Deployment Guide

• Framework 8.1 Genesys Administrator Help
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Chapter

2 Supported CTI Through SIP 
Server Configurations
The Voice Platform Solution (VPS) 8.1 supports a number of configurations 
where CTI is provided by SIP Server only (CTI Connector is not used). The 
diagrams and descriptions in this chapter demonstrate some of the more 
common CTI through SIP Server configurations, describing the kinds of voice 
applications each configuration supports, as well as the methods used to 
deliver CTI.

This chapter includes the following configurations:
 PBX Trunk-Side Connection, page 31
 Carrier-Connected Architecture, page 33
 Carrier-Connected—Voice Treatment Port Configuration, page 35
 Pure IP Configuration, page 36
 Outbound Calls Using SSG, page 38

PBX Trunk-Side Connection
Figure 7 on page 32 shows a PBX architecture configuration, where CTI is 
provided through SIP Server.
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Figure 7: PBX Trunk-Side Connection, CTI Through SIP Server

In this architecture, the VPS is integrated with either a Time-Division 
Multiplexing (TDM) or Internet Protocol (IP) Private Branch Exchange 
(PBX). With an IP PBX, a direct trunk connection to the SIP Server is used. 
For more detail about the difference between TDM and IP PBX configurations, 
see “REFER Transfers to Agents on a PBX” on page 53.

For this architecture, you can build the following kinds of applications:

• URS-centric applications

• Standard VoiceXML applications

Incoming Calls

Incoming calls arrive at the VPS differently, depending on the kind of initial 
application invoked.
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executes the application—customer data is collected, then returned to SIP 
Server in the BYE message. The routing strategy receives the attached data and 
determines the next action for the call.

Standard VoiceXML Applications

For a Standard VoiceXML application, the inbound call is forwarded to GVP 
directly through the Trunk DN to execute the self-service application. When 
the VoiceXML application determines that the call should be transferred to an 
agent, it executes the <transfer> tag (using SIP REFER) in order to transfer the 
call to a Routing Point DN on the SIP Server switch. After the transfer to SIP 
Server, the URS routing strategy takes control of the call (the call is considered 
parked on URS). The strategy initiates call treatments before transferring the 
call to an agent. To make the transfer, SIP Server communicates with the 
premise T-Server through Inter Server Call Control (ISCC) and sends a REFER 
request to the media gateway (or directly to the trunk for an IP PBX). This 
completes the transfer.

Outbound Calls

In this architecture, outbound calls are initiated using a trigger application 
through the SSG. The call is placed to GVP through either a Trunk Group DN 
or a Routing Point DN, depending on the kind of voice application used to 
connect with the called party. For more information, see “Outbound Calls 
Using SSG” on page 38.

Carrier-Connected Architecture
Figure 8 on page 34 shows a carrier-connected architecture configuration, 
where CTI is provided through SIP Server, and the agents are located 
off-premises.
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Figure 8: Carrier Connected, CTI Through SIP Server

In a carrier-connected architecture, the VPS and agents may reside on different 
premises. In this case, transfers from the VPS to an agent are made through 
ISCC communication with SIP Server on the VPS side, and with the premise 
T-Server for the site where the agents are located.

This architecture supports the following kinds of applications (as described for 
PBX trunk-side connected configurations):

• URS-centric applications

• Standard VoiceXML applications

Incoming Calls

Incoming calls arrive at the VPS differently, depending on the kind of initial 
application invoked: 

• For URS-centric applications, see “URS-centric Applications” on page 32

• For Standard VoiceXML applications, see “Standard VoiceXML 
Applications” on page 33.
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Outbound Calls

In this architecture, outbound calls are initiated using a trigger application 
through the SSG. The call is placed to GVP through either a Trunk Group DN 
or a Routing Point DN, depending on the kind of voice application used to 
connect with the called party. For more information, see “Outbound Calls 
Using SSG” on page 38.

Carrier-Connected—Voice Treatment Port 
Configuration

Figure 9 shows a carrier-connected configuration for legacy GVP customers, 
where GVP is configured as a series of Voice Treatment Port DNs.

Figure 9: PBX—GVP Configures as Voice Treatment Port DNs

In this configuration, GVP acts only as an IVR when incoming calls are routed 
to the Voice Treatment Port DNs. At the same time, GVP can also act as the 
media server for all other Voice over IP services configured on SIP Server—
SIP Server can use GVP as both an IVR and media server for the same call 
session.
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This architecture supports the following type of application only:

• Standard VoiceXML applications

Incoming Calls

Inbound calls arrive at a Routing Point DN. The strategy routes the call to a 
Place Group, where the individual Places are configured as a set of Voice 
Treatment Port DNs. When routed to this Place Group, SIP Server selects a 
port and forwards it to Resource manager. Resource Manager selects an IVR 
Profile for a particular VoiceXML application, based on the DNIS provided in 
the To header of the original INVITE.

Transferring the Inbound Call

When the VoiceXML application determines that the call should be transferred 
to an agent, it can execute the <transfer> tag (using SIP REFER) in order to 
transfer the call to a DN on the SIP Server. For example, a Routing Point DN, 
where a second routing strategy can request that GVP—acting as a media 
server—supply call treatments while the customer is parked on the Routing 
Point DN, awaiting transfer to an available contact center agent.

Outbound Calls

In this architecture, outbound calls are initiated using a trigger application 
through the SSG, and the call is placed to GVP through a Routing Point DN. 
SIP Server sends an INVITE to GVP as the media server (Voice over IP 
Service DN with service-type set to msml). If the HTTP request specifies 
CPD, then CPD can be performed on the media server. After CPD, if the called 
line is determined to be suitable, the routing strategy can select a Place Group 
to determine the Voice Treatment Port DN that will be sent in the INVITE to 
Resource Manager, in order to select the IVR Profile for the voice application 
to be connected to the customer. After the initial customer interaction, the 
application can use the VoiceXML <transfer> tag to deliver the call to a 
destination—for example, a Routing Point DN for agent queuing. You can 
also use direct CTI from the application to transfer the call.

Pure IP Configuration
Figure 10 on page 37 shows a pure-IP configuration where SIP Server acts as 
both a T-Server and as a SIP switch to which the contact center agent registers. 
GVP is configured as a Trunk DN and can act as a media server.
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Figure 10: Pure IP Configuration

This architecture supports the following types of applications:

• URS-centric applications

• Standard VoiceXML applications

Incoming Calls

Incoming calls arrive at the VPS differently, depending on the kind of initial 
application invoked: 
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Applications” on page 33.
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or a Routing Point DN, depending on the kind of voice application used to 
connect with the called party. For more information, see “Outbound Calls 
Using SSG” on page 38.

Outbound Calls Using SSG
In CTI through SIP Server architectures, outbound calls are made through 
either a Trunk Group DN or a Routing Point DN, depending on the kind of 
voice application used to connect with the called party.

NGI Applications—Trunk Group Call Flow

For NGI applications, SIP Server sends the outbound INVITE through a Trunk 
Group DN configured for MSML communication to GVP. SIP Server can apply 
call progress detection (CPD) on the media gateway. After CPD, if the called 
line is determined to be suitable, it is connected to the voice application.

GVPi Applications—Routing Point Call Flow

For GVPi applications, SIP Server places the originating call leg on a Routing 
Point DN. SIP Server sends an INVITE to GVP as the media server (Voice over 
IP Service DN with service-type set to msml). If the HTTP request specifies 
CPD, then CPD can be performed on the media server. After CPD, if the called 
line is determined to be suitable, the routing strategy can select a Place Group 
to determine the Voice Treatment Port DN that will be sent in the INVITE to 
Resource Manager, in order to select the IVR Profile for the voice application 
to be connected to the customer.

Transferring the Call

After the initial customer interaction, the application can use the VoiceXML 
<transfer> tag to deliver the call to a destination—for example, a Routing 
Point DN for agent queuing. 

Note: For information about how to integrate SSG into the solution, see 
Chapter 13, “Integrating with SSG,” on page 195.
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3 Supported CTI Through IVR 
Server Configurations
The Voice Platform Solution (VPS) 8.1 supports a number of configurations 
where CTI is provided through the IVR Server, with CTI Connector providing 
the link between GVP and the rest of the Genesys suite. The diagrams and 
descriptions in this chapter demonstrate some of the more common CTI 
through IVR Server architectures, describing the kinds of voice applications 
each architecture supports, as well as the methods used to deliver CTI.

This chapter includes the following sections:
 Carrier-Connected, CTI Through IVR Server, page 39
 Station Side-Connected, CTI Through IVR Server, page 43
 Outbound Calls Using SSG, page 45

Carrier-Connected, CTI Through IVR 
Server

Figure 11 on page 40 shows a carrier connected architecture configuration, 
where CTI is provided through IVR Server, and the agents are located 
off-premise.

In this architecture, the VPS is integrated with an IVR Server configured for 
Behind mode operation. To facilitate this integration, an additional VPS 
component is required—CTI Connector. For a detailed call flow of an 
integration with IVR Server in Behind mode, see “Integration with IVR 
Server—Behind Mode” on page 90.
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Figure 11: Carrier Connected, CTI Through IVR Server
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the following kinds of applications:
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The VoiceXML application maintains control of the call while the caller 
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Incoming Calls

In this architecture, the VPS can be configured to flag the gateway resource for 
the SIP Server, as well as the IVR Profile for the voice application, so that the 
call will be sent through IVR Server—for applications that require CTI 
through IVR Server functionality; it can also be configured to bypass the IVR 
Server for voice-only applications that do not required direct CTI functionality 
from the application itself.

Note: To configure this functionality, see “Configuring CTI Flagging for IVR 
Profiles” on page 188.

Incoming Call for an Application with CTI Functionality

For applications that include direct CTI functionality, the incoming call arrives 
at a Routing Point DN on the SIP Server switch, where a routing strategy 
selects a Place object mapped to a Voice Treatment Port DN. This operation 
selects the IVR port that SIP Server includes as the user part of the request URI 
in the INVITE message that it sends to Resource Manager. CTI Connector, 
through IVR Server, performs the DNIS lookup and provides the Resource 
Manager with the DNIS it needs in order to map the IVR Profile for the 
destination voice application.

Incoming Call for a Self-Service Application (No CTI)

For voice-only applications with no direct CTI, the incoming call arrives at 
GVP through a Trunk DN on the SIP Server switch. SIP Server does not select 
a Voice Treatment Port DN at this time. Based on CTI flagging, the Resource 
Manager forwards the INVITE from SIP Server to MCP directly, instead of 
going through CTI Connector. The VoiceXML application cannot perform any 
CTI functionality.

Transfers

For Standard VoiceXML applications, this architecture supports both blind 
(REFER) and bridge (INVITE) transfers. For IVR-centric applications, this 
architecture supports blind transfers through CTI link or through SIP, as well 
as bridge transfers through SIP.

Standard VoiceXML Applications

Transfers from Standard VoiceXML applications work in this configuration as 
follows:

• Blind transfer to an agent—The application uses the <transfer> tag to 
initiate a REFER transfer from the voice self-service portion of the call to the 
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agent-assisted portion. When the agent is ready to receive the caller, the 
IVR Server sends a route number to CTI Connector, and CTI Connector 
sends a REFER request to the SIP Server. The media gateway negotiates the 
transfer from the VPS site, through the PSTN, to the site where the agent is 
located. For a more detailed description of the setup for these transfers, see 
“Standard VoiceXML Applications—REFER” on page 97.

• Bridge transfer to an agent—The application also uses the <transfer> tag. 
In this case, CTI Connector receives an INVITE request for a bridged 
transfer. For a more detailed description, see “Standard VoiceXML 
Applications—Bridge Transfer” on page 98. 

IVR-centric Applications

After the IVR phase of the call, the RouteRequest block in the IVR-centric 
application can be used to send a request through CTI Connector to find an 
agent. CTI Connector acts as a SIP back-to-back user agent (B2BUA), 
remaining in the call path until the transfer to the agent is complete.

Transfers from IVR-centric applications work in this configuration as follows:

Blind transfer Blind transfers in IVR-centric applications have two distinct steps:

1. CTI—A RouteRequest block in the VoiceXML application obtains a route 
number.

2. REFER transfer or OneStepXfer—Once the route number is known, the 
VoiceXML application uses <transfer> to perform the actual call transfer. 
MCP sends a REFER message to CTI Connector. CTI Connector can choose, 
based on the IVR Profile, whether to pass the REFER to SIP Server and the 
gateway to complete the transfer, or to use OneStepXfer for a CTI transfer 
through IVR Server to a ready agent.

In a carrier-connected deployment, the REFER through SIP Server method 
would typically be used; however, OneStepXfer is also supported.

Note: If the connection between SIP Server and the premise T-Server is 
through ISCC, then transfers through CTI require the use of 
AccessNumGet block in the VoiceXML application. For more 
information, see “Enabling Midcall CTI Routing (IVR-centric 
Applications)” on page 191. 

Bridge transfer If the IVR-centric application is configured for a bridge transfer, MCP sends 
an INVITE through Resource Manager to CTI Connector, requesting a bridge 
transfer. When the agent is ready, CTI Connector obtains the agent DN, sends 
an INVITE to the SIP Server, and bridges the call to the ready agent.

Configuring IVR-centric Transfers

For detailed information about configuring IVR Profiles for these various 
transfers, see “Task Summary: Configuring Transfers” on page 163.
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Outbound Calls

In this architecture, outbound calls are initiated using a trigger application 
through the SSG. The call is placed to GVP through a Routing Point DN. For 
more information, see “Outbound Calls Using SSG” on page 45.

Station Side-Connected, CTI Through IVR 
Server

Figure 12 shows a VPS integration with a PBX that does not support 
trunk-side connections, but that requires a station-side port connection instead.

Figure 12: PBX Station Side-Connected, CTI Through IVR Server

In this architecture, the PBX forwards the incoming call to the media gateway 
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forwards the call to CTI Connector, so that the call can be registered through 
the IVR Server. 

This architecture supports the following kinds of applications:

• Standard VoiceXML applications

• IVR-centric applications

Note: For the relevant procedures for this configuration, see “Task Summary: 
IVR Behind, TDM-Connected Integration” on page 151.

Incoming Calls

A Trunk DN is required for every incoming port number from the PBX. The 
media gateway forwards the port number in the INVITE to the SIP Server. CTI 
Connector, through IVR Server, uses this port number to request the DNIS for 
the call. CTI Connector then sends the DNIS in an INVITE to the Resource 
Manager, for IVR Profile mapping to the voice application.

Note: In this architecture, all calls must go through CTI Connector. 
Configure the gateway resource so that CTI usage is set to Always On 
(use-cti=1)

Transfers

For Standard VoiceXML applications, this architecture supports both blind 
(REFER) and bridge (INVITE) transfers. For IVR-centric applications, this 
architecture supports blind transfers through CTI link, as well as bridge 
transfers through SIP. Blind transfers through SIP Server are not available for 
this configuration.

Standard VoiceXML Applications

Transfers from Standard VoiceXML applications work in this configuration as 
follows:

• Blind transfer to an agent—The application uses the <transfer> tag to 
initiate a REFER transfer from the voice self-service portion of the call to the 
agent-assisted portion. When the agent is ready, the IVR Server sends a 
route number to CTI Connector, CTI Connector initiates a CTI transfer to 
the premise T-Server through the IVR Server, and the PBX connects the 
caller to the agent directly. For a more detailed description of the setup for 
these transfers, see “Standard VoiceXML Applications—REFER” on 
page 97.

• Bridge transfer to an agent—The application also uses the <transfer> tag. 
In this case, CTI Connector receives an INVITE requesting a bridged 
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transfer. For a more detailed description, see “Standard VoiceXML 
Applications—Bridge Transfer” on page 98.

IVR-centric Applications

After the IVR phase of the call, an IVR-centric application can send a request 
through CTI Connector to find an agent. CTI Connector acts as a SIP B2BUA, 
remaining in the call path until the transfer to the agent is complete.

Transfers from IVR-centric application work in this configuration as follows:

• Blind transfers through CTI—In configurations with IVR Server in Behind 
mode, the application can initiate REFER transfers through IVR Server by 
using the OneStepxfer request. In this case, if the application is configured 
to use IVR Server (CTI Transfer in the IVR Profile is set to true), when an 
agent is ready, the application retrieves the agent number and MCP sends a 
REFER to CTI Connector. Instead of passing the REFER to the media gateway, 
CTI Connector performs a CTI transfer using the IVR XML OneStepXfer 
message, and the PBX connects the caller to the agent directly. For a more 
detailed description of the setup for these transfers, see “IVR-centric 
Applications—REFER Transfer” on page 98. 

• Bridge transfers—If the IVR-centric application is configured for a bridge 
transfer, MCP sends an INVITE through Resource Manager to CTI 
Connector, requesting a bridge transfer. CTI Connector sends a 
RouteRequest to the IVR Server. When the agent is ready, IVR Server 
returns a route number, and CTI Connector sends an INVITE to the SIP 
Server and bridges the call to the ready agent.

Outbound Calls

In this architecture, outbound calls are initiated using a trigger application 
through the SSG. The call is placed to GVP through a Routing Point DN. For 
more information, see “Outbound Calls Using SSG”.

Outbound Calls Using SSG
In CTI through IVR Server architectures, SIP Server places the originating call 
leg on a Routing Point DN. SIP Server sends an INVITE to GVP as the media 
server (Voice over IP Service DN with service-type set to msml). If the 
HTTP request specifies CPD, then CPD can be performed on the media server. 
After CPD, if the called line is determined to be suitable, the routing strategy 
can select a Place Group to determine the Voice Treatment Port DN that will 
be sent in the INVITE to Resource Manager, in order to select the IVR Profile 
for the voice application to be connected to the customer.
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Transferring the Call

After the initial customer interaction, you can also use direct CTI from the 
application to transfer the call.

Note: For information about how to integrate SSG into the solution, see 
Chapter 13, “Integrating with SSG,” on page 195.
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Chapter

4 Supported Call Flow 
Scenarios
The Voice Platform Solution 8.1 supports a variety of transfer types, call 
features, and integrations with different Genesys or third-party components. 
The diagrams in this chapter demonstrate how the call behaves for some of the 
more common call flow scenarios. Application developers can design the URS 
routing strategies and VoiceXML/CCXML applications to accommodate these 
scenarios.

Some common call flow scenarios used by the solution include:
 URS-Centric Voice Applications, page 48
 Transfer Types, page 49
 CCXML, page 55
 Speech Recognition, page 56
 Cisco CallManager, page 57
 Outbound Calls, page 58
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URS-Centric Voice Applications
Figure 13 shows a basic configuration that supports the URS method for 
launching the voice self-service application.

Figure 13: URS Starts the VoiceXML Application—Basic Configuration

In this IP-based scenario, the incoming call reaches a Routing Point DN on the 
SIP Server. In the URS strategy loaded on the routing point, a Play Application 
treatment launches the self-service application on GVP. For each treatment, 
GVP collects prompts from the user and attaches application data along with 
the BYE request. After the treatment is finished, URS retakes control of the call, 
at which point it can either execute more Play Application treatments, or route 
the call to an available agent. The MCP treats any additional treatment from 
URS as a new SIP call.

Note: When you design a self-service application that is intended for launch 
from a URS routing strategy, do not include any <transfer> tags in the 
application. GVP cannot execute call control operations in a Play 
Application treatment.
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Transfer Types
Supported transfer types included:

• “REFER Transfers to Agents on SIP Server”

• “Bridged Transfers to Agents on SIP Server”

• “Media Redirect Transfers to Agents on SIP Server”

• “REFER Transfers to Agents on a PBX”

• “GVP Launches the REFER with Replaces Transfer Method”

Note: For detailed information about SIP Server behavior and configuration 
for REFER transfers, consult the “Call Transfer and Conference” section 
of the Framework 8.1 SIP Server Deployment Guide. That section 
includes descriptions of how the following options are used:
• refer-enabled
• oosp-transfer-enabled
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REFER Transfers to Agents on SIP Server

Figure 14 shows a basic configuration where GVP initiates a blind transfer to 
an agent registered on the SIP Server.

Figure 14: Blind Transfer—Basic Configuration

In this IP-based scenario, the incoming call is forwarded directly to GVP 
(configured as a Trunk DN on the SIP Server switch), which then executes the 
initial greeting prompts in a VoiceXML application. When the application 
decides to transfer the call to an agent, the application executes the <transfer> 
tag, which uses a REFER request to execute a blind transfer of the call to a 
Routing Point DN (or any other DN) on the SIP Server. After SIP Server 
receives the call, the URS strategy takes control and can route the call to an 
agent who is registered on the SIP Server or other T-Server. After the REFER 
transfer is accepted, the call is considered parked at the URS strategy.

Bridged Transfers to Agents on SIP Server

Figure 15 on page 51 shows a basic configuration where GVP initiates a 
bridged transfer to an agent registered on the SIP switch.
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Figure 15: Bridged Transfer—Basic Configuration

In this scenario, the VoiceXML application initiates a bridged transfer to an 
agent by transferring the call to a Routing Point DN on the SIP switch. While 
the call is being transferred to the agent, SIP Server parks the call on GVP, at 
which point the URS routing strategy launches a Play Application treatment. 
After the treatment is finished, SIP Server receives the DN number for the 
agent and sends an INVITE request to both the agent and the bridged call leg 
simultaneously. This connects the call to the agent. After the call with the agent 
is completed, the VoiceXML application can continue the voice dialog to 
complete the call.

Note: Figure 15 shows two instances of the SIP Server, to demonstrate the 
call path when the caller is connected to the agent; it shows the second 
SIP dialog established between the MCP and SIP Server during the 
bridged transfer.

Media Redirect Transfers to Agents on SIP Server

Figure 16 on page 52 shows a basic configuration where GVP initiates a media 
redirect transfer to an agent registered on the SIP switch.
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Figure 16: Media Redirect Transfer—Basic Configuration

In this scenario, the VoiceXML application initiates a media redirect transfer 
to an agent on the SIP Server. Similarly to the bridged transfer, the call is 
considered parked on the GVP until the transfer is completed. If the agent 
hangs up the call, the VoiceXML application can continue the voice dialog 
with the customer—to play further prompts, for example.

The main difference between a media redirect transfer and a bridged transfer is 
that during a media redirect transfer, the RTP media path is established directly 
between the customer endpoint and the agent endpoint—the MCP does not 
bridge the media path. After the transfer is completed, the MCP sends a 
re-INVITE to the customer endpoint to get the media stream back to the MCP. If 
the transfer fails, the MCP can continue the current VoiceXML dialog to 
complete the call.

Note: Figure 16 shows two instances of the SIP Server, to demonstrate the 
second SIP dialog established between the MCP and SIP Server during 
the media redirect transfer.

Special Configuration

For Media Redirect transfers, you must either change the default transfer type 
in MCP to mediaredirect, or configure the <transfer> tag in the VoiceXML 
application with the appropriate gvp extensions. For configuration details, see 
“Configuring the Solution for Media Redirect Transfers” on page 125.
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REFER Transfers to Agents on a PBX

Figure 17 shows a configuration that includes a Private Branch Exchange 
(PBX) in an enterprise deployment.

Figure 17: Enterprise PBX—Basic Configuration

In this scenario, GVP sits behind an IP PBX, and the PBX can direct calls to 
the VPS using a SIP trunk to the SIP Server. Agents are registered as telephone 
extensions on the PBX.
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to SIP Server through the media gateway.
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application can transfer the call to an agent by invoking a blind transfer with 
REFER on the MCP, at which point the MCP also attaches application data to the 
REFER request.

The URS strategy can then use Play Application treatments to launch further 
prompts, or it can transfer the call to the routing point on the PBX—the 
premise T-Server performs an Inter Server Call Control (ISCC) transfer from 
the SIP Server to an available agent and completes the call.

In the second method, SIP Server receives the call from the PBX and then 
recognizes the DID number as matching the routing point, at which point the 
URS strategy takes control of the call. The strategy can use Play Application 
treatments to launch VoiceXML applications. The application can collect 
customer information, and the MCP attaches that data to the BYE message.

GVP Launches the REFER with Replaces Transfer Method

Figure 18 shows a configuration where the MCP performs a consultation 
transfer using the REFER with replaces method.

Figure 18: REFER with replaces—Basic Configuration

In this scenario, the VoiceXML application initiates a transfer, at which point 
the MCP sends a consultation call to the destination DN. After the SIP dialog 
is established, the MCP sends a REFER with replaces request to the originating 
DN to merge the original and consultation calls. If the originating DN is 
connected through a media gateway, the outbound call to the destination DN 
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must land on the same media gateway as well. Resource Manager ensures that 
this happens.

Figure 18 on page 54 shows the call state where the MCP has reached the 
destination DN, but just before it sends the REFER with replaces request to the 
originating party. After call establishment is completed, MCP is no longer 
involved in either call, as both calls then reside on the media gateway.

Note: In Figure 18, SIP Server is involved in passing the REFER with 
replaces messages from MCP to merge these calls; however, to 
simplify the call flow, those parts of the flow are not included in the 
diagram.

Limitation

Consultation transfers using the SIP REFER with replaces method are not 
completely supported.

REFER is not supported if the inbound leg is originally pinned on a route point 
(e.g., GVP is configured as a VOIP service DN).

CCXML
Figure 19 shows an example of third party call control involving a CCXML 
application.

Figure 19: CCXML Conferencing—Basic Configuration
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In this scenario, SIP Server forwards the incoming call to GVP, at which point 
the Resource Manager maps the DID number to a CCXML application. The 
RM then forwards the call to the Call Control Platform (CCP), which executes 
the CCXML application. The application starts a conference call with the 
MCP. CCP establishes the media session between the originating DN and the 
conference call. At the same time, the CCXML application starts a new voice 
dialog with the MCP, which allows the application to join the media output 
from the voice dialog to the conference call. The CCP makes a call to a routing 
point on the SIP Server, at which point the URS strategy takes control and 
routes the call to the agent. The CCP adds the media path with the agent to the 
conference. After the call is established, the originating DN, the VoiceXML 
dialog, and the agent are all joined in the conference.

Note: Only GVP can initiate conferences from the CCXML application. In 
cases where the URS routing strategy Play Application treatment calls 
a CCXML application, that application cannot include any requests for 
conferences.

Speech Recognition
Figure 20 shows a scenario where MCP establishes a Media Resource Control 
Protocol (MRCP) session for speech recognition.

Figure 20: Speech Recognition—Basic Configuration

In this scenario, the MCP establishes a SIP dialog directly with the third-party 
speech server to establish an MRCP session for speech recognition. The SIP 
dialog establishes the RTP media path between the MCP and the speech server 
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so that speech can be recognized, and between the MCP and the media 
gateway so that it can play prompts for the caller.

Cisco CallManager
Figure 21 shows a configuration that includes the Cisco CallManager (CCM) 
in an enterprise deployment.

Figure 21: VPS Integration with Cisco CallManager

In this scenario, the Voice Platform Solution is integrated with the Cisco 
CallManager (CCM), an IP telephony call-processing system that acts as both 
a softswitch, with control over the media gateway for routing incoming calls, 
and as a PBX, with enterprise agents registering with the CCM.

Note: The CCM does not support line-side connections. You must configure 
a SIP trunk connection for the VPS on the CCM. For information about 
configuring CCM, consult the Cisco-specific documentation Cisco 
CallManager System Guide and the Cisco CallManager Administration 
Guide.
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Outbound Calls
Supported outbound call flows include:

• “Outbound Calls Using the Supplementary Services Gateway”

• “Outbound Calls Using Remote Dialer Service”

• “Outbound Calls Using CCP”

Outbound Calls Using the Supplementary Services Gateway

Figure 22 shows an outbound call scenario initiated by a trigger application 
and controlled by the Supplementary Services Gateway (SSG).

Figure 22: Outbound Call Initiated Using SSG

In this scenario, a trigger application sends an HTTP POST request with the 
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Making Calls Through a Trunk Group DN

Depending on the call scenario, SIP Server will send calls initiated by SSG to 
GVP through either a Trunk Group DN or a Routing Point DN.

The Trunk Group DN call flow is used for the following scenarios:

• CTI through SIP Server, where NGI applications are used.

Making Calls Through a Routing Point

For other scenarios, the outbound call from SSG must go through a Routing 
Point, with GVP configured as a series of Voice Treatment Port DNs. These 
scenarios include:

• CTI through IVR Server integrations. CTI Connector cannot process 
MSML INVITE requests. For deployments that include CTI Connector, 
you must configure VPS to support this call flow.

• Legacy GVPi applications. The Media Control Platform cannot process 
GVPi applications in an MSML scenario. If you want the outbound call to 
connect customers to legacy a GVPi application, you must configure VPS 
to support the Routing Point call flow.

Outbound Calls Using Remote Dialer Service

Figure 23 shows an outbound call scenario initiated by the Remote Dialer 
(remdial) service provided by the Media Control Platform. This scenario is 
supported by any configuration in which the solution is able to make an 
outbound call to the network.

Figure 23: Outbound Call Initiated Using the Remdial Service

Note: To configure VPS for either call flow, see Chapter 13, “Integrating 
with SSG,” on page 195.
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With the remote dial service, you can use a Telnet command-line interface to 
connect to a preconfigured remote dialing port in order to place outbound calls.

Basic Remote Dialing

In basic remote dialing—where no Call Progress Analysis (CPA) is 
performed—the user sends a remote dial service request from a telnet session. 
The telnet command takes the following format:
call <telno> <ani> <url> <refno> [uuidata] [defaults] [parameter_list]

For example:
call 6796500 65 file://C:/samples/main.vxml 205

Table 1 describes these command parameters in more detail.

On receiving the request, MCP loads the specified VoiceXML page and sends 
an INVITE to the Resource Manager. Resource Manager forwards the INVITE to 
SIP Server, which then routes the call to the media gateway, and from there to 
the destination specified in the request. An RTP media stream is established 
between the destination and MCP—the customer begins interaction with the 
VoiceXML page.

For information about configuring remote dialing—including the required 
semantics for making the request—see the chapter “Enabling Outbound 
Dialing” in the Genesys Voice Platform 8.1 User’s Guide.

Table 1: Remote Dialing Command Parameters

Parameter Description

<telno> This can be any request URI, but MCP will generate a call 
through Resource Manager only.

<ani> Set this to the local SIP URI for MCP. If you enter a 
number instead, Reporting may return incorrect 
information.

<url> Enter the http:// or file:// path of the VoiceXML 
application.

<refno> Enter the unique number by which this call will be 
identified.

[uuidata], 
[defaults], 
[parameter_list]

Optional parameters. For more information, see the 
Genesys Voice Platform 8.1 User’s Guide.
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Outbound Calls Using CCP

Figure 24 shows an outbound call scenario initiated by the Call Control 
Platform. This scenario is supported by any configuration in which the solution 
is able to make an outbound call.

Figure 24: Outbound Call Initiated by the Call Control Platform

In this scenario, an initiating application defines the customer number to be 
dialed, and then passes this as a parameter through the HTTP interface. The 
initiating application uses the HTTP session-creation event processor in CCP 
to start a new CCXML application. This new CCXML application creates the 
outbound call that connects the destination—the customer—to a VoiceXML 
application. First, the CCXML application prepares the VoiceXML dialog, and 
then it starts a new connection to the customer. When the customer answers the 
call, the CCXML application receives a connection.connected event, and can 
then start the prepared VoiceXML dialog using the <dialogstart> tag.

Note: VPS does not support video outbound calls when initiated by a 
CCXML application; you can only make outbound video calls using 
the remote dialer service (see See “Outbound Calls Using Remote 
Dialer Service” on page 59).

Call Progress Analysis

CPA for outbound calls using CCXML is available for Paraxip media gateways 
only. Using CPA, the media gateway can determine the actual outcome of the 
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call and report that information to the CCXML application. The CCXML 
application can then determine whether it needs to drop the call—for example, 
if the call connects to a fax machine—or connect the call to a VoiceXML 
dialog if a customer voice is detected. 

Outbound Call With CPA—Paraxip Media Gateway

For the Paraxip media gateway, a typical CPA call flow is as follows:

1. The session creation event processor starts the CCXML application, which 
negotiates with the MCP to prepare the VoiceXML dialog.

2. The CCP sends an INVITE with the customer destination to the Resource 
Manager. This INVITE includes a private header that the Paraxip media 
gateway will use to start CPA. In order to insert this header to the INVITE, 
the CCXML must include the following sample code:

<var name="hints" expr="new Object()"/>
<assign name="hints.protocol" expr="new Object()"/>
<assign name="hints.protocol.name" expr="'sip'"/>
<assign name="hints.protocol.sip" expr="new Object()"/>
<assign name="hints.protocol.sip.headers" expr="new Array()"/>
<assign name="hints.protocol.sip.headers['X-Detect']" 
expr="'Request: cpd=on'"/>
<assign name="hints.deviceprofile" expr="'Paraxip Gateway'"/>
<createcall ... hints="hints"/>
INVITE sip:4161234567@rm SIP/2.0
...

X-Detect: Request: cpd=on
...

3. The Resource Manager sends the INVITE to SIP Server, which then routes 
the call to the Paraxip media gateway.

4. The Paraxip media gateway delays sending the 200 OK message until it 
analyses the destination.

5. After it gets the CPA result, the Paraxip media gateway sends this 
information back to CCP (through SIP Server and Resource Manager) in 
the 200 OK message.

6. In order to receive the CPA result, the CCXML application must be 
configured to look for the result in the connection.connected event that is 
sent when the customer answers the call. The following is a sample of the 
required code:

...
<transition event="connection.connected">
  <if cond="event$.protocol.sip.headers['CPD-Result'] == 'Voice'">
    <dialogstart prepareddialogid="dialogid" 
connectionid="event$.connectionid"/> 
  </if>
<transition>
...
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Environments
The Voice Platform Solution 8.1 supports hierarchical multi-tenant 
configurations, which allows you to create levels of tenants, where each 
Tenant object can be a parent, child, or both. The diagrams and descriptions in 
this chapter demonstrate some of the more common VPS deployments that 
make use of Genesys 8.1 hierarchical multi-tenant capability.
 About VPS in a Hierarchical Multi-Tenant Deployment, page 63
 Supported Multi-Tenant Deployments, page 65

About VPS in a Hierarchical Multi-Tenant 
Deployment

In hierarchical multi-tenant environments, you can create any number of 
parent/child layers of tenants, where each child tenant inherits the resources 
(MCP instances, CTI Connector instances, for example) of its parent tenant, 
while policies (port counting, usage limits, dialing rules, permissions, for 
example) are enforced top-down in the hierarchy. For example, a service 
provider, configured as the parent tenant, can create a separate child tenant for 
each reseller that it services. The parent tenant can enforce specific policies for 
the child tenants that the parent owns.

One Resource Manager Per Hierarchical Family

In the Voice Platform Solution 8.1, Resource Manager is used to manage the 
resources and policies required in a hierarchical multi-tenant deployment. To 
ensure there are no conflicting port counting policies, you can only deploy one 
Resource Manager within any single hierarchical “family”. 
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For example:

• A Resource Manager instance cannot have any other Resource Manager 
instance configured on any of its child tenants.

• A Resource Manager instance cannot have any other Resource Manager 
instance configured on any of its direct parent tenants.

In other words, multiple Resource Managers cannot share the same tenant 
hierarchy at the same time (one exception is when the Resource Manager 
instances are deployed separately at different sites, or in separate physical 
deployment). For examples of correct and incorrect multi-tenant Resource 
Manager deployments, see Figure 25.

Figure 25: Incorrect and Correct Multi-Tenant Resource Managers

In the incorrect deployment, the parent Tenant 2 and its child Tenant 2.2 are 
both deployed with their own instance of Resource Manager. In this case, the 
port counting policies for the Resource Manager in the parent tenant will 
conflict with the policies of the Resource Manager on the child tenant.

In the correct sample deployment, Tenant 2.1 and Tenant 2.2 are located at 
the same level in the hierarchy. In this case, because the two tenants are fully 
independent of one another, sharing no child tenants, and having no Resource 
Manager instances located higher up in the hierarchy, they can be deployed 
with independent instances of Resource Manager.

Multiple Sites Allow For Multiple Resource Managers

You can deploy multiple Resource Managers on a single tenant in order to 
manage multiple sites. In this case, the port-counting policies are not enforced 
across the multiple sites—each Resource Manager shares the management of 
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all the child tenants, but maintains independent port counting polices for each 
site. For an example, see Figure 26.

Figure 26: Multi-site on a Single Tenant

In this deployment, all of the Resource Manager instances manage all tenants, 
since the Resource Manager instances all belong to the Environment tenant.

Supported Multi-Tenant Deployments
The following sample architectures describe how hierarchical multi-tenancy 
can work in a variety of typical supported VPS configurations.

• “Service Provider—Hosted IVR”

• “Service Provider—Hosted IVR With Resellers”

• “Service Provider—Hosted IVR with CTI on a Premise PBX”

• “Enterprise—TDM PBX Configuration with IVR Server”

Service Provider—Hosted IVR

Figure 27 on page 66 shows a CTI through SIP Server deployment, where a 
service provider maintains two different pools of Media Control Platform 
(MCP) resources—one common pool available to all child tenants, and an 
independent pool of resources assigned to a particular child tenant. For 
example, a preferred customer that needs dedicated resources that are not 
shared with any other tenants.
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Figure 27: Hosted IVR Deployment

Sample Hierarchy Tree

Figure 28 on page 67 shows a sample hierarchy tree for a hosted IVR 
deployment.
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Figure 28: Sample Hierarchy Tree for Hosted IVR Deployment

Sample Configuration

The following table summarizes some sample configuration steps for this kind 
of deployment, based on the following assumptions:

• The MCP (common) pool of resources hosted on the service provider 
tenant is shared with all customer tenants.

• The MCP (dedicated) pool of resources is assigned to Customer 4 
(preferred) and cannot be shared with any of the other customers.

Task Summary: Sample Hosted IVR Deployment

Objective Tenant Recommended Configuration

1. Deploy Resource 
Manager.

Service 
Provider

This instance of Resource Manager is used to 
manage the resources of all child tenants.

2. Configure MCP 
pools.

Service 
Provider

Create a logical resource group for each pool 
of MCPs:

• shared MCPs—In the Resource Group 
Wizard, do not assign this resource group 
to any tenants.

• dedicated MCPs—In the wizard, assign 
this resource group to Tenant 4.

Customer 1

Customer 2

Customer 3

Service 
Provider

Customer 4
(preferred)
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Service Provider—Hosted IVR With Resellers

Figure 29 shows a CTI through SIP Server deployment, where a service 
provider is the parent tenant for several reseller tenants.

Figure 29: Hosted IVR With Resellers

In this deployment, the service provider physically hosts the Media Control 
Platform (MCP) applications for all resellers and customers.

3. Configure IVR 
Profiles.

Tenant 1 Create the IVR Profiles for the Voice XML 
applications required by this customer.

Tenant 2 Create the IVR Profiles for the Voice XML 
applications required by this customer.

Tenant 3 Create the IVR Profiles for the Voice XML 
applications required by this customer.

Tenant 4 Create the IVR Profiles for the Voice XML 
applications required by this customer.

Task Summary: Sample Hosted IVR Deployment (Continued) 

Objective Tenant Recommended Configuration
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Shared Resources For MCP resources that are shared across child tenants—the dedicated reseller 
tenants, or any other customers in the environment—the service provider 
tenant creates a logical resource group for those MCP applications to be 
shared.

Owned Resources Each reseller can also own a dedicated group of MCP resources hosted by the 
service provider. In this case, the reseller tenant creates a logical resource 
group, selecting those MCP applications that it will then own. The reseller has 
administrative rights to these resources, and can assign the resources to 
customer tenants.

Assigned
Resources

The reseller can also assign its owned resources to any child tenant underneath 
it. In this case, you specify which tenant the resource group will be assigned to 
on the Tenant Assignment page of the Resource Group Wizard. Only assigned 
tenants will be able to use these MCP resources.

Sample Hierarchy Tree

Figure 30 shows a sample hierarchy tree for a hosted IVR with resellers 
deployment.

Figure 30: Sample Hierarchy Tree for Hosted IVR With Reseller Deployment
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Sample Configuration

The following table summarizes some sample configuration steps for this kind 
of deployment, based on the following assumptions:

• Each reseller owns its own pool of MCP resources hosted by the service 
provider.

• Reseller C assigns its MCP resources to specific customer tenants. These 
resources are not shared across customers, but remain dedicated to the 
assigned customer. Note: reseller cannot dedicate resources to itself.

Task Summary: Sample Hosted IVR with Resellers Deployment

Objective Tenant Recommended Configuration

1. Deploy Resource 
Manager.

Tenant 1 This instance of Resource Manager is 
used to manage the resources of all child 
tenants.

2. Deploy MCPs. Tenant 1 Deploy the MCP applications to be used 
by the resellers.

3. Group MCPs per 
ownership.

Tenant 1.1 Create an MCP resource group for the 
MCP instances to be used by Reseller A.

Tenant 1.2 Create an MCP resource group for the 
MCP instances to be used by Reseller B.

4. Assign MCPs. Tenant 1.3 1. Create two MCP resource groups, one 
for each customer tenant that 
Reseller C will service. For example:
 RG_1
 RG_2

2. Assign each MCP resource group to 
the customer tenant:
 In the Resource Group Wizard for 

RG_1, assign the group to Tenant 
1.3.1.

 In the wizard for RG_2, assign the 
group to Tenant 1.3.2.

5. Configure IVR 
Profiles.

Tenant 1.3.1 Create the IVR Profiles for the Voice 
XML applications required by this 
customer.

Tenant 1.3.2 Create the IVR Profiles for the Voice 
XML applications required by this 
customer.
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Service Provider—Hosted IVR with CTI on a Premise PBX

Figure 31 shows a hosted IVR environment where a single pool of MCPs 
deployed on the service provider site are then shared across several different 
customer sites. In this case, the service provider and customer sites can be 
deployed on separate instances of Management Framework. CTI is provided to 
the customer premise PBX through communication between the CTI 
Connectors on the service provider site and the IVR Servers on the customer 
sites.

Figure 31: Hosted IVR with CTI on a Premise PBX

Sample Hierarchy Tree

Figure 32 on page 72 shows a sample hierarchy tree for a hosted IVR with CTI 
on premise PBX deployment.
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Figure 32: Sample Hierarchy for Hosted IVR with CTI on Premise PBX

Sample Configuration

The following table summarizes some sample configuration steps for this kind 
of deployment, based on the following assumptions:

• One group of MCP resources will be shared by all customer sites.

• No customer site will own any MCP resources, or be assigned any 
resources.

Task Summary: Hosted IVR with CTI on PremisePBX

Objective Tenant Recommended Configuration

1. Deploy Resource 
Manager.

Tenant 1 This instance of Resource Manager is 
used to manage the resources of all child 
tenants.

2. Configure gateway Tenant 1 1. Create a gateway resource group for 
SIP Server.

2. Set CTI Usage to Based on DN Lookup 
(use-cti=2).

3. Configure MCPs. Tenant 1 1. Deploy the MCP applications to be 
used by the customers.

2. Create an MCP resource group (Voice 
XML) to be shared by all customers.

Customer 
Site 1

Customer 
Site 2

Customer 
Site 3

Service 
Provider
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Enterprise—TDM PBX Configuration with IVR Server

Figure 33 shows an enterprise environment where different business groups are 
configured as separate tenants, for the purposes of self-service applications.

Figure 33: TDM PBX Configuration with IVR Server

In this deployment, all tenants share the same TDM PBX (the premise 
T-Server itself only has a single tenant). The VPS connects to the PBX—

4. Configure CTI 
Connectors.

Tenant 1 1. Create a CTI Connector resource 
group for each child tenant:
 Tenant 1.1
 Tenant 1.2
 Tenant 1.3

2. Deploy the CTI Connector instance 
for each of these resource groups.

5. Configure IVR 
Profiles.

Tenant 1.1 1. On each customer tenant, create the 
IVR Profiles for the Voice XML 
applications required by this customer.

2. Set CTI Allowed in the IVR Profile to 
true.

Tenant 1.2

Tenant 1.3

Task Summary: Hosted IVR with CTI on PremisePBX (Continued)  

Objective Tenant Recommended Configuration
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through the PSTN Connector—using a station-side connection, where only the 
port number is provided in the incoming INVITE request, with no DNIS 
available. To get the DNIS, Resource Manager sends the call to CTI 
Connector, deferring the decision about tenant hierarchy until the IVR Server 
returns the DNIS information. CTI Connector forwards the request and DNIS 
back to Resource Manager, which can then determine the tenant hierarchy 
from the IVR profile.

Sample Hierarchy Tree

Figure 34 shows a sample hierarchy tree for an Enterprise TDM PBX 
deployment with multiple business group tenants.

Figure 34: Sample Hierarchy for Enterprise TDM PBX With Business Groups

Sample Configuration

The following table summarizes some sample configuration steps for this kind 
of deployment, based on the following assumption:

• All Business Groups share a common pool of MCP resources hosted by the 
Environment tenant.

Note: Hierarchical multi-tenancy can be created within GVP and is separate 
from T-Server tenancy. In this scenario, for example, the premise 
T-Server itself has only a single tenant. For GVP, tenant selection is 
deferred until after initial call processing by CTI Connector and IVR 
Server (register the call and obtain the actual DNIS) is finished.

Business 
Group 1

Business 
Group 2

Business 
Group 3

Enterprise

Business 
Group 4



Integration Guide 75

Chapter 5: Hierarchical Multi-Tenant Environments Supported Multi-Tenant Deployments

Task Summary: Sample Hosted IVR with CTI on Premise PBX

Objective Tenant Recommended Configuration

1. Deploy Resource 
Manager.

Environment This instance of Resource Manager is 
used to manage the resources of all child 
tenants.

2. Configure gateway Environment 1. Create a gateway resource group for 
SIP Server.

2. Set CTI Usage to Based on DN Lookup 
(use-cti=2).

3. Configure CTI 
Connectors.

Environment 1. Create a CTI Connector resource 
group.

2. Deploy the CTI Connector instance 
for this resource group.

4. Configure MCPs. Environment 1. Deploy the MCP applications to be 
used by the business groups.

2. Create an MCP resource group to be 
shared by all business groups.

5. Configure IVR 
Profiles.

Tenant 1 1. On each business group tenant, create 
the IVR Profiles for the Voice XML 
applications required by this group.

2. If CTI is required by the application, 
set CTI Allowed in the IVR Profile to 
true.

Tenant 2

Tenant 3

Tenant 4
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6 High Availability
High availability (HA) ensures that a service is not interrupted in the event of a 
failure or a process restart. High availability is configured at the component 
level. This chapter provides an overview of supported HA methods, a 
description of how HA works for the different solution interfaces, as well as 
details about how a failover takes places for variously scaled solutions.

This chapter contains the following sections:
 About HA in the Voice Platform Solution, page 77
 HA In Scaled Deployment, page 81

About HA in the Voice Platform Solution
At the solution level, HA for the various components can help ensure that the 
following communication interfaces remain viable in the event of component 
failure: 

• SIP/RTP communication—Active/standby SIP Server pairs deployed using 
Windows Network Load Balancing (NLB) clusters, virtual IPs, DNS-based 
distribution, or client-side intelligence can ensure availability of the 
external SIP interface. 

GVP 8.1.x components and interfaces use different methods of availability and 
failure recovery, and some examples are:

• Load balancing is used to distribute interactions across multiple resources, 
providing a means of scaling capacity for a given type of resource, and for 

Note: This chapter describes HA configuration requirements at a high-level. 
For detailed configuration procedures, or for more information about 
how HA works at the component level, consult the respective product 
Deployment Guides. 
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providing access to more resources (one kind of resource grouping) than 
might be needed in case one resource fails—for example, (N+1) designs. 

• CTIC ‘load balancing’ can use a round-robin selection of IVR Servers if 
more than one is available in a primary group, and failure spillover to a 
backup group if the primary group fails to answer.

• Some HA solutions use purely a primary and backup pair; if one fails the 
other can be manually brought up (standby) or automatically brought up 
(hot standby) to provide high availability. The MRCP Proxy (GVP 8.1.6) is 
an example of a hot standby solution.

• The Resource Manager has its own load balancing and backup failover 
mechanism for a group of Media Servers (MCP). Resource Manager is 
deployed in pairs. It can be configured as a standalone Primary, an active 
Primary/standby Backup, or uniquely within GVP/GMS, an active-active 
pair where both RMs are available, communicate with each other 
(redundant), and are used in a round-robin manner (through a load 
balancer).

Solution Level Components and Interfaces

At the solution level, HA and failure recovery for the various components can 
help ensure that the following platform elements and their communication 
interfaces remain viable in the event of component failure.

Configuration, Reporting and Development Tools

Genesys Administrator (GA) is a web-based interface that allows the solution 
owner to configure the various resources and application objects associated 
with solution components, addressing, and some quality reporting. The 
configuration data is stored in Genesys Management Framework 
Configuration Server. Please see the Framework Deployment Guide for 
descriptions of how Configuration Server is deployed in HA modes. GA comes 
with the Genesys Voice Platform.

Genesys Administrator Extended (GAX) is a web-based interface, separate 
from GA, allowing solution owners and their customers access to reports using 
data available from the GMS/GVP Reporting Server. GAX fetches this 
information as needed via a reporting interface request from the Reporting 
Server (RS) that is active at the time. GAX comes with Genesys Voice 
Platform. GAX will try the primary RS first and then backup RS. GAX will 
remember the last RS that was tried and try that again for the next request, i.e., 
if the primary is down and GAX does use the backup RS, GAX will try the 
backup RS to get a report until the backup RS fails.

Composer is a Genesys provided VoiceXML development and visual design 
tool which comes with Genesys Voice Platform (GVP). Composer operates as 
a thick client usually on a workstation which is not a part of the production 
GVP call processing solution environment. Composer can communicate with 
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the production system however. Please see the Composer Deployment Guide 
for configuration options where Composer can permit testing of VoiceXML 
applications with web services, Media Control Platform (MCP) components. 

Core Components

SIP Server

SIP Server can be deployed in HA mode and several groups of SIP Servers can 
be front-ended by load balancers to divide incoming voice traffic across SIP 
Servers at the same or different sites. Active/standby SIP Server pairs deployed 
using Windows Network Load Balancing (NLB) clusters, F5, virtual IP 
solutions, DNS-based distribution, or client-side intelligence can ensure 
availability of the external SIP interface. See the SIP Server Deployment Guide 
for details.

Resource Manager

Resource Manager (RM) communicates bi-directionally with SIP Server, the 
Media Control Platform (MCP), the Call Control Platform (CCP if used), 
CTI-C clients. RM reads from Policy Server, and writes to the Reporting 
Server. 

Resource Manager supports both active/standby and active/active clustering of 
RM pairs, depending on the HA solution selected. SIP Server communication 
with RM may require either a third party load balancing solution (NLB, F5) or 
a Virtual IP takeover solution. See the GVP Deployment Guide Appendices for 
RM HA configuration details. 

• RM can access both primary and backup MCP resource groups, if 
configured. RM selects the next MCP in a group, round robin, upon each 
MSML or SIP Invite request.

• RM can access both Primary and Backup CTI-C clients and/or CTI-C 
groups if configured.

• RM can access both Primary and Backup Reporting Servers. If a single RS 
is used, and is down, RM can use either a memory-based or external 
(optional) DB to buffer logs, and update RS when RS is restored.

• RM generally reads from Policy Server only once at start-up unless alerted 
to refresh.

Media Control Platform and Call Control Platforms

Multiple independent instances of MCP and CCP (N+1) are used to ensure 
load support. 

MCP/CCP communicates bi-directionally with Web Applications Servers and 
Resource Manager, and writes to the Reporting Server. The MCP 
communicates bi-directionally with the MRCP Proxy server if configured or 



80 Voice Platform Solution 8.1

Chapter 6: High Availability About HA in the Voice Platform Solution

MRCP speech servers otherwise if speech is used, to the PSTN Connector if 
deployed, and to T-Library via RM/SIP Server SIP messaging. 

• MCP/CCP will work in an N+1 Web Application Server configuration, and 
a third party, customer selected, load-balancer may be used between the 
MCP and web servers.

• MCP/CCP will buffer logs if the Reporting Server is down similar to the 
methods used by RM as discussed above. 

• If a primary speech server is down, MCP can look for a secondary speech 
server. However, it is unlikely that a deployment would have two MRCP 
speech servers (e.g. Nuance NSS) deployed. 

• If a speech resource is not available, GVP will return an event message to 
the application for application recovery and control, as well as send an 
alarm to Genesys Management Framework SCS monitoring.

MRCP Proxy Server

The MRCP Proxy /Server communications with the MCP and writes to the 
Reporting Server. The MRCP Proxy can be configured as primary/backup in 
warm-standby (GVP 8.1.5 or later) or hot-standby (GVP 8.1.6 or later) modes 
for MRCP Proxy HA. MRCP proxy is required in deployments where statistics 
on peak ASR and TTS use are required including breakdown of use by tenant 
and application. 

If RS is down, the MRCP Proxy Server will use the same methods as RM to 
buffer logs as explained above.

MRCP Speech Services

Nuance depends on GVP to provide MRCP HA. If GVP is directly 
communicating with the MRCP Speech Servers (rare now) it can place each 
server in a primary and back-up group. If GVP is communicating to the 
Nuance NSS MRCP Server, then the NSS might deploy an N+1 strategy for 
speech servers to achieve HA. To support the MRCP Proxy in HA mode, the 
latest versions of Management Framework and LCA must be installed and the 
Solution Control Server (SCS) application configured to support HA licenses.

Reporting Server

Active/standby Reporting Server can be configured in HA. In GVP 8.1.6 and 
later, RS can be configured in Hot Standby. For more information on Reporting 
Server HA, please see the GVP Deployment Guide Appendix for Reporting 
Server HA.

CTI Support

GVP has two major methods of CTI support: SIP messaging via T-Server 
Library or CTI messaging via Genesys IVR Server using a CTI-C client. A 
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T-Library interface is used by Genesys Universal Routing Server for route 
requests and sharing call-related ‘attached’ data.

• For T-Library communication involving IVR Server (in CTI through IVR 
Server configurations), IVR Server can also be configured as primary and 
secondary pairs to provide a highly available connection to the T-Server. 
GVP does NOT support IVR Server 8 HA, but rather can address multiple 
instances of IVR Server as primary and secondary components in a 
failover solution. Effectively GVP CTI-C clients load balance across IVR 
Server instances within a CTI group in round robin fashion.

• When using SIP CTI mode, GVP is assured HA access to T-Server via SIP 
Server pairs that maintain the HA solution. 

SSG Service Interface

The Supplementary Services Gateway (SSG), which manages this interface, 
can not be deployed in high availability configurations. However, each 
instance of the SSG manages an independent queue for outbound calls, 
providing persistence for this queue that can survive application failures. In 
case of failure, the queue continues after the application restarts.

Third Party Access to the Reporting Server {non Genesys}

If a customer wants to read CDR and VAR information from the Reporting 
Server, Genesys provides a Web Services API for this purpose. Direct SQL 
access, while possible, is not supported by Genesys with rare exception. 

• If RS fails to respond, the third party entity must have its own recovery 
plan. 

RTSP Streaming Server (Non-Genesys)

The GVP/GMS media services will support access and use of third party RTSP 
Streaming media for audio and video. However, this is not HA, and if the 
RTSP Streaming server fails to respond, the MCP will send a failure message 
to the requesting VoiceXML application to handle.

Depending on the particular configuration or scale of your solution, high 
availability has different capabilities, or in some instances, limitations as to 
what services can survive a component failure. The priority is on ensuring that 
all new calls are processed.

HA In Scaled Deployment
For an overview of how different solution configurations at various scales can 
respond to failures of any of the individual components, see the following 
sections:

• “All-In-One Configuration”



82 Voice Platform Solution 8.1

Chapter 6: High Availability HA In Scaled Deployment

• “Small Scale Enterprise”

• “Medium Scale Enterprise”

All-In-One Configuration

The All-In-One Platform provides a complete voice self-service solution on a 
single physical server. All software components that make up the Voice 
Platform Solution are installed on the same physical server, including any 
speech engines required for speech services—Text to Speech (TTS) and 
Automatic Speech Recognition (ASR). The VoiceXML applications, and the 
web server that services them, can be deployed on a separate server. In CTI 
configurations, URS and Stat Server (and any other routing/CTI components) 
can be deployed on a separate server.

This configuration does not provide any high availability—the failure of a 
single component essentially causes all calls to fail.

Figure 35 shows the distribution of components in an All-In-One Voice 
Platform Solution configuration.

Figure 35: All-In-One Server Configuration

Table 2 on page 83 describes how the Voice Platform Solution responds to 
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Table 2: HA Response to Component Failure—All-In-One Scenario

Failure Solution Response

Machine fails. All calls are lost. The solution cannot accept new incoming calls until the 
machine restarts.

SIP Server fails. Because SIP Server is a third-party call control (3pcc) component, its 
failure does not immediately affect all outstanding voice calls until a call 
control request is made (for example, a transfer). The remote SIP endpoint 
will eventually terminate the call after the session timeout expires. The 
solution cannot accept new incoming calls or make outbound calls until SIP 
Server is restarted.

Resource Manager fails. Because Resource Manager is a SIP proxy, its failure does not affect 
ongoing voice calls—the voice dialog can continue, and call control 
requests can be initiated after the Resource Manager is restarted. After the 
restart, resource tracking is reset, and so the Resource Manager will not 
have an accurate view of current resource usage until all calls started before 
the failure have been terminated.

MCP fails. All voice calls are terminated. No new calls are processed until after MCP 
restarts.

CCP fails. Because CCP is a 3pcc component, its failure does not affect ongoing voice 
calls until a call control request is required. As in a SIP Server failure, the 
other SIP endpoint will eventually terminate the call after the session 
timeout expires.

IVR Server fails. The failure of IVR Server does not affect ongoing voice calls until a CTI 
function is requested. CTI functions in this case will fail—however, the 
voice application may recover from the failure, keeping the caller on the 
line for continued voice self-service. New calls will not have CTI 
functionality.

CTI Connector fails. Because CTI-C is a 3pcc component, its failure does not affect ongoing 
voice calls until the application requests a CTI function, or attempts a call 
transfer. At this point, SIP transactions for the call will fail and the call will 
be terminated. New calls will not have CTI functionality. 

SSG fails Outbound call requests already queued in the SSG can survive a failure of 
the application—after restart, SSG will continue with the same queue. Calls 
placed in queue but not reported to the client application (and whose 
TimeToLive (TTL) timer has not expired) are still considered to be in the 
queue, and will also be retried after process restart.
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Small Scale Enterprise

The Small Scale Enterprise configuration provides an off-board speech server 
in order to offload the most resource intensive process in the solution to a 
separate server from the one used for the rest of the Voice Platform Solution 
components. This configuration is similar to the All-In-One configuration, 
except for the off-board speech server. Like the All-In-One configuration, the 
Small Scale Enterprise configuration does not offer high availability to protect 
against component failures. In this case, the solution responds as it does in an 
All-In-One configuration (see Table 2 on page 83).

Figure 36 shows the distribution of components in a Small Scale Enterprise 
Voice Platform Solution configuration.

Figure 36: Small Scale Enterprise Configuration

Medium Scale Enterprise
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Figure 37: Medium Scale Enterprise Configuration

High Availability for SIP Server

In the Medium Scale Enterprise deployment shown in Figure 37, high 
availability is configured using Windows Network Load Balancing clusters of 
primary/backup SIP Server pairs, deployed on separate physical servers. These 
SIP Server pairs will synchronize call states to ensure that the backup SIP 
Server can take over if the primary instance fails. NLB provides a single IP 
address for both the primary and backup SIP Servers, so that if the primary SIP 
Server fails, the backup can resume service using the same IP address that was 
used before the failover. The Universal Routing Server, if deployed, connects 
to both SIP Server instances as a T-Library client, which enables the URS to 
switch over to the backup SIP Server if the primary instance fails. 

For more information about configuring high availability for SIP Server, 
consult the Framework 8.1 SIP Server Deployment Guide. 

High Availability for Resource Manager

High availability for Resource Manger, as for SIP Server, is configured using 
Windows Network Load Balancing clusters of primary/backup Resource 
Manager pairs, deployed on separate physical servers. NLB provides a single 
IP address for both primary and backup Resource Managers, so that the other 
SIP endpoints—including SIP Server—can continue communicating with the 
same IP address after a failover. Because Resource Manager is a SIP proxy, 

Web Application 
Server

Management Framework
(Management, Configuration, Logging)

Customer 
Endpoint

Genesys Administrator

Speech Services
(ASR and TTS)

Management 
Display

Reporting ServerHTTP

Stat Server

URS

GVP

Resource 
Manager

GVP

CTI 
Connector

CCP

MCP

IVR Server

SIP Server

TLIB

TLIB

SIP
SIP

MRCPv1/v2

VXML/CCXML
Application

(HTTP)

SIP

IVR XML

GVP

SSG

TLIB



86 Voice Platform Solution 8.1

Chapter 6: High Availability HA In Scaled Deployment

call state synchronization between primary and backup instances is not 
required. However, the failover from primary to backup Resource Manager 
resets resource tracking, and so Resource Manager will not have an accurate 
view of current resource usage until all calls started before the failure have 
been terminated.

For information about configuring active/standby Resource Manager pairs for 
high availability, see “NLB Clustering for Resource Manager” in the Genesys 
Voice Platform 8.1 Deployment Guide. 

High Availability for MCP/CCP

For a Medium Scale Enterprise configuration, the number of ports typically 
required by the solution outnumbers the port capacity for a single MCP/CCP, 
and so multiple instances of these components are deployed across several 
servers. The Resource Manager performs load balancing of the incoming calls 
for even distribution across the multiple servers. Because of how VoiceXML 
and CCXML applications work, neither MCP or CCP is fault tolerant. If a 
failure occurs at any one instance of MCP/CCP, all outstanding calls at that 
instance will fail. However, because Resource Manager monitors the status of 
each resource continuously, it will forward any new incoming call to one of the 
remaining instances; it will not attempt to forward an incoming call to a failed 
server.

High Availability for Reporting Server

High availability for the Reporting Server is also configured using 
primary/backup pairs on separate servers. If the primary Reporting Server fails, 
the backup can take over, enabling the continuous reporting of data to the 
database.

Solution Response to a Component Failure

Table 3 describes how the Voice Platform Solution responds to different failure 
scenarios.

Table 3: HA Response to Component Failure—Medium Scale Enterprise

Failure Solution Response

SIP Server (or its machine) 
fails.

The backup SIP Server takes over, using the shared IP address. Calls in an 
unstable state will fail, but stable calls—those connected to the VoiceXML 
application or an agent—will continue to operate, with no impact on the 
customer experience.
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Resource Manager (or its 
machine) fails.

The backup Resource Manager takes over, using the shared IP address. 
Ongoing SIP transactions will fail, but this affects only incoming calls 
currently in the ringing state. All other calls remain unaffected, with no 
impact on the customer experience. Because resource tracking is reset after 
a failover, Resource Manager will not have an accurate view current 
resource usage until all calls started before the failure have been terminated

MCP fails. All voice calls on the failed server will be terminated. The customer will 
hear silence from the IVR and will presumably hang up the call. If the 
customer does not hang up, SIP Server will eventually timeout and 
terminate the call. Resource Manager tracks this resource as unavailable, 
and does not forward any new calls to this instance—resulting in a 
temporary reduction in solution capacity. The LCA on the host machine 
should automatically restart the MCP, at which point solution capacity 
returns to normal levels.

CCP fails. Because CCP is a 3pcc component, its failure does not affect ongoing voice 
calls until a call control request is required. As in a SIP Server failure, the 
other SIP endpoint—MCP or SIP Server—will eventually terminate the call 
after its session timeout expires. As in an MCP failure, the Resource 
Manager detects the failure and forwards new calls to the remaining 
instances. Any temporary reduction in solution capacity is remedied after 
the LCA automatically restarts the CCP.

The GVP server (machine 
with MCP and CCP) fails.

The response is identical to the response described for MCP and CCP 
failures, except both failures and responses occur at the same time.

IVR Server fails. IVR Server failures affect only the calls processed by that particular 
instance. Voice calls remain unaffected until a CTI function is requested. 
Even if the CTI function fails, the voice application may be able to recover 
from the failure, keeping the caller connected for continued voice 
self-service. New incoming calls are forwarded to the backup IVR Server 
instance, where CTI functions are still available.

CTI Connector fails. CTI Connector failures affect only the calls processed by that particular 
instance. Because CTI-C is a 3pcc component, its failure does not affect 
ongoing voice calls until the application requests a CTI function or attempts 
a call transfer. At this point, SIP transactions for the call will fail and the 
call will be terminated. New incoming calls are forwarded to a secondary 
CTI Connector instance, where CTI functions are still available. 

Reporting Server fails. The backup Reporting Server takes over as the active instance in the pair; 
all reporting data will be processed by this instance.

Table 3: HA Response to Component Failure—Medium Scale Enterprise (Continued) 

Failure Solution Response
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SSG fails Outbound call requests already queued in the SSG can survive a failure of 
the application—after restart, SSG will continue with the same queue. Calls 
placed in queue but not reported to the client application (and whose 
TimeToLive (TTL) timer has not expired) are still considered to be in the 
queue, and will also be retried after process restart.

Table 3: HA Response to Component Failure—Medium Scale Enterprise (Continued) 

Failure Solution Response
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7 Support for IVR Server
For deployments that require the use of IVR Server, Genesys offers the CTI 
Connector (CTI-C), a GVP 8.1 component that, together with the IVR Server, 
provides the CTI required to integrate the Voice Platform Solution (VPS) with 
the larger Genesys suite, in cases where the standard SIP interface cannot 
provide CTI itself.

This chapter includes the following sections:
 About the CTI Connector, page 89
 Integration with IVR Server—Behind Mode, page 90
 Integration with IVR Server—In-Front Mode, page 94
 Integration with Network IVR Server, page 96
 Call Transfers Using CTI Connector, page 97
 Call Treatments Using CTI Connector, page 99

About the CTI Connector
CTI Connector is used for the integration of legacy CTI-enabled 
VoiceXML/TXML applications. It is also used in some configurations where 
IVR Server is required to integrate CTI with the voice application. CTI 
Connector is compatible with both NGI and GVPi applications—though 
Genesys recommends building new applications using NGI.

Using CTI Connector, the Voice Platform Solution is able to integrate with the 
IVR Server in different ways, depending on the role that the IVR Server plays 
in the deployment. The VPS supports integration with IVR Server configured 
for the following modes:

• Behind mode (see page 90)

• In-Front mode (see page 94)

• Network mode (see page 96)
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Integration with IVR Server—Behind Mode
In this deployment, IVR Server is configured for Behind mode. In a TDM PBX 
integration, this mode refers to the physical location of the IVR Server behind 
the switch. In an IP-based integration, the mode refers to the configured or 
logical relationship of the IVR Server to the switch.

Depending on the deployment, the inbound call reaches either a Routing Point 
DN (IP-based deployment) or a Trunk DN (TDM deployments) on the SIP 
Server.

Behind-mode integrations are supported in the following deployments:

• “Carrier-Connected Deployments”

• “PBX-Connected Deployments”

Carrier-Connected Deployments

Figure 38 illustrates how the VPS, in a carrier-connected integration with IVR 
Server in Behind mode, handles call setup for a typical inbound call, where a 
legacy IVR application (GVPi) is triggered.

Figure 38: Call Setup for Typical Inbound Call—Behind Mode
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2. The SIP Server forwards the port number (as the user part of the 
Request-URI and in the To header) in the INVITE it sends to Resource 
Manager.

3. The Resource Manager creates a session ID, and then forwards this ID and 
the IVR port in an INVITE to CTI Connector. 

4. The CTI Connector sends the IVR Server an XML request to register the 
new call with SIP Server. This anchors the call on the CTI Connector, so 
that CTI functions can be executed directly from the application.

5. After obtaining the response from the IVR Server, the CTI Connector 
sends an INVITE to Resource Manager with the DNIS in the To header.

6. The Resource Manager matches the DNIS with an IVR Profile, and then 
sends an INVITE to the Media Control Platform with the URL to launch the 
VoiceXML application.

7. The Real-time Transport Protocol (RTP) media path is established between 
the Media Control Platform and the gateway and through to the caller.

The caller is now interacting with the voice application. For information about 
call transfers from the voice self-service application to an available agent for 
assisted-service, see “Call Transfers Using CTI Connector” on page 97.

Configuration Overview

The relevant configuration steps required for a carrier-connected deployment 
include the following:

1. Create Place objects for each Voice Treatment Port DN in the SIP Server 
switch, then add all the Places to a Place Group. The routing strategy needs 
to target this Place Group.

2. Create Voice Treatment Port DNs in the dummy switch for TServer_IVR 
to match the DNs in the SIP Server switch. These DNs do not require any 
configuration.

3. Configure IVR Ports. The numbers for these ports must match the Voice 
Treatment Port DNs in the dummy switch, and also follow the same range.

4. Go to the SIP Server Application object, add connections to:
 Message Server

5. In the IVR Server Application object, add a connection to TServer_IVR.

6. Go to Provisioning > Voice Platform > Resource Groups, and use the 
wizard to configure resource groups for the following:
 Media Control Platform
 Call Control Platform
 CTI Connector
 Gateway (SIP Server, with CTI Usage set to Based on DN Lookup 

(use-cti set to 2)).
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Note: This configuration uses CTI flagging to allow Standard VoiceXML 
applications to bypass CTI Connector. If your deployment uses only 
IVR-centric applications, you can set CTI Usage to Always On (use-cti 
to 1). In this case, you do not need to create matching DNs in the 
dummy switch. 

For detailed step-by-step procedures, see “Task Summary: IVR 
Behind, Carrier-Connected Integration” on page 147.

For more information about CTI flagging, see “Configuring CTI 
Flagging for IVR Profiles” on page 188.

PBX-Connected Deployments

In a TDM PBX deployment, the IVR Server is a T-Library client of the 
premise T-Server and not the SIP Server. Figure 39 illustrates how the VPS, in 
a TDM deployment, handles call setup for a typical inbound call.

Figure 39: Call Setup for Typical Inbound Call—Behind Mode
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1. Caller dials a number on the PSTN network and the call is routed to the 
customer premise, where it reaches the PBX.

2. From the PBX, the call arrives at the media gateway—the PBX sends the 
port number to the gateway, not the DNIS as dialed by the customer. At the 
same time, the premise T-Server (connected to the PBX) sends an 
EventRinging message to the IVR Server.

3. The media gateway sends the call to the SIP Server, where it reaches a 
Trunk DN. This Trunk DN has the contact option configured to the sip 
address for Resource Manager.

4. As per the configuration for the gateway resource group on Resource 
Manager (CTI Usage set to Always On (use-cti set to 1), Resource Manager 
sends the call to CTI Connector.

5. CTI Connector retrieves the DNIS (in this case, the Trunk DN number) 
from the Request URI it receives from Resource Manager, then sends this 
number to the IVR Server in a <NewCall> message (Genesys proprietary 
IVR XML). IVR Server returns the DNIS for the IVR Profile to CTI 
Connector.

6. CTI Connector generates a new call leg with Resource Manager.

7. The Resource Manager matches the DNIS returned from the IVR Server 
with an IVR Profile, then sends an INVITE to the Media Control Platform 
with the URL to launch the VoiceXML application.

8. The RTP media path is established between the Media Control Platform 
and the media gateway—and through the PBX to the caller.

Configuration Overview

The relevant configuration steps required for a TDM deployment include the 
following:

1. Create Trunk DNs with the prefix option set to match the initial digits of 
the range to match the number of ports configured on the PBX for GVP. 

2. Configure Voice Treatment Port DNs on the premise T-Server switch. The 
number and name of Voice Treatment Port DNs depends on the type of 
switch. No configuration of options for these DNs is required.

3. Configure IVR Ports:
 The number of IVR ports must match the number of ports configured 

on the PBX for GVP.
 The names for the IVR ports must match the port numbers that the 

media gateway will send to SIP Server as the DNIS.
 Map each IVR port to the appropriate Voice Treatment Port DN on the 

premise switch.

4. In the IVR Server Application object, add a connection to the premise 
T-Server.
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5. In the premise T-Server Application object, add connections to the 
following:
 Message Server

6. In the SIP Server Application object, add connections to the following:
 Message Server

7. Go to Provisioning > Voice Platform > Resource Groups, and use the 
wizard to configure resource groups for the following:
 Media Control Platform
 Call Control Platform
 CTI Connector
 Gateway (SIP Server, with CTI Usage set to Always On (use-cti set to 1)

For detailed step-by-step procedures, see “Task Summary: IVR Behind, 
TDM-Connected Integration” on page 151.

Integration with IVR Server—In-Front Mode
In this deployment, IVR Server is configured for In-Front mode—used in 
premise deployments where the VPS is running on a different instance of 
Genesys Framework than the premise switch where the agents are registered. 
In this case, the IVR Server acts as the link between the two instances of 
Genesys Framework, allowing GVP to transfer a call from the service provider 
to the agent.

With this premise-based IVR Server In-Front configuration, the call typically 
arrives at the VPS through a TDM PBX. In this case, the station-side 
connection cannot provide the DNIS, so the CTI Connector sends a request to 
IVR Server for information about the call (including the DNIS). IVR Server, 
running as a T-Server, assigns its own connection ID (ConnID) to the call—
required for reporting purposes.

This deployment is suitable for Managed Service Provider (MSP) 
configurations, where the host site and customer site are not linked together in 
the same Management Framework. All IVR Server functionality resides at the 
MSP site, and the customer connects to the MSP site only through the IVR 
Server, configured for In-Front mode.

Figure 40 on page 95 illustrates how the VPS, integrated with IVR Server in 
the In-Front mode, handles call setup for a typical inbound call.
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Figure 40: Call Setup for a Typical Inbound Call—In-Front Mode
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6. The Resource Manager selects an IVR Profile based on the DNIS, and then 
sends an INVITE to the Media Control Platform with the URL to launch the 
VoiceXML application.

7. The voice path is established between the Media Control Platform and the 
caller. 

Integration with Network IVR Server
In this deployment, IVR Server is configured for Network mode in order to 
integrate with a Network T-Server. The VPS is located at the carrier 
environment where it is connected to a Service Switching Point (SSP).

Figure 41 illustrates how the VPS, integrated with IVR Server in Network 
mode, handles a typical inbound call.

Figure 41: Typical Inbound Call Flow—IVR Server Integration

1. The incoming call reaches the SSP, which sends a route request through the 
Service Control Point (SCP) to a Routing Point DN on the Network 
T-Server switch.

2. The routing strategy selects the Trunk DN that represents GVP as the 
target, and the call is routed through Inter Server Call Control (ISCC) 
transfer back to the SSP.

3. The SSP forwards the call to the Trunk DN on the SIP Server, which then 
sends an INVITE to the Resource Manager with either the DNIS or a toll 
free number in the header.
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4. The Resource Manager generates a session ID. It forwards this ID, along 
with the DNIS or toll free number, to CTI Connector

5. The CTI Connector sends an XML request to the IVR Server for call 
registration with the Network T-Server and URS.

6. The IVR Server obtains the ConnID, IVR port, and other call-related data 
and sends it by XML to CTI Connector.

7. The CTI Connector sends this call-related data in an INVITE to the 
Resource Manager.

8. The Resource Manager selects an IVR Profile based on the DNIS or toll 
free number, and then sends an INVITE to the Media Control Platform with 
the URL to launch the VoiceXML application.

9. The RTP media path is established between the Media Control Platform 
and the caller. 

Call Transfers Using CTI Connector
For integrations that provide CTI through IVR Server, CTI Connector is the 
essential component for negotiating and completing call transfers to agents. 
Depending on your architecture configuration and the kind of voice application 
used, different methods may or may not be supported for transferring the caller 
from the self-service portion of the call to the agent-assisted portion.

Supported call transfers include:

• REFER transfer for Standard VoiceXML applications

• Bridge transfer for Standard VoiceXML applications

• REFER transfer for IVR-centric applications

Standard VoiceXML Applications—REFER

In Standard VoiceXML applications, the application uses the <transfer> tag to 
place the call in queue when the caller wants to transfer to an agent. CTI 
Connector receives a blind transfer request from the REFER message. In 
response, CTI Connector sends RouteRequest to the IVR Server. Call 
treatments can be applied while the caller waits in the queue. CTI Connector 
initiates a new call leg with the MCP for each call treatment request. If the 
treatment collects any customer data, MCP can provide a treatment result.

For Carrier-Connected Architectures

When the agent is ready, the IVR Server sends a route number to CTI 
Connector, and CTI Connector sends a REFER request to the SIP Server. The 
media gateway negotiates the transfer from the VPS site, through the PSTN, to 
the site where the agent is located.
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For Station Side-Connected Architectures

When the agent is ready, the IVR Server sends a route number to CTI 
Connector, and CTI Connector initiates a CTI transfer to the premise T-Server 
through the IVR Server; the PBX patches the caller to the agent directly.

Standard VoiceXML Applications—Bridge Transfer

For bridged transfers from Standard VoiceXML applications, the application 
also uses the <transfer> tag. In this case, CTI Connector receives an INVITE 
requesting a bridged transfer. In response, CTI Connector sends a RouteRequest 
to the IVR Server. Call treatments can be applied while the caller waits in the 
queue. CTI Connector initiates a new call leg with the MCP for each call 
treatment request. If the treatment collects any customer data, MCP can 
provide a treatment result. When the agent is ready, the IVR Server sends a 
route number to CTI Connector, and CTI Connector sends an INVITE request to 
the SIP Server and bridges the call to the agent. 

IVR-centric Applications—REFER Transfer

IVR-centric applications can use TXML (in legacy GVPi applications) or 
proprietary <send> and <receive> tags (in NGI applications) to access CTI 
functionality directly from the application, through CTI Connector and IVR 
Server. For these functions, MCP sends and receives SIP INFO messages. CTI 
Connector provides a tunnel for communication with the IVR Server. CTI 
Connector acts as a SIP back-to-back user agent (B2BUA), remaining in the 
call path until the transfer to the agent is complete. While the caller is waiting 
in the queue, the call is considered parked at MCP, and any treatments must be 
provided by the application.

For Station Side-Connected Architectures (IVR Behind 
Mode)

When the agent is ready, the application retrieves the agent number and MCP 
sends a REFER to CTI Connector. Instead of passing the REFER to the media 
gateway, CTI Connector performs a CTI transfer using the IVR XML 
OneStepXfer message, and the PBX patches the caller to the agent directly. This 
functionality requires that you set the CTI Transfer option to true in the IVR 
Profile.

Configuring the IVR Profile for Transfer Type

For a description of the service parameters that you must configure on the IVR 
Profile for the various types of supported transfers, see the following:

• Procedure: Task Summary: Configuring Voice Treatments, on page 166
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Call Treatments Using CTI Connector
When queuing call transfers using either the REFER or INVITE transfer methods, 
CTI Connector can be used to request a call treatment. When CTI Connector 
receives a request for a treatment—for example, a Play Application treatment 
from a URS routing strategy—it translates this request into a new terminating 
call leg to MCP, with the required treatment parameters provided in NETANN 
format.

Using CTI Connector, MCP supports the following treatments for both GVPi 
and NGI applications:

• Play Application—Invokes a particular VoiceXML application as a 
separate call leg.

• Play Announcement (TTS)—Plays an announcement for the caller.

• Play Announcement (TTS) and Collect Digits—Plays an announcement 
and connects digits from the caller.

• Music—Plays a .vox/.wav file.

Basic Configuration Using Interaction Routing Designer

These treatments are configured using Voice Treatment objects in the 
Interaction Routing Designer (IRD), where you can design your routing 
strategy and then load it on a particular Routing Point DN. 

For information about configuring Voice Treatment blocks, see the “Voice 
Treatment Options” section of the Universal Routing 8.1 Reference Manual.

Additional Solution-Level Treatment Configuration

When integrated with CTI Connector and IVR Server, VPS supports the 
standard methods for configuring Voice Treatment blocks in IRD. CTI 
Connector also provides some additional configuration options to give 
designers more flexibility when building their applications.

For a task summary of these special configuration steps, see the following:

• Procedure: Task Summary: Configuring Voice Treatments, on page 166
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8 PSTN Connector
For deployments that require the use of Dialogic hardware, Genesys offers the 
PSTN Connector, a GVP 8.1 component that provides connectivity to 
traditional telephony environments (PSTN switches, TDM PBXs or ACDs, 
and so on) for GVP deployments.

This chapter includes the following sections:

• Sample Deployment, page 101

• PSTN Connector Limitations, page 103

Sample Deployment
PSTN Connector can be used as an equivalent to the media gateway for most 
of the supported call flow scenarios described in this guide. However, it is 
beyond the scope of this document to detail all deployments where PSTN 
Connector could be included. To provide an overview of how PSTN Connector 
works, this section presents a sample of one of the more common supported 
scenarios that might include the PSTN Connector.

Station-side Connected, With PSTN Connector

The sample configuration described here is similar to “Station Side-Connected, 
CTI Through IVR Server” on page 43, except that instead of a media gateway, 
the solution uses the GVP component PSTN Connector, which integrates with 
Dialogic hardware and software to provide the TDM signaling interface.

Note: PSTN Connector is not intended as a media gateway replacement. 
Certain media gateway functions—for example, conferencing—are 
not supported in PSTN Connector integrations.

PSTN Connector is intended for legacy TDM deployments with 
Dialogic cards.
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Figure 42 shows a VPS integration with PSTN Connector.

Figure 42: TDM PBX with PSTN Connector

In this architecture, the PBX forwards the incoming call to the PSTN 
Connector. At the same time it sends info related to the call (ANI, DNIS) 
through the CTI interface. PSTN Connector sends the call to SIP Server, which 
in turn forwards the call to the Resource Manager through a Trunk DN. 
Resource Manager then forwards the call to CTI Connector, so that the call can 
be registered through the IVR Server.

This architecture supports the following kinds of applications:

• Standard VoiceXML applications

• IVR-centric applications

Note: To match legacy deployments, PSTN Connector and MCP can be 
deployed on the same host machine (optional). On Windows 2008 
host machines, some additional configuration for this deployment may 
be required. For details, see the Genesys Voice Platform 8.1 
Deployment Guide.

Note: For the relevant procedures for this sample configuration, see  
Integrating with PSTN Connector, on page 211.
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Inbound Call Flows and Transfers

The inbound call flows, including the different kinds of available transfer 
types, are identical to the call flows described in “Station Side-Connected, CTI 
Through IVR Server” on page 43—except with PSTN Connector taking the 
role of the media gateway. For details, please see the previous section.

Outbound Calls

In this architecture, outbound calls can be initiated using a trigger application 
through the SSG. SIP Server sends the outbound INVITE through a Trunk Group 
DN configured for MSML communication to GVP. SIP Server can apply call 
progress detection (CPD) on the PSTN Connector. After CPD, if the called line 
is determined to be suitable, the line is connected to the voice application. The 
application can use the VoiceXML <transfer> tag to deliver the call to a 
destination. PSTN Connector is able to synchronize ports with the IVR Server, 
allowing for CTI call control from the application (unavailable for outbound 
calls through a Media Gateway).

PSTN Connector Limitations
While PSTN Connector can be used in most supported call flow scenarios, 
there are certain limitations. PSTN Connector cannot be used for the 
following:

• CCXML applications.

• Outbound call scenarios involving the Outbound Contact Solution (OCS). 
Note that outbound through SSG is supported.

• Media services provided by the following Voice over IP Service DN 
types: mcu, recorder.
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2 Integration Procedures
For the procedures that you need to complete to integrate the various 
components that make up the Voice Platform Solution, to integrate any 
additional components, or perform any special configuration required by your 
deployment, see the Task Summary tables and related procedures in the 
following chapters:

• Chapter 9, “Integration Prerequisites,” on page 107

• Chapter 10, “Configuration Tasks for All Deployments,” on page 111

• Chapter 11, “Configuration Tasks for CTI Through SIP Server,” on 
page 129

• Chapter 12, “Configuration Tasks for CTI Through IVR Server,” on 
page 145

• Chapter 13, “Integrating with SSG,” on page 195

• Chapter 14, “Integrating with PSTN Connector,” on page 211
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9 Integration Prerequisites
Before you begin the integration, all VPS components must be installed and 
configured according to the procedures in their respective product Deployment 
Guides. If properly deployed, you can run these applications from Genesys 
Administrator or the Solution Control Interface (SCI).

This chapter contains the following section:
 Integration Prerequisites, page 107

Integration Prerequisites
Table 4 lists all of the required prerequisite components, their respective 
Deployment Guides, and any key actions that you must complete before 
starting the integration procedures.

Table 4: Prerequisite Components for VPS Integration

Component Key Actions or Info Documentation

VPS Components

SIP Server version 
8.0.3 or later

Requires the following SIP Server-related 
configuration objects:

• SIP Server Application object.

• SIP Switching Office object.

• SIP Switch object.

• SIP or agent endpoints, configured as 
Extension DNs on the SIP Switch.

Framework 8.1 SIP Server 
Deployment Guide
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Genesys Voice 
Platform 8.1

Key GVP components required for the VPS 
include:

• Resource Manager

• Media Control Platform

• Call Control Platform (optional for CCXML)

• Squid Caching Proxy (one per MCP/CCP host)

• Reporting Server (optional, required for 
solution reporting)

At a minimum, go to the “List of Procedures” 
section at the start of the Genesys Voice 
Platform 8.1 Deployment Guide, and complete the 
following procedures:

1. Configuring system performance settings

2. Adding a host in Genesys Administrator

3. Installing the Local Control Agent

4. Importing the installation packages into the 
Deployment Repository

5. Using the Installation Wizard to install GVP

6. Creating a Resource Solution object

7. Integrating Application objects with Resource 
Manager

Genesys Voice Platform 8.1 
Deployment Guide

Supplementary 
Services Gateway 8.1

This is an optional GVP 8.1 component—used for 
initiating outbound calls and connecting the called 
number to a Standard Voice XML application.

For details about integrating the VPS with SSG, 
see Chapter 13 on page 195

Genesys Voice Platform 8.1 
Deployment Guide

CTI Connector 8.1 This is an optional GVP 8.1 component—
however, it is required for CTI through IVR 
Server configurations.

For details about integrating the VPS with CTI 
Connector, see Chapter 12 on page 145.

Genesys Voice Platform 8.1 
Deployment Guide

PSTN Connector 8.1 This is an optional GVP 8.1 component—used for 
TDM integrations with Dialogic hardware and 
software.

For deployment procedures, see the Genesys 
Voice Platform 8.1 Deployment Guide

For details about integrating the PSTN Connector 
into the solution, see Chapter 14 on page 211.

Genesys Voice Platform 8.1 
Deployment Guide

Table 4: Prerequisite Components for VPS Integration (Continued) 

Component Key Actions or Info Documentation
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Management 
Framework 8.0.3 or 
later

A centralized Genesys Management Framework, 
with all required components, must be installed.

To start the Management Layer (required for 
Genesys Administrator):

1. Start the LCA.

2. Start the DB Server that provides access to the 
Configuration Database.

3. Start Configuration Server.

4. Start Message Server.

5. Start Solution Control Server.

Management Framework 8.1 
Deployment Guide

Genesys 
Administrator 8.1

Genesys Administrator must be installed.

Before logging on to Genesys Administrator, 
make sure the following are started:

• Configuration Server

• Solution Control Server

• Microsoft Internet Information Services (IIS)

To log on to Genesys Administrator:

1. Enter the application URL in a web browser, 
using the following format:

http://<genesys_administrator_host>/wcm

Note: Make sure you enter the host where you 
installed Genesys Administrator (do not confuse 
with Configuration Manager host).

2. Login to the tool by entering the following 
info:

• User name

• Password

• Application

• Host Name (Configuration Server host)

• Port (Configuration Server port)

Framework 8.1 Genesys 
Administrator Deployment 
Guide

Framework 8.1 Genesys 
Administrator Help

Genesys Composer 
8.0.2 or later

This is an optional component. Genesys 
recommends that you use Composer for authoring 
VoiceXML and editing CCXML applications.

You can start Composer from the Windows Start 
menu.

For information about using the tool, press F1 in 
the application to bring up the Help system.

Genesys Composer 8.1 
Deployment Guide

Genesys Composer 8.1 Help

Genesys Voice Platform 8.1 
VoiceXML 2.1 Help

Table 4: Prerequisite Components for VPS Integration (Continued) 

Component Key Actions or Info Documentation
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Other Genesys Components

Note: These components are not part of the Voice Platform Solution, although they may be included in 
your deployment.

Universal Routing 
Server 7.6 or later

Required for routing to agents and for launching 
Play Application treatments.

Required connections:

• Message Server

• SIP Server Application object

• Any other TServer Application included your 
deployment.

• Stat Server

Universal Routing Server 
8.1 Deployment Guide

Universal Routing Server 
8.1 Reference Manual

Interaction Routing 
Designer 7.6 or later

Required for building URS routing strategies, and 
for defining the UserData attributes that SIP 
Server collects from the headers and passes to 
GVP.

Universal Routing 8.1 
Business Process User’s 
Guide

Universal Routing 8.1 
Interaction Routing 
Designer Help

Stat Server 7.6 or 
later

Required for monitoring the availability of agents 
targeted in the routing strategies.

Required connections:

• Message Server

• SIP Server Application object

Framework 8.1 Stat Server 
Deployment Guide

IVR Server 7.5 or 
later

This is an optional component—however, it is 
required for CTI through IVR Server 
configurations.

For details, see Chapter 12 on page 145.

IVR Interface Option 8.1 
IVR Server System 
Administrator’s Guide

Table 4: Prerequisite Components for VPS Integration (Continued) 

Component Key Actions or Info Documentation
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10 Configuration Tasks for All 
Deployments
This chapter describes how to integrate the main components of the Voice 
Platform Solution (VPS)—primarily the configuration steps that are required 
to integrate SIP Server with Genesys Voice Platform (GVP) components 
included in the solution. These procedures assume that all of the components 
involved in the solution have already been installed and their initial 
configuration completed, according to the procedures in their respective 
product Deployment Guides.

These procedures support the common configuration tasks that must be 
completed for all VPS deployments. After completing these steps, further 
configuration for CTI through SIP Server or CTI through IVR Server is also 
required, depending on the needs of your deployment.

This chapter includes the following sections:
 Task Summary: Baseline Configuration Tasks, page 111
 Integrating SIP Server with GVP, page 116
 Configuring SNMP Monitoring, page 122
 Integrating With Gateways That Do Not Support REFER, page 124
 Configuring the Solution for Media Redirect Transfers, page 125
 Special Configuration for Outbound Calls, page 126

Task Summary: Baseline Configuration 
Tasks

Task Summary: Common Configuration Tasks for All Deployments, on 
page 112 provides an overview of the main steps that you must complete to 
integrate SIP Server with the other VPS components. 
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Task Summary: Common Configuration Tasks for All Deployments

Objective Related Procedures and Actions

1. Check that prerequisite components 
are successfully deployed.

Make sure all required VPS components are deployed before 
you begin the integration procedures.

For a list of required components, their respective 
deployment guides, as well as any key actions or information 
to ready the component for the integration, see “Integration 
Prerequisites” on page 107.

2. Check default ports. Go to: Provisioning > Environment > Applications

Check default port settings for the various components:

1. All GVP components are assigned different default ports, 
allowing you to run GVP on a single host—typically for 
lab or testing purposes. If you change any of these default 
port settings, be sure they do not conflict with the settings 
of any other component running on that computer.

2. The Resource Manager uses a default port setting of 5060, 
which is also the default for SIP Server. If your 
deployment includes Resource Manager and SIP Server 
on the same host, Genesys recommends that you change 
the Resource Manager default port to avoid conflicts with 
SIP Server, or any other GVP components.

3. Configure MCP for integration with 
SIP Server.

Go to: Provisioning > Environment > Applications

To prepare MCP for integration with SIP Server, in the SIP 
section of the MCP Application object, configure the 
following options:

• Set the outcalluseoriggw option to 1.

• For the routeset option, enter the IP address and port for 
the Resource Manager, in the following format (outer 
angle brackets included):
<sip:<RM IP address>:<RM SIP port>,lr>

For the detailed procedure, see “Configuring MCP for 
integration with SIP Server” on page 118.
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4. Create a resource group for MCP. Go to: Provisioning > Voice Platform > Resource Groups

• Click New and follow the wizard to create a new resource 
group of the type Media Control Platform.

Key Parameters

• Monitoring Method—Accept the default.

• Load Balancing Scheme—Select least percent.

• Leave the maximum conference size and count 
parameters blank for a basic deployment.

For the detailed procedure, see “Configuring a resource 
group for MCP” on page 119

5. Create SIP Server application objects. Go to: Provisioning > Switching

If your configuration does not already include the following 
prerequisite SIP Server-related objects, create them now:

1. Create a SIP Switching Office object.

2. Create a SIP Switch object.

For detailed procedures, see the Framework 8.1 SIP Server 
Deployment Guide.

6. Create SIP extensions for your agent 
endpoints.

Go to: Provisioning > Switching > Switches

If your SIP Server configuration does not already include SIP 
agent endpoints (SIP phones connected to the switch), then 
you must create at least one in order to test the sample 
routing strategy that you will create in later steps.

1. On the DNs tab of the SIP Switch, click Add and create an 
extension for each SIP phone you want to connect to the 
switch.

2. On the Options tab of the DN, create a TServer section 
with a contact option whose value points to the IP 
address of the SIP or agent endpoint.

Note: This is the minimum configuration required for a SIP 
endpoint, suitable for testing the integrated solution. For 
more information about configuring endpoints, see the 
Framework 8.1 SIP Server Deployment Guide.

Task Summary: Common Configuration Tasks for All Deployments (Continued) 

Objective Related Procedures and Actions
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7. Configure a GVP DN for Standard 
VoiceXML applications.

Go to: Provisioning > Switching > Switches

To enable SIP Server to identify GVP in the solution, create 
the following DN:

• Create a GVP Trunk DN on the SIP switch, pointing the 
TServer > contact option to the IP address and port for 
Resource Manager.

• prefix—Set this option to the first three or four digits of 
the incoming DNIS

For a detailed procedure, see Procedure: Configuring a GVP 
DN for Standard VoiceXML applications, on page 116.

8. (Optional) Integrate SSG into the 
deployment.

Optional: Required for SSG-initiated outbound call 
functionality.

For information about configuring the VPS with SSG for 
outbound call initiation, see Chapter 13, “Integrating with 
SSG,” on page 195.

9. (Optional) Configure management 
and monitoring tools.

Optional: These procedures are only required if you are 
capturing alarm and trap information.|

1. Install and configure an SNMP Master Agent an all GVP 
hosts.

2. Install MIBs on the machine where your SNMP 
management console (for example HP Open View) is 
running.

3. Connect GVP components to the SNMP Master Agent on 
each host.

For a detailed procedure, see Procedure: Configuring SNMP 
Monitoring, on page 123.

Additional Special Configuration

If your gateway does not support REFER 
transfers...

Go to: Provisioning > Switching > Switches

On the Trunk DN for the gateway, configure the TServer 
section with the following options:

• Set the refer-enabled option to false.

• For the prefix option, enter the prefix of the ANI for the 
incoming call.

• For the contact option, enter the IP address and port of 
the media gateway.

For the detailed procedure, see “Creating a Trunk DN for 
gateways that do not support REFER” on page 124.

Task Summary: Common Configuration Tasks for All Deployments (Continued) 

Objective Related Procedures and Actions
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If SIP Server needs to be taken out of the 
signaling path after a REFER transfer...

Go to: Provisioning > Switching > Switches

• In the Trunk DN that represents the SIP device, set 
oosp-transfer-enabled to true. This takes SIP Server 
out of the signaling path.

When to Use

In some scenarios, SIP Server needs to be taken out of the 
signaling path after single-step transfer is completed. For 
example, if the SIP device cannot receive a different IP 
address in the Refer-to header of the REFER message other 
than its own.

To configure MCP for media redirect 
transfers.

Go to: Provisioning > Environment > Applications

The VPS supports two types of bridged transfers: bridge and 
media redirect. You can configure these methods by defining 
the default transfer method in the MCP Application object:

• For bridge transfers, no special configuration is required. 
The solution defaults to this method for bridged transfers.

• For media redirect transfers, do one of the following:

• On the Options tab in the MCP object, in the sip section, 
set the defaultbridgexfer option to MEDIAREDIRECT.

• OR

For NGI applications, if you want to leave the default as 
BRIDGE, you can override the default by setting the 
genesys:method parameter in the <transfer> tag of the 
voice application to mediaredirect.

For a detailed procedure, see “Configuring the solution for 
media redirect transfers” on page 126.

Task Summary: Common Configuration Tasks for All Deployments (Continued) 

Objective Related Procedures and Actions
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Integrating SIP Server with GVP
To integrate the SIP Server and GVP components, complete the following 
procedures:

1. Procedure: Configuring a GVP DN for Standard VoiceXML applications

2. Procedure: Configuring MCP for integration with SIP Server

3. Procedure: Configuring a resource group for MCP

4. Procedure: Configuring GVP for URS-controlled applications

Procedure:
Configuring a GVP DN for Standard VoiceXML 
applications

Purpose:  To create a Trunk DN that SIP Server uses to identify GVP in the 
solution. SIP Server uses this Trunk DN to access VoiceXML applications that 
are mapped as IVR Profiles on the Resource Manager. For more information 

To integrate a PBX into the VPS. For deployments that include a TDM-based or IP-based 
PBX, additional integration steps include:

1. Install and configure the premise T-Server for your 
switch, including the following switch-related 
configuration objects:
 Switch object
 Switching Office object
 Premise T-Server Application object

2. Configure Access Codes for ISCC communication 
between the premise switch and the SIP switch.

3. Configure coordinated telephony objects (DNs) on the 
premise switch and in the Configuration Layer.

For example, in a Cisco CallManager (CCM) integration, 
an ACD Queue DN in the Configuration Layer must be 
configured as a Routing Point DN in the CCM.

For more information, refer to the T-Server Deployment 
Guide for your particular switch.

For an overview of a PBX scenario, see “REFER Transfers to 
Agents on a PBX” on page 53.

Task Summary: Common Configuration Tasks for All Deployments (Continued) 

Objective Related Procedures and Actions
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about mapping applications on the Resource Manager, see the Genesys Voice 
Platform 8.1 Deployment Guide.

Prerequisites

• For the Trunk DN, the VoiceXML application must be mapped on the 
Resource Manager, using the IVR Profile method—which you can 
configure in Genesys Administrator, under Provisioning > Voice 
Platform > IVR Profile. For detailed procedures, see the Genesys Voice 
Platform 8.1 User’s Guide.

Start of procedure

1. Go to Provisioning > Switching > Switches, and double-click your SIP 
Server Switch object.

2. On the DNs tab, click Add.

A New DN window opens.

3. On the Configuration tab, enter the following information:
• Number—Number the DN according to the phone number that 

customers use to dial the contact center. For example, if the contact 
number is (123) 456-7890, then enter 1234567890 as the number for this 
DN.

• Type—Select Trunk from the drop-down list.

4. On the Options tab, click New and create a new section called TServer, then 
add a new option called contact. For the value of this option, enter the IP 
address and SIP port for the Resource Manager, as shown in Figure 43.

Figure 43: Trunk DN—Contact Option

When an incoming call arrives at the SIP Server, and the user part of the 
Request-URI matches the newly created DN, SIP Server forwards the 
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request to the configured contact—the Resource Manager, as identified by 
this IP address and port.

5. To ensure that SIP Server selects the GVP Trunk DN, set the prefix option 
to the first three or four digits of the incoming DNIS (correspondingly, you 
must provision the IVR Profile for this DNIS range, which is handled by 
GVP RM).

6. Click Save and Close to save all changes.

7. Repeat Steps 2 to 6 for every unique contact number that customers can 
use to dial into the contact center.

End of procedure

Next Steps

• Procedure: Configuring MCP for integration with SIP Server

Procedure:
Configuring MCP for integration with SIP Server

Purpose:  To configure the Media Control Platform (MCP) for integration with 
SIP Server.

Start of procedure

1. In Genesys Administrator, select Provisioning > Environment > 
Applications, and click the GVP Media Control Platform Application 
object.

2. On the Options tab, set the Use Original Gateway in Outbound Call 
parameter (sip section, outcalluseoriggw option) to Enable.

3. On the Options tab, set the Route Set parameter (sip section, routeset 
option) to the IP address and port for the Resource Manager, in the format 
(outer angle brackets included):

<sip:<ip_address:port>;lr>

For example:
<sip:192.168.50.169:5070;lr>

4. Click Save to save the changes.

End of procedure

Tip: For more information about this parameter, and other parameters 
used in this procedure, see Table 5.
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Additional Info

Table 5 describes in greater details the options that are configured in this 
procedure.
.

Next Steps

• If your Resource Manager already includes a resource group for MCP, 
continue at:
 Procedure: Configuring a gateway resource group for SIP Server

• Otherwise, continue at:
 Procedure: Configuring a gateway resource group for SIP Server

Procedure:
Configuring a resource group for MCP

Purpose:  To create the resource group on Resource Manager used to define the 
connection to the MCP.

Start of procedure

1. In Genesys Administrator, go to the Provisioning > Voice Platform > 

Resource Groups panel (see Figure 44 on page 120).

Table 5: Configuring MCP Options for SIP

Name Section Option Value

Use Original Gateway 
in Outbound Call

sip outcalluseoriggw Set this value to 1 so that MCP is able to 
resolve hosts in cases where the VoiceXML 
<transfer> request does not specify the 
destination attribute.

See the option description on page 225.

Route Set sip routeset To point MCP to the routeset on the 
Resource Manager, enter the IP address and 
port number for the sip proxy (Resource 
Manager), using the following format (outer 
angle brackets included):

<sip:<RM IP address>:<RM SIP port>;lr>

Note: If including multiple proxies in the 
string, separate each by a comma.

See the option description on page 226.



120 Voice Platform Solution 8.1

Chapter 10: Configuration Tasks for All Deployments Integrating SIP Server with GVP

Figure 44: The Resource Groups Panel

2. Click New to start the Resource Group Wizard.

3. When the wizard opens, click Next.

4. On the Resource Manager Selection page, select the Resource Manager for 
which you want to configure the resource group, then click Next.

5. On the Group Name and Type page, give your resource group a name, and 
select Media Control Platform as the type. Then click Next.

6. On the Tenant Assignment page, select the child tenant (if available) that 
you want to dedicate these resources to. Leave unassigned to share the 
resources across all child tenants. Click Next.

7. On the Group Properties page, configure the parameters as follows:
• Monitoring Method—Accept the default of SIP-OPTIONS.
• Load Balancing Scheme—Select least percent.

8. On the Resource Assignment page, do the following:

a. Select your Media Control Platform from the list.

b. Select the Scheme—either SIP or SIPS (secure SIP).

c. Select the Port number—typically 5070.

d. Click Next.

9. On the Confirmation page, click Finish.

End of procedure

• Procedure: Configuring a gateway resource group for SIP Server, on 
page 121

Tip: The parameters Maximum Conference Size and Maximum 
Conference Count are optional. For information about configuring 
conferences, consult the Genesys Voice Platform 8.1 User’s Guide.



Integration Guide 121

Chapter 10: Configuration Tasks for All Deployments Integrating SIP Server with GVP

Procedure:
Configuring GVP for URS-controlled applications

Purpose:  To configure GVP by creating a default IVR Profile to enable the 
connection to the Media Control Platform.

Summary

The URS-controlled application that you specify in the APP_URI parameter will 
override the application that is specified in the default IVR Profile.

Start of procedure

1. Check that a default IVR Profile has been created. For more information 
about creating default IVR Profiles, see Chapter 7 in the Genesys Voice 
Platform 8.1 Deployment Guide.

2. You can also create a separate IVR Profile for this particular application, if 
there are special requirements (which you can specify in the profile) to be 
applied to the URS-controlled application. 

For example, after creating the IVR Profile for this application, append the 
gvp-tenant-id parameter to the end of the APP_URI parameter in the Play 
application. For more information about creating Play applications, see 
Procedure: Creating and loading a routing strategy, on page 141.

End of procedure

Next Steps

• No further steps are required.

Procedure:
Configuring a gateway resource group for SIP Server

Purpose:  To create a gateway resource that Resource Manager uses to 
communicate with SIP Server.

Prerequisites

• To configure SIP Server as a gateway resource, and GVP requires a 
connection between the RM and the SIP Server.

Start of procedure

1. In Genesys Administrator, go to Provisioning > Voice Platform > 

Resource Groups panel.
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2. Click New to start the Resource Group Wizard.

3. When the wizard opens, click Next.

4. On the Resource Manager Selection page, select the Resource Manager for 
which you want to configure the resource group, then click Next.

5. On the Group Name and Type page, give your resource group a name, and 
select Gateway as the type. Then click next.

6. On the Group Properties page, configure the parameters as follows:
• Monitoring Method—Accept the default of SIP-OPTIONS.
• Load Balancing Scheme—Accept the default of Round Robin.
• CTI Usage—Select Always Off.

7. On the Resource Assignment page, do the following:

a. Select your SIP Server from the list.

b. Select the Scheme—either SIP or SIPS (secure SIP).

c. Select the SIP Port number—typically 5060.

d. Select the Max Ports for this SIP Server gateway group.

e. Click Next.

8. On the Confirmation page, click Finish.

End of procedure

Next Steps

• If your solution does not yet include the required SIP Server-related 
objects, create the following before moving on to the next step:
 SIP Switching Office
 SIP Switch

• This completes the baseline integration of the VPS. Additional 
configuration is also required, depending on how CTI is provided in the 
solution. Continue at one of the following:
 Chapter 11, “Configuration Tasks for CTI Through SIP Server,” on 

page 129
 Chapter 12, “Configuration Tasks for CTI Through IVR Server,” on 

page 145.

Configuring SNMP Monitoring
VPS supports Simple Network Management Protocol (SNMP) monitoring for 
the Resource Manager, Media Control Platform, Call Control Platform, and 

Tip: For CTI through IVR Server deployments, you may want to select a 
different CTI usage. For more information, see “Configuring CTI 
Flagging for IVR Profiles” on page 188.
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Supplementary Services Gateway components. If configured for it, these 
components can maintain status information and statistics in SNMP 
Management Information Base (MIB) tables. You can query these MIBs with 
an SNMP Management Console (for example, HP Open View).

Procedure:
Configuring SNMP Monitoring

Purpose:  To install and configure the Management Framework and GVP 
components required to capture alarm and trap information to a third-party 
SNMP management console.

Prerequisites

• Management Framework 8.1 CD

• Genesys Voice Platform 8.1 CD

Start of procedure

1. Verify that an MIB management console (for example, HP Open View) is 
up and running in your environment. 

2. From the Management Framework 8.1 CD, install and configure an SNMP 
Master Agent (SNMP_MA) application on every machine that hosts a 
GVP component.

a. Import the SNMP_Master_Agent_811 template to the Application 
Templates folder.

b. Create an SNMP_MA Application object on each GVP host.

c. Install the SNMP_MA application on each GVP host.

d. On the Options tab of each SNMP_MA application, in the snmp section, 
set the trap_target option to the IP address and port number of the 
machine where your MIB browser is running.

3. From the Genesys Voice Platform 8.1 CD, load the MIBs Installation 
Package on your SNMP management console (for example, HP Open 
View).

a. Run the setup.exe file for the MIB Installation Package.

b. When prompted, select the default installation path:

Note: For more information about the about SNMP traps, as well as basic 
troubleshooting information for the Genesys Voice Platform, see the 
Genesys Voice Platform 8.1 Troubleshooting Guide.

Note: For more information about installing SNMP Master Agents, 
consult the Framework 8.1 Deployment Guide.

Windows C:\Program Files\GCTI\VP MIB 8.1
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4. For every GVP component that you want to monitor, on the Configuration 
tab, add a connection to the SNMP_MA installed on the same host.

End of procedure

Integrating With Gateways That Do Not 
Support REFER

If your media gateway supports REFER requests, it can respond to a Blind 
transfer from GVP—forwarded as a REFER request from SIP Server to the 
gateway. No special configuration is required.

However, if your media gateway does not support REFER requests, it cannot 
initiate the outbound leg of the call. In this case, you must create a Trunk DN, 
which represents the gateway when sending the second INVITE request to SIP 
Server.

Procedure:
Creating a Trunk DN for gateways that do not support 
REFER

Purpose:  Additional configuration to force the re-INVITE transfer method for 
media gateways that do not allow REFER transfers.

Start of procedure

1. Go to Provisioning > Switching > Switches, and double-click the SIP 
Server Switch.

2. On the DNs tab, click Add.

3. Enter a Number and select Trunk as the type.

4. On the Options tab, create a TServer section, and add new options as 
follows:
• Set refer-enabled to false.
• Set prefix to the initial digits of the ANI for the incoming call.
• Set contact to the IP address and port of the media gateway.

Linux sh install.sh /opt/genesys/gvp/VP_MIB_8.1

Note: For more information about installing MIBs, consult the Genesys 
Voice Platform 8.1 Deployment Guide.

Tip: For more information about these options as configured in this 
procedure, see Table 6.
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5. Click Save to save all changes.

End of procedure

Additional Info

Table 6 describes in greater detail the options configured in this procedure.
.

Next Steps

• You have completed all of the required steps to configure the solution for 
media gateways that do not support REFER requests.

Configuring the Solution for Media 
Redirect Transfers

The VPS supports two types of bridged transfers: bridge and media redirect. 
For bridge transfers, no special configuration is required.

For media redirect transfers, however, you must set the default transfer method 
for MCP to MEDIAREDIRECT, otherwise MCP will try to process the transfer 
using the bridge method. 

For NGI applications, if you want to use a different bridge transfer method 
than the default method specified in MCP, you can override the default by 
setting the gvp.method parameter in the <transfer> tag of the application to the 
transfer type you want to use: mediaredirect or bridge. Or if building your 
application in Composer, for the transfermethod, select mediaredirect.

Table 6: Configuring DN Options

Section Option Value

TServer refer-enabled Set refer-enabled to false so that SIP Server 
will use a re-INVITE message instead of a REFER 
message for single-step call transfers.

TServer prefix Set this option to the initial digits of the ANI for 
the incoming call. For example, if the caller 
number is 9051234567, then set this option to 
905.

TServer contact Enter the IP address and port for the media 
gateway. Use the following format:

<IP address>:<port>

Note: The default port for the media gateway is 
5060. If using the default port, you do not need 
to include it in this string.
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Procedure:
Configuring the solution for media redirect transfers

Purpose:  To configure the MCP so that the solution can support media redirect 
transfers.

Start of procedure

1. In Genesys Administrator, under Provisioning > Environment > 
Applications, select the GVP/MCP Group from the configuration unit 
drop-down menu.

2. Open the MCP application, and on the Options tab, set the Default Bridge 
Transfer parameter (sip section, defaultbridgexfer option) to 
MEDIAREDIRECT.

3. Click Save to save the changes.

End of procedure

Special Configuration for Outbound Calls
Depending on your media gateway, the VPS supports outbound calls using 
either the remote dialer service feature of MCP, CCXML and the Call Control 
Platform (CCP), or the Supplementary Services Gateway (SSG). Call Progress 

Tip: If you want to switch back to the bridge transfer method, then you 
must set this defaultbridgexfer option back to the default value of 
BRIDGE. Or for NGI applications, you can set gvp.method to bridge in 
the voice application, which overrides the default.
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Analysis (CPA) is available for outbound calls, also depending on the media 
gateway.

Task Summary: Configuring the Solution for Outbound Calls provides an 
overview of the special configuration steps required for outbound calls in 
different scenarios to work.

Note: This configuration is meant for legacy deployments or applications, 
where the Supplementary Services Gateway (SSG) is not involved in 
initiating or controlling the outbound application. However, Genesys 
recommends using SSG when possible. For details about configuring 
the solution for SSG, see Chapter 13, “Integrating with SSG,” on 
page 195,

Task Summary: Configuring the Solution for Outbound Calls

Objective Related Procedures and Actions

For outbound calls using remote dialer... 1. Check that the defaultgw option in the sip section of 
MCP is set to the host name or IP address and SIP port—
for example:

pstn-gw.voiceplatform.com:5060

2. Check that the routeset option in MCP is configured to 
point to the Resource Manager—for example:

<sip:rm:5060;lr>

MCP needs to have the address of the next hop, which is the 
Resource Manager, when making outbound calls.

3. Use the PuTTY terminal emulator to establish a telnet 
connection to MCP. The default telnet port for MCP is 
6999.

4. For basic remote dialing, use the following Telnet 
command:

call <telno> <ani> <url> <refno> [uuidata] [defaults] 
[parameter_list]

5. For CPA-enabled remote dialing, use the command in 
Step 4, appended with an additional parameter—for 
example (the appended parameter is in bold):

call 6796500 65 file://C:/samples/main.vxml 205 -- 
Sip.Invite.X-Detect=Request=FAX,AMD
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For outbound calls with CCP, using NGI 
applications...

1. In the IVR Profile, check that the 
default-properties-page parameter points to the 
default-ng.vxml file, not to default.vxml.

2. For Call Progress Analysis, the CCXML application must 
add a private header to the INVITE to trigger CPA on the 
Paraxip gateway.

For sample code required to trigger CPA, see Step 2 on 
page 62.

3. The initiating application must conform to the CCXML 
specification for creating new sessions. You can find the 
specification at the following URL:

http://www.w3.org/TR/ccxml/#createsession

Task Summary: Configuring the Solution for Outbound Calls (Continued) 

Objective Related Procedures and Actions
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11 Configuration Tasks for CTI 
Through SIP Server
This chapter describes the additional configuration tasks required to integrate 
the solution for a CTI through SIP Server deployment. This basic infrastructure 
supports multiple architecture configurations and transfer modes, as described 
in “How It Works—The Basic Inbound Call Flow” on page 23 and “Supported 
CTI Through SIP Server Configurations” on page 31.

This chapter includes the following sections:
 Task Summary: CTI Through SIP Server Configuration, page 130
 Integrating SIP Server with GVP for CTI Through SIP Server, page 132
 Mapping User Data, page 134
 Building a URS-Controlled Application, page 139
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Task Summary: CTI Through SIP Server 
Configuration

Task Summary: Task Summary: Configuration for CTI Through SIP Server, on 
page 130 provides an overview of the main steps that you must complete in 
order to integrate SIP Server with the other VPS components. 

Task Summary: Task Summary: Configuration for CTI Through SIP Server

Objective Related Procedures and Actions

1. Verify the baseline integration tasks 
are completed.

All baseline tasks in Common Configuration Tasks for All 
Deployments, page 112 must be completed.

To verify that the solution is working:

1. Go to Provisioning > Environment > Applications.

2. Check that the green Started bar appears under the 
Status column for the following applications:

• SIP Server

• Resource Manager

• Media Control Platform/Call Control Platform

• Universal Routing Server

• Stat Server

If any of these applications are not shown as started, click the 
application, and then click the green Start arrow. If any 
application does not start, recheck the configuration.

2. Configure Resource Manager for 
integration with SIP Server.

Go to: Provisioning > Voice Platform > Resource Groups

To communicate with SIP Server, Resource Manager requires 
a gateway resource that represents SIP Server.

• Click New and follow the wizard to create a new resource 
group of the type Gateway.

Key Parameters

• Accept the defaults for Monitoring Method and Load 
Balancing Scheme.

• Set CTI Usage to Always Off.

For the detailed procedure, see “Configuring a gateway 
resource group for CTI through SIP Server” on page 132.
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3. Configure a GVP DN for URS-centric 
applications.

Go to: Provisioning > Switching > Switches

To enable SIP Server to identify GVP for in the solution, 
create the following DN:

• Create a Voice over IP Service DN on the SIP switch, 
pointing the TServer > contact option to the IP address 
and port for Resource Manager. Set the service-type 
option to application.

For the detailed procedure, see “Configuring a GVP DN for 
URS-centric applications” on page 133.

4. Configure user data exchange 
between SIP Server and GVP.

Go to: Provisioning > Switching > Switches

If your call flow design requires the exchange of customer 
data between SIP Server and the VoiceXML application, you 
must configure SIP Server so that it maps data in both of the 
following directions:

• SIP Server takes data from GVP SIP messages and 
attaches it to the call (that is, maps the data to the 
T-Library EventAttachedDataChanged message).

• SIP Server attaches data from the T-Library message and 
adds it as headers in the SIP message sent to GVP.

There are two options available to configure this mapping:

• userdata-map-trans-prefix—SIP Server maps user data 
from all custom headers with the prefix specified in this 
option. Configure this option in the TServer section of the 
SIP Server Application object.

• userdata-map-filter—Use this option to specify which 
headers need to be mapped for user data required by GVP. 
If GVP does not need the user data, then you can leave 
this option undefined. Configure this option in the 
TServer section of the GVP Trunk and Voice over IP 
Service DNs.

For a more detailed procedure, see “Enabling user data 
exchange between SIP Server and GVP” on page 135.

For examples of user data mapping, see Appendix A on 
page 219.

5. Create a Routing Point DN on the SIP 
Server.

Go to: Provisioning > Switching > Switches

For URS routing to agents, as well as to start the VoiceXML 
application, you need to create a Routing Point DN on the 
SIP Server switch.

For the detailed procedure, see “Creating a Routing Point on 
the SIP Server” on page 140.

Task Summary: Task Summary: Configuration for CTI Through SIP Server (Continued) 

Objective Related Procedures and Actions
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Integrating SIP Server with GVP for CTI 
Through SIP Server

To integrate the SIP Server and GVP components for CTI through SIP Server 
deployments, complete the following procedures:

1. Procedure: Configuring a gateway resource group for CTI through SIP 
Server

2. Procedure: Configuring a GVP DN for URS-centric applications, on 
page 133

Procedure:
Configuring a gateway resource group for CTI through 
SIP Server

Purpose:  To create a gateway resource that Resource Manager uses to 
communicate with SIP Server, in CTI though SIP Server configurations.

Prerequisites

• To configure SIP Server as a gateway resource, and GVP requires a 
connection between the RM and the SIP Server.

Start of procedure

1. Go to Provisioning > Voice Platform > Resource Groups panel.

2. Click New to start the Resource Group Wizard.

3. When the wizard opens, click Next.

4. On the Resource Manager Selection page, select the Resource Manager for 
which you want to configure the resource group, then click Next.

6. Create a routing strategy and load it 
on the Routing Point DN.

Use the Interaction Routing Designer to:

1. Create the routing strategies that URS uses to route calls 
to agents and launch VoiceXML applications.

2. Load the strategy on the Routing Point DN that you 
created in Step 5.

For the detailed procedure, see “Creating and loading a 
routing strategy” on page 141.

Task Summary: Task Summary: Configuration for CTI Through SIP Server (Continued) 

Objective Related Procedures and Actions
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5. On the Group Name and Type page, give your resource group a name, and 
select Gateway as the type. Then click next.

6. On the Group Properties page, configure the parameters as follows:
• Monitoring Method—Accept the default of SIP-OPTIONS.
• Load Balancing Scheme—Accept the default of Round Robin.
• CTI Usage—Select Always Off.

7. On the Resource Assignment page, do the following:

a. Select your SIP Server from the list.

b. Select the Scheme—SIP.

c. Select the SIP Port number—typically 5060.

d. Select the Max Ports for this SIP Server gateway group.

e. Click Next.

8. On the Confirmation page, click Finish.

End of procedure

Next Steps

• Next, you will create the DNs that SIP Server uses to identify GVP in the 
solution. DNs are created on a configured switch—a prerequisite to these 
procedures. If your solution does not yet include the required SIP 
Server-related objects, create the following before moving on to the next 
step:
 SIP Switching Office
 SIP Switch

• If your configuration already includes these objects, continue with 
“Configuring a GVP DN for URS-centric applications”.

Procedure:
Configuring a GVP DN for URS-centric applications

Purpose:  To create a Voice over IP Service DN that SIP Server uses to 
identify GVP in the solution. SIP Server uses this Voice over IP Service DN 
to process Play Application requests that arrive on SIP Server from a URS 
routing strategy. The routing strategy can access the VoiceXML application 
directly by using the URL specified in the Play Application treatment—no 
mapping on the Resource Manager is required for this method..
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Start of procedure

1. Go to Provisioning > Switching > Switches, and double-click your SIP 
Server Switch object.

2. On the DNs tab, click Add.

A New DN window opens.

3. On the Configuration tab, enter the following information:
• Number—Enter a name or number for this DN.
• Type—Select Voice over IP Service from the drop-down list.

4. On the Options tab, click New and create a new section called TServer, then 
add the following new options:
• contact—Enter the IP address and SIP port for the Resource Manager 

as the value.
• service-type—Enter application as the value.

5. Click Save and Close to save all changes.

End of procedure

Next Steps

• If your call flow design requires the exchange of customer user data 
between SIP Server and GVP, you must configure SIP Server so that it 
maps data in both of the following directions:
 SIP Server attaches data from GVP SIP messages to the call.
 SIP Server attaches data from the T-Library message and adds it as 

headers in the SIP message sent to GVP.

Continue with “Enabling user data exchange between SIP Server and 
GVP” on page 135.

• If your call flow design does not require any user data mapping, continue 
with “Building a URS-Controlled Application” on page 139.

Mapping User Data
This section provides procedures for enabling the exchange of user data 
between Management Framework and the GVP voice application.

Data Flows in Two Directions

The exchange of user data takes place in two directions:

• From SIP Server to GVP—In this case, UserData data that is part of a call 
is mapped to custom headers in the INVITE message that SIP Server sends 
to GVP, making the data available to the VoiceXML application.
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• From GVP to Management Framework—In this case, customer info sent in 
the body of INFO and BYE requests, or in the headers of REFER, or re-INVITE 
messages, is mapped to the T-Library event, making the data available to 
the URS routing strategy, or to any other Genesys application that needs it. 
 For info sent in the body of BYE or INFO requests, no special 

configuration is required.
 For info sent in the headers of REFER messages or re-INVITE transfers, 

mapping will occur, provided that the prefix in the name of the custom 
header matches the prefix specified in the userdata-map-trans-prefix 
option.

Mapping Samples

For examples of user data mapping from SIP Server to GVP, and from GVP to 
SIP Server, see Appendix A on page 219.

Procedure:
Enabling user data exchange between SIP Server and 
GVP 

Purpose:  To enable the exchange of user-defined customer information 
between SIP Server and the VoiceXML application. 

Prerequisites

For mapping user data from SIP Server to GVP, you need to modify the GVP 
Trunk DN and Voice over IP Service DN that you created in “Configuring a 
GVP DN for URS-centric applications” on page 133.

Start of procedure

1. If any user data mapping is required, in the TServer section of the SIP 
Server Application object, use the userdata-map-trans-prefix option to 
specify the prefix for the custom headers that SIP Server will map to the 
T-Library UserData attributes. All headers that start with this prefix will be 
mapped.

For a more detailed procedure, see “Configuring user data mapping on SIP 
Server” on page 136.

2. If user data mapping is required from SIP Server to GVP, in the GVP Trunk 
and Voice over IP Service DNs, use the userdata-map-filter option to 
specify which user data key-value pairs will be mapped to the custom 
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headers in the INVITE request. Separate the values with a comma. If GVP 
does not need to receive any user data, then you can leave this option 
undefined.

For a more detailed procedure, see “Configuring user data mapping on the 
GVP DNs” on page 137.

End of procedure

Next Steps

• If you have completed the mapping procedures required for your CTI 
operations, continue with “Building a URS-Controlled Application” on 
page 139.

Procedure:
Configuring user data mapping on SIP Server

Purpose:  To configure SIP Server so that it maps custom headers in the INVITE 
request to UserData attributes in the T-Library event, according to a defined 
custom header prefix. Any header that matches this prefix will be mapped. 

Mapping takes place as follows:

• For data mapping from SIP Server to GVP, this prefix is added to the user 
data sent out by SIP Server.

• For data mapping from GVP to SIP Server, user data in the body of INFO or 
BYE messages are automatically mapped. For user data configured to pass 
in the headers of REFER messages or re-INVITE transfers, any data in 
headers starting with this prefix are mapped to the T-Library event.

Start of procedure

1. Go to Provisioning > Environment > Applications, and double-click the 
SIP Server Application object.

2. On the Options tab, in the TServer section, select the option 
userdata-map-trans-prefix.

3. For the value, enter the prefix used by the custom headers that carry the 
user data. Use a single value for this option.

Figure 45 shows the SIP Server Options tab with the 
userdata-map-trans-prefix option set for the X-Genesys- prefix. Genesys 
recommends using this prefix to identify custom headers in the SIP 
request.
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Figure 45: Sample Mapping—Prefix Method

4. Click Save to save all changes.

End of procedure

Next Steps

• If GVP needs to get user data from SIP Server, you must also define the 
userdata-map-filter option. See “Configuring user data mapping on the 
GVP DNs” on page 137.

• If GVP does not need any user data, then continue with “Building a 
URS-Controlled Application” on page 139.

Procedure:
Configuring user data mapping on the GVP DNs

Purpose:  To enable user data mapping from SIP Server to GVP. Use this 
procedure to specify only those headers that need to be sent to GVP. If GVP 
does not need any user data, then skip this procedure.

Prerequisites

• Procedure: Configuring a GVP DN for URS-centric applications, on 
page 133

• Procedure: Configuring user data mapping on SIP Server, on page 136

Tip: SIP Server can handle 16K bytes of user data by default. If your 
routing strategy and VoiceXML application require a larger amount of 
data, adjust the user-data-limit option to meet your needs. This option 
defaults to a value of 16000.
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Start of procedure

1. Go to Provisioning > Switching > Switches, and double-click your SIP 
Server Switch object.

2. On the DNs tab, select the Trunk DN that you created in Step 2 of 
“Configuring a GVP DN for URS-centric applications” on page 133.

A new window for this DN opens.

3. On the Options tab, in the TServer section, create a new option called 
userdata-map-filter.

4. For the value, enter the prefix for any UserData attributes that you want to 
be mapped from the T-Library message to the INVITE request. Separate the 
values with a comma. Enter * to map all user data.

Figure 46 shows the GVP Trunk DN configured with the sample UserData 
attributes CustomerParam and CustomerName.

Figure 46: Sample Mapping—Filter Method

In this example, any user data in the T-Library message starting with these 
attributes (for example, CustomerParam1, CustomerParam2, and so on) will 
be added to the INVITE request.

5. Click Save to save all changes.

6. Repeat steps 2 to 5 for the Voice over IP Service DN that you created in 
Step 2 of “Configuring a GVP DN for URS-centric applications” on 
page 133.

End of procedure

Next Steps

• “Building a URS-Controlled Application”

Tip: All user data filtered from the T-Library message will show up 
in the custom header of the INVITE with an additional custom 
prefix, as defined in the userdata-map-trans-prefix option.
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Building a URS-Controlled Application
Genesys recommends that you build your voice call flows using a 
URS-controlled application paradigm. In this paradigm, simple VoiceXML 
applications handle the voice dialog portion of the call, while the routing 
strategy provides all CTI functionality.

Task Summary: Building a URS-Controlled Application

Task Summary: Building a URS-Controlled Voice Application, on page 139 
provides an overview of the steps required to build a typical URS-controlled 
application.

It is important that you create a default IVR Profile before you start building 
your URS-controlled applications. See Procedure: Configuring GVP for 
URS-controlled applications, on page 121.

Task Summary: Building a URS-Controlled Voice Application

Call Event Related Procedures and Actions

1. Call arrives on VPS. Configure a Routing Point DN on the SIP Server switch.

Incoming calls for a URS-controlled application should arrive at 
this DN.

For a detailed procedure, see Procedure: Creating a Routing Point 
on the SIP Server.

2. A routing strategy starts. Configure a routing strategy to be loaded on the Routing Point 
DN. 
Collecting User Data

The strategy can perform actions before the voice dialog starts—for 
example, it can collect digits or look up customer information in the 
database, and then pass this info on to the voice application.

3. The strategy launches a voice 
dialog.

Use Composer (recommended) to build a VoiceXML application, 
and then add a Play Application treatment block to the routing 
strategy, configuring the APP_URI parameter so that it points to the 
VoiceXML application.
Collecting User Data

If you want the application to collect data from the customer, 
include the following key blocks in the application:

• An Input block to collect the data.

• An InteractionData block to send the data to the strategy. 
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Procedure:
Creating a Routing Point on the SIP Server

Purpose:  To create the Routing Point DN on the SIP Switch that will be used 
to invoke the routing strategy that you will create later in these procedures.

Calls to SIP Server can arrive on this routing point after coming in from the 
PSTN, or as a result of a transfer after the initial self-service portion of the call 
is finished.

Start of procedure

1. Go to Provisioning > Switching > Switches, and double-click your SIP 
Server Switch object.

2. On the DNs tab, click Add.

A New DN window opens.

3. On the Configuration tab, enter the following information:
• Number—Enter a name and number for the routing point.
• Type—Select Routing Point from the drop-down list.

4. Click Save and Close.

End of procedure

4. Call control returns to the 
strategy.

The Exit block in the VoiceXML application ends the voice dialog, 
and call control (as well as any collected data) returns to the routing 
strategy—no transfer from the application is required.
Using the Attached Data

If the VoiceXML application collected any data, the routing strategy 
can use a GetInteractionData function to assign the collected 
information to a variable. The strategy can use this variable in 
segmentation functions to route the caller—for example, to 
different agent groups depending on an account number.

5. The call is routed to an 
appropriate agent.

A TRoute function block in the routing strategy can be used to send 
the call to a specific agent.

For a detailed procedure outlining how to create a simple routing 
strategy, see Procedure: Creating and loading a routing strategy, on 
page 141.

Task Summary: Building a URS-Controlled Voice Application (Continued) 

Call Event Related Procedures and Actions
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Next Steps

• Procedure: Creating and loading a routing strategy

Procedure:
Creating and loading a routing strategy

Purpose:  To create a simple routing strategy that demonstrates the minimum 
requirements for an integrated solution (suitable for lab or integration testing 
purposes).

This strategy serves two purposes: to launch a simple VoiceXML application 
directly from URS, and to route the call to an agent after the treatment is 
finished. It supports the configuration that is described in “How It Works—The 
Basic Inbound Call Flow” on page 23.

Before you create the URS-controlled applications, ensure that you have an 
existing default IVR Profile. See Procedure: Configuring GVP for 
URS-controlled applications, on page 121.

Prerequisites

• A Routing Point DN on which to load the strategy. See Procedure: 
Creating a Routing Point on the SIP Server, on page 140.

• A simple VoiceXML application on GVP to which you can point the 
routing strategy’s Play Application. Creating VoiceXML applications is 
outside the scope of this guide. For more information, see the following:
 For information about VoiceXML, see Genesys Voice Platform 8.1 

VoiceXML 2.1 Help.
 For information about creating VoiceXML applications using Genesys 

Composer, press F1 from the Composer application to access its Help 
system.

Note: This VoiceXML application must be voice self-service only. The 
<transfer> block is unavailable for URS-controlled applications. 
Routing to assisted service must be done in the strategy, as no 
transfer capability exists for this type of voice application.

• A SIP agent endpoint on the SIP switch.

Summary

1. In the Interaction Routing Designer (IRD), create the simple routing 
strategy.

2. Configure the PlayApplication block so that the APP_URI parameter targets 
the URI of the prerequisite VoiceXML application.

3. Configure the Function block so that the strategy routes the call to an agent 
on the SIP switch, after the Play Application treatment is finished.
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4. Load the strategy on the prerequisite Routing Point DN.

Start of procedure

1. Start Interaction Routing Designer (IRD) and enter your login information.

2. In the Routing Design window, create the routing strategy.

The sample strategy consists of the following routing objects: Entry, 
PlayApplication, Function, and two Exit blocks (see Figure 47 on 
page 142).

Figure 47: Sample VPS Routing Strategy

3. Configure the PlayApplication block in this strategy, so that the App_URI 
parameter points to the VoiceXML application:

a. Double-click the PlayApplication block.

b. For the APP_ID parameter, enter a value of 1.

c. For the Language parameter, select English (US).

d. Click the Add item icon and create a new parameter called APP_URI, 
with a value that specifies the fully qualified URI of the prerequisite 
VoiceXML application. Enter the value by using the following format:
• Add the prefix {s}, so that the parameter is read as a string.
• Use percent-encoding (%20) for any spaces in the URI path.

You can also append the gvp-tenant-id parameter to the end of the 
APP_URI parameter in the Play application to specify a particular 
tenant. For more information about this parameter, see the Genesys 
Voice Platform 8.1 User’s Guide.

Figure 48 on page 143 shows a sample Play application properties 
window, as configured to launch the GVP VoiceXML application.

Tip: For more information about using IRD, see the Universal Routing 
8.1 Deployment Guide. You can also refer to Interaction Routing 
Designer Help, which you can access by pressing F1 in the application.
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Figure 48: Sample Play Application Properties Window

4. Configure the Function block so that URS will route the call to a specified 
agent on the SIP Server, after the Play Application treatment is finished:

a. Double-click the Function block.

b. Select the TRoute function.

c. For the Destination parameter, enter the DN number for one of the 
prerequisite SIP endpoints on the SIP switch.

d. For the Route Type parameter, select RouteTypeUknown from the value 
drop-down list.

e. Click Add, then click OK.

Figure 49 on page 144 shows a sample Function properties window, 
configured for the SIP endpoint DN 9001 on the SIP switch.

Tip: In this example, the VoiceXML application is stored locally. If 
using an application server, the APP_URI will point to the HTTP path for 
the application instead.
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Figure 49: Sample Function Properties Window

5. In the Monitoring window of IRD, load the new strategy on the Routing 
Point DN that you created in “Creating a Routing Point on the SIP Server” 
on page 140:

a. In the Shortcut bar, click the Loading icon.

b. In the Loading window, expand the SIP switch.

c. Right-click the prerequisite Routing Point, and select Load strategy.

d. Select the newly created strategy, and then click OK.

End of procedure

Next Steps

• You have completed all of the required steps for a CTI through SIP Server 
VPS integration.
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Chapter

12 Configuration Tasks for CTI 
Through IVR Server
This chapter describes how to integrate the Voice Platform Solution with the 
IVR Server, using the VPS 8.1 CTI Connector (CTI-C) component. The tasks 
to integrate IVR Server into the VPS differ, depending on the IVR Server 
mode your deployment requires.

For a description of how this integration works, or why it might be necessary 
in your deployment, see Chapter 7, “Support for IVR Server,” on page 89.

Complete the following tasks, depending on the IVR Server mode:
 Task Summary: Verify Prerequisites, page 145
 Task Summary: IVR Behind, Carrier-Connected Integration, page 147
 Task Summary: IVR Behind, TDM-Connected Integration, page 151
 Task Summary: Integrating with IVR Server—In-Front Mode, page 156
 Task Summary: Integrating with Network IVR Server, page 160
 Task Summary: Configuring Midcall CTI Functions, page 162
 Task Summary: Configuring Transfers, page 163
 Task Summary: Configuring Voice Treatments, page 166

Detailed procedures are provided in the following sections:
 Integrating with IVR Server in Behind Mode—Procedures, page 169
 Integrating with IVR Server in In-Front Mode—Procedures, page 180
 Integrating with Network IVR Server—Procedures, page 186
 Configuring CTI Flagging for IVR Profiles, page 188
 Enabling Midcall CTI Routing (IVR-centric Applications), page 191

Task Summary: Verify Prerequisites
Task Summary: Verify Prerequisites, on page 146 lists the component 
configurations and other actions that must be completed before you begin 
integrating the VPS with the IVR Server. 
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Task Summary: Verify Prerequisites

Requirement Related Procedures and Actions

Verify the baseline integration tasks are 
completed.

All baseline tasks in Common Configuration Tasks for All 
Deployments, page 112 must be completed.

To verify that the solution is working:

1. Go to Provisioning > Environment > Applications.

2. Check that the green Started bar appears under the 
Status column for the following applications:
 SIP Server
 Resource Manager
 Media Control Platform/Call Control Platform
 Universal Routing Server
 Stat Server

If any of these applications are not shown as started, click the 
application, and then click the green Start arrow. If any 
application does not start, recheck the configuration.

(Optional) The Supplementary Services 
Gateway (SSG) has been integrated into 
the VPS.

Optional: Required for SSG-initiated outbound call 
functionality.

If the SSG has not already been integrated into the solution, 
complete the procedures in Chapter 13, “Integrating with 
SSG,” on page 195.

The IVR Server and related objects have 
been created, and the IVR Server is 
installed.

If IVR Server is not already included in your deployment, 
you must install and configure new objects as follows.

Behind or In-Front Mode

• I-Server application

• TServer_IVR application

Genesys recommends that you use the Genesys 8.1 IVR 
Interface Option Wizard (available on the product CD) to 
initially configure these objects. For more information, see 
the “Wizard Configuration” chapter in the IVR Interface 
Option 8.1 IVR Server System Administrator’s Guide.

Network Mode

• TServer_IVR_Network application

• Network T-Server switch and application

For information about configuring a Network T-Server, refer 
to the Network T-Server Deployment Guide for your 
particular switch.
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Task Summary: IVR Behind, 
Carrier-Connected Integration

Task Summary: TDM-Connected, IVR Behind provides an overview of the 
main steps that you must complete in order to integrate the VPS with IVR 
Server in the Behind mode, in a carrier-connected deployment, with CTI 
flagging enabled.

The CTI Connector application has been 
created, and the application is installed.

If CTI Connector is not already included in your baseline 
GVP deployment, go to the “List of Procedures” section in 
the Genesys Voice Platform 8.1 Deployment Guide, and 
complete the following procedure:

• Installing the CTI Connector (Windows)

Task Summary: Verify Prerequisites (Continued) 

Requirement Related Procedures and Actions

Task Summary: Carrier-Connected, IVR Behind

Objective Related Procedures and Actions

1. Log in to Genesys Administrator. In your web browser, enter the application URL in the following 
format:

http://<genesys_administrator_host>/wcm

2. Verify prerequisites. Before starting the integration, verify the following prerequisites 
have been met:

• The basic Voice Platform Solution is deployed.

• The IVR Server and related objects have been created, and the 
IVR Server is installed.

• The CTI Connector application has been created, and the 
application is installed.

For a more detailed description of this task, see Procedure: Task 
Summary: Verify Prerequisites, on page 145.

3. Configure the SIP Server for 
Behind mode integration.

Go to: Provisioning > Environment > Applications

Configure the SIP Server options as follows:

• Set override-to-on-divert to false.

• Set event-ringing-on-100trying to true.

• Set handle-vsp to all.

• Add connections to URS, Stat Server, and Message Server.

For the detailed procedure, see Procedure: Configuring the SIP 
Server for Behind mode, on page 169.
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4. Configure the IVR Server. For step-by-step procedures, see the following:

1. Procedure: Creating the dummy switching office, on page 171

2. Procedure: Creating the dummy switch for TServer_IVR, on 
page 171

3. Procedure: Configuring the TServer_IVR object, on page 172

4. Procedure: Adding required connections to the I-Server, on 
page 172

Key Actions

• Associate TServer_IVR with the dummy switch.

• In TServer_IVR, configure the Router Timeout option to a 
value of 7 s.

• In TServer_IVR, configure active-release to false. 

• In the I-Server object, add a connection to TServer_IVR.

5. Create the IVR object to represent 
GVP.

Go to: Provisioning > Switching > IVRs

1. Create an IVR object to represent GVP:
 Select Genesys Voice Platform as the IVR Server.

2. Click Save to register with the Configuration Layer.

For a detailed procedure, see Procedure: Creating an IVR object 
to represent GVP in the solution, on page 173.

6. Configure the CTI Connector. Go to: Provisioning > Environment > Applications

1. Open your CTI Connector Application object.

2. On the Options tab, configure the following mandatory 
parameters:
 Resource Manager IP Address

 IVR Client Name

 IVR Server Host IP Address

 IVR Server Communication Port

 Local Host Name

3. On the Options tab, configure the following IVR port options:
 Max IVRPorts

For a detailed procedure, see Procedure: Configuring the CTI 
Connector for IVR Behind, on page 174.

Task Summary: Carrier-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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7. Configure IVR Ports. To configure IVR channels as Voice Treatment Port DNs, 
complete the following procedures:

1. Procedure: Creating Voice Treatment Port DNs, on page 175

2. Procedure: Mapping IVR Ports to their matching DNs, on 
page 177

3. Procedure: Configuring a Place object for each IVR Port, on 
page 178

4. Procedure: Configuring a Place Group as the target for IVR 
Ports, on page 178

Key Rules

• Create the DNs in the SIP Server switch, configuring the 
TServer section for each as follows:

• contact—Point this option to the Resource Manager, using 
the format sip:<RM_ip_address>:<RM_sip_port>.

• event-ringing-on-100trying—Set this option to true.

• Create matching DNs in the dummy switch for TServer_IVR—
no configuration required.

• Map each IVR Ports to appropriate DN in the dummy switch..

• Use identical numbering for the DNs, ports, and places.

• Use continuous numbering (in increments of one) when 
naming the DNs.

8. Configure Resource Manager for 
integration with CTI Connector.

Go to: Provisioning > Voice Platform > Resource Groups

For step-by-step procedures, see the following:

1. Procedure: Creating a resource group for the CTI Connector, 
on page 179

2. Procedure: Configuring the gateway resource for CTI through 
IVR Server, on page 188

3. Procedure: Flagging the IVR Profile for CTI, on page 190

Key Actions

• Create a resource group of type CTI for the CTI Connector.

• To enable CTI flagging:

1. Set CTI USage to Based On DN Lookup (use-cti to 2).

2. For non-CTI applications, set CTI Allowed in the IVR 
Profile to false.

Task Summary: Carrier-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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Additional Special Configuration

To fetch the script ID from URS... If your switch cannot supply the DNIS for the incoming call, you 
must configure CTI Connector to fetch the script ID from URS. 
CTI Connector uses the value of this key as the DNIS in the 
INVITE to Resource Manager for IVR Profile selection:

1. In URS, define the key-value pair for the script ID:
 Key—Define the key name that you will match in the CTI 

Connector application. The default is scriptidkeyname.
 Value—Define the value that matches the DNIS used to 

select the desired IVR Profile in Resource Manager.

2. In the CTI Connector Application object, set the following 
options in the IVRSC section:
 Fetch Script ID from URS—Enter 1 to enable CTI 

Connector to fetch the defined key from URS.
 Script Id Key Name—Enter the key name as defined in 

URS. CTI Connector sends this key to retrieve the value for 
the script ID.

Integrating SSG into CTI-C 
deployments.

Outbound calls initiated by SSG cannot go through CTI 
Connector. For deployments that include CTI-Connector, 
configure as follows:

1. In this behind-mode configuration, CTI Usage is already set to 
Based on DN Lookup (use-cti=2). No further configuration is 
required.

2. In the IVR Profile, configure CTI Allowed as follows:
 For outbound calls—Set CTI Allowed to false. Resource 

Manager will bypass CTI-C.
 For inbound calls, your IVR Profiles should already be 

configured to allow or disallow CTI. No further 
configuration is required.

For more information, see “Configuring CTI Flagging for IVR 
Profiles” on page 188.

Task Summary: Carrier-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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Task Summary: IVR Behind, 
TDM-Connected Integration

Task Summary: TDM-Connected, IVR Behind, on page 152 provides an 
overview of the main steps that you must complete in order to integrate the 
VPS with IVR Server in the Behind mode, in a TDM deployment.

No CTI flagging required... If your deployment does not require CTI flagging (all calls will 
go through CTI Connector), then modify the above procedures as 
follows:

• Set CTI Usage in the SIP Gateway to Always On (use-cti=1).

• Set GetDNISFromIServer in the CTI Connector to true.

• Do not configure the IVRPortBaseIndex or MaxIVRPorts 
options in the CTI Connector.

• Do not create Voice Treatment Port DNs in the dummy 
switch for TServer_IVR.

• In the I-Server application, add a connection to SIP Server, 
not TServer_IVR.

• Map the IVR Ports to the DNs on the SIP Server switch, not 
the dummy switch for TServer_IVR.

To configure the socket layer... 1. In the TServer_IVR application, configure the listening port for 
the socket layer in the GLI sections:
 gli_server > gli-server-mode—Enter circuit to enable 

the server to open multiple circuits.
 gli_server > gli-n-servers—Enter the number of circuit 

groups the server can open.

2. Create a gli-server-group_n section for each circuit group:
 gli-server-address—Enter the IP address and listening 

port, in the format <ip_address>:<port>.

3. In the CTI Connector Application object, set the 
iserversocket option to the GLI port as configured in Step 2. 
(For configuration details, see Procedure: Configuring the CTI 
Connector for IVR Behind, on page 174.)

Task Summary: Carrier-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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Task Summary: TDM-Connected, IVR Behind

Objective Related Procedures and Actions

1. Log in to Genesys Administrator. In your web browser, enter the application URL in the following 
format:

http://<genesys_administrator_host>/wcm

2. Verify prerequisites. Before starting the integration, verify the following prerequisites 
have been met:

• The basic Voice Platform Solution is deployed.

• The IVR Server and related objects have been created, and the 
IVR Server is installed.

• The CTI Connector application has been created, and the 
application is installed.

For a more detailed description of this task, see Procedure: Task 
Summary: Verify Prerequisites, on page 145.

3. Configure the SIP Server for 
Behind mode integration.

Go to: Provisioning > Environment > Applications

Configure the SIP Server options as follows:

• Set override-to-on-divert to false.

• Set event-ringing-on-100trying to true.

• Set handle-vsp to all.

• Add connections to the URS, Stat Server, and Message Server.

For the detailed procedure, see Procedure: Configuring the SIP 
Server for Behind mode, on page 169.

4. Configure Trunk DN. Go to Provisioning > Switching > Switches > and select your 
SIP Server Switch object.

1. On the DNs tab, click New and create a DN of type Trunk.

2. On the Options tab, create a TServer section with the options:
 contact—Set this to the IP address and port number for 

Resource Manager.
 prefix—Set this to the initial digits that will match the 

range of port numbers coming in from the gateway. Prefix 
matching lets you create a single DN for a range of 
incoming port numbers.

Key Actions

• Before creating the Trunk DN, check whether the port 
numbers are coming in from the media gateway or the PBX.
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5. Configure the IVR Server. For step-by-step procedures, see the following:

1. Procedure: Creating the dummy switching office, on page 171

2. Procedure: Creating the dummy switch for TServer_IVR, on 
page 171

3. Procedure: Configuring the TServer_IVR object, on page 172

4. Procedure: Adding required connections to the I-Server, on 
page 172

Key Actions

• Create the DNs on the premise T-Server switch.

• Associate TServer_IVR with a dummy switch.

• In TServer_IVR, configure the Router Timeout option to a 
value of 7 s.

• In TServer_IVR, configure active-release to false. 

• In the I-Server object, add a connection to the premise 
T-Server.

6. Add connections to the premise 
T-Server.

In the premise T-Server Application object, add connections to 
the following:

• Universal Routing Server

• Stat Server

• Message Server

7. Create the IVR object to represent 
GVP.

Go to: Provisioning > Switching > IVRs

1. Create an IVR object to represent GVP:
 Select Genesys Voice Platform as the type.
 Select your I-Server application as the IVR Server.

2. Click Save to register with the Configuration Layer.

For a detailed procedure, see Procedure: Creating an IVR object 
to represent GVP in the solution, on page 173.

Task Summary: TDM-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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8. Configure the CTI Connector. Go to: Provisioning > Environment > Applications

1. Open your CTI Connector Application object.

2. On the Options tab, configure the following mandatory 
parameters:
 Resource Manager IP Address

 IVR Client Name

 IVR Server Host IP Address

 IVR Server Communication Port

 Local Host Name

3. On the Options tab, in the CTIC section, set Fetch DNIS from 
IServer to true.

For a detailed procedure, see Procedure: Configuring the CTI 
Connector for IVR Behind, on page 174.

9. Configure IVR Ports. To configure IVR channels as Voice Treatment Port DNs, 
complete the following procedures:

1. Procedure: Creating Voice Treatment Port DNs, on page 175

2. Procedure: Mapping IVR Ports to their matching DNs, on 
page 177

3. Procedure: Configuring a Place object for each IVR Port, on 
page 178

4. Procedure: Configuring a Place Group as the target for IVR 
Ports, on page 178

Key Rules

• Create the DNs in premise T-Server switch (no configuration 
is required).

• Use identical numbering for the DNs, ports, and places.

• Map each IVR port to the appropriate Voice Treatment Port 
DN on the premise switch.

• Use continuous numbering (in increments of one) when 
naming the DNs.

Task Summary: TDM-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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10.Configure Resource Manager for 
integration with CTI Connector.

Go to: Provisioning > Voice Platform > Resource Groups

For step-by-step procedures, see the following:

1. Procedure: Creating a resource group for the CTI Connector, 
on page 179

2. Procedure: Configuring the gateway resource for CTI through 
IVR Server, on page 188

3. Procedure: Flagging the IVR Profile for CTI, on page 190

Key Actions

• Create a resource group of type CTI for the CTI Connector.

• Set CTI Usage to Always On (use-cti=1).

Additional Special Configuration

Integrating SSG into CTI-C 
deployments.

Outbound calls initiated by SSG cannot go through CTI 
Connector. For deployments that include CTI-Connector, 
configure as follows:

1. Set CTI Usage on the SIP Server gateway resource group to 
Based on DN Lookup (use-cti=2). Resource Manager checks 
the IVR Profile to decide about CTI-C usage.

2. In the IVR Profile, configure CTI Allowed as follows:
 For outbound calls—Set CTI Allowed to false. Resource 

Manager will bypass CTI-C.
 For inbound calls—Set CTI Allowed to true. Resource 

Manager will process the call through CTI-C.

For more information, see “Configuring CTI Flagging for IVR 
Profiles” on page 188.

Task Summary: TDM-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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Task Summary: Integrating with IVR 
Server—In-Front Mode

With IVR Server in an In-Front configuration, the call arrives at the VPS 
directly from the PSTN, with the DNIS available for immediate IVR Profile 
mapping. No DN lookup through an IVR Profile is required for call setup. 
However, the call is still forwarded to CTI Connector and IVR Server for call 
registration—typically for reporting purposes.

To fetch the script ID from URS... If your switch cannot supply the DNIS for the incoming call, you 
must configure CTI Connector to fetch the script ID from URS. 
CTI Connector uses the value of this key as the DNIS in the 
INVITE to Resource Manager for IVR Profile selection:

1. In URS, define the key-value pair for the script ID:
 Key—Define the key name that you will match in the CTI 

Connector application. The default is scriptidkeyname.
 Value—Define the value that matches the DNIS used to 

select the desired IVR Profile in Resource Manager.

2. In the CTI Connector Application object, set the following 
options in the IVRSC section:
 Fetch Script ID from URS—Enter 1 to enable CTI 

Connector to fetch the defined key from URS.
 Script Id Key Name—Enter the key name as defined in 

URS. CTI Connector sends this key to retrieve the value for 
the script ID.

To configure the socket layer... 1. In the TServer_IVR application, configure the listening port for 
the socket layer in the GLI sections:
 gli_server > gli-server-mode—Enter circuit to enable 

the server to open multiple circuits.
 gli_server > gli-n-servers—Enter the number of circuit 

groups the server can open.

2. Create a gli-server-group_n section for each circuit group:
 gli-server-address—Enter the IP address and listening 

port, in the format <ip_address>:<port>.

3. In the CTI Connector Application object, set the 
iserversocket option to the GLI port as configured in Step 2. 
(For configuration details, see Procedure: Configuring the CTI 
Connector for IVR Behind, on page 174.)

Task Summary: TDM-Connected, IVR Behind (Continued) 

Objective Related Procedures and Actions
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For a sample configuration and a description of a typical call flow, see 
“Integration with IVR Server—In-Front Mode” on page 94.

Task Summary: Integrating IVR Server—In-Front Mode, on page 157 
provides an overview of the main steps that you must complete in order to 
integrate the VPS with an IVR Server configured for In-Front mode.

Task Summary: Integrating IVR Server—In-Front Mode

Objective Related Procedures and Actions

1. Log in to Genesys 
Administrator.

In your web browser, enter the application URL in the following 
format:

http://<genesys_administrator_host>/wcm

2. Verify prerequisites. Before starting the integration, verify the following prerequisites have 
been met:

• The basic Voice Platform Solution is deployed.

• The IVR Server and related objects have been created, and the IVR 
Server is installed.

• The CTI Connector application has been created, and the 
application is installed.

For a more detailed description of this task, see Procedure: Task 
Summary: Verify Prerequisites, on page 145.

3. Configure the IVR Server. For step-by-step procedures, see the following:

1. Procedure: Creating the virtual switching office, on page 180

2. Procedure: Creating the virtual switch for TServer_IVR_InFront, 
on page 181

3. Procedure: Adding required connections to the 
TServer_IVR_InFront, on page 181

4. Procedure: Adding required connections to the I-Server_InFront, 
on page 182

Key Actions

• Associate TServer_IVR_InFront with the virtual switch. Add a 
connection to the SIP Server.

• In the I-Server object, add connections to SIP Server and 
TServer_IVR_InFront.

4. Create the IVR object to 
represent GVP.

Go to: Provisioning > Switching > IVRs

1. Create an IVR object to represent GVP:
 Select Genesys Voice Platform as the type.
 Select your I-Server application as the IVR Server.

2. Click Save to register with the Configuration Layer.

For a detailed procedure, see Procedure: Creating an IVR object to 
represent GVP in the solution, on page 182
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5. Configure the CTI 
Connector.

Go to: Provisioning > Environment > Applications

1. Open your CTI Connector Application object.

2. On the Options tab, configure the following mandatory parameters:
 Resource Manager IP Address

 IVR Client Name

 IVR Server Host IP Address

 IVR Server Communication Port

 Local Host Name

3. On the Options tab, configure the following IVR port options:
 IVRPort Base Index
 Max IVRPorts

Note: These IVR port options are optional for In Front 
configurations. If the gateway provides the IVRPort in the 
incoming INVITE, these options are not required.

For a detailed procedure, see Procedure: Configuring the CTI 
Connector for IVR In-Front, on page 183.

6. Configure IVR Ports. To configure mapping for IVR ports generated by the CTI Connector, 
complete the following procedures:

1. Procedure: Creating Voice Treatment Port DNs, on page 184

2. Procedure: Mapping IVR Ports to their matching DNs, on page 185

Key Rules

• For In-Front mode, create Voice Treatment Port DNS on the 
virtual switch.

• Use identical numbering for the DNs and ports.

• Use continuous numbering (in increments of one) when naming the 
DNs.

Task Summary: Integrating IVR Server—In-Front Mode (Continued) 

Objective Related Procedures and Actions
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7. Configure Resource 
Manager for integration 
with CTI Connector.

Go to: Provisioning > Voice Platform > Resource Groups

For step-by-step procedures, see the following:

1. Procedure: Creating a resource group for the CTI Connector, on 
page 185

2. Procedure: Configuring the gateway resource for CTI through IVR 
Server, on page 188

3. Procedure: Flagging the IVR Profile for CTI, on page 190

Key Actions

• Create a resource group of type CTI for the CTI Connector.

• For TDM deployments, set CTI Usage to Always On (use-cti=1).

• For carrier-connected deployments:

1. Set CTI Usage to Based On DN Lookup (use-cti=2).

2. For non-CTI applications, set cti-allowed in the IVR Profile to 
false.

8. Enable midcall CTI routing 
for IVR-centric 
applications.

For midcall CTI transfers, you must configure Access Codes for 
interswitch communication between the SIP Server switch and the 
virtual switch for GVP (In-Front mode only):

1. Procedure: Configuring access from the SIP Server to GVP, on 
page 191

2. Procedure: Configuring access from GVP to the SIP Server, on 
page 192

3. Verify that the SIP Server switch includes a connection to the 
TServer_IVR_InFront object.

4. When configuring the AccessNumGet block in Composer, provision 
the required parameters as follows:

• Destination DN—Enter the number for the External Routing 
Point DN you created on the SIP Server switch.

• Location—Select the SIP Server switch from the drop-down list.

5. Configure the <transfer> tag in the VoiceXML application to use 
the number received in the AccessNumGet block. This can be either 
a Blind or Bridge transfer (applies to both NGI and GVPi 
applications).

Task Summary: Integrating IVR Server—In-Front Mode (Continued) 

Objective Related Procedures and Actions
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Task Summary: Integrating with Network 
IVR Server

With IVR Server in a Network configuration, the IVR Server does not map 
incoming calls to IVR Port numbers. Instead of forwarding the port number to 
IVR Server as in other modes, the CTI Connector sends the number used to 
call the solution—either the DNIS or a toll free Number—as the Called Number 
in the NewCall request to the IVR Server.

For a sample architecture diagram and a description of a typical call flow, see 
“Integration with IVR Server—In-Front Mode” on page 94.

Task Summary: Integrating with Network IVR Server provides an overview of 
the main steps that you must complete in order to integrate the VPS with a 
Network IVR Server. 

Additional Special Configuration

Integrating SSG into CTI-C 
deployments.

Outbound calls initiated by SSG cannot go through CTI Connector. 
For deployments that include CTI-Connector, configure as follows:

1. In this in front-mode configuration, CTI Usage is already set to 
Based On DN Lookup (use-cti=2). No further configuration is 
required.

2. In the IVR Profile, configure CTI Allowed as follows:
 For outbound calls—Set CTI Allowed to false. Resource 

Manager will bypass CTI-C.
 For inbound calls, your IVR Profiles should already be 

configured to allow or disallow CTI. No further configuration is 
required.

For more information, see “Configuring CTI Flagging for IVR 
Profiles” on page 188.

Task Summary: Integrating IVR Server—In-Front Mode (Continued) 

Objective Related Procedures and Actions

Task Summary: Integrating with Network IVR Server

Objective Related Procedures and Actions

1. Log in to Genesys 
Administrator.

In your web browser, enter the application URL using the following 
format:

http://<genesys_administrator_host>/wcm
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2. Create an IVR Network switch. Go to: Provisioning > Switching > Switching Offices

1. Create a Switching Office object with the switch type GenSpec 
XML.

2. Create a Switch object and:
• Associate it with the Network IVR switching office.
• Select TServer_IVR_810_Network as the associated 

T-Server.

For more information, see the “Sample Configurations” chapter in 
the IVR Interface Option 8.1 IVR Server System Administrator’s 
Guide.

3. Configure inter-switch access. Go to: Provisioning > Switching > Switches

1. In the Network T-Server switch, configure the Access Code used 
to reach the IVR Network switch, and then create the 
corresponding access resource DN in the Network T-Server 
switch.

2. In the IVR Network switch, configure the access code used to 
reach the Network T-Server switch, and then create the 
corresponding access resource DN in the Network T-Server 
switch.

For more information, see the “Configuring Multi-site Support” 
chapter in the IVR Interface Option 8.1 IVR Server System 
Administrator’s Guide.

4. Configure the CTI Connector. Go to: Provisioning > Environment > Applications

1. Open your CTI Connector Application object.

2. On the Options tab, configure the following mandatory 
parameters:
• Resource Manager IP Address

• IVR Client Name

• IVR Server Host IP Address

• IVR Server Communication Port

• Local Host Name

3. On the Options tab, configure the following network mode 
option:
 Use Called Number—If customers use a toll-free number to 

contact the VPS, set this option to TFN.

For a detailed procedure, see Procedure: Configuring the CTI 
Connector for Network IVR Server, on page 187.

Task Summary: Integrating with Network IVR Server (Continued) 

Objective Related Procedures and Actions
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Task Summary: Configuring Midcall CTI 
Functions

Task Summary: Configuring Midcall CTI Functions provides an overview of 
the different midcall CTI actions available for IVR-centric applications, and 
any additional configuration steps required to enable them. 

5. Configure the IVR Profile. If customers use a toll-free number to contact the VPS, you must 
configure this number in the IVR Profile.

• From the Service Properties page in the IVR Profile Wizard, 
enter the number in the Toll Free Number box.

Task Summary: Integrating with Network IVR Server (Continued) 

Objective Related Procedures and Actions

Task Summary: Configuring Midcall CTI Functions

Objective Related Procedures and Actions

Configuring Peek/Get stat results 1. Create a new section in the I-Server application for the statistic 
you want to gather—for example:

ExpectedWaitTime.

2. For this sample section, configure the following options:

• obj_id—Set this to <dn>@<switch>.

• obj_type—Set this to SObjectQueue.

• server_name—Set this to <stat server name>.

• stat_type—Set this to ExpectedWaitTime.

• update_frequency—Set this to 5.

3. Create a matching section in the Stat Server application object—
for example:

ExpectedWaitTime, with the above options.

4. Verify that the required connections are in place:

• TServer_IVR — Message Server

• I-Server — TServer_IVR, Stat Server

• URS — TServer_IVR, Stat_Server, Message Server

• Stat Server — TServer_IVR, Message Server

5. Configure the Peek/Get Stat block in the voice application, 
using Composer.
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Task Summary: Configuring Transfers
Task Summary: Configuring the IVR Profile for Transfer Type provides an 
overview of the service parameter configuration steps required to enable 
different transfer types in the IVR Profile for your voice application. 0

Enable midcall CTI routing for 
IVR-centric applications.

For midcall CTI transfers, you must configure Access Codes for 
inter-switch communication between the SIP Server switch and the 
virtual switch for GVP (IVR In-Front mode only):

1. Procedure: Configuring access from the SIP Server to GVP, on 
page 191

2. Procedure: Configuring access from GVP to the SIP Server, on 
page 192

3. Verify that the SIP Server switch includes a connection to the 
TServer_IVR_InFront object.

4. When configuring the AccessNumGet block in Composer, 
provision required parameters as follows:

• Destination DN —Enter the number for the External Routing 
Point DN you created on the SIP Server switch.

• Location —Select the SIP Server switch from the drop-down 
list.

Task Summary: Configuring Midcall CTI Functions (Continued) 

Objective Related Procedures and Actions

Note: The VPS uses the default agent number that you specify in the Default 
Agent option in the IVR Profile as the target for the transfer, in cases 
where the IVR Server returns the default agent number due to a 
timeout or other error.
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Task Summary: Configuring the IVR Profile for Transfer Type

Transfer Type Related Procedures and Actions

Blind Transfer (Using 
OneStepXfer through CTI)

On the Options tab of the IVR Profile:

1. In the gvp.policy section, configure the following options:
 Transfer Allowed—Set the value for this option to true.

2. In the gvp.service-parameters section, configure the following 
options:
 cti.DefaultAgent—Set the value for this option to 

fixed,<Agent DN>

 cti.TransferOnCTI—Set the value for this option to 
fixed,yes.

For GVPi applications only:
 voicexml.gvpi.$transfer-type$—For GVPi applications 

only, set the value for this option to fixed,1SignalChannel.
 voicexml.gvpi.$transfer-option$—For GVPi applications 

only, set the value for this option to fixed,SipRefer.

Blind Transfer (Using REFER on 
SIP Server

On the Options tab of the IVR Profile:

1. In the gvp.policy section, configure the following options:
 Transfer Allowed—Set the value for this option to true.

2. In the gvp.service-parameters section, configure the following 
options:
 cti.DefaultAgent—Set the value for this option to 

fixed,<Agent DN>

 cti.TransferOnCTI—Set the value for this option to 
fixed,no.

For GVPi applications only:
 voicexml.gvpi.$transfer-type$—For GVPi applications 

only, set the value for this option to fixed, 1SignalChannel.
 voicexml.gvpi.$transfer-option$—For GVPi applications 

only, set the value for this option to fixed,SipRefer.



Integration Guide 165

Chapter 12: Configuration Tasks for CTI Through IVR Server Task Summary: Configuring Transfers

Bridge Transfer (Using INVITE on 
SIP Server)

On the Options tab of the IVR Profile:

1. In the gvp.policy section, configure the following options:
 Transfer Allowed—Set the value for this option to enabled.
 outboundcallallowed—Set the value for this option to 

enabled

2. In the gvp.service-parameters section, configure the following 
options:
 Default Agent—Set the value for this option to fixed, 

<Agent DN>

 voicexml.gvpi.$transfer-type$—For GVPi applications 
only, set the value for this option to fixed, 2SignalChannel.

 voicexml.gvpi.$transfer-option$—For GVPi applications 
only, set the value for this option to not set.

Media Redirect Transfer For GVPi applications:

1. In the gvp.service-parameters section of the IVR Profile, set 
voicexml.gvpi.$transfer-type$ to 2 Signal Channel.

2. In the MCP application, set defaultbridgexfer to 
MEDIAREDIRECT.

Note: If voicexml.gvpi.$cti_endcall_on_agentleg_hup$ is set to 
false in the IVR Profile, MCP will ignore the MEDIAREDIREC 
parameter, and force a BRIDGE transfer instead.

For NGI applications:

1. Set the method attribute in the VoiceXML <transfer> tag to 
MEDIAREDIRECT.
OR
In the MCP application, set set defaultbridgexfer to 
MEDIAREDIRECT.

2. Set the connectwhen attribute in the VoiceXML <transfer> tag 
to answered. (If you set this to immediate, the transfer will fail.)

3. In the sessmgr section of the MCP application, set 
sendsdpininvite to false.

Task Summary: Configuring the IVR Profile for Transfer Type (Continued) 

Transfer Type Related Procedures and Actions
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Task Summary: Configuring Voice 
Treatments

Task Summary: Additional Voice Treatment Configuration, on page 166 
provides an overview of the solution-level configuration steps required in 
addition to the configuration of basic Interaction Routing Designer (IRD) 
Voice Treatment object parameters. For information about basic Voice 
Treatment block configuration, see the “Voice Treatment Options” section of 
the Universal Routing 8.1 Reference Manual.

Task Summary: Additional Voice Treatment Configuration

Treatment Type Related Procedures and Actions

Play Application GVPi Applications

For GVPi applications, you must configure both the APP_ID 
parameter in the routing strategy and the ScriptID variable in the 
Studio application with the same value. For example:

1. In the Play Application block of the routing strategy, set 
APP_ID to 2.

2. In the Branching block of the Studio application, set the 
ScriptID to 2.

NGI Applications

For NGI applications, you can configure Play Application 
treatments in one of two ways:

• In the routing strategy Play Application block, configure the 
{s}APP_URL parameter with a value that specifies the fully 
qualified URL of the VoiceXML application.

OR

• If you do not include the {s}APP_URL in the routing strategy, you 
must configure the IVR Profile to include the URL instead:

1. In the gvp.service-prerequisite section of the IVR Profile, 
set the script-url option to the URL of the VoiceXML 
application that will provide the treatment.

2. If the script-url option is not configured, Resource 
Manager instead uses the value of the initial-page-url 
option from the IVR Profile.

Sending User Data back to the Application

Using CTI Connector, PlayApplication treatments can pass all 
forms of interaction data (CED, UData, ExtnsEx) back to the strategy.
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Play Announcement GVPi Applications

1. In the routing strategy, add a Play Announcement block with 
empty parameter values.

2. In the Studio application, configure a property in the Branching 
block as follows:
 Node—Can be any identifier.
 Variable—ScriptID

 Value—TRT:PlayAnnounce, chosen from the drop-down list

NGI Applications

MCP provides a default VoiceXML application to handle 
PlayAnnounce treatments. If you want to use a different application, 
configure the following:

1. In the IVRSC section of the CTI Connector Application object, 
set the PlayAnnounce Resource Path parameter to the location 
of the VoiceXML application you want to use.

2. If this parameter is not set, Resource Manager instead uses the 
value of the script-url option from the IVR Profile.

Sending User Data back to the Application

No interaction data is passed back to the strategy at the end of this 
treatment.

Task Summary: Additional Voice Treatment Configuration (Continued) 

Treatment Type Related Procedures and Actions
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Play Announcement and Collect 
Digits

GVPi Applications

1. In the routing strategy, add a Play Announcement and Collect 
Digits block with empty values.

2. In the Studio application, configure a property in the Branching 
block as follows:
 Node—Can be any identifier.
 Variable—ScriptID

 Value—TRT:PlayAnnounceAndDigits, chosen from the 
drop-down list

NGI Applications

MCP provides a default VoiceXML application to handle 
PlayAnnounceAndDigit treatments. If you want to use a different 
application, configure the following:

1. In the IVRSC section of the CTI Connector Application object, 
set the PlayAnnounceAndDigit Resource Path parameter to the 
location of the VoiceXML application you want to use.

2. If this parameter is not set, Resource Manager instead uses the 
script-url option from the IVR Profile.

Sending User Data back to the Application

For NGI—CED interaction data is passed back using the <exit> tag 
with the namelist attribute, which is translated into the body of the 
INFO message at the end of the treatment.

For GVPi—Use the treatment result block in Studio to specify 
what data should be sent.

Task Summary: Additional Voice Treatment Configuration (Continued) 

Treatment Type Related Procedures and Actions
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Integrating with IVR Server in Behind 
Mode—Procedures

Complete the procedures in this section to integrate the Voice Platform 
Solution with the IVR Server in a Behind mode configuration.

Procedure:
Configuring the SIP Server for Behind mode

Purpose:  To perform additional configuration of the SIP Server Application 
object for VPS integration with IVR Server in a Behind mode configuration.

Start of procedure

1. Go Provisioning > Environment > Applications, and click the SIP Server 
Application object.

Play Music GVPi Applications

1. In the routing strategy:
 Add a Play Music block with empty values.
 Add a Pause block, with a duration a few seconds longer than 

the treatment itself.

2. In the Studio application:
 Configure the Branching block with a new property, where 

the ScriptID equals TRT:Music.
 Specify the same duration in this block as you did in the 

routing strategy.

NGI Applications

Configure the routing strategy as follows:

1. Add a Music block with the following parameters:
 MUSIC_DN—Enter the http path of the music file.
 DURATION—Enter the duration of the music file in ms.

2. Add a Pause block with the following parameters:
 DURATION—Enter a duration a few seconds longer than the 

duration of the music file itself.

Task Summary: Additional Voice Treatment Configuration (Continued) 

Treatment Type Related Procedures and Actions
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2. On the Options tab, in the TServer section, configure the options as 
described in Table 7.

3. In the extrouter section, configure the handle-vsp option as described in 
Table 8.

4. Click Save and close.

End of procedure

Next Steps

• Procedure: Creating the dummy switching office, on page 171

Table 7: SIP Server Options—TServer Section

Option Value Description

override-to-on-divert false Set this option to false to ensure that the 
INVITE request sent to GVP contains the 
same user name in the To header as it did in 
the original INVITE request.

Note: The originally dialled number 
(Routing Point) must exist on GVP as a 
DID number.

event-ringing-on-100trying true Set this option to true to force the SIP 
Server to generate an EventRinging 
message without waiting for the 180 
Ringing message from the IPCS.

Note: For proper synchronization with the 
IVR Server application, this option must 
also be set at the DN level.

Table 8: SIP Server Options—Extrouter Section

Option Value Description

handle-vsp all If agents are located on a T-Server other than 
the SIP Server, and call queuing takes place 
on the GVP side, then setting this option to 
all ensures that ISCC messages flow 
properly between the SIP Server and the 
remote T-Server.
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Procedure:
Creating the dummy switching office

Start of procedure

1. Go to Provisioning > Switching > Switching Offices.

2. Click New.

3. Enter a name, and select any type of switch. Genesys recommends Virtual 
Switch for IVR In-Front.

4. Click Save.

End of procedure

Next Steps

• Procedure: Creating the dummy switch for TServer_IVR

Procedure:
Creating the dummy switch for TServer_IVR

Start of procedure

1. Go to Provisioning > Switching > Switches.

2. Click New and provision the switch as follows:
• Name—Enter a name for the dummy switch.
• Switching Office—Click the browse icon and select the dummy 

switching office that you created in “Creating the dummy switching 
office”.

• TServer—Click the browse icon and select the Tserver_IVR.

3. Click Save.

End of procedure

Next Steps

• Procedure: Configuring the TServer_IVR object, on page 172

Tip: This dummy switch performs a logical function for IVR Server. No 
DNs or Agent Logins are required.
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Procedure:
Configuring the TServer_IVR object

Purpose:  To add the required connections and configure mandatory options 
required to integrate the TServer_IVR into the VPS (with IVR Server in 
Behind mode).

Suggested Configuration Option Settings for Behind Mode

For integration with IVR Server in Behind mode, Genesys recommends setting 
the following options:

• Router Timeout—Genesys recommends increasing the length of time that 
elapses before URS will route to a default DN, in cases where there is a 
delay in providing the next treatment request to IVR Server. 

• active-release—Set this option to false to prevent the IVR Server from 
forwarding an end call request received from GVP, since GVP should 
receive these messages from SIP Server only. This avoids the race 
condition where the end call message is sent/received by IVR Server.

Start of procedure

1. Go to Provisioning > Environment > Applications and select 
TServer_IVR.

2. On the Options tab, in the Timers section, create the following new option:
• Router Timeout—Change the default value for this option from 4 s to 

7 s. IVR Server waits this length of time before it performs default 
routing for the call.

3. On the Options tab, in the IServer section, create the following new option:
• active-release—Set this to false.

4. Click Save and close.

End of procedure

Next Steps

• Procedure: Adding required connections to the I-Server

Procedure:
Adding required connections to the I-Server

Start of procedure

1. Go to Provisioning > Environment > Applications and select I-Server.
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2. On the Configuration tab, under Connections, add connections as follows:
• CTI flagging enabled (carrier-connected)—Add a connection to the 

TServer_IVR.
• CTI flagging disabled (carrier-connected)—Add a connection to the 

SIP Server Application object.
• TDM-connected—Add a connection to the premise T-Server 

Application object.

3. Click Save.

End of procedure

Next Steps

• Procedure: Creating an IVR object to represent GVP in the solution

Procedure:
Creating an IVR object to represent GVP in the 
solution

Start of procedure

1. Go to Provisioning > Switching > IVRs.

2. Click New, and configure the parameters Configuration tab as follows:
• Name—Enter a name for this IVR.
• Description—Enter a useful description of this IVR. For example, the 

switch configuration, or the IVR mode.
• Type—Select Genesys Voice Platform as the type.
• Version—Enter the software release number for the GVP that this IVR 

will represent. For example, 8.1.

3. Click Save.

End of procedure

Next Steps

• After you save the IVR object, the IVR Port tab appears. Use this tab to 
create the IVR Ports that you map to the corresponding DNs on the SIP 
Server switch.

Before creating the IVR Ports, configure CTI Connector for integration 
with the IVR Server in Behind mode. See Procedure: Configuring the CTI 
Connector for IVR Behind, on page 174.
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Procedure:
Configuring the CTI Connector for IVR Behind

Purpose:  To configure the CTI Connector Application object for integration 
with the IVR Server in Behind mode.

Summary

In an IVR behind mode integration, the key configuration option is Fetch DNIS 
from IServer. When set to true, the VPS sends a request to the IVR Server in 
order to retrieve the DNIS required to map the IVR Profile. In a TDM 
deployment, where the DNIS is not available at the outset of the call, this 
setting is mandatory. In carrier-connected deployments, however, where the 
DNIS is available with the incoming call, you can configure the gateway 
resource to perform CTI flagging in order to skip CTI Connector (and IVR 
Server) for Standard VoiceXML applications that do not require any CTI 
functionality. In this case, you can set Fetch DNIS from IServer to false, and 
the VPS will retrieve the DNIS from the SIP header.

Prerequisites

• The CTI Connector Application object is created and the component is 
installed. For an overview of the deployment process, see Task Summary: 
Verify Prerequisites, on page 146.

Start of procedure

1. Go to Provisioning > Environment > Applications > <CTI_Connector>.

2. On the Options tab, select Mandatory Options from the View drop-down list 
and configure the following mandatory parameters:
• Resource Manager IP Address—Enter the IP address and SIP port for 

the Resource Manager in the following format:
<RM_ip_address>:<RM_sip_port>

For example:
10.10.10.10:5060

• IVR Client Name—Enter the login name of the IVR Server Application 
object, as it appears in Management Framework.

• IVR Server Host IP Address—Enter the IP address of the IVR Server 
host.

• IVR Server Communication Port—Enter the GLI port number as 
configured in the gli-server-address option of the TServer_IVR object. 

• Local Host Name—Enter the IP address of the CTI Connector host.
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3. For TDM-connected deployments, select Advanced View (Options) from 
the View drop-down list and configure the following parameters:
• Fetch DNIS From IServer—Set this option to true.
• Default DNIS—If Fetch DNIS from IServer is enabled, enter a default 

DNIS to be used in case the IVR Server fails to return the DNIS during 
the fetch operation.

4. For carrier-connected deployments, configure the following parameters:

Carrier-Connected with CTI Flagging

• IVRPort Base Index—Set the starting number for the range of IVR 
Ports to match the Voice Treatment Port DN range that you will later 
create in the SIP Switch and in the dummy switch for TServer_IVR.

• Max IVRPorts—Set the maximum number of IVR Ports to the total 
number of Voice Treatment Port DNs that GVP allows (you will 
create this number of DNs in the next procedure).

5. Click Save.

End of procedure

Next Steps

• Procedure: Creating Voice Treatment Port DNs

Procedure:
Creating Voice Treatment Port DNs

Purpose:  To create and configure Voice Treatment Port DNs on the 
appropriate switch. These DNs will be mapped to IVR Ports configured in the 
IVR object.

Tip: The application template provides an IServer_Sample section that 
you can configure as-is, rename, or use as a model. Add a new section 
for every additional IVR Server in your configuration. If you rename 
this section, or add any new sections, make sure you add the section 
name to the Customer IServers List parameter in the IVRSC section.

Tip: For carrier-connected deployments (CTI flagging enabled as 
recommended), skip this step. The default settings are acceptable.

Tip: For carrier-connected deployments, in which CTI flagging is not 
required, you can skip this step and instead set Fetch DNIS from 
IServer to true and add a value for Default DNIS (see Step 3).
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Summary

Carrier-Connected For carrier-connected deployments with CTI flagging enabled, create one set 
Voice Treatment Port DNs in the SIP Server switch.

TDM-Connected For TDM-connected deployments, create one set of Voice Treatment Port 
DNs in the premise T-Server switch (no option configuration required). The 
numbers for these DNs must match the port numbers coming in from the media 
gateway or PBX.

Start of procedure

1. Go to Provisioning > Switching > Switches > <your_switch>.

2. On the DNs tab, click Add.

3. On the Configuration tab, configure the following mandatory parameters:
• Number—Assign the new DN a number.
• Type—For a regular DN that is always ready to receive calls (no agent 

login required), select Voice Treatment Port from the drop-down list.

4. If you created the DN in the SIP Server switch, on the Options tab, click 
New and do the following:

a. Enter TServer as the section name.

b. Enter contact as the option name.

c. For the value, enter the IP address and port of the Resource Manager:

sip:<RM_ip_address>:<RM_sip_port> 

5. On the Options tab, in the TServer section, click New and add the following 
option:
• event-ringing-on-100trying—Set this option to true.

6. To create another DN, click Save and New. Create as many new Voice 
Treatment Port DNs as GVP allows, provisioning each as you did in the 
preceding steps. 

7. Click Save and Close.

End of procedure

Next Steps

• For carrier-connected deployments with CTI flagging enabled, you must 
create another set of matching DNs in the dummy switch for TServer_IVR. 
Repeat the above configuration steps, but in the dummy switch instead.

Tip: Skip this step if creating DNs in either the premise T-Server switch 
or in the dummy switch for TServer_IVR.

Tip: Use continuous numbering (in increments of one) when naming all 
subsequent DNs.
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• If no CTI flagging is required in your deployment, continue at Procedure: 
Mapping IVR Ports to their matching DNs.

Procedure:
Mapping IVR Ports to their matching DNs

Purpose:  To create IVR Ports in the IVR object and link them to the Voice 
Treatment Port DNs configured on the switch. SIP Server manages these ports 
for incoming calls, forwarding the port number to the Resource Manager in the 
INVITE.

Start of procedure

1. Go to Provisioning > Switching > IVRs.

2. Double-click the IVR object you created to represent GVP in the solution.

3. On the IVR Ports tab, click Add.

4. Enter the Port Number as follows:
• For carrier-connected deployments—enter the same number as you did 

for the Voice Treatment Port DN that you want to map this port to.
• For TDM-connected deployments—Enter the port number of the 

channel on the switch (or media gateway).

5. To enter the Associated DN do the following:

a. Click the browse icon, then select one of the following switches:
• CTI flagging enabled (carrier-connected)—Select the dummy 

switch for TServer_IVR.
• CTI flagging disabled (carrier-connected)—Select the SIP Server 

switch.
• TDM-connected—Select the premise T-Server switch.

b. In the DNs folder, select the matching Voice Treatment Port DN.

6. Click Save & New. Create additional IVR Ports until all matching Voice 
Treatment Port DNs are mapped.

7. Click Save and Close.

End of procedure

Next Steps

• Procedure: Configuring a Place object for each IVR Port, on page 178
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Procedure:
Configuring a Place object for each IVR Port

Purpose:  To create a Place object for every corresponding Voice Treatment 
Port DN mapped to an IVR Port. Incoming calls arriving on a Routing Point 
DN will be targeted to these places, allowing SIP Server to pass the port 
number to the Resource Manager.

Note: For TDM-connected deployments, the call arrives at a Trunk DN. The 
routing strategy to select a Voice Treatment Port DN is not required. 
You can skip this procedure.

Start of procedure

1. Go to Provisioning > Switching > Places.

2. Click New.

3. Provision the new Place as follows:
• Name—Enter a number that matches the Voice Treatment Port DN that 

you will map this Place to.
• DNs—Click Add, select the SIP Server switch, and then select the 

corresponding Voice Treatment Port DN.

4. Click Save & New. Create a new Place to match every Voice Treatment Port 
DN mapped to an IVR Port.

5. Click Save and Close.

End of procedure

Next Steps

• Procedure: Configuring a Place Group as the target for IVR Ports

Procedure:
Configuring a Place Group as the target for IVR Ports

Purpose:  To create the Place Group object that the routing strategy can use to 
distribute calls to IVR ports for treatment. Stat Server determines the 
availability of the individual Places.

Start of procedure

1. Go to Provisioning > Switching > Place Groups.

2. Click New.
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3. Enter a name for this Place Group.

4. Click Save to register the Place Group with the Management Layer.

Once registered, the Places tab appears in the Place Group object. 

5. On the Place tab, click Add.

6. Hold down the Shift or Ctrl key while selecting the Places that you 
created in Procedure: Configuring a Place object for each IVR Port, on 
page 178.

7. Click Save & Close.

End of procedure

Next Steps

• Procedure: Creating a resource group for the CTI Connector

Procedure:
Creating a resource group for the CTI Connector

Purpose:  To create the resource group on Resource Manager that is used to 
define the connection to CTI Connector.

Start of procedure

1. Go to Provisioning > Voice Platform > Resource Groups.

2. Click New to open the Resource Group Wizard.

3. Follow the wizard instructions to create a new Resource Group for the CTI 
Connector:

a. Click New, then Next, and select the Resource Manager to which this 
group will belong.

b. Enter a name for the group and select CTI Connector as the Group Type, 
and click Next.

c. Keep the defaults for monitoring method and load balancing scheme, 
and click Next.

d. Select the CTI Connector that you want to add, configuring as follows:

i. Select sip as the scheme.

ii. Select the SIP Port used to communicate with CTI Connector 
(typically 5080)

iii. Click Next.

Tip: For more information about using this wizard, see the “Creating 
Resource Groups” procedure in the Genesys Voice Platform 8.1 
Deployment Guide.
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4. At the end of the wizard, click Finish.

End of procedure

Next Steps

• For TDM deployments, all calls must go through CTI Connector. Make 
sure that CTI Usage in the gateway resource group for the SIP Server is set 
to Always on (use-cti=1).

• For carrier-connected deployments, you can configure the gateway 
resource group to send applications either to SIP Server or to CTI 
Connector, depending on the application. To configure this feature, see 
Procedure: Configuring CTI Flagging for IVR Profiles.

Integrating with IVR Server in In-Front 
Mode—Procedures

Complete the procedures in this section to integrate the Voice Platform 
Solution with the IVR Server in an In-Front mode configuration.

Procedure:
Creating the virtual switching office

Start of procedure

1. Go to Provisioning > Switching > Switching Office.

2. Click New.

3. Enter a Name.

4. For the type, select Virtual Switch for IVR In-Front.

5. Click Save.

End of procedure

Next Steps

• Procedure: Creating the virtual switch for TServer_IVR_InFront, on 
page 181
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Procedure:
Creating the virtual switch for TServer_IVR_InFront

Purpose:  To create the virtual switch that represents GVP when the VPS is 
integrated with IVR Server in an In-Front mode configuration. The CTI 
Connector uses this virtual switch to manage the Voice Treatment Port DNs 
used to map an IVR port for each incoming call.

Start of procedure

1. Go to Provisioning > Switching > Switches.

2. Click New, and provision the switch as follows:
• Name—Enter a name for the virtual switch.
• Switching Office—Click the browse icon, and select the virtual switch 

that you created in Procedure: Creating the virtual switching office, on 
page 180.

• TServer—Click the browse icon, and select the Tserver_IVR.

3. Click Save.

End of procedure

Next Steps

• Procedure: Adding required connections to the TServer_IVR_InFront

Procedure:
Adding required connections to the 
TServer_IVR_InFront

Start of procedure

1. Go to Provisioning > Environment > Applications, and select 
TServer_IVR.

2. On the Configuration tab, under Connections, add connections to:
• TServer Application object for the premise switch
• Message Server.

3. Click Save and Close.

End of procedure

Next Steps

• Procedure: Adding required connections to the I-Server_InFront, on 
page 182
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Procedure:
Adding required connections to the I-Server_InFront

Start of procedure

1. Go to Provisioning > Environment > Applications, and select I-Server.

2. On the Configuration tab, under Connections, add a connection to:
• TServer_IVR_InFront

3. Click Save.

End of procedure

Next Steps

• Procedure: Creating an IVR object to represent GVP in the solution

Procedure:
Creating an IVR object to represent GVP in the 
solution

Start of procedure

1. Go to Provisioning > Switching > IVRs.

2. Click New, and configure the parameters on the Configuration tab as 
follows:
• Name—Enter a name for this IVR.
• Description—Enter a useful description of this IVR. For example, the 

switch configuration, or the IVR mode.
• Type—Select Genesys Voice Platform.
• Version—Enter the software release number for the GVP that this IVR 

will represent. For example, 8.1.

3. Click Save.

End of procedure

Next Steps

• After you save the IVR object, the IVR Port tab appears. Use this tab to 
create the IVR Ports that you map to the corresponding DNs on the virtual 
switch for GVP.

Before creating the IVR Ports, configure the CTI Connector for integration 
with the IVR Server in the In-Front mode. See Procedure: Configuring the 
CTI Connector for IVR In-Front, on page 183.
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Procedure:
Configuring the CTI Connector for IVR In-Front

Purpose:  To configure the CTI Connector Application object for integration 
with the IVR Server in the In-Front mode. You will specify the range of IVR 
Ports that CTI Connector will generate in order to map each call to a specific 
port and attach the port number in the NewCall message to IVR Server.

Prerequisites

• The CTI Connector Application object is installed and basic configuration 
is completed. For an overview of the deployment process, see Table Task 
Summary: on page 146.

Start of procedure

1. Go to Provisioning > Environment > Applications > <CTI_Connector>.

2. On the Options tab, select Mandatory Options from the View drop-down list 
and configure the following mandatory parameters:
• Resource Manager IP Address—Enter the IP address and SIP port for 

the Resource Manager in the following format:
<RM_ip_address>:<RM_sip_port>

For example:
10.10.10.10:5060

• IVR Client Name—Enter the login name of the IVR Server Application 
object, as it appears in Management Framework.

• IVR Server Host IP Address—Enter the IP address of the IVR Server 
host.

• IVR Server Communication Port—Enter the GLI port number as 
configured in the gli-server-address option of the TServer_IVR object. 

• Local Host Name—Enter the IP address of the CTI Connector host.

3. Select Advanced View (Options) from the View drop-down list and 
provision the number of IVR ports as follows:
• IVRPort Base Index—Set the starting number for the range of IVR 

Ports that CTI Connector will generate. Later, you will create matching 
ports/DNs in the Configuration Layer for IVR port mapping.

Tip: The application template provides an IServer_Sample section that 
you can configure as is, rename, or use as a model. Add a new section 
for every additional IVR Server in your configuration. If you rename 
this section, or add any new sections, make sure you add the section 
name to the Customer IServers List parameter in the IVRSC section.
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• Max IVRPorts—Set the maximum number of IVR Ports that the VPS 
can allow into the system. Later, you will create this number of 
matching ports/DNs in the Configuration Layer.

4. Click Save.

End of procedure

Next Steps

• Procedure: Creating Voice Treatment Port DNs

Procedure:
Creating Voice Treatment Port DNs

Purpose:  To create and configure Voice Treatment Port DNs on the virtual 
switch for GVP. These DNs will be used to map the IVR ports generated by 
CTI Connector to the ports configured in the IVR object.

Start of procedure

1. Go to Provisioning > Switching > Switches > 
<virtual_switch_for_GVP>.

2. On the DN tab, click New.

3. On the Configuration tab, configure the following mandatory parameters:
• Number—Assign the new DN a number, starting with the first number 

in the range you defined in the IVRPortBaseIndex option in CTI 
Connector (see Step 3 on page 183).

• Type—For a regular DN that is always ready to receive calls (no agent 
login required), select Voice Treatment Port from the drop-down list.

4. To create another DN, click Save & New. Create as many new Voice 
Treatment Port DNs as GVP allows, provisioning each as you did in 
Step 3. 

5. Click Save.

End of procedure

Note: These IVR port options are optional for In Front configurations. If 
the gateway provides the IVRPort in the incoming INVITE, these 
options are not required.

Tip: Use continuous numbering (in increments of one) when naming all 
subsequent DNs. Create as many DNs as you defined in the 
MaxIVRPorts option in CTI Connector (Step 3 on page 183).
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Next Steps

• Procedure: Mapping IVR Ports to their matching DNs

Procedure:
Mapping IVR Ports to their matching DNs

Purpose:  To create IVR Ports in the IVR object and link them to the Voice 
Treatment Port DNs configured on the virtual switch. CTI Connector manages 
these ports for incoming calls, forwarding the port number to the IVR Server in 
the NewCall request.

Start of procedure

1. Go to Provisioning > Switching > IVRs.

2. Click the IVR object you created to represent GVP in the solution.

3. On the IVR Port tab, click New.

4. Provision the new IVR port as follows:
• Port Number—Enter the same number here that you entered for the 

Voice Treatment Port DN that you want to map this port to.
• Associated DN—Click browse, and select the virtual switch for GVP; 

then, in the DNs folder, select the matching Voice Treatment Port DN.

5. Click Save & New. Create additional IVR Ports until all matching Voice 
Treatment Port DNs are mapped.

6. Click Save and Close.

End of procedure

Next Steps

• Procedure: Creating a resource group for the CTI Connector

Procedure:
Creating a resource group for the CTI Connector

Purpose:  To create the resource group on Resource Manager that is used to 
define the connection to the CTI Connector.

Start of procedure

1. Go to Provisioning > Voice Platform > Resource Groups.

2. Click New to open the Resource Group Wizard.
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3. Follow the wizard instructions to create a new Resource Group for the CTI 
Connector as follows:

a. Click New, then Next, and select the Resource Manager to which this 
group will belong.

b. Enter a name for the group and select CTI Connector as the Group Type, 
and click Next.

c. Keep the defaults for monitoring method and load balancing scheme, 
and click Next.

d. Select the CTI Connector that you want to add, configuring as follows:

i. Select sip as the scheme.

ii. Select the SIP Port used to communicate with CTI Connector 
(typically 5080)

iii. Click Next.

4. At the end of the wizard, click Finish.

End of procedure

Next Steps

• Check that a Trunk DN to contact Resource Manager has been created in 
the SIP Server switch. If it has not, go to Procedure: Configuring a GVP 
DN for Standard VoiceXML applications, on page 116.

• If the Trunk DN exists in the SIP Server switch, continue at Procedure: 
Configuring CTI Flagging for IVR Profiles, on page 188.

Integrating with Network IVR Server—
Procedures

Complete the procedures in this section to integrate the Voice Platform 
Solution with the Network IVR Server. 

Tip: For more information about using this wizard, see the “Creating 
Resource Groups” procedure in the Genesys Voice Platform 8.1 
Deployment Guide.
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Procedure:
Configuring the CTI Connector for Network IVR Server

Prerequisites

• The CTI Connector Application object is installed, and basic configuration 
is completed. For an overview of the deployment process, see Table Task 
Summary:, “Verify Prerequisites,” on page 146.

Start of procedure

1. Go to Provisioning > Environment > Applications > <CTI_Connector>.

2. On the Options tab, select Mandatory Options from the View drop-down list 
and configure the following mandatory parameters:
• Resource Manager IP Address—Enter the IP address and SIP port for 

the Resource Manager in the following format:
<RM_ip_address>:<RM_sip_port>

For example:
10.10.10.10:5060

• IVR Client Name—Enter the login name of the IVR Server Application 
object, as it appears in Management Framework.

• IVR Server Host IP Address—Enter the IP address of the IVR Server 
host.

• IVR Server Communication Port—Enter the GLI port number as 
configured in the gli-server-address option of the TServer_IVR object. 

• Local Host Name—Enter the IP address of the CTI Connector host.

3. Select Advanced View (Options) from the View drop-down list and 
provision the number that the VPS sends to IVR Server as follows:
• Use Called Number—If customers use a toll-free number to contact the 

VPS, set this parameter to TFN. Otherwise, leave the default value of DN. 
Depending on this value, either the toll-free number or the DNIS used 
to contact the solution is forwarded to the IVR Server, instead of the 
port number, which is forwarded for other modes.

4. Click Save.

End of procedure

Tip: The application template provides an IServer_Sample section that 
you can configure as-is, rename, or use as a model. Add a new section 
for every additional IVR Server in your configuration. If you rename 
this section, or add any new sections, make sure you add the section 
name to the Customer IServers List parameter in the IVRSC section, 
separating each section name by a semicolon (;).
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Next Steps

• If you are configuring CTI Connector for use with a toll-free number, 
verify that the tollfreenum parameter is also set in the corresponding IVR 
Profile.

Configuring CTI Flagging for IVR Profiles
Complete the procedures in this section to configure the rules that Resource 
Manager uses to determine whether it should forward calls to the CTI 
Connector.

Depending on your deployment architecture and the applications that it 
services, you can flag the gateway resource as follows:

• Always Off—For CTI through SIP Server only deployments, where CTI 
Connector and IVR Server are not included in the architecture. Resource 
Manager performs IVR Profile mapping based on the DNIS provided in 
the incoming call.

• Always On—For deployments where CTI through IVR Server is always 
required. For example, if your deployment only services IVR-centric 
applications, where CTI through IVR Server is required for midcall CTI 
functionality. Or in TDM-connected configurations, where the DNIS must 
be retrieved from the IVR Server in all cases.

• Based on DN Lookup—For deployments with architecture configurations 
that support both CTI through IVR Server and CTI through SIP Server call 
flows, and that include both Standard VoiceXML and IVR-centric voice 
applications. For this option, you must set the IVR Profile for a specific 
application as either CTI or non-CTI. For non-CTI applications 
(self-service only), Resource Manager bypasses CTI Connector and 
instead maps the IVR Profile directly.

Outbound
Applications

The Based on DN Lookup setting is also required for deployments that 
include SSG for outbound calls. When SSG initiates an outbound call, it 
cannot go through CTI Connector. In this case, the IVR Profile for an 
outbound VoiceXML application must be set as non-CTI. CTI-enabled 
applications are still available for inbound calls, and must be configured 
accordingly.

Procedure:
Configuring the gateway resource for CTI through IVR 
Server

Purpose:  To create a gateway resource that Resource Manager uses to 
communicate with SIP Server, in CTI though IVR Server configurations. This 
includes flagging the resource group so that Resource Manager can determine 
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whether it should send the call to CTI Connector or, for voice applications that 
do not require CTI through IVR Server, bypass CTI Connector altogether.

Start of procedure

1. Go to Provisioning > Voice Platform > Resource Groups panel.

2. Click New to start the Resource Group Wizard.

3. When the wizard opens, click Next.

4. On the Resource Manager Selection page, select the Resource Manager for 
which you want to configure the resource group, then click Next.

5. On the Group Name and Type page, give your resource group a name, and 
select Gateway as the type. Then click next.

6. On the Group Properties page, configure the parameters as follows:
• Monitoring Method—Accept the default of None.
• Load Balancing Scheme—Accept the default of Round Robin.
• CTI Usage—Configure this option as follows:

• Always On—For CTI through IVR Server-only deployments, set 
use-cti to 1.

• Based on DN Lookup—For CTI through IVR Server deployments 
that can also include CTI through SIP Server call flows, set 
use-cti to 2.

For outbound calls using SSG, set use-cti to 2.

7. On the Resource Assignment page, do the following:

a. Select your SIP Server from the list.

b. Select the Scheme—either SIP or SIPS (secure SIP).

c. Select the SIP Port number—typically 5060.

d. Select the Max Ports for this SIP Server gateway group.

e. Click Next.

8. On the Confirmation page, click Finish.

End of procedure

Next Steps

• If you configured the gateway resource to send the call to CTI Connector 
based on DN lookup (set CTI Usage to Based On DN Lookup (use-cti=2)), 
you must also flag the IVR Profile so that the lookup knows what to do 
with the application. See Procedure: Flagging the IVR Profile for CTI.

Note: Do not set CTI Usage to Always On (use-cti=1) for 
deployments that include SSG for outbound calls. Calls 
initiated by SSG cannot go through CTI Connector.
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Procedure:
Flagging the IVR Profile for CTI 

Purpose:  To set the IVR Profile for a specific application as either CTI or 
non-CTI. In flexible architectures where the gateway resource (SIP Server) can 
handle both CTI through SIP Server and CTI through IVR Server call flows, 
this setting enables the Resource Manager to determine where to send the call.

Inbound Calls Enabling this setting is only available in VPS deployments where the SIP 
Server is able to get the DNIS from the incoming call. In deployments where 
this is not possible—for example, a TDM-connected configuration—all calls 
must go through CTI Connector, including calls with no midcall CTI 
requirement.

Outbound Calls For outbound calls initiated by SSG, you must configure the voice application 
that connects to the called number so that it does not allow CTI. Calls initiated 
by SSG cannot pass through CTI Connector.

Prerequisites

• In Resource Manager, the gateway resource group for SIP Server must be 
configured to allow both CTI and non-CTI calls. Set the CTI Usage option 
in the resource group to Based on DN Lookup (use-cti=2).

Start of procedure

1. Go to Provisioning > Voice Platform > IVR Profile.

2. On the Options tab, in the gvp.policy section, configure the CTI Allowed 
option as follows:
• true—For IVR-centric applications requiring mid-call CTI 

functionality, set CTI Allowed to true.
• false—For voice applications that do not require any mid-call CTI 

functionality (for example, a Standard VoiceXML application with no 
CTI extensions), set CTI Allowed to false.

For outbound voice applications, set CTI Allowed to false.

3. Click Save.

End of procedure

Next Steps

• This completes the basic procedures for a CTI through IVR Server in 
Behind mode integration.

• For CTI through IVR Server in the In-Front mode, additional configuration 
is required to enable CTI transfers from an IVR-centric application to the 
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SIP Server. See Procedure: Enabling Midcall CTI Routing (IVR-centric 
Applications).

Enabling Midcall CTI Routing (IVR-centric 
Applications)

When the VPS is integrated with IVR Server in the In-Front mode, GVP is 
configured as a virtual switch. In the voice application, transfers between this 
virtual switch for GVP and the SIP Server switch are treated as inter-switch 
transfers. Inter-switch transfers require an additional request—AccessNumGet—
in order to prepare the call before the routerequest starts the actual transfer.

Procedure:
Configuring access from the SIP Server to GVP

Purpose:  To configure SIP Server access to the virtual switch for GVP, and to 
create the access resource that the virtual switch uses to reach the SIP Server 
switch.

Start of procedure

1. Go to Provisioning > Switching > Switches > <SIP_Server_switch>.

2. On the Configuration tab, under Switch Access Code, click the ADD icon.

3. In the Switch Access Code dialog box, configure the required parameters as 
follows:
• Switch—Click the browse icon and select the virtual switch for GVP.
• Target Type—Select Target ISCC from the drop-down list.
• Route Type—Select DNIS Pooling from the drop-down list.
• ISCC Protocol Parameters—Enter dnis-tail=4.

4. Click Ok.

5. On the DN tab, click New, and create a a DN of type External Routing Point.

The virtual switch for GVP will use this DN to reach the SIP Server 
switch.

6. Click Save and Close.

7. Click Save and Close.

End of procedure

Tip: In this case, no prefix is required to reach the DN on the virtual 
switch, so you can leave the Access Code box empty. 
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Next Steps

• Procedure: Configuring access from GVP to the SIP Server

Procedure:
Configuring access from GVP to the SIP Server

Purpose:  To configure the virtual switch for GVP access to the SIP Server 
switch, and to create the access resource that the SIP Server switch uses to 
reach the virtual switch.

Start of procedure

1. Go to Provisioning > Switching > Switches > <virtual_switch_GVP>.

2. On the Configuration tab, under Switch Access Code, click the ADD icon.

3. In the Switch Access Code dialog box, configure the required parameters as 
follows:
• Switch—Click the browse icon and select your SIP Server Switch 

object.
• Access Code—Enter the prefix required to reach the DN on the SIP 

Server switch.
• Target Type—Select Target ISCC from the drop-down list.
• Route Type—Select Route from the drop-down list.

4. Click Ok.

5. Create the Access Resource DN that the SIP Server switch uses to reach the 
virtual switch:

a. Click New.

b. On the Configuration tab, configure the required parameters as 
follows:
• Number—Enter a number for the DN.
• Type—Select Access Resource from the drop-down list.
• Resource Type— Enter dnis.

c. Enter a number for the DN.

d. Click Save and Close.

6. Click Save and Close.

End of procedure

Next Steps

1. Verify that the SIP Server includes a connection to the 
TServer_IVR_InFront application.
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2. When configuring the AccessNumGet block in Composer, configure the 
required parameters as follows:
 Destination DN—Enter the number for the External Routing Point 

DN you created on the SIP Server switch.
 Location—Select the SIP Server switch from the drop-down list.

3. Configure the <transfer> tag in the VoiceXML application to use the 
number received in the AccessNumGet block. You can configure this as 
either a Blind or Bridge transfer (applies to both NGI and GVPi 
applications).
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Chapter

13 Integrating with SSG
This chapter describes the configuration steps required to support outbound 
call functionality from the Voice Platform Solution 8.1, using the 
Supplementary Services Gateway (SSG).

This chapter includes the following sections:
 Task Summary: SSG Integration, page 195
 Task Summary: SSG Integration, Routing Point Call Flow, page 201
 Integrating SIP Server with SSG, page 205
 Enabling CPD on the Media Gateway, page 209
 Sample Routing Strategy, page 210

Task Summary: SSG Integration
The following table provides an overview of the main steps that you must 
complete in order to integrate the SSG into the Voice Platform Solution, for 
outbound call functionality.

Task Summary: Integrating the SSG for Outbound Calls

Objective Related Procedures and Actions

1. Log in to Genesys Administrator In your web browser, enter the application URL in the 
following format:

http://<genesys_administrator_host>/wcm
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2. Verify prerequisites. To verify that the baseline solution is working:

1. Go to Provisioning > Environment > Applications.

2. Check that the green Started bar appears under the 
Status column for the following applications:
 SIP Server
 Resource Manager
 Media Control Platform/Call Control Platform
 Supplementary Services Gateway

3. If any of these applications are not shown as started, 
click the application, and then click the green Start 
arrow. If any application does not start, recheck the 
configuration.

3. Configure the SIP Server Application. Go to: Provisioning > Environment > Applications > 
<your_SIP_Server_application> > TServer section

1. Configure the following mandatory options:
 sip-invite-treatment-timeout—Set this option to 

60. This sets the timeout for the treatment that SSG 
connects the customer to.

 msml-support—Set to true.
 divert-on-ringing—Set to false.
 userdata-map-trans-prefix—To enable the passing 

of user data back to the application, set to X-Genesys-.

2. Configure the default behavior for how SIP Server 
responds on receiving CPD result from the gateway or 
MCP:
 am-detected—For answering machine detection, set 

this option to connect.
 fax-detected—For fax machine detection, set this 

option to connect.
 cpd-info-timeout—Set this option to the length of 

time, in seconds, that SIP Server will wait for the 
CPD results. Set this to 7 or higher for CPD on MCP, 
leave the default of 3 for CPD on media gateway.

For a detailed procedure, see Procedure: Configuring SIP 
Server for outbound calls through SSG, on page 205.

Task Summary: Integrating the SSG for Outbound Calls (Continued) 

Objective Related Procedures and Actions
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4. Create a Trunk Group DN to represent 
GVP.

Go to: Provisioning > Switching > Switches

To configure GVP as a DN in the SIP Server switch for 
making outbound calls:

1. Create a Trunk Group DN with the name Environment.

2. On the Options tab, in the TServer section, configure the 
following mandatory parameters:
 contact
 request-uri
 subscription-id
 make-call-rfc3725-flow
 refer-enabled
 ring-tone-on-make-call
 userdata-map-filter

3. To enable CPD on the MCP, on the Options tab, 
configure the following optional parameter:
 cpd-capability—Set this to mediaserver.

For a detailed procedure, see Procedure: Creating a Trunk 
Group DN for outbound calls, on page 207.

5. Configure the SSG Application object. Point the SSG to the Trunk Group DN on the SIP Server 
instance from which outbound calls will be placed:

1. Add a connection to SIP Server.

2. Configure the following mandatory options:
 TenantName
 TGDN

Key Actions and Rules

• Create a Tenant<n> section for every tenant that this 
SSG will service.

• The variable <n> ranges from 1 to 200.

For a detailed procedure, see Procedure: Integrating SSG 
with SIP Server, on page 208.

Task Summary: Integrating the SSG for Outbound Calls (Continued) 

Objective Related Procedures and Actions
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6. Configure the gateway Trunk DN. Go to: Provisioning > Switching > Switches

Basic Trunk Configuration

1. Number—Enter a text-based name (word or letter) for 
this trunk.

2. Type—Select Trunk from the drop-down menu.

3. Contact—Enter the IP address and port of the media 
gateway.

4. event-ringing-on-100trying—Set to true.

5. prefix—(for multiple Trunks) Set this to the initial 3 or 
4 digits of the TelNum provided in the HTTP request.

Note: Prefix is just one parameter used by SIP Server to 
select among available trunks. For more information 
about working with multiple devices, see the 
Framework 8.1 SIP Server Deployment Guide.

Enabling CPD

To make predictive calls using a supported gateway, 
additional configuration includes: 

• cpd-capability—Set this option to one of the 
following supported media gateway types: audiocodes 
or paraxip.

• cpd-info-timeout—Set this option to the length of 
time, in seconds, that SIP Server will wait for the INFO 
with CPD results, after the 200 OK from the media 
gateway.

Note: VPS supports CPD on Paraxip and Audiocodes 
media gateways only. Paraxip has been tested with 
CCXML applications only.

For a detailed procedure, see Procedure: Configuring a 
Media Gateway Trunk for CPD, on page 209

Task Summary: Integrating the SSG for Outbound Calls (Continued) 

Objective Related Procedures and Actions
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7. Configure trigger application Mandatory Parameters

The HTTP POST sent by the trigger application must be 
designed to include the following mandatory parameters:

• Request URI must contain the TenantName as a query 
string parameter. In a multi-tenant setup, use 
Environment or an equivalent identifier. In a 
single-tenant setup, substitute this value with Resources 
or an equivalent name.

• IVRProfileName—Specifies the name of the IVR Profile 
of the voice application to be used for the outbound call.

• Telnum—Specifies the telephone number used to make 
the outbound call.

• NotificationURL—An encoded URL that the SSG will 
use to send asynchronous notifications to the TA to 
indicate the success or failure of the outbound call.

For a description of all available CreateRequest attributes 
that can be included in the HTTP POST request, see the 
HTTP Interface section of the Genesys Voice 
Platform 8.1 User’s Guide.

CPD Control Parameters

For Call Progress Detection, the trigger application must 
include the following parameters in the CreateRequest that 
it sends to SSG:

• preconnect—Specifies when to start CPD. If set to true, 
SSG includes the cpd-on-connect Extension in the 
TMakePredictiveCall request.

• detect—Specifies the action that SSG will take on the 
outbound call when CPD is detected. 

SSG translates these parameters into Extensions attributes 
in the T-Library MakeCall request that it sends to SIP 
Server

For a description of all available custom parameters 
supported by the VPS, see the Call Progress Detection 
section of the Genesys Voice Platform 8.1 User’s Guide.

Task Summary: Integrating the SSG for Outbound Calls (Continued) 

Objective Related Procedures and Actions
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Additional Special Configuration

Configure the voice application. NGI Applications

For NGI applications, the application can transfer the call to 
an agent using the <transfer> tag only. You can create the 
VoiceXML application using Composer.
Legacy GVPi Applications

For GVPi applications, you must use the Routing Point DN 
call flow. Additional configuration is required. See the 
following procedures:

• Task Summary: Additional Configuration for Routing 
Point Call Flow, on page 201

Integrating SSG into CTI-C deployments. For CTI through IVR Server deployments, you must use the 
Routing Point DN call flow. Additional configuration is 
required. See the following procedures:

• Task Summary: Additional Configuration for Routing 
Point Call Flow, on page 201.

Configure SSG for SNMP monitoring. Optional: This procedure is only required if you are 
capturing alarm and trap information for SSG.

1. Go to the Configuration tab of the SSG Application 
object.

2. Under Connections, click Add and fill the parameters 
that point to the SNMP Master Agent installed on this 
host.

Note: If no SNMP Master Agent is available, you might 
need to configure SNMP monitoring for the baseline 
solution. See “Configuring SNMP Monitoring” on 
page 122.

Task Summary: Integrating the SSG for Outbound Calls (Continued) 

Objective Related Procedures and Actions
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Task Summary: SSG Integration, Routing 
Point Call Flow

For CTI through IVR Server deployments, or when using legacy GVPi 
applications, you must configure VPS to use the Routing Point DN call flow 
for SSG initiated outbound calls.

Task Summary: Additional Configuration for Routing Point Call Flow, on 
page 201 provides an overview of the additional steps you must complete to 
use this Routing Point call.

Warning! Legacy GVPi applications that use attached data must be 
configured as "IVR-centric,” i.e. they apps require CTIC to 
exchange attached data with Framework.

Task Summary: Additional Configuration for Routing Point Call Flow

Objective Related Procedures and Actions

1. Verify baseline configuration. Complete the basic configuration steps for SSG integration.

• Verify that Steps 1 to Step 7 are completed in the following 
task table:
 Task Summary: Integrating the SSG for Outbound Calls, 

on page 195

Note: The Trunk Group DN will not be used to place the call, 
but is still required for getting available/total port details for the 
tenant. 
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2. Configure the Voice over IP 
Service DN for CPD.

Go to: Provisioning > Switching > Switches > and 
double-click your SIP Server Switch object

SIP Server uses this DN to contact RM to initiate MSML dialog 
for CPD on the Genesys Media Server:

1. On the DNs tab, click Add and create a new DN of the type 
Voice over IP Service .

2. On the Options tab, in the TServer section, configure the 
following mandatory parameters:
 contact—Set this to the IP address and SIP port for 

Resource Manager: 
sip.<RM_IP>:<RM_port>

 make-call-rfc3725-flow—Set to 1.
 refer-enabled—Set to false.
 request-uri—Point this to RM, with msml in the user 

part, and identify the tenant-id as the name of the tenant:
sip:msml@<RMHost>:<RMport>;gvp-tenant-id=<Tenant
_Name>

 ring-tone-on-make-call—Set to false.
 service-type—Set to msml.
 subscription-id—Set this to the name of the tenant.
 partition-id—Set this to the name of the tenant.

3. To enable CPD on the MCP, on the Options tab, configure 
the following optional parameter:
 cpd-capability—Set this to mediaserver.

3. Configure the Voice over IP 
Service DN for playing treatments.

Go to: Provisioning > Switching > Switches

SIP Server uses this DN to contact RM to initiate MSML dialog 
for playing treatments on the Genesys Media Server:

1. On the DNs tab of the Switch object, click Add and create a 
new DN of the type Voice over IP Service.

2. On the Options tab, in the TServer section, configure the 
following mandatory parameters:
 contact—Set this to the IP address and SIP port for 

Resource Manager: 
sip.<RM_IP>:<RM_port>

 service-type—Set to treatment.

Task Summary: Additional Configuration for Routing Point Call Flow (Continued) 

Objective Related Procedures and Actions
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4. Configure GVP as a series of Voice 
Treatment Port DNs.

Go to: Provisioning > Switching > Switches

VPS uses this set of DNs to select the IVR Profile in order to 
play the VoiceXML application for the connected customer.

1. On the DNs tab of the Switch object, click Add and create a 
new DN of the type Voice Treatment Port.

2. On the Options tab, in the TServer section, configure the 
following mandatory parameters:
 contact—Set this to the IP address and SIP port for 

Resource Manager: 
sip.<RM_IP>:<RM_port>

 prefix—Set to the name of the DN.
 request-uri—Use the following format:

sip:<vtp_DN_name>@<RM_contact>;gvp-tenant-id=<te
nant_name>

 event-ringing-on-100trying—Set to true when CTI 
Connector is used for the call.

 cpd-capability—Set to mediaserver.
 userdata-map-filter—Set to the required GVP headers, 

using a constant string. Mandatory values are as follows:
gsw-ivr-profile-name, gsw-session-dbid

You can also include the following additional parameters 
to this option:

OutboundData—Include to pass user data from SSG to 
IVR Application.

AnswerClass—Include to pass CPD result back to 
VoiceXML application.

GVP-IVRPort—Must include if SSG is integrated with 
PSTN Connector and CTI Connector.

GVP-PSTNC-DBID—Must include if SSG is integrated 
with PSTN Connector and CTI Connector.

Task Summary: Additional Configuration for Routing Point Call Flow (Continued) 

Objective Related Procedures and Actions
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5. Configure the Place Group used by 
the routing strategy.

1. Configure a Place object for each Voice Treatment Port 
DN.

a. Go to Provisioning > Switching > Places.

b. Click New and create a new Place with the same name as 
the corresponding Voice Treatment Port DN.

c. Under DNs, click Add and browse to select the 
corresponding Voice Treatment Port DN.

d. Repeat for as many Voice Treatment Ports 

2. Configure a Place Group as the target for the Voice 
Treatment Port DNs.

a. Go to Provisioning > Switching > Place Groups.

b. Click New, and give the Place Group a name.

c. On the Places tab, click Add and browse to select all the 
Places you created in Step 1.

6. Configure the Routing Point DN. Go to: Provisioning > Switching > Switches

The solution uses this DN to place the outbound call request.

1. On the DNs tab of the switch object, click Add.

2. Create a new DN of the type Routing Point.

Key Rules

• You will use the name of this DN RPDN parameter in the SSG 
application.

• If serving multiple tenants, create a separate Routing Point 
DN for each tenant. In the TServer section, set the 
partition-id to the name of the tenant.

7. Configure the SSG Application 
object.

Go to: Provisioning > Environment > Applications > your 
SSG application

Point the SSG to the Routing Point DN through which the 
outbound call will be placed.

• On the Options tab, in the Tenant<n> section, configure the 
following:
 RPDN—Set to the Routing Point DN you configured in 

Step 6.

Note: The other mandatory parameters should already be 
configured as described in Step 5 of the baseline integration.

Task Summary: Additional Configuration for Routing Point Call Flow (Continued) 

Objective Related Procedures and Actions
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Integrating SIP Server with SSG 
To integrate SSG with SIP Server, complete the following procedures.

1. Procedure: Configuring SIP Server for outbound calls through SSG

2. Procedure: Integrating SSG with SIP Server

3. Procedure: Creating a Trunk Group DN for outbound calls

4. Additional configuration for Routing Point call flow:  Task Summary: 
SSG Integration, Routing Point Call Flow, on page 201

Procedure:
Configuring SIP Server for outbound calls through 
SSG

Purpose:  To configure the SIP Server Application object to support outbound 
calls initiated through the Supplementary Services Gateway.

Start of procedure

1. Go to Provisioning > Environment > Applications, and double-click on 
your SIP Server Application object.

2. On the Options tab, in the TServer section, configure the options as 
described in Table 9 on page 206.

8. Create a routing strategy Use Interaction Routing Designer to:

1. Create the routing strategy that URS uses to select an 
available Voice Treatment Port DN.

2. Load the strategy on the Routing Point DN that you created 
in Step 6.

For an example, see “Sample Routing Strategy” on page 210.

Task Summary: Additional Configuration for Routing Point Call Flow (Continued) 

Objective Related Procedures and Actions
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3. Click Save and close.

End of procedure

Table 9: SIP Server Options—TServer Section

Option Value Description

sip-invite-treatment-timeo
ut

30 Set this option to 30 and SIP Server 
will wait this length of time for a 
response to the INVITE it sends to start 
a treatment, before the call times out.

If the call times out, SIP Server 
disconnects the call leg, sends an error 
response back to SSG, and retries the 
call.

am-detected connect Set this option to connect. This sets the 
default to be used by SIP Server, which 
gives the trigger application control 
over whether SSG will drop or connect 
the call, depending on the CPD result.

fax-detected connect Set this option to connect. This sets the 
default to be used by SIP Server, which 
gives the trigger application control 
over whether SSG will drop or connect 
the call, depending on the CPD result.

cpd-info-timeout 3, 7 or 
higher

CPD on MCP

Set this option to 7 (seconds) or higher 
if CPD is to be performed on the MCP. 
The MCP requires up to 6 seconds to 
detect CPD.
CPD on Media Gateway

Set this option to the default of 3 
(seconds) if CPD is to be performed on 
a supported media gateway (Paraxip or 
Audiocodes).

Note: Paraxip has been tested with 
CCXML applications only.

userdata-map-trans-prefix X-Genesys- SIP Server maps any header with this 
X-Genesys- prefix to corresponding 
T-Library messages.
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Next Steps

• Procedure: Creating a Trunk Group DN for outbound calls

Procedure:
Creating a Trunk Group DN for outbound calls

Purpose:  To create the Trunk Group DN from which SIP Server sends the 
outbound INVITE to the customer endpoint.

Start of procedure

1. Go to Provisioning > Switching > Switches, and double-click your SIP 
Server Switch object.

2. Create a Trunk Group DN:

a. On the DNs tab, click Add.

A New DN window opens.

b. On the Configuration tab, enter the following information:
• Number—Name the DN according to the tenant from which the 

outbound call will be made.
• Type—Select Trunk Group from the drop-down list.

Mandatory
Options

3. On the Options tab, click New and create a new section called TServer, then 
add new options as follows:
 Contact—Set this option to the Resource Manager IP address and sip 

port (typically 5060), using the following format:
sip:<RM_ip_address>:<RM_sip_port>

 make-call-rfc3725-flow—Set this option to 1. This instructs SIP 
Server to use the 3pcc call flow as defined in the RFC 3725

 refer-enabled—Set this option to false. It forces SIP Server to use the 
re-INVITE method instead of REFER, as required for 3pcc calls.

 ring-tone-on-make-call—Set this option to false (no ring tone is 
required for scenarios that may include CPD)

 request-uri—Set the user part of the URI to msml, and identify the 
tenant-id as the name of the tenant. Format the value of this option as 
follows: sip:msml@<RMHost>:<RMport>;gvp-tenant-id=<Tenant_Name>

SIP Server sends an INVITE to Resource Manager with the Request-uri 
modified to tell GVP to act as media server for the call.

 subscription-id—Set this to the name of this Trunk Group DN. In this 
case, set the value for this option to Environment.

• userdata-map-filter—Set this to the following string:
gsw-ivr-profile-name,gsw-session-dbid,CustomerParam

This ensures that these required parameters are provided as UserData 
parameters to Resource Manager. It also allows any custom data 
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provided by the Trigger Application to be passed through the 
CustomParam attribute in the TMakePredictiveCall.

Enable CPD 4. On the Options tab, in the TServer section, add the following option:
 cpd-capability—Set this option to mediaserver. This enables CPD 

analysis to be performed by the MCP.

5. Click Save and Close to save all changes.

End of procedure

Next Steps

• Procedure: Integrating SSG with SIP Server

Procedure:
Integrating SSG with SIP Server

Purpose:  To point the SSG Application object to the SIP Server instance and 
related Trunk Group DN from which outbound calls will be made.

Prerequisites

• A Trunk Group DN for outbound call flow. See Procedure: Creating a 
Trunk Group DN for outbound calls, on page 207.

Start of procedure

1. Go to Provisioning > Environment > Applications, and double-click your 
SSG Application object.

2. On the Configuration tab, under Connections, add a connection to the SIP 
Server Application object.

3. On the Options tab, in the Tenant<n> section, configure the following 
mandatory options:
• TenantName—Set to the name of the tenant this section belongs to.
• TGDN—Set this to the name of the prerequisite Trunk Group DN. 

4. Click Save and close.

End of procedure

Tip: If CPD is also configured for the media gateway, then SIP 
Server selects the gateway for CPD, over MCP.

Note: Create a Tenant<n> section for every tenant that this SSG will 
service. The variable <n> can range from 1 to the maximum 
number of tenants, 200.
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Next Steps

• Procedure: Configuring a Media Gateway Trunk for CPD

Enabling CPD on the Media Gateway
CPD can be performed on either the MCP or using one of two supported media 
gateways: Paraxip or Audiocodes. If CPD is enabled for both MCP and the 
media gateway, SIP Server chooses the gateway to perform the analysis.

Procedure:
Configuring a Media Gateway Trunk for CPD

Purpose:  To configure a Trunk DN that the VPS will use to perform call 
progress analysis for outbound calls using SSG.

Start of procedure

1. Go to Provisioning > Switching > Switches, and double-click the SIP 
Server Switch.

2. On the DNs tab, click Add.

3. On the Configuration tab, enter parameters as follows:
• Number—Enter a name for this DN.

• Type—Select Trunk from the drop-down list.

4. On the Options tab, create a TServer section, and add new options as 
follows:
• contact—Set this to the IP address and port of the media gateway.
• cpd-capability—Set this to the exact string that identifies the type of 

supported gateway you are using: audiocodes or paraxip.

Note: Paraxip has been tested with CCXML applications only.

Note: This procedure describes the minimum configuration required for a 
Trunk DN in order to support CPD on a media gateway. For a more 
complete description of the options available when configuring a 
gateway, see the procedure “Configuring a gateway” in the SIP Server 
8.1 Deployment Guide.

Tip: Genesys recommends entering a text-based name for Trunk DNs 
(letters or words: for example, My_Trunk), to differentiate from 
regular DNs.
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• cpd-info-timeout—Set this to the length of time, in seconds, that SIP 
Server will wait for the INFO with CPD results, after the 200 OK from 
the media gateway.

5. Click Save and close.

End of procedure

Sample Routing Strategy
For deployments that use the Routing Point DN call flow (see “Outbound 
Calls Using the Supplementary Services Gateway” on page 58), the following 
sample routing strategy provides some basic details about the required routing 
blocks.

Figure 50: Routing Point Call Flow—Sample Routing Strategy

Tip: This DN-level option takes precedence over the 
application-level configuration. If call_timeguard_timeout is 
included in the TMakePredictiveCall request, then it takes 
precedence over either option setting.

Selection Block – used to select an available 
Voice Treatment Port from the Place Group. 

Function Block – used in error path to 
add the user data “SSGDisposition=fail”.

Music Treatment Block – used to 
convey the error to the external party.
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14 Integrating with PSTN 
Connector
This chapter describes the configuration steps required to integrate the PSTN 
Connector into the solution. 

This chapter includes the following sections:
 Task Summary: Integrating With PSTN Connector, page 211

Task Summary: Integrating With PSTN 
Connector

The Task Summary: Integrating With PSTN Connector, on page 212 provides 
an overview of the main steps required to integrate the PSTN Connector into 
the solution.

Note: It is beyond the scope of this document to provide detailed 
configuration steps for all scenarios that the PSTN Connector 
supports. The procedures in this chapter can be used to integrate the 
PSTN Connector into a station-side connected architecture, as an 
example.

For general deployment procedures, see the Genesys Voice 
Platform 8.1 Deployment Guide.

Note: For an overview of how PSTN Connector fits into a TDM-connected, 
IVR Behind solution, see Chapter 8, “PSTN Connector,” on page 101.
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Task Summary: Integrating With PSTN Connector

Objective Related Procedures and Actions

1. Verify baseline configuration. Before integrating the PSTN Connector, the rest of the solution must 
be properly integrated. 

In keeping with the “Sample Deployment” on page 101 deployment 
described in this guide, verify that the following procedures have 
been completed:

•  Task Summary: IVR Behind, TDM-Connected Integration, on 
page 151

Key Actions

Some small changes to the baseline configuration are required for 
integration with PSTN Connector:

• GVP Trunk DN—set the prefix option to match the first few 
digits of the Default DNIS you will configure later in Step 4.

• Gateway Resource Group—Set CTI Usage to Always On (use-cti 
set to 1).

2. Install Dialogic card. For information about installing and configuring Dialogic hardware 
and software, visit the vendor’s website.

Required Software Version: Dialogic® SR 6.0 PCI for Windows SU 
241 (2003/2008)

Special Configuration for Windows Server 2008

After installation on Windows Server 2008, you must disable the 
Physical Address Extension (PAE) on the server. 

1. From the command line interface (CLI), enter:
 C:\bcdedit /set nx OptOut
 C:\bcdedit /set pae ForceDisable

2. Restart the server.

For information about supported Dialogic cards, see the Genesys 
Voice Platform 8.1 Deployment Guide.
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3. Deploy PSTN Connector. 1. Install and configure the PSTN Connector application and object, 
with the following connections:
 Message Server (optional)
 SIP Server
 SNMP Master Agent

2. Configure DialogicManager_Route1 section:
 Channels—Set this to the port numbers for this route, using the 

format Card:PortRange. For example: 1:1-23
 Routetype—Set this the call direction for this route: Inbound, 

Outbound, or In/Out
 Signaling type—Set this to the signaling type for this route:

 T1-ISDN (PRI),
 0;Analog,
 1;E1-ISDN (PRI),
 2;T1-RobbedBit,
 3;E1-CAS,4

3. Configure GatewayManager section:
 SIP Destination IP Address—Set this to the SIP Server IP 

address.
 SIP Destination Port Number—Set this to the SIP Server port 

number.

4. Configure MediaManager section:
 Supported Local Codec Type—Set to Alaw or MuLaw

Sample screenshot: See Figure 51 for an example of a configured 
application.

For more information: For detailed procedures, go to theGenesys 
Voice Platform 8.1 Deployment Guide for information about the 
following:

• Using the deployment wizard to install GVP

• Creating a connection to a server

• Configuring the PSTN Connector

Task Summary: Integrating With PSTN Connector (Continued) 

Objective Related Procedures and Actions
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Sample PSTN Connector Configuration

Figure 51 on page 215 shows an example of how the mandatory options for 
PSTN Connector might be configured.

4. Configure default DNIS. Go to Provisioning > Environment > Applications > and select 
your PSTN Connector application.

• On the Options tab, in the DialogicManager section, configure the 
following option:
 DefaultDNIS—Set this to any number to be used as the default 

DNIS (for example, 74388485). You must set the prefix in the 
GVP Trunk to the first few digits of this number (see Step 1).

Note: This is only required for behind the switch deployments, where 
the DNIS is not immediately available from the switch.

5. Configure the PSTN 
Connector Trunk.

Go to Provisioning > Switching > Switches > and select your SIP 
Server switch object.

1. On the DNs tab, click New and create a DN of the type Trunk .

2. On the Options tab of the DN, create a TServer section with the 
following options:
 contact—Enter the IP address and port for the PSTN 

Connector.
 sip-replaces-mode—Set this to 1. For consultation transfers, 

SIP Server forwards the REFER with Replaces to the external 
destination.

 oosp-transfer-enabled—Set this to true.

For deployments with multiple PSTN Connectors
 prefix—Used internally by GVP/SIP Server in bridge transfer 

scenarios. This setting ensures that the outbound leg of the 
transfer is routed to the same PSTN Connector where the 
inbound call came from.

 replace-prefix—Create this option, but leave the value as an 
empty string. SIP Server removes the prefix added by Resource 
manager before forwarding the call to the PSTN Connector 
instance.

Task Summary: Integrating With PSTN Connector (Continued) 

Objective Related Procedures and Actions
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Figure 51: Sample PSTN Connector Configuration
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Part

3 Appendixes
Use the following appendixes for additional information related to the 
solutions:

• Appendix A, “Sample User Data Mapping,” on page 219

• Appendix B, “Configuration Options,” on page 225
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Appendix

A Sample User Data Mapping
Depending on the needs of your call flow design, user data needs to flow from 
SIP Server to GVP or from GVP to SIP Server. This appendix includes sample 
data exchanges between SIP Server and the T-Library event, in both directions, 
as well as VoiceXML code samples used to map user data.

All examples show data mapping for user data that is defined as CustomerName 
and CustomerParam with a prefix of X-Genesys. 

This appendix includes the following examples of mapped user data:
 Mapping User Data Received from GVP, page 219
 Mapping User Data Received from URS, page 221
 Mapping User Data Received from GVP in INFO/BYE Body, page 222

Mapping User Data Received from GVP
The following samples show the mapping of user data from the INVITE request 
to the T-Library event. User data appears in bold.

Sample SIP INVITE Request

INVITE sip:5555@138.120.84.32:5060 SIP/2.0
Via: SIP/2.0/UDP 
138.120.84.33:5070;branch=z9hG4bK0167dea01f24e6abcdef09
Via: SIP/2.0/UDP 138.120.84.239:5060;branch=z9hG4bK0aef28e81f24e6
From: 
sip:9059683348@10.0.0.193;tag=B03F2519-A7ED-4FD0-E5A8-525C101B5725
To: <sip:5555@138.120.84.33:5070>
Max-Forwards: 69
CSeq: 1 INVITE
Call-ID: 59774435-B48E-45A4-C885-D61B28BC3828-5060@138.120.84.239
Contact: <sip:RM_GVP@138.120.84.239:5060>
Content-Length: 291
Content-Type: application/sdp
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Record-Route: <sip:22687272@138.120.84.33:5070;lr;gvp.rm.datanodes=1>
X-Genesys-CustomerName: John Doe
X-Genesys-CustomerPassword: 1234
X-Genesys-CustomerZipcode: 90210
Min-SE: 90
X-Genesys-CallUUID: DHU3UHQ5TT5DFBQ7OP3BP9P7NC000001
X-Genesys-GVP-Session-ID: 
4C9B7DD1-C405-428F-409A-4C14BA62DE06;gvp.rm.datanodes=1;gvp.rm.tenant-id
=GVADS_App_vmdit5
Supported: timer
Session-Expires: 1800
X-Genesys-RM-Application-dbid: 105

Sample T-Library Event

AttributeANI '9059683348'
AttributeDNIS '5555'
AttributeUserData[256] 00 05 00 00..

'CustomerName' 'John Doe'
'CustomerPassword' '1234'
'CustomerZipCode' '90210'
'CallUUID' 'DHU3UHQ5TT5DFBQ7OP3BP9P7NC000001'
'GVP-Session-ID' '4C9B7DD1-C405-428F-409A-4C14BA62DE06;

gvp.rm.datanodes=1;gvp.rm.tenant-id=GVADS_App_vmdit5'
'RM-Application-dbid''105'

AttributeCallUUID'DHU3UHQ5TT5DFBQ7OP3BP9P7NC000006'
AttributeConnID008b01918c3dd002

Sample VoiceXML Code

The following code sample shows a bridged <transfer> in a VoiceXML 
application, with attached user data:
<form>

 <script>
var userdata = new Object();
userdata.CustomerName = “John Doe”;
userdata.CustomerPassword = “1234”;
userdata.CustomerZipCode = “90210”;
</script>
<transfer bridge=”true” 

dest=”sip:5555@” gvp:signalvar=”userdata”/>
</form>
...
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Mapping User Data Received from URS
The following samples show the mapping of user data from the T-Library 
event to the INVITE request that is sent to GVP. User data appears in bold.

Sample T-Library Event

AttributeANI '9059683348'
AttributeDNIS '5555'
AttributeUserData[704] 00 18 00 00..

'CustomerName' 'John Doe'
'CustomerPassword' '1234'
'CustomerZipCode' '90210'
'CallUUID' 'DHU3UHQ5TT5DFBQ7OP3BP9P7NC00000B'
'GVP-Session-ID' 'FCBCBF00-4FBD-418B-6DB3-0B3FE4861960;

gvp.rm.datanodes=1;gvp.rm.tenant-id=GVADS_App_vmdit5'
'RM-Application-dbid' '105'
'RVQID' ' '
'RTargetTypeSelected' '100'
'RTargetRuleSelected' ' '
'RTargetObjectSelected'' '
'RTargetObjSelDBID' ' '
'RTargetAgentSelected' ' '
'RTargetPlaceSelected' ' '
'RTenant' 'Environment'
'RStrategyName' 'Route2DN'
'RStrategyDBID' '104'
'CBR-actual_volume' ' '
'CBR-Interaction_cost' ' '
'CBR-contract_DBIDs' ' '
'CBR-IT-path_DBIDs' ' '
'RRequestedSkillCombination'' '
'RRequestedSkills'(list) 
'CustomerSegment' 'default'
'ServiceType' 'default'
'ServiceObjective' ' '

AttributeCallUUID'DHU3UHQ5TT5DFBQ7OP3BP9P7NC00000G'
AttributeConnID 008b01918c3dd004
AttributeCallID 4
AttributeCallType2

Sample INVITE Request (to GVP)

INVITE sip:1800@138.120.84.33:5070 SIP/2.0
From: sip:9059683348@10.0.0.193;tag=36A7A329-0740-4AD8-87A1-
AC6AB366EF0B-11
To: <sip:5555@138.120.84.32:5060>
Call-ID: 8B5B60DB-901C-4F20-9AB3-8577E4698254-5@138.120.84.32
CSeq: 1 INVITE
Content-Length: 292
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Content-Type: application/sdp
Via: SIP/2.0/UDP 
138.120.84.32:5060;branch=z9hG4bKCBA0C951-5D81-4EB9-904F-99E50A51A3
23-10
Contact: <sip:1800@138.120.84.32:5060>
Max-Forwards: 70
Allow: INVITE, ACK, PRACK, CANCEL, BYE, REFER, INFO
X-Genesys-CustomerName: John Doe
X-Genesys-CustomerPassword: 1234
X-Genesys-CustomerZipcode: 90210
X-Genesys-CallUUID: DHU3UHQ5TT5DFBQ7OP3BP9P7NC00000G
Session-Expires: 1800;refresher=uac
Min-SE: 90

Sample VoiceXML Session Variables

The VoiceXML application receives user data in the following 
session.com.genesyslab.userdata session variables:
session.com.genesyslab.userdata.customername = ’John Doe’;
session.com.genesyslab.userdata.customepassword =‘1234’
session.com.genesyslab.userdata.customerzipcode =‘90210’

Mapping User Data Received from GVP in 
INFO/BYE Body

Mapping for INFO and BYE requests does not require any special configuration, 
but takes place automatically in the body of the SIP message. The following 
samples show the mapping of user data from a BYE request to the T-Library 
event. User data appears in bold.

Sample BYE Request

BYE sip:PlayApp@138.120.84.32:5060 SIP/2.0
Via: SIP/2.0/UDP 
138.120.84.33:5070;branch=z9hG4bK02ba3488d74d19abcdef09
Via: SIP/2.0/UDP 138.120.84.33:5060;branch=z9hG4bK0a9d6548d74d18
From: <sip:PlayApp@138.120.84.32:5060>;tag=E218369F-7B05-4EE7-518A-
D73F8D84417E
To: sip:9059683348@10.0.0.193;tag=2E3CBB9D-3D21-4C6C-ADAE-
239E06E083EA-2
Max-Forwards: 69

CSeq: 1 BYE
Call-ID: FBCC203E-7D2E-4E22-9460-94E3625B7379-1@138.120.84.32
Content-Length: 74
Content-Type: application/x-www-form-urlencoded;charset=utf-8
X-Genesys-GVP-Session-ID: 701F7A30-4AE0-458C-75A3-2887610F96FE;

gvp.rm.datanodes=1;gvp.rm.tenant-id=IVRAppDefault
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Min-SE: 90
Supported: timer

CustomerName=Jane%20Doe&CustomerPassword=1234&__reason=disconnect

Sample T-Library Event

AttributeANI '9059683348'
AttributeDNIS '8000'
AttributeUserData[65] 00 03 00 00..

'CustomerName' 'Jane Doe'
'CustomerPassword' ‘1234'
'__reason' 'disconnect'

AttributeCallUUID'F20VBH6HQ54VPAU31P6FT2E79C000001'
AttributeConnID 006d018d0ec19001

Sample VoiceXML Code—Mapping to BYE Body

The following code sample shows the mapping of user data received from 
GVP to the body of a BYE message:
...
<form>
...

<var name=”CustomerName” expr=”Jane Doe”/>
<var name=”CustomerPassword” expr=”1234”/>
<exit namelist=”CustomerName CustomerPassword”/>

</form>
...

Sample VoiceXML Code—Mapping to INFO Body

You can design the VoiceXML application to attach user data to SIP Server in 
the middle of the call. The following VoiceXML code sample shows the 
mapping of user data received from GVP to the body of an INFO message:
...
<form>
...

<var name=”CustomerName” expr=”Jane Doe”/>
<var name=”CustomerPassword” expr=”1234”/>
<vg:send namelist=”CustomerName CustomerPassword”/>

</form>
...

Note: In this case, because this is not a disconnect request but a midcall 
request, “_reason=disconnect” will not appear as user data in either the 
SIP message or the T-Library event, as it does in the codes samples 
“Sample BYE Request” and “Sample T-Library Event”.
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B Configuration Options
This appendix describes the configuration options that are modified during 
procedures in this guide. Options are organized according to component type, 
and include the following:
 Media Control Platform Options, page 225
 Logical Resource Group Options, page 227
 CTI Connector Options, page 228
 Supplementary Services Gateway Options, page 232

Media Control Platform Options
All of these options are all found in the SIP section on the MCP Options tab.

defaultbridgexfer
Default Value: BRIDGE
Valid Values: BRIDGE, MEDIAREDIRECT
Changes Take Effect: At restart

Specifies the default transfer method for SIP, for bridge-type transfers. For 
more information about the transfer types and methods, see the section 
“Transfers” in the Genesys Voice Platform 8.1 User’s Guide.

outcalluseoriggw
Default Value: 1
Valid Values: 0, 1
Changes Take Effect: Immediately

Specifies how the Media Control Platform will determine which gateway to 
use for an outbound call or transfer, if the destination address does not contain 
a host name or IP address.

Example:
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If sip.outcalluseoriggw=1 and the inbound call came from a gateway with 
host name 3000, the call will be placed to one of the following:

• tel://3000

• sip:3000@—The “at” symbol (@) is required to delimit the user part from 
the host part of the address.

referxferhold
Default Value: 0
Valid Values: 0,1
Display Name in Genesys Administrator: Refer Transfer Hold
Changes Take Effect: At start/restart.

Specifies whether to place the original caller on hold (INVITE hold) before 
sending the REFER message to transfer the call.

routeset
Default Value: Empty
Valid Values:
<sip:<Resource Manager IP address>:<Resource Manager SIP 
port>;lr>[,<sip:<Next SIP Proxy or UA IP address>:<Proxy SIP 
port>;[lr]>,...]

Note: The outer angle brackets are required characters in the string.

Changes Take Effect: Immediately

A comma-separated list of SIP Proxy addresses that defines a route set for 
non-secure SIP outbound calls. If defined, this route set is inserted as the 
ROUTE header for all outgoing calls. This forces GVP to use the defined route 
set for SIP messages.

Using the lr parameter with the URI (see syntax) forces the User Agent Client 
(UAC) to place the remote target URI into the Request-URI and to include the 
route set in the ROUTE header.

Example:
<sip:RM_host.yourdomain.com:5060;lr>,<sip:Proxy2.yourdomain.com:5060;lr
>—

Media Control Platform will send the outgoing request to Resource Manager, 
which will, in turn, route the request to Proxy 2, which will redirect the 
message to its intended destination.

Note: The route set does not apply to SIP REGISTER messages.

transport.<x>
Default Values:

 transport.0=transport0 udp:any:5070
 transport.1=transport1 tcp:any:5070
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 transport.2=transport2 tls:any:5071 
cert=$InstallationRoot$\config\x509_
certificate.pem 
key=$InstallationRoot$\config\x509_private_key.pem

Valid Values: <transport_name> <transport_type>:<ip>:<port> 
[<parameters>]

where:
 <transport_name> is any alphanumeric string.
 <transport_type> is the transport layer protocol: udp|tcp|tls.
 <ip> is the IP address of the network interface that accepts incoming 

SIP messages (the default value of any means all network interfaces).
 <port> is the port number where SIP stack accepts incoming SIP 

messages.
 [<parameters>] are any additional, optional SIP transport parameters.

Changes Take Effect: Immediately

The parameters that define the transport layer for SIP stack and the network 
interfaces that are used to process SIP requests.

<x> is the transport interface index that identifies the transport, so that you can 
specify different combinations of parameters for different protocols.

For a secure SIP connection, ensure that you specify Transport Layer Security 
(TLS) parameters:

• cert=<TLS certificate path and file name> (required)

• key=<TLS key path and file name> (required)

• type=<type of secure transport> (optional)
Valid values: TLSv1|SSLv2|SSLv3|SSLv23
Default value: SSLv23

• password=<password associated with the certificate and key pair> 
(required only if the key file is password protected)

Note: The default transport is the smallest non-empty transport interface 
index. If all sip.transport.<x> values are empty, UDP, TCP, and TLS 
transports are all enabled, with the default parameter values, and UDP 
is the default transport.

Logical Resource Group Options
You can modify these resource group options using the Genesys Administrator 
Resource Group Wizard: Provisioning > Voice Platform > Resource Groups.

port-usage-type
Default Value: Empty
Valid Values: in-and-out, outbound
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Changes Take Effect: After restart

Determines which SIP dialogs the Resource Manager will consider when 
calculating the current usage on each resource, for resource management 
purposes.

Current usage is defined as the outstanding number of established SIP dialogs 
on a resource plus the current pending requests on the resource. The SIP 
dialogs that are included in the calculation are:

• in-and-out—SIP dialogs originated from and directed to the resource.

• outbound—SIP dialogs directed to the resource.

service-types
Default Value: None
Valid Values: voicexml, ccxml, gateway, conference, msml
Changes Take Effect: After restart

Specifies the types of service provided by resources in this resource group.

To specify multiple types of service (for example, CCXML and Conference), 
hold down the Ctrl key while selecting additional service types. Resources can 
be assigned to the group only if they support all the service types that you 
specify in this parameter.

A more detailed description of the valid values is as follows:

• voicexml—Voice application services provided by Media Control Platform 
resources.

• ccxml—Call control application services provided by Call Control

• Platform resources.

• gateway—Network gateway services provided by Resource Access Point 
resources.

• conference—Conference services, which can be provided by Media 
Control Platform and Call Control Platform resources.

• msml—Media streaming services using the Media Server Markup Language 
(MSML).

CTI Connector Options
ClientName
Default Value: None
Valid Values: Any valid string
Display Name in Genesys Administrator: IVR ClientName
Changes Take Effect: After restart

Specifies the IVR Group Name that is configured in Genesys Administrator. 
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DefaultDNIS
Default Value: None
Valid Values: Any DNIS
Display Name in Genesys Administrator: Default DNIS
Changes Take Effect: After restart

Specifies the default DNIS that CTI-Connector will send to Resource Manager, 
in case the IVR Server in Behind mode fails to return the DNIS during the 
fetch DNIS operation. This mandatory option must be set for all IVR Server 
modes, though it is only effective for Behind mode.

fetchscriptidfromurs
Default Value: 0
Valid Values: 0, 1
Display Name in Genesys Administrator: Fetch Script ID from URS
Changes Take Effect: After restart

Specifies whether CTI Connector needs to fetch the user-defined key value to 
represent the DNIS from the Management Layer. This option is used in 
situations where the switch cannot provide the DNIS through the CTI link. CTI 
Connector sends the key to URS, where the predefined value is returned—
typically the DNIS that is required for IVR Profile mapping.

To set this option, you must perform the following additional configuration:

• Define a key-value pair in URS.

• Define the script ID key name (scriptidkeyname) to be sent to URS.

GetDNISFromIServer
Default Value: False
Valid Values: True, False
Display Name in Genesys Administrator: Fetch DNIS from IServer
Changes Take Effect: After restart

Specifies whether CTI Connector needs to get the DNIS value that is required 
to map an IVR Profile from the IVR Server. Set this option to true only for 
integration with IVR Server in Behind mode—required for TDM integrations, 
optional for carrier-connected (if CTI flagging is disabled). For other IVR 
Server mode integrations, leave this option set to the default false, so that CTI 
Connector obtains the DNIS from the history-info or to header of the INVITE 
message (the default behavior).

iserveraddr
Default Value: None
Valid Values: <IServer_ip_address>
Display Name in Genesys Administrator: IServer Host IP Address
Changes Take Effect: After restart

Specifies the IP address of the host machine where the IVR Server is running.
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iserversocket
Default Value: No default (9090 is recommended)
Valid Values: <IServer_port>
Display Name in Genesys Administrator: IServer Communication Port
Changes Take Effect: After restart

Specifies the gli_server_address port number as configured in the IVR Server 
Application object. Typically the port used is 9090.

IVRPortBaseIndex
Default Value: -1
Valid Values: Any integer
Display Name in Genesys Administrator: IVRPort Base Index
Changes Take Effect: After restart

Specifies the starting IVR port number. Each port number increments by one 
after this is set. If this parameter is set to -1, CTI Connector will not generate 
an IVR Port, instead it will take the port base on DNIndicator.

This parameter is applicable when IVR Server is deployed in-front-of-switch 
mode.

localhostname
Default Value: None
Valid Values: <CTIC_host_ip_address>
Display Name in Genesys Administrator: Local Hostname
Changes Take Effect: After restart

Specifies the IP address of the CTI Connector host machine.

MaxIVRPorts
Default Value: 2000
Valid Values: Any integer
Display Name in Genesys Administrator: Max IVR Ports
Changes Take Effect: After restart

Specifies the upper limit to the number of IVR ports that CTI Connector will 
generate for IVR In-Front mode integrations.

playannouncepath
Default Value: file://../treatments/PlayAnn.vxml
Valid Values: <path_to_playannaounce_vxml_file>
Display Name in Genesys Administrator: PlayAnnounce Resource Path
Changes Take Effect: After restart

Note: Use this option when the port information is unavailable. IVR Server 
uses this port number to pass the DNIS information. For deployments 
using multiple CTI Connectors, the port range must be distinct.
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Specifies the path to the default resource that will play the announcement 
treatments triggered from the IVR Server application.

playannounceanddigitpath
Default Value: file://../treatments/PlayAnnDigits.vxml
Valid Values: <path_to_playannaounceanddigit_vxml_file>
Display Name in Genesys Administrator: PlayAnnounceAndDigit Resource 
Path

Changes Take Effect: After restart

Specifies the path to the default resource that will play the announcement and 
collect digit treatments triggered from the IVR Server application.

RMIPAddr
Default Value: None
Valid Values: <RM_ip_address>:<RM_sip_port>
Display Name in Genesys Administrator: Resource Manager IP Address
Changes Take Effect: After restart

Specifies the IP address and port information of the Resource Manager. The 
value should take the following form: <RM_ip_address>:<RM_sip_port>

Example:
10.10.10.10:5060

scriptidkeyname
Default Value: None
Valid Values: <script_id_key_name>
Display Name in Genesys Administrator: Script Id Key Name
Changes Take Effect: After restart

Specifies the key name, configured in Framework side that will be used by the 
IVR Server Client in UdataGet messages. This option is applicable only when 
the IVR Server is running in Behind mode.

UseCalledNumAs
Default Value: DN
Valid Values: DN, TFN
Display Name in Genesys Administrator: Use Called Number
Changes Take Effect: After restart

Specifies whether CTI Connector will send the toll free number (TFN) or the 
DNIS. To send the TFN, set the value to TFN. To send the DNIS, set the value 
to the default DN.
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Supplementary Services Gateway Options
These options should be created in a section called Tenant<n>, where each 
section corresponds to a particular tenant services by this instance of SSG. For 
example, the Environment tenant would appear in SSG as section Tenant1, 
with TenantName set to Environment.

TenantName
Default Value: No default value
Valid Values: Name of tenant
Changes Take Effect: On restart

Specifies the tenant to which the options in this section apply. For example, if 
this section is to control the Environment tenant, set this to the name of the 
tenant: Environment.

RPDN
Default Value: No default value
Valid Values: Name of valid Routing Point DN
Changes Take Effect: On restart

Specifies the Routing Point DN that the solution uses when placing the 
outbound call through SSG, in cases where the Routing Point call flow is 
required. For example, use this option for CTI through IVR server 
deployments, or when connecting the customer to GVPi applications.

For outbound calls through Trunk Group call flow, do not configure this 
option.

TGDN
Default Value: No default value
Valid Values: Name of valid Trunk Group DN
Changes Take Effect: On restart

Specifies the Trunk Group DN that the solution uses when placing outbound 
calls through SSG, in cases were the Trunk Group call flow is required. For 
example, use this option for CTI through SIP Server deployments, where the 
called customer is connected to an NGI application.

Note: CPD results are not processed by SSG when TMPC request is placed 
on Routing Point.
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Supplements

Related Documentation 
Resources
The following resources provide additional information that is relevant to this 
software. Consult these additional resources as necessary.

SIP Server

• Framework 8.1 SIP Server Deployment Guide, which provides information 
to configure and install SIP Server.

Genesys Voice Platform

• Genesys Voice Platform 8.1 Deployment Guide, which provides 
information about installing and configuring Genesys Voice Platform 
(GVP).

• Genesys Voice Platform 8.1 User’s Guide, which provides information 
about configuring, provisioning, and monitoring GVP and its components.

• Genesys Voice Platform 8.1 Genesys VoiceXML 2.1 Reference Help, which 
provides information about developing Voice Extensible Markup 
Language (VoiceXML) applications. It presents VoiceXML concepts, and 
provides examples that focus on the GVP Next Generation Interpreter 
(NGI) implementation of VoiceXML.

• Genesys Voice Platform 8.1 Legacy Genesys VoiceXML 2.1 Reference 
Manual, which describes the VoiceXML 2.1 language as implemented by 
the Legacy GVP Interpreter (GVPi) in GVP 7.6 and earlier, and which is 
now supported in the GVP 8.1 release.

• Genesys Voice Platform 8.1 CCXML Reference Manual, which provides 
information about developing Call Control Extensible Markup Language 
(CCXML) applications for GVP.

• Genesys Voice Platform 8.1 Troubleshooting Guide, which provides 
information about Simple Network Management Protocol (SNMP) 
Management Information Bases (MIBs) and traps for GVP, as well as 
troubleshooting methodology.
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• Genesys Voice Platform 8.1 Configuration Options Reference, which 
replicates the metadata available in the Genesys provisioning GUI, to 
provide information about all the GVP configuration options, including 
descriptions, syntax, valid values, and default values.

• Genesys Voice Platform 8.1 Metrics Reference, which provides 
information about all the GVP metrics (VoiceXML and CCXML 
application event logs), including descriptions, format, logging level, 
source component, and metric ID.

Composer

• Composer 8.1 Deployment Guide, which provides information about 
installing and configuring Composer.

• Composer 8.1 Help, which provides information about using Composer, a 
GUI for developing applications based on VoiceXML and CCXML.

Genesys

• Genesys Technical Publications Glossary, which ships on the Genesys 
Documentation Library DVD, provides a comprehensive list of the 
Genesys and computer-telephony integration (CTI) terminology and 
acronyms used in this document.

• Genesys Migration Guide, which ships on the Genesys Documentation 
Library DVD, provides documented migration strategies for Genesys 
product releases. Contact Genesys Technical Support for more 
information.

• Release Notes and Product Advisories for this product, which are available 
on the Genesys Technical Support website at 
http://genesyslab.com/support.

Genesys Voice Platform 8.1 Web Services API wiki, which describes the Web 
Services API that the Reporting Server supports. 

Composer

• Composer 8.1 Deployment Guide, which provides installation and 
configuration instructions for Composer.

• Composer 8.1 Help, which provides online information about using 
Composer, an Integrated Development Environment used to develop 
applications for GVP and Universal Routing.

http://docs.genesyslab.com/wiki/index.php?title=GVP_Web_Services_API
http://genesyslab.com/support
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Open Standards

• W3C Voice Extensible Markup Language (VoiceXML) 2.1, W3C 
Recommendation, 19 June 2007, which is the World Wide Web 
Consortium (W3C) VoiceXML specification that GVP NGI supports.

• W3C Voice Extensible Markup Language (VoiceXML) 2.0, W3C 
Recommendation, 16 March 2004, which is the W3C VoiceXML 
specification that GVP supports.

• W3C Speech Synthesis Markup Language (SSML) Version 1.0, 
Recommendation, 7 September 2004, which is the W3C SSML 
specification that GVP supports.

• W3C Voice Browser Call Control: CCXML Version 1.0, W3C Working 
Draft, 29 June 2005, which is the W3C CCXML specification that GVP 
supports.

• W3C Semantic Interpretation for Speech Recognition (SISR) Version 1.0, 
W3C Recommendation, 5 April 2007, which is the W3C SISR specification 
that GVP supports.

• W3C Speech Recognition Grammar Specification (SRGS) Version 1.0, 
W3C Recommendation, 16 March 2004, which is the W3C SRGS 
specification that GVP supports.

Genesys

• Genesys Technical Publications Glossary, which ships on the Genesys 
Documentation Library DVD and provides a comprehensive list of the 
Genesys and computer-telephony integration (CTI) terminology and 
acronyms that are used in this document.

• Genesys Migration Guide, which ships on the Genesys Documentation 
Library DVD, and which provides documented migration strategies for 
Genesys product releases. Contact Genesys Technical Support for more 
information.

• Release Notes and Product Advisories for this product, which are available 
on the Genesys Customer Care website at http://genesyslab.com/support.

Information about supported operating systems and third-party software is 
available on the Genesys Customer Care website in the following documents:

Genesys Supported Operating Environment Reference Guide

Genesys Supported Media Interfaces Reference Manual

http://genesyslab.com/support
http://docs.genesyslab.com/wiki/index.php/Special:Repository/80g_ref_smi.pdf?id=73c96eb2-c7cb-4839-95e5-0c910861e615
http://docs.genesyslab.com/wiki/index.php?title=Genesys_Supported_Operating_Environment_Reference_Guide
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For additional system-wide planning tools and information, see the 
release-specific listings of System Level Documents on the Genesys Technical 
Support website, accessible from the system level documents by release tab 
in the Knowledge Base Browse Documents Section.

Genesys product documentation is available on the:

• Genesys Customer Care website at http://genesyslab.com/support.

• Genesys Documentation Library DVD, which you can order by e-mail 
from Genesys Order Management at orderman@genesyslab.com.

• Genesys Online Documentation at docs.genesyslab.com.

Document Conventions
This document uses certain stylistic and typographical conventions—
introduced here—that serve as shorthands for particular kinds of information.

Document Version Number

A version number appears at the bottom of the inside front cover of this 
document. Version numbers change as new information is added to this 
document. Here is a sample version number:

80fr_ref_06-2008_v8.0.001.00 

You will need this number when you are talking with Genesys Technical 
Support about this product.

Screen Captures Used in This Document

Screen captures from the product graphical user interface (GUI), as used in this 
document, may sometimes contain minor spelling, capitalization, or 
grammatical errors. The text accompanying and explaining the screen captures 
corrects such errors except when such a correction would prevent you from 
installing, configuring, or successfully using the product. For example, if the 
name of an option contains a usage error, the name would be presented exactly 
as it appears in the product GUI; the error would not be corrected in any 
accompanying text.

http://genesyslab.com/support/dl/browse/Default.asp?view=list&list=mrno-cnti&grby=epms;0&publ=11,39&nflt=publ&show=tabl&epms=1&mask=83&indx=141&ctgr=30,23,27,31,683,736,1097,1241,1311,1321
http://genesyslab.com/support
mailto:orderman@genesyslab.com

http://docs.genesyslab.com/
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Type Styles

Table 10 describes and illustrates the type conventions that are used in this 
document. 

Table 10: Type Styles

Type Style Used For Examples

Italic • Document titles

• Emphasis

• Definitions of (or first references to) 
unfamiliar terms

• Mathematical variables

Also used to indicate placeholder text within 
code samples or commands, in the special case 
where angle brackets are a required part of the 
syntax (see the note about angle brackets on 
page 238).

Please consult the Genesys 8 Migration 
Guide for more information.

Do not use this value for this option.

A customary and usual practice is one 
that is widely accepted and used within a 
particular industry or profession.

The formula, x +1 = 7 
where x stands for . . .

Monospace 
font

(Looks like 
teletype or 
typewriter 
text)

All programming identifiers and GUI 
elements. This convention includes:

• The names of directories, files, folders, 
configuration objects, paths, scripts, dialog 
boxes, options, fields, text and list boxes, 
operational modes, all buttons (including 
radio buttons), check boxes, commands, 
tabs, CTI events, and error messages.

• The values of options.

• Logical arguments and command syntax.

• Code samples.

Also used for any text that users must 
manually enter during a configuration or 
installation procedure, or on a command line.

Select the Show variables on screen 
check box.

In the Operand text box, enter your 
formula.

Click OK to exit the Properties dialog 
box.

T-Server distributes the error messages in 
EventError events.

If you select true for the 
inbound-bsns-calls option, all 
established inbound calls on a local agent 
are considered business calls.

Enter exit on the command line.

Square 
brackets ([ ])

A particular parameter or value that is optional 
within a logical argument, a command, or 
some programming syntax. That is, the 
presence of the parameter or value is not 
required to resolve the argument, command, or 
block of code. The user decides whether to 
include this optional information.

smcp_server -host [/flags]
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Angle 
brackets 
(< >)

A placeholder for a value that the user must 
specify. This might be a DN or a port number 
specific to your enterprise.

Note: In some cases, angle brackets are 
required characters in code syntax (for 
example, in XML schemas). In these cases, 
italic text is used for placeholder values.

smcp_server -host <confighost>

Table 10: Type Styles (Continued) 

Type Style Used For Examples
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