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Preface
Welcome to the IVR Interface Option 7.5 IVR Driver for WVR for AIX System 
Administrator’s Guide. This guide describes the IVR Driver for WVR for AIX, 
which is the driver component of the Genesys IVR Interface Option 7.5. This 
document also describes the Genesys-provided functions supported in IVR 
Interface Option 7.5.

Note: The full product name for the vendor-provided IVR that this Genesys 
driver supports is IBM WebSphere Voice Response for AIX. However, 
in this document, the IVR product is generally referred to as WVR for 
AIX.

This document is valid only for the 7.5 release of this product.

Note: For releases of this document created for other releases of this product, 
please visit the Genesys Technical Support website, or request the 
Documentation Library CD, which you can order by e-mail from 
Genesys Order Management at orderman@genesyslab.com.

This chapter contains the following sections:
Intended Audience, page 6
Chapter Summaries, page 6
Document Conventions, page 6
Related Resources, page 8
Making Comments on This Document, page 9

Interactive Voice Response (IVR) technology has emerged as an integral part 
of contact centers, financial institutions, and the travel industry. IVR 
components provide the initial interface when a client calls a business. Using 
IVRs, businesses can realize significant savings, and customers can conduct 
their business more efficiently.
The IVR Interface Option 7.5 architecture simplifies the integration of vendor-
provided IVRs with the Genesys environment. Genesys IVR Interface Option 
7.5 has two major components, the IVR Server and the IVR Driver. For more 
information about these and other IVR Interface Option 7.5 components, see 
Architecture, page 12.

mailto:orderman@genesyslab.com


6 IVR Interface Option 7.5

Preface Intended Audience

Intended Audience
This guide, primarily intended for contact center administrators, contact center 
managers, operations personnel, and IVR developers, assumes that you have a 
basic understanding of:
• Computer-telephony integration (CTI) concepts, processes, terminology, 

and applications.
• Network design and operation.
• Your own network configurations.
You should also be familiar with the Genesys Framework architecture and 
functions.

Chapter Summaries
In addition to this preface, this guide contains the following chapters and 
appendix:
• Chapter 1, “IVR Driver Overview,” on page 11, generally discusses 

deployment of IVR Interface Option 7.5, and provides a description and 
illustrations of the IVR Interface Option 7.5 architecture.

• Chapter 2, “Pre-Installation Setup for the IVR Driver,” on page 17, 
describes the pre-installation tasks for the IVR Driver.

• Chapter 3, “Installing the IVR Driver,” on page 23, describes how to install 
the IVR Driver.

• Chapter 4, “Starting and Stopping the IVR Driver,” on page 33, describes 
how to start and stop the IVR Driver.

• Chapter 5, “Functions,” on page 35, describes the Genesys-provided 
functions.

• An Appendix, “Customer Test Package” on page 63, describes how to test 
the IVR Driver installation and configuration.

Document Conventions
This document uses certain stylistic and typographical conventions—
introduced here—that serve as shorthands for particular kinds of information.
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Document Version Number

A version number appears at the bottom of the inside front cover of this 
document. Version numbers change as new information is added to this 
document. Here is a sample version number:
75fr_ref_10-2006_v7.5.000.10

You will need this number when you are talking with Genesys Technical 
Support about this product.

Type Styles

Italic

In this document, italic is used for emphasis, for documents’ titles, for 
definitions of (or first references to) unfamiliar terms, and for mathematical 
variables.

Examples: • Please consult the Genesys 7 Migration Guide for more information.
• A customary and usual practice is one that is widely accepted and used 

within a particular industry or profession.
• Do not use this value for this option.
• The formula, x +1 = 7 where x stands for . . .

Monospace Font

A monospace font, which looks like teletype or typewriter text, is used for 
all programming identifiers and GUI elements.
This convention includes the names of directories, files, folders, configuration 
objects, paths, scripts, dialog boxes, options, text and list boxes, operational 
modes, all buttons (including radio buttons), check boxes, commands, tabs, 
CTI events, and error messages; the values of options; logical arguments and 
command syntax; and code samples.

Examples: • Select the Show variables on screen check box.
• Click the Summation button.
• In the Properties dialog box, enter the value for the host server in your 

environment.
• In the Operand text box, enter your formula.
• Click OK to exit the Properties dialog box.
• The following table presents the complete set of error messages T-Server 

distributes in EventError events.
• If you select true for the inbound-bsns-calls option, all established 

inbound calls on a local agent are considered business calls.



8 IVR Interface Option 7.5

Preface Related Resources

Monospace is also used for any text that users must manually enter during a 
configuration or installation procedure, or on a command line:

Example: • Enter exit on the command line.

Screen Captures Used in This Document

Screen captures from the product GUI (graphical user interface), as used in this 
document, may sometimes contain a minor spelling, capitalization, or 
grammatical error. The text accompanying and explaining the screen captures 
corrects such errors except when such a correction would prevent you from 
installing, configuring, or successfully using the product. For example, if the 
name of an option contains a usage error, the name would be presented exactly 
as it appears in the product GUI; the error would not be corrected in any 
accompanying text.

Square Brackets

Square brackets indicate that a particular parameter or value is optional within 
a logical argument, a command, or programming syntax. That is, the 
parameter’s or value’s presence is not required to resolve the argument, 
command, or block of code. The user decides whether to include this optional 
information. Here is a sample:
smcp_server -host [/flags]

Angle Brackets

Angle brackets indicate a placeholder for a value that the user must specify. 
This might be a DN or port number specific to your enterprise. Here is a 
sample:
smcp_server -host <confighost>

Related Resources
Consult these additional resources as necessary:
• The IVR Interface Option 7.5 IVR Server System Administrator’s Guide, 

which describes how to install, configure, and use the IVR Server.
• The Genesys Technical Publications Glossary, which ships on the Genesys 

Documentation Library CD, and which provides a comprehensive list of 
the Genesys and CTI terminology and acronyms used in this document.

• The Genesys 7 Migration Guide, also on the Genesys Documentation 
Library CD, which contains a documented migration strategy for Genesys 
product releases 5.x and later. Contact Genesys Technical Support for 
additional information.
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• The Release Notes and Product Advisories for this product, which are 
available on the Genesys Technical Support website at 
http://genesyslab.com/support.

Information about supported hardware and third-party software is available on 
the Genesys Technical Support website in the following documents:
• Genesys 7 Supported Operating Systems and Databases Reference Manual 
• Genesys 7 Supported Media Interfaces Reference Manual 
Genesys product documentation is available on the:
• Genesys Technical Support website at http://genesyslab.com/support.
• Genesys Documentation Library CD, which you can order by e-mail from 

Genesys Order Management at orderman@genesyslab.com.

Making Comments on This Document
If you especially like or dislike anything about this document, please feel free 
to e-mail your comments to Techpubs.webadmin@genesyslab.com.
You can comment on what you regard as specific errors or omissions, and on 
the accuracy, organization, subject matter, or completeness of this document. 
Please limit your comments to the information in this document only and to the 
way in which the information is presented. Speak to Genesys Technical 
Support if you have suggestions about the product itself.
When you send us comments, you grant Genesys a nonexclusive right to use or 
distribute your comments in any way it believes appropriate, without incurring 
any obligation to you.

http://www.genesyslab.com/support
http://genesyslab.com/support/dl/retrieve/default.asp?item=B6C52FB62DB42BB229B02755A3D92054&view=item
http://genesyslab.com/support/dl/retrieve/default.asp?item=A9CB309AF4DEB8127C5640A3C32445A7&view=item
http://www.genesyslab.com/support
mailto:orderman@genesyslab.com
mailto:techpubs.webadmin@genesyslab.com
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Chapter

1 IVR Driver Overview
This chapter describes the architecture of Genesys IVR Interface Option 7.5, 
and how the IVR Driver is used in this solution. It also discusses deployment 
tasks and tips. This chapter contains the following sections:

New in Release 7.5, page 11
Deployment, page 11
Architecture, page 12

New in Release 7.5
The following changes have been implemented in release 7.5 of the IVR 
Driver for WVR for AIX:
• There are no new enhancements or features for this release of the IVR 

Driver for WVR for AIX. This is a compatibility release.

Note: To take advantage of the full range of Driver functions you must use 
the IVR Server 7.5, Genesys Framework 7.5, and Genesys 7.5 
licensing.

Deployment
This System Administrator’s Guide describes how to install the IVR Driver for 
WVR for AIX, and how to configure it in Configuration Manager.
The IVR Interface Option 7.5 deployment process includes the installation and 
configuration of the following components:
• IVR Driver
• IVR Server



12 IVR Interface Option 7.5

Chapter 1: IVR Driver Overview Architecture

Before deploying IVR Interface Option 7.5, see the deployment planning 
chapters in the IVR Interface Option 7.5 IVR Server System Administrator’s 
Guide.
In order for the IVR Driver to operate successfully, the IVR Server must be 
installed and running. For compatible IVR Driver and IVR Server releases, see 
the Genesys 7 Migration Guide.
For information about installing and configuring the IVR Server, see the IVR 
Interface Option 7.5 IVR Server System Administrator’s Guide.
For information about the Genesys functions provided for this IVR Driver, see 
Chapter 5 on page 35. For information about the Customer Test Package, see 
the Appendix on page 63.

Architecture
This section describes the architecture of IVR Interface Option 7.5. This 
software application integrates vendor-provided Interactive Voice Response 
(IVR) software and hardware with Genesys Framework.

IVR Server
IVR Server, the key component of Genesys IVR Interface Option 7.5, provides 
the following functionality:
• Tracks call flow
• Interfaces multiple drivers with multiple T-Servers
• Works with other Genesys services (such as T-Server, Stat Server, and 

Universal Routing Server)
• Can be used in Load Sharing or Warm Standby mode
Genesys provides the following configuration modes for the IVR Server:
• IVR-Behind-Switch, a basic configuration in which a T-Server that is 

connected to the premise switch (using computer-telephony integration 
[CTI] links) can monitor the call activity on IVR channels. For more 
information, see “IVR-Behind-Switch Configuration.”

• IVR-In-Front, in which a CTI link is not involved in the call processing. 
For more information, see “IVR-In-Front Configuration.”

• IVR Network T-Server, in which the IVR Server is a link to a user-
provided Network IVR application. The Service Control Point (SCP) and a 
Genesys Network T-Server are used to redirect calls to the Network IVR 
for processing. In this mode, IVR Server functions as a Network T-Server. 
Although Genesys IVR Drivers 7 do not support the IVR Network 
T-Server configuration mode, you can use it with a driver that you build 
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using the IVR XML SDK. For more information about the IVR Network 
T-Server configuration mode, see the IVR Interface Option 7.5 IVR Server 
System Administrator’s Guide.

Library Usage

IVR Server is built with 7.x T-Library, and therefore it can connect to 
T-Servers. IVR Server supports connection to a regular T-Server, the 
TServer_IVR function of an IVR Server operating in IVR-In-Front mode, 
and a Network T-Server.

IVR-Behind-Switch Configuration

In the IVR-Behind-Switch configuration mode, an incoming call arrives at the 
premise switch before going to the vendor-provided IVR (see Figure 1). The 
premise switch and T-Server are at the same site.

Figure 1: IVR-Behind-Switch Configuration

In this configuration, a T-Server is connected to a premise switch, and the IVR 
is connected directly to both the switch (through phone lines) and the IVR 
Server (through data lines). The IVR Server communicates with T-Server and 
Stat Server.
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IVR-In-Front Configuration

If a vendor-provided IVR is connected directly to the PSTN (Public Switched 
Telephone Network), without a premise switch, the configuration is called 
IVR-In-Front. In the Site A configuration shown in Figure 2, there is no 
T-Server to connect to, because there is no premise switch. The TServer_IVR 
function resides within the IVR Server.
An IVR Server operating in IVR-In-Front mode supports IVRs that are 
connected directly to a PSTN, by performing functions similar to those of a 
regular T-Server. If an IVR is considered a termination point for incoming 
calls, no premise switch is involved, and no local T-Server receives notification 
of the incoming call. Instead, the IVR Server provides this functionality.

Figure 2: IVR-In-Front Configuration

In the IVR-In-Front configuration shown in Figure 2, Site A is configured for 
IVR-In-Front mode. The IVR Server communicates with the IVR, the 
Universal Routing Server, and Stat Server. The IVR Server also simulates a 
T-Server, which enables it to communicate with other T-Servers, such as the 
T-Server at Site B. The IVR at Site A is physically connected to the public 
telephony network for phone lines, and to the IVR Server for data lines.
Site B includes a physical switch connected to a T-Server, which, in turn, 
provides data to agents in an agent pool.
This distributed configuration across Sites A and B enables coordinated Call 
Data Transfers.
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IVR Driver
The IVR Driver component integrates vendor-specific IVR hardware and 
software with the Genesys environment. This adds to the IVR’s user interface a 
set of functions or calls that can be used to generate scripts and to integrate the 
vendor-provided IVR with the Genesys environment. All interactions between 
the IVR Driver and other IVR Interface Option components are based on the 
request-response architecture of the IVR Library and use a TCP/IP connection.
The major functions provided by the IVR Driver include:
• Telephony function support (such as transfer, conference, answer, and 

release).
• Call data manipulation (such as attach, update, and delete).
Each vendor-provided IVR needs one Genesys IVR Driver in order to operate 
in the Genesys environment. If you want to run vendor-provided IVRs from 
various manufacturers, each must have a corresponding IVR Driver that is 
designed for it.

IVR Library
The IVR Library component is embedded in Genesys IVR Drivers. Typically, 
it is used to return any IVR Driver error messages.
With IVR Interface Option 7.5, the IVR Library’s communication interface 
uses the industry-standard XML (eXtensible Markup Language) protocol for 
the transport layer. For more information about the XML interface, see the IVR 
SDK 7.5 XML Developer’s Guide, which is available only with purchase of the 
Genesys IVR SDK.
For more information about the IVR Library interface, see the Genesys 
Developer Program 7 IVR SDK C Developer’s Guide.

IVR Server Redundancy Methods
You can achieve redundancy for IVR Servers by using either Warm Standby or 
Load Sharing. These following sections briefly describe each of these 
configurations in turn. For more information about how to configure the IVR 
Server applications, see the IVR Interface Option 7.5 IVR Server System 
Administrator’s Guide.

Note: You configure Load Sharing and Warm Standby in Configuration 
Manager, on the Options tab the Properties dialog box for the 
I-Server and IVR_Driver applications. For more information, see the 
concepts and the configuration option sections in the IVR Interface 
Option 7.5 IVR Server System Administrator’s Guide.
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Warm Standby

If two IVR Servers are in a Warm Standby configuration, the primary IVR 
Server handles all calls on all IVR ports until it fails. At that point, the IVR 
Server that is configured as the Warm Standby backup server takes over the 
load.

Benefit You can perform Inter Server Call Control (ISCC) routing with the IVR 
Servers as the target of an ISCC transfer.

Drawback If the primary server fails, you lose all calls that were in progress at the time of 
failure.

Load Sharing

If two or more IVR Servers are in a Load Sharing configuration, calls on the 
IVR ports are distributed according to the following formula:
<number of ports> modulo <number of active IVR Servers>

If one IVR Server fails, this configuration enables the surviving IVR Server(s) 
to continue handling their current calls, and new incoming calls are distributed 
according to the preceding formula, with the number of active IVR Servers 
now decreased by one. When the failed IVR Server is restored, it is 
automatically added back into the distribution.

Benefit If an IVR Server fails, you lose only the active calls that were in progress on 
that server.

Drawback You cannot perform ISCC routing with the Load Sharing IVR Servers as the 
target of an ISCC transfer.

Note: If you want redundancy, but you do not need to use ISCC, Load 
Sharing is the better method, because you lose only a portion of the 
calls that are in progress. The number of calls that are lost when an 
IVR Server fails follows the formula:
1 / <number of Load Sharing IVR Servers>

For example, if you configure three Load Sharing IVR Servers, and 
one fails, you will lose one-third of the calls that are in progress—
namely, the calls on the IVR Server that failed.
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2 Pre-Installation Setup for 
the IVR Driver
This chapter describes the steps that you must perform before you can 
successfully install the IVR Driver. It contains the following sections:

Before Configuring the IVR Driver, page 17
Configuring the IVR Driver, page 18

Before Configuring the IVR Driver
Before you configure the IVR Driver, you must complete the tasks described in 
this section.

Component Compatibility
Important: Before you can configure Configuration Manager objects and 
install IVR Interface Option 7.5, you must install a supported release of 
Genesys Framework. For IVR-Behind-Switch configurations, you must also 
install a compatible release of Genesys T-Server. For more information, see the 
Framework 7.5 Deployment Guide, and the IVR Interface Option 7.5 chapters 
in the Genesys 7 Migration Guide.

Installing the IVR
Before you manually install the IVR Driver for WVR for AIX on the AIX 
operating system, you must install both the hardware and software for the 
WVR for AIX IVR application. For more information, see the vendor-provided 
WVR for AIX IVR documentation.
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Install the IVR Driver only on the computer on which the vendor-provided 
application is installed. Also, keep in mind that the IVR Driver is intended to 
be used with the IVR Server.

Installing the IVR Server
You can install the IVR Server on any computer that belongs to the site where 
the IVR Interface Option 7.5 product is used (including the computer on which 
the IVR Driver is installed). However, make sure that the operating system of 
the host on which you install the IVR Server matches the operating system on 
which the IVR Server was built.

Note: Genesys strongly recommends that, before installing the IVR Driver, 
you install the IVR Server, and that you configure it, the IVR object, 
and the IVR_Driver application in Configuration Manager.

For information about setting up and configuring the Genesys IVR Server, see 
the IVR Interface Option 7.5 IVR Server System Administrator’s Guide.

Installing LCA and Other Configuration
Before you can start the IVR Driver, you must complete the following steps:
1. Install the Genesys Local Control Agent (LCA) on the same computer as 

the IVR Driver, and then restart the computer. LCA is enabled and starts 
automatically during system startup.

2. In Configuration Manager, create a Host object for your IVR.
3. Open the Properties dialog box for the IVR_Driver application, and click 

the Server Info tab.
4. In the Name box, enter the IVR host name that you specified for the IVR’s 

Host object in Step 2.
5. Configure a log file name that is valid for the operating system on which 

the IVR Driver is running.

Note: If you omit any of these steps, the IVR Driver will not operate or log 
properly.

Configuring the IVR Driver
This section describes how to configure the IVR Driver.

Note: For information about how to migrate from IVR Driver 6.x releases, 
see the Genesys 7 Migration Guide.
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Defining IVRs and IVR Ports
You can use the IVR Interface Option Wizard to define an IVR object, and to 
define an entire range of IVR ports at once. For information about how to use 
the wizard, see the wizard configuration chapter in the IVR Interface Option 
7.5 IVR Server System Administrator’s Guide.
You can also define an IVR object or a single IVR port manually in 
Configuration Manager. For more information, see the manual configuration 
chapter in the IVR Interface Option 7.5 IVR Server System Administrator’s 
Guide.
After you define an IVR object in Configuration Manager (either by using the 
wizard or manually), you must configure the IVR for use with an IVR Driver, 
using the procedure in “Configuring IVR Driver Options.”

Configuring IVR Driver Options
You must configure all configuration options for the IVR Driver in 
Configuration Manager, on the Options tab of the IVR_Driver application’s 
Properties dialog box. For information about how to import and configure the 
IVR_Driver application, see the pre-installation setup chapter and the IVR 
configuration options chapter in the IVR Interface Option 7.5 IVR Server 
System Administrator’s Guide.
You can use the IVR Interface Option Wizard to configure the IVR_Driver 
application and its options. For more information, see the wizard configuration 
chapter in the IVR Interface Option 7.5 IVR Server System Administrator’s 
Guide.

Notes: IVR Driver configuration options that in 6.x releases were configured 
on the Annex tab of the IVR object’s Properties dialog box are 
configured in the IVR_Driver application starting with release 7.2. For 
more information, see the Genesys 7 Migration Guide.
For each IVR Driver running on the same IVR, you must define a 
separate IVR_Driver application.

Managed Service Availability Parameters
The parameters to enable and configure the managed service availability 
features are located on the Annex tab of the IVR object’s Properties dialog box 
in the AgentControl section (see the IVR configuration options chapter in the 
IVR Interface Option 7.5 IVR Server System Administrator’s Guide).
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AgentControl

There are four parameters in the AgentControl section: LegacyMode, 
DriverIgnoreReady, DriverReadyWorkMode, and DriverRetryTimeout. These 
parameters are used to specify which AgentControl values IVR Library 
expects, and what effect they have. Any values other than those described in 
this section are ignored.

Warning! It is important to set the Shutdown Timeout option (on the Server 
Info tab of the IVR_Driver application’s Properties dialog box) to 
a time interval that will allow all calls to end normally on the IVR. 
Any calls that are still in progress when the timer expires will be 
terminated immediately.

Note: All parameter names are case-sensitive.

LegacyMode
Default Value: true

Changes Take Effect: Immediately
Specifies whether the IVR Server or the IVR Driver controls agent state, to 
provide consistency with the values configured for the IVR ports in the IVR 
object.

Notes: If LegacyMode is set to false:
Only one IVR Driver at a time may connect to this IVR object.
Dynamic disabling of IVR ports while the IVR Driver is running is 
not supported. If you attempt to dynamically disable IVR ports 
while the IVR Driver is running, the IVR port’s agents might not 
being logged off.

The following three parameters apply only when LegacyMode is set to false.

DriverIgnoreReady
Default Value: false

Changes Take Effect: Immediately
Specifies whether the IVR Driver attempts to use the SetReady parameter.

Valid Values: true The IVR Server controls the agent activity.
false The IVR Driver controls the agent activity.

Valid Values: true The IVR Driver ignores the SetReady parameter.
false The IVR Driver attempts to set agents to the 

configured SetReady state.
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DriverReadyWorkMode
Default Value: ManualIn

Changes Take Effect: Immediately
Specifies the workmode for AgentReady and AgentNotReady messages.

DriverRetryTimeout
Default Value: 60
Valid Values: Any integer > 0
Changes Take Effect: Immediately
Specifies the amount of time (in seconds) that the IVR Driver waits to make 
another attempt, after receiving an error message from IVR Server for a 
previous AgentControl message on that port.

Valid Values: ManualIn The IVR Driver sends AgentReady and AgentNotReady 
messages with workmode = ManualIn. An AgentReady 
message is sent whenever an AgentNotReady status is 
received from IVR Server.

AutoIn The IVR Driver sends AgentReady and AgentNotReady 
messages with workmode = AutoIn.

Unknown The IVR Driver sends AgentReady and AgentNotReady 
messages with workmode = Unknown.
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3 Installing the IVR Driver
This chapter describes how to install the IVR Driver. It contains the following 
sections:

Identifying the Driver Version, page 23
Installing the IVR Driver, page 24
Importing d2is*.tar into WVR for AIX, page 25
Custom Server Installation, page 26
Configuring d2is Custom Server Properties, page 27
Testing the Installation and Configuration, page 31

Before you install the IVR Driver, complete the tasks described in Chapter 2 
on page 17.

Identifying the Driver Version
To help users identify the version number of the IVR Driver, the file name for 
the IVR Driver for WVR for AIX package consists of the following subfields, 
separated by underscores:
• The name and version of the vendor-provided IVR
• The name and version of the operating system on which the product was 

designed to run
• The Genesys IVR Interface Option type
• The Genesys IVR Driver version

Example for WVR for AIX
dtalk3-1-4_AIX5-1_IS_7-5-000-00.tar
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The file name in the example indicates the following:
1. dtalk3-1-4—This Genesys IVR Driver package was created for the WVR 

for AIX IVR, version 3.1.4.
2. sol2-8—It runs on the AIX version 5.1 operating system.
3. IS—The IVR Interface Option type is IS (IVR Server).
4. 7-5-000-00—The Genesys IVR Driver version is 7.5.000.00.
5. .tar—The package is self-installing.

Supported IVR Versions
The IVR Driver for WVR for AIX, and this System Administrator’s Guide, 
support only the following WVR for AIX IVR versions and operating systems:
• WVR for AIX version 4.2.2 on AIX version 5.2 and 5.3
• WVR for AIX version 3.1.4 on AIX version 5.1 ML 4

Installing the IVR Driver
To untar the Genesys software package so that you can install the IVR Driver 
for WVR for AIX (d2is):
1. Become superuser.
2. Insert the IVR Driver 7.5 installation CD.
3. On the local WVR for AIX host, create a directory called /home/dtuser/

gcti and ensure that it has 20 MB of free space.
4. Locate the directtalk folder on the installation CD.
5. Open the subfolder for the operating system that you use for your IVR, and 

locate the .tar file (for example, dtalk3-1-4_AIX5-1_IS_7-5-000-00.tar).
6. Copy the .tar file into the /home/dtuser/gcti directory that you created 

on the local IVR host.
7. At the command line, enter the command to untar the package file—for 

example:
tar -xvf dtalk3-1-4_AIX5-1_IS_7-5-000-00.tar

The preceding command extracts the following files from the package file:
d2is_aix51.tar—This file contains the Genesys IVR Driver for WVR 
for AIX and the Customer Test Package (CTP) for use on AIX 5.1, 5.2 
and 5.3.
install.man—This text file contains brief instructions for installing, 
configuring, and starting the interface.
Genesys_libs.tar—This file contains the libraries used by the driver.
install_libs—This shell script is used to install the libraries.
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8. Ensure that the d2is driver (the custom server) is not already running. 
Then, still as superuser, execute the command install_libs.

Importing d2is*.tar into WVR for AIX
To import the d2is*.tar file (which contains the d2is driver file and the CTP) 
into the WVR for AIX IVR application:

Note: You must import the d2is_aix51.tar file, regardless of whether you are 
installing the IVR Driver on any of the AIX 5.x operating systems.

1. Open the WVR for AIX application.
2. In the WVR for AIX Welcome window (see Figure 3), click Applications.

Figure 3: WVR for AIX Welcome Window

The Applications dialog box appears (see Figure 4).

Figure 4: Applications Dialog Box
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3. Select Application > Import > Replace > File. The Import File dialog 
box appears (see Figure 5).

Figure 5: Import File Dialog Box

The d2is_aix51.tar file should be listed in the Files box. The path shown 
in the Search String box is the directory where each package is located.

4. Select d2is_aix51.tar, and click OK to import the file.
For more information about importing objects into the WVR for AIX 
application, see the WVR for AIX IVR documentation.

Custom Server Installation
After importing the d2is custom server and the Customer Test Package, install 
the d2is custom server using the menu on the WVR Welcome window.
1. In the WVR for AIX Welcome window, select Applications > Custom 

Server. The Custom Server... dialog box appears.
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2. Locate and double-click the d2is line in the list. The Custom Server (d2is) 
dialog box appears (see Figure 6).

Figure 6: Custom Server (d2is) Dialog Box

3. Select Utilities > Install.
After installation, the Custom Server (d2is) dialog box remains open, so 
that you can configure the custom server properties as described in 
“Configuring d2is Custom Server Properties” on page 27.

Configuring d2is Custom Server Properties
The d2is custom server requires a connection to IVR Server. To establish this 
connection, you must configure parameters for d2is in the WVR for AIX IVR 
application. You must define these parameters as main() arguments, which can 
be updated and saved without rebuilding or re-installing the custom server. 
Modified main() arguments are used the next time the custom server is started.
To define main() arguments:
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1. In the Custom Server (d2is) dialog box, select File > Properties. The 
Properties (d2is) dialog box appears (see Figure 7).

Figure 7: Properties (d2is) Dialog Box

2. Edit the contents of the main() args box:
On the first line, enter GS_7.0.
On the second line, enter the name of the host where the Configuration 
Server will be running.
On the third line, enter the communications port number of the 
Configuration Server, as specified in the Configuration Server 
application’s Properties dialog box in Configuration Manager. The 
default value is 2020.
On the fourth line, enter the name of the IVR Driver, as specified in the 
IVR_Driver application’s Properties dialog box in Configuration 
Manager.
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Note: For each IVR Driver that is running on the same IVR, you must 
define a separate IVR Driver application.

On the fifth line, enter the name assigned to the IVR object in 
Configuration Manager (for example, DT6000).

The following three parameters are optional. You do not need to configure 
them. In most cases, you can use the default values:

On the sixth line, enter the number of milliseconds between queue 
reads. The default value is 50.
On the seventh line, enter the number of Receive messages available. 
The default value is 1.
On the eighth line, enter the number of GetReply functions available. 
The default value is 255.

Note: These arguments are case-sensitive.

3. Click OK, which returns you to the Custom Server (d2is) dialog box.
4. Select File > Save.

Configuring Multiple IVR Drivers for WVR for AIX
If you want to run multiple applications on a single WVR for AIX IVR and 
you want these applications to communicate with two or more IVR Servers, 
you can configure multiple IVR Drivers. The following sections describe how 
to create, compile, configure, and use multiple IVR Drivers.

Note: This is not the recommended approach for Load Sharing. To achieve 
redundancy or Load Sharing, configure a single IVR Driver for use 
with multiple IVR Servers that have been configured for Load Sharing. 
For more information about configuring IVR Servers for Load Sharing, 
see “IVR Server Redundancy Methods” on page 15.

Creating Multiple IVR Drivers

To create multiple IVR Driver instances:
1. Install and configure the IVR Driver, using the instructions in “Installing 

the IVR Driver” on page 24, and in the IVR Interface Option 7.5 IVR 
Server System Administrator’s Guide. Verify that the IVR Driver and IVR 
Server are both functioning correctly (you can use the CTP—see the 
Appendix on page 63).

2. In the WVR for AIX Welcome window, select Applications > Custom 
Servers. The Custom Servers dialog box appears.
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3. Select the d2is custom server, and then select Copy from the Server drop-
down list.

4. In the Copy Target box, enter a name for the copy of your IVR Driver 
(d2is2 in this example), and then click OK to create a copy of the custom 
server (the original IVR Driver) within the WVR for AIX environment.

5. Manually copy the custom server files from the existing IVR Driver to the 
folder for the new custom server (the copy of the IVR Driver):
a. Locate the directory for the new custom server.
b. In the Custom Servers dialog box, select the name of your new IVR 

Driver.
c. Select Server > Open.
d. Select Utilities > Import. The Import dialog box appears.
e. Enter the following command to copy the files from the original IVR 

Driver:
cp ../d2is_dir/* .

Compiling Multiple IVR Drivers

Complete the following steps for each new IVR Driver (WVR for AIX custom 
server) that you create:
1. In the Custom Servers dialog box, select Utilities > Build to change the 

new custom server to the built state.
2. Select Utilities > Import. The Import dialog box appears.
3. In the Import dialog box, enter the command to copy the original IVR 

Driver executable file into the directory that contains your new copy of the 
IVR Driver—for example:
cp ../d2is_dir/d2is d2is2

4. Select Utilities > Install to install the new IVR Driver as a WVR for 
AIX custom server.

5. At the command line, enter the following command to verify that the new 
IVR Driver was successfully installed:
ls -l $CUR_DIR/ca/bin

Configuring Multiple IVR Drivers

Configure the new IVR Driver, using the instructions in “Configuring the IVR 
Driver” on page 18. Keep in mind the following configuration considerations:
• Configure the new driver to communicate with a different IVR Server than 

the original driver.
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• If both IVR Servers are defined and configured in the same Configuration 
Server database, you must use different names for your original IVR 
Driver and the copied IVR Driver.

• If you want to use this new IVR Driver on multiple IVRs, see the IBM 
WVR for AIX manuals for information about how to export and import a 
custom server.

Using Multiple IVR Drivers

Start and stop the new IVR Driver by using the instructions in “Starting and 
Stopping the IVR Driver” on page 33. Keep in mind the following usage notes 
for multiple IVR Drivers:
• Channels (IVR ports) are not assigned to a particular driver. Any channel 

can be used with any driver.
• Ensure that your IVR applications use the correct driver and that their 

corresponding IVR Servers and Configuration Servers are appropriately 
configured.

• The Genesys CTP will test the driver only if it is called d2is (the default 
driver name).

Testing the Installation and Configuration
As part of the standard installation, Genesys has provided a Customer Test 
Package (CTP) to help test the installation and configuration of the IVR 
Driver. You should configure the IVR Driver before using the CTP. For 
information about how to use the CTP, see the Appendix on page 63.
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4 Starting and Stopping the 
IVR Driver
This chapter describes how to start and stop the IVR Driver, which you can do 
only after you have properly installed and configured both the IVR Driver and 
the IVR Server. For more information about installing and configuring the IVR 
Server, see the IVR Interface Option 7.5 IVR Server System Administrator’s 
Guide.
This chapter contains the following sections:

Prestart Information, page 33
Starting the IVR Driver, page 33
Stopping the IVR Driver, page 34

Prestart Information
After installing and configuring the IVR Server and the IVR Driver, you can 
start the vendor-provided IVR application. Genesys recommends that you start 
the IVR Server before the IVR Driver.

Starting the IVR Driver
The IVR Driver for WVR for AIX can be started manually, or it can be started 
automatically by using the automatic start/stop option.
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Manually Starting the IVR Driver
To manually start the IVR Driver for WVR for AIX (d2is):
1. In the WVR for AIX Welcome window, select Operations > Custom Server 

Manager. The Custom Server Manager dialog box appears. The Custom 
Server Name should be d2is.

2. Select Run Status > Start. The Run Status value changes to Active.

Automatically Starting the IVR Driver
To have the IVR Driver automatically start each time WVR for AIX is stopped 
and restarted:
1. In the WVR for AIX Welcome window, select Operations > Custom Server 

Manager. The Custom Server Manager dialog box appears. The Custom 
Server Name should be d2is.

2. In the IPL Status column, click Installed and select Auto-Start On. The 
Run Status value changes to Autoexec.

Stopping the IVR Driver
The IVR Driver for WVR for AIX can be stopped manually, or it can be 
stopped automatically by using the automatic start/stop option.

Manually Stopping the IVR Driver
To manually stop the IVR Driver for WVR for AIX (d2is):
1. In the WVR for AIX Welcome window, select Operations > Custom Server 

Manager. The Custom Server Manager dialog box appears. The Custom 
Server Name should be d2is.

2. In the Run Status column, click Active and select Stop. The Run Status 
value changes to None.

Repeat these steps for each instance of the IVR Driver that you want to stop.

Automatically Stopping the IVR Driver
When the Run Status value is Autoexec (as described in “Automatically 
Starting the IVR Driver”), the IVR Driver is automatically stopped when WVR 
for AIX is stopped, and it is restarted when WVR for AIX is restarted.
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After you install, configure, and start the IVR Driver, IVR Interface Option 7.5 
is ready to be used and tested as a user function within the vendor-provided 
Interactive Voice Response (IVR) application. This chapter describes the 
functions supported in IVR Interface Option 7.5. It contains the following 
sections:

Input Constraints, page 35
Genesys-Provided Functions, page 36

Input Constraints
Some of the functions described in this chapter use key-value pairs. The 
following constraints apply:
• Characters with a value less than 0x20 are not valid in key names or data 

values. The only exceptions are the characters 0x09, 0x0A, and 0x0D, which 
correspond to the ASCII control characters TAB, LINE FEED, and CARRIAGE 
RETURN. No other ASCII control characters are allowed.

• Although you can use a colon (:) when defining the values for a key, a key 
that includes a colon can be used to perform only the following operations:

UDataAddKVP
UDataAddList
UDataDelKVP

• You cannot issue a UDataGetKVP function call from the IVR Driver by using 
a key that contains a colon (although other Genesys software might be able 
to access this type of key-value pair).

• The length of the key can be no more than 1023 characters. The length of 
any individual data string is limited to 2047 characters. The combined key-
value pairs (including delimiters) on a given call instance can total no more 
than 3399 bytes.
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Genesys-Provided Functions
The Genesys IVR Driver for WVR for AIX (d2is) provides functions that can 
be called within the State Table of DirectTalk. For specific instructions on how 
creating voice applications using Genesys-provided functions, refer to the 
following documents:
• IBM WebSphere Voice Response for AIX with DirectTalk Technology: 

Designing and Managing State Table Applications
• IBM WebSphere Voice Response for AIX with DirectTalk Technology: 

Application Development using State Tables
All input parameters specify parameters in the SendData State Table action, and 
all output parameters specify parameters in the ReceiveData State Table action. 
The types of parameters (String or Number) are given using DirectTalk 
terminology.
If a function returns more than one variable, you must check the Result 
variable before using any other variable. You can use other variables only if the 
Result is successful.
The Genesys IVR Driver is part of the custom server category, as described in 
the DirectTalk for AIX Custom Servers document. IVR administrators should 
refer to this document for information about the interrelationship between the 
state tables and custom server.
Table 1 lists the Genesys-provided functions.

Table 1: Functions

Function Summary Page

Notify Functions 

NotifyCallStart Notifies the IVR Server that the call has started. Page 38

NotifyCallEnd Notifies the IVR Server that the call has ended. Page 39

Telephone Functions 

CallInit Initiates a new call to the destination DN. Page 40

CallTransfer Makes a transfer to the DN (mute transfer). Page 40

CallTransferKVList Attaches (updates) a list of key-value pairs to a call before 
making a transfer.

Page 41

CallComplete Completes the current call. Page 42

CallConsultInit Initiates a consulting call with a DN. Page 42

CallConsultRetrieve Retrieves the original consulting call. Page 43
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CallConsultTransfer Completes the consulting call by making a transfer. Page 44

CallConference Connects the original two parties of a conversation with a 
third party.

Page 45

CallConsultConference Completes the consulting call by creating a conference. Page 46

User Data Manipulation Functions 

UDataAddKVP Attaches (updates) a key-value pair to a call. Page 46

UDataGetKVP Requests an attached key value, which is associated with a 
key-value pair.

Page 47

UDataDelKVP Deletes a key-value pair from the call database. Page 48

UDataAddList Attaches (updates) a list of key-value pairs to a call. Page 48

UDataDelAll Deletes all user data from the call database. Page 49

Call Information Functions 

GetCallInfo Returns the requested information from the call database. Page 49

Call Data Transfer Functions 

CDT_Init Requests an access number in order to make a Call Data 
Transfer to a remote destination.

Page 50

CDT_Cancel Cancels the CDT_Init request. Page 52

Route Functions 

RouteRequest Requests a service point from the router. Page 55

RouteStart Requests the start of a new session from the router (assigned 
to the service point).

Page 55

RouteAbort Aborts the previously requested service session from the 
router.

Page 56

GetRequest Requests the next action from the router. Page 57

SendReply Sends a reply from the IVR script to the router. Page 59

General-Purpose Functions 

GetReply Retrieves the reply for a request that was sent earlier. Page 59

Table 1: Functions (Continued) 

Function Summary Page
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The remainder of this chapter describes the function calls that the IVR Driver 
for WVR for AIX supports.

Notify Functions

NotifyCallStart

This function notifies the IVR Server that the IVR channel has answered the 
call.
Your script must call the NotifyCallStart function as the first Genesys 
function at the start of each call instance—typically after the script’s Answer 
function. After a successful NotifyCallStart, the next call must be 
GetCallinfo(EventName). This call must return a valid Genesys event 
(EventEstablished, EventAttachedDataChanged, or EventPartyChanged) before 
the script can use any other function calls (except NotifyCallEnd). The script 
must call NotifyCallEnd as its last function. The script must call only one 
NotifyCallStart and one NotifyCallEnd function for each call.
To ensure that your application has received an EventEstablished, 
EventAttachedDataChanged, or EventPartyChanged event:
1. Issue the NotifyCallStart call.
2. Issue a GetCallInfo call on the line, asking for the EventName.
3. Verify that your application receives an EventEstablished, 

EventAttachedDataChanged, or EventPartyChanged event.
The IVR Driver will be ready to perform additional API requests only after the 
EventEstablished, EventAttachedDataChanged, or EventPartyChanged event has 
been received.

GetErrorCode Returns additional information about a previous function call 
that returned an error.

Page 60

GetVersion Returns the version of the IVR Driver, IVR Server, or IVR 
Library.

Page 61

ToLog Places a specified text string into a log file. Page 61

Statistical Functions 

StatPeek Sends a request to Stat Server to provide information about a 
predefined statistic.

Page 62

Table 1: Functions (Continued) 

Function Summary Page
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Input

String CallID

The Call ID (a unique identifier assigned to each call by the switch). The 
CallID should be empty when the call is issued.

String ANI

The ANI.
String DNIS

The DNIS.
String CDT_Tag

A tag that can be used to provide the Call Data Transfer function. The 
CDT_Tag must be empty when the call is issued.
The String ANI and String DNIS parameters can be included (if available) 
when the PBX is not present at the site, and IVR Server is operating in 
IVR-In-Front mode. When the PBX is present at the site, these strings must 
be empty.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

NotifyCallEnd

This function notifies the IVR Server that the IVR channel has disconnected 
the call.
This function must be called as the last Genesys-provided function in the 
script. Therefore, the NotifyCallEnd function must be invoked before the 
TerminateCall action of the State Table. No Genesys function call other than a 
GetCallInfo(LastEvent) is expected for the call session after this function.

Input

None

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.
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Note: The NotifyCallStart function must be used at the start of each script, 
typically after the Answer function. The NotifyCallEnd function must be 
called as the last function in the script.

Telephone Functions

CallInit

This function initiates a new call to the destination DN (B) (see the scenario). 
The CallInit function works with the switch, which is monitored by T-Server. 
This function is used only for the IVR-Behind-Switch configuration.

Scenario

Input
String DstDN

The phone number of the new destination party.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

CallTransfer

This function produces a direct transfer without an intervening conference call 
(see the description in the T-Library SDK 7.5 C Developer’s Guide). The call 
moves from an extension (B), where a transfer is initiated, to a new extension 
(C) specified in the destination DN (see the scenario). In other words, the party 
(A) who initiates the call is disconnected from the original DN (B) and 
reconnected to the destination DN (C). This function is only used for the 
IVR-Behind-Switch configuration.

A B

A

Before:

After:
B
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Scenario

Input
String DstDN

The phone number of the new destination party.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

CallTransferKVList

This function adds the list of key-value pairs to the current call before making 
the transfer.

Input
String DstDN

The phone number of the new destination party.
String KVList

A list of key-value pairs, in the format:
<delimiter>Key<delimiter>Value

Note: The length of the Key string can be no more than 1023 characters. The 
combined key-value pairs (including delimiters) in the KVList string 
can total no more than 3399 bytes.
If the UU_DATA key is used, T-Server will handle the data part of the 
key-value pair as UUIData.

Example 1 *Customer ID*id01*UU_DATA*uui info*CustomerName*Jim Doe

In this example, * is the delimiter.

Example 2 #Customer ID#id02#UU_DATA#uui info#Customer2 ID#1234

In this example, # is the delimiter.

A B C

A

Before:

After:
B C
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Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

CallComplete

This function ends the current call (see the scenario). This function is used 
only for the IVR-Behind-Switch configuration.

Scenario

Input

None

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

CallConsultInit

This function initiates a consulting call (see the description in the T-Library 
SDK 7.5 C Developer’s Guide). The original party (A) is placed on hold for the 
duration of the consulting call. The party (B) who requests the 
CallConsultInit function is involved in a new consulting call with a third 
party (C) (see the scenario). This function is used only for the IVR-Behind-
Switch configuration.

A B

A

Before:

After:
B
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Scenario

Note: After this function is called, use one of the following functions to 
complete the operation:

“CallConsultRetrieve” on page 43
“CallConsultTransfer” on page 44
“CallConsultConference” on page 46

Input
String DstDN

This phone number describes the new destination party.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

CallConsultRetrieve

This function completes a consulting call. For the duration of the consulting 
call, the original party (A) is place on hold. The second party (B) then creates a 
consulting call to the third party (C) (see the scenario). After the 
CallConsultRetrieve function, the third party (C) is released, and the call 
between the first party (A) and second party (B) is restored. This function is 
used only for the IVR-Behind-Switch configuration.

Note: Use this function only after CallConsultInit has been successfully 
completed. For more information, see “CallConsultInit” on page 42.

A B C

A

Established

Hold

Before:

After:
B CConsult
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Scenario

Input

None

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

CallConsultTransfer

This function completes a transfer (see the description in the T-Library SDK 
7.5 C Developer’s Guide). During the transfer, the caller (A) is placed on hold. 
The original recipient (B) makes a call to a new party (C) (see the scenario). A 
consulting call is established between the original recipient (B) and the new 
party (C). The CallConsultTransfer function initiates the completion of the 
transfer. When the transfer is complete, the original recipient (B), who initiated 
the transfer, is dropped. The ongoing call involves only two participants: the 
original caller (A) and the new party (C). This function is used only for the 
IVR-Behind-Switch configuration.

Note: Use this function only after CallConsultInit has been successfully 
completed. For more information, see “CallConsultInit” on page 42.

Scenario

A B C

A

Hold

Retrieved

Before:

After:
B C

Consult 
Established

A B CHold ConsultBefore:

AAfter:
B C
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Input

None

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

CallConference

This function makes a conference call to a new DN, by connecting the two 
parties (A and B) of the original conversation with an additional party (C) (see 
the scenario). As a result, three or more people can participate in the same 
phone conversation, talking from three or more extensions. This function is 
used only for the IVR-Behind-Switch configuration.

Scenario

Input
String DstDN

The phone number of the new destination party.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

A B C

C

B

A

Established

Conference

Before:

After:
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CallConsultConference

This function completes a consulting call, by connecting the two parties (A and 
B) of the original conversation with an additional party (C) from the consulting 
call. See the scenario below. As a result, several people can participate in one 
phone conversation at the same time, talking from several extensions (see the 
description in the T-Library SDK 7.5 C Developer’s Guide). This function is 
used only for the IVR-Behind-Switch configuration.

Note: Use this function only after CallConsultInit has been successfully 
completed. For more information, see “CallConsultInit” on page 42.

Scenario

Input

None

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

User Data Manipulation Functions

UDataAddKVP

This function attaches User Data (a value) and a corresponding name (key) to 
the current call. T-Server (or the IVR Server in IVR-In-Front mode) uses this 
key-value pair to track data for call that is handled at the contact center. If the 
key of the key-value pair (which is created when new user data is attached) 
duplicates a key that already exists, the new pair replaces the existing pair.

A B C

C

B

A

Hold
Consult 

Conference

Before:

After:
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Note: Both the user key and user value must be present—for example:
Key = Customer ID

Value = 1672

Input
String Key

The key for the user data.
String UserValue

Any customer data or other relevant data.

Note: The length of the Key string can be no more than 1023 characters. The 
length of the UserValue data string is limited to 2047 characters. The 
combined key-value pairs (including delimiters) on a given call 
instance can total no more than 3399 bytes.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

UDataGetKVP

This function returns the user data associated with a key-value pair that was 
previously attached to the call. If a key is given that is not in the current call 
information, the string NoMatch is returned by default.

Input
String Key

The key for the requested user data.

Note: The length of the Key string can be no more than 1023 characters.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

String UserValue

A value for the specified key.
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Note: The length of the UserValue data string can be no more than 2047 
characters.

UDataDelKVP

This function deletes one key-value pair specified by the key from the current 
call.

Input
String Key

The key string for deleting the pair.

Note: The length of the string Key can be no more than 1023 characters.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

UDataAddList

This function adds a list of key-value pairs to the current call.

Input
String KVList

A list of key-value pairs in the format:
<delimiter>Key<delimiter>Value

Note: The length of the Key string can be no more than 1023 characters. The 
combined key-value pairs (including delimiters) in the KVList string 
can total no more than 3399 bytes.

Example 1 *Customer ID*4942*CustomerName*Jim Doe

In this example, * is the delimiter.

Example 2 #Customer ID#4943#Customer2 ID#1234

In this example, # is the delimiter.

Output
Number Result
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If 1, the request succeeded.
If 0, the request failed.

UDataDelAll

This function deletes all user data from the current call.

Input

None

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

Call Information Functions

GetCallInfo

This function requests information related to an active call. If a particular value 
is not available (for example, ANI), the string NULL is returned by default.

Input
String TypeInfo

The type of requested information. Table 2 lists the possible TypeInfo 
values.

 

Table 2: TypeInfo Arguments

Value Requested Information

All All call information available from the IVR Server, as 
described in the rest of this table

ANI ANI information

CallID PBX call ID

ConnID T-Server connection ID

DN Current port assigned to the IVR channel

DNIS DNIS information
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Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

String Info

Contains the requested information.

Call Data Transfer Functions

CDT_Init

This function requests an access number to make a Call Data Transfer to a 
remote destination.
This access number can be used as a DN to make a transfer either through the 
IVR itself or by using the CallTransfer function of d2is.

Input
String DN

The destination DN for the requested Call Data Transfer.
String Location

The name of the destination Call Data Transfer server.

EventName Name of the last event received on the current IVR 
channel

FirstHomeLocation First Home Location of the call

OtherDN Calling DN (if any)

OtherTrunk Calling Trunk (if any)

OtherQueue Calling Queue (if any)

ThisDN Current (called) DN assigned to the IVR channel

ThisTrunk Current (called) Trunk assigned to the IVR channel

ThisQueue Called Queue (if any)

Table 2: TypeInfo Arguments (Continued) 

Value Requested Information
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String CDT_Type

The type of Call Data Transfer protocol. Table 3 lists the possible Call Data 
Transfer types.

Note: If your IVR application passes in a string that is not equal to one of 
these Call Data Transfer types, the string is passed on to the IVR 
Server unchanged.

The IVR Server supports the following types:
Default|Route|Reroute|Direct|DirectAni|DirectNotoken|DirectAniDnis|
DirectUUI|DirectDigits|DnisPool

String CDT_Tag

The Call Data Transfer tag.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

String AccessDN

The access DN that should be used for the requested external transfer.
String CDT_Tag

The Call Data Transfer tag (as the input argument, or as generated by the 
Call Data Transfer Layer).

String RefID

The Reference ID that can be used to cancel a transfer using the CDT_Cancel 
function.

Table 3: Call Data Transfer Types

Value Description

Default Uses the type already configured in your multi-site 
routing environment.

Indirect CDT_Type is changed to Route.

DirectNT CDT_Type is changed to DirectNotoken.

DirectTO CDT_Type is changed to Direct.

DirectTI CDT_Type is changed to Direct.

ReRoute Passes unchanged to the IVR Server.
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CDT_Cancel

This function can be used only after the CDT_Init function has been called. 
This function cancels the preceding request by the CDT_Init function for an 
access number.

Input
String RefID

The Reference ID taken from the previous CDT_Init request.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

Route Functions
When you use the IVR Driver routing functions in your applications, they must 
be coded in a certain order. The pseudocode example in Figures 8 and 9 shows 
the correct order in which the routing APIs must be used. You will need to 
convert this example into valid code for your applications.
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Figure 8: Comments About the Pseudocode

/*

 Port             = type ilPORT with the port of IVR channel

                                (see interface.h)

 ilRQRouteStart   = type ilRQ - returned Request ID for Route Start

                                (see interface.h)

 psRouteStartRep  = type PSTR - pointer to buffer - preallocated

                                for Get Reply to return result in

 iRepLen          = type int - length of above buffer

 ilGetReplyRet    = type ilRet - returned from Get Reply indicating 

                                 result of request (see interface.h)

 ilRQGetRequest   = type ilRQ - returned Request ID for Get Request -

                                used in Send Reply (see interface.h)

 ilSendReplyRet   = type ilRet - returned from Send Reply

                            indicating result of request (see interface.h)

 bResult          = type BOOL - set true if treatment was success -

                                else false (see interface.h)

 psReply          = type CPSTR - pointer to buffer with result of

                        treatment - if return is required

(see interface.h)

  ilRQ_ANY - generate the request id (see interface.h)

 nlrepeat = a number if type int to indicate strategy still active

*/
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Figure 9: Pseudocode for Routing Functions

 ilRQRouteStart = ilSRqRouteStart(ilRQ_ANY,Port,”7000”);
                  /* route sequence start on route dn */
 if (ilRQRouteStart > 0)
                 /* make sure Route Start worked */
 {
     nlrepeat = 1;
     while(nlrepeat == 1)
     {
         ilGetReplyRet = ilGetReply(ilRQRouteStart,psRouteStartRep,iRepLen);
                 /* check reply for Route Start */
                 /* timeout means that the routing strategy */ 
         if(ilGetReplyRet == ilRET_TIMEOUT)
                 /*  is still active */
         {
             ilRQGetRequest = ilGetRequest(Port,psRep,iRepLen);
                 /* retrieve the next treatment - if one exists */
                 /* treatment details in the return buffer      */

             if(ilRQGetRequest>0)
                 /* make sure Get Request worked before        */
             {
              /* processing the returned treatment          */
                 /* processing by application to apply treatment */
                 ilSendReplyRet = ilSendReply(ilRQGetRequest,bResult,psReply);
                      /* send treatment result to URS */
             }
         }
         else
            nlrepeat = 0;
                 /* the get reply returned other than timeout */
     }
     /* this implies the strategy has ended - and */
     /* a RouteResponse has been processed by the library */
     /* the route destination - if it exists in the */
     /* RouteResponse will be returned in psRouteStartRep */
 }
 else /* RouteStart failed */
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RouteRequest

This function sends a request to the router, and the IVR waits for routing 
instructions. The router returns the destination DN of the next service point. 
This function is used for both IVR-In-Front and IVR-Behind-Switch 
configurations.

Input
String Service

The service name requested from Interaction Router.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

String NextService

The name of the next service point/destination DN provided by Universal 
Routing Server (URS).

Note: URS returns the destination of the next service point, and the IVR 
Server immediately responds to URS with a RouteDone event. If the 
IVR is unable to route the call to the destination (or service point) that 
URS has requested, there is no way to indicate that the new route has 
failed. If this error condition could occur, you must use the RouteStart 
API instead of RouteRequest.
For more information about how to code and use the RouteStart, 
GetRequest, SendReply, and RouteAbort function calls, see the Appendix 
on page 63.

RouteStart

This function requests the start of a new session from the router (assigned to 
the service port).
This function begins the information interchange between the IVR channel and 
the router. During this session, the router can send IVR commands 
(treatments), which the IVR must execute. The IVR uses the GetRequest 
function to receive treatments, and the SendReply function to inform the router 
that treatments have been executed. When the session ends, the router has the 
option of sending the name of the next service (usually a phone number for the 
transfer call) to the IVR. The IVR can also end the session by using the 
RouteAbort function.
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This function returns no router response. To receive a response from the router, 
the IVR script must call either the GetReply or GetRequest function. The 
GetReply function can be used only when the router strategy sends the next 
service (DN for transfer only), not when it sends the treatment command. If the 
router strategy uses treatments, the GetRequest function must be used in the 
IVR script.

Note: For more information about how to code and use the RouteStart, 
GetRequest, SendReply, and RouteAbort function calls, see the Appendix 
on page 63.

Input
String Route Point

The name associated with a service that was requested from the router. The 
router must be registered for monitoring this resource.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

Number Request ID

A unique ID that can be used later in the RouteAbort function.

RouteAbort

This function aborts the previously requested service session from Universal 
Routing Server. When URS receives a RouteAbort request, it starts the 
transfer_time timer. If it receives no other events or routing operations before 
the timer expires, it exits the current routing strategy.

Note: You must wait until the timer expires before issuing any other routing 
requests.

Input
Number Request ID

A unique ID assigned by the RouteStart function.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.
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GetRequest

This function takes the request for the next action from the IVR Server. If this 
function is used in the router session, it returns the IVR treatment or the name 
of the next service (usually a number for transfer).

Note: For more information about how to code and use the RouteStart, 
GetRequest, SendReply, and RouteAbort function calls, see the Appendix 
on page 63.

Commands coming from the Genesys router are represented by strings with the 
following (ordered list) format:
“:”,“CommandType”,“:”,“Data”,...

This format begins with a delimiter that is also used later in the string to divide 
fields. The number of actual parameters coming with a command depends on 
the particular command type. The command string contains at least a delimiter 
and a CommandType. Table 4 lists the set of Genesys routing commands and their 
equivalent T-Server treatment types.

Table 4: Routing Commands

Routing Command T-Server Treatment

IVR TreatmentIVR

Music TreatmentMusic

RingBack TreatmentRingBack

Silence TreatmentSilence

Busy TreatmentBusy

CollectDigits TreatmentCollectDigits

PlayAnnounce TreatmentPlayAnnouncement

PlayAnnouncementAndDigits TreatmentPlayAnnouncementAndDigits

VerifyDigits TreatmentVerifyDigits

RecordAnnouncement TreatmentRecordUserAnnouncement
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For a detailed description of treatments and parameters, see the Universal 
Routing 7.5 Reference Manual. See your vendor-provided IVR documentation 
for a description of whether and how the IVR supports these treatments.

Input

None

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

String RouteRequestID

The request ID number assigned to the current router request. This request 
ID can be for either a treatment or a route. (A route is sometimes referred 
to as the next service.)
If RouteRequestID = 0, a route has been returned in the data string, and 
your route sequence has been completed.
If RouteRequestID > 0, a treatment has been returned in the data string. 
Save the RouteRequestID, and send it back to the router when you issue the 
next SendReply function. Then, after the SendReply, issue another 
GetRequest to see whether another treatment (or a route) follows.

DeleteAnnounce TreatmentDeleteUserAnnouncement

CancelCall TreatmentCancelCall

PlayApplication TreatmentPlayApplication

SetDefaultRoute TreatmentSetDefaultRoute

TextToSpeech TreatmentTextToSpeech

TextToSpeechAndDigits TreatmentTextToSpeechAndDigits

FastBusy TreatmentFastBusy

RAN TreatmentRAN

Table 4: Routing Commands (Continued) 

Routing Command T-Server Treatment
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String Data

A request (either a treatment or the next service from the router), as 
determined by the RouteRequestID string.

SendReply

This function sends a reply from the IVR script to IVR Server. Within the 
router session, this function sends the result of the treatment execution.

Note: For more information about how to code and use the RouteStart, 
GetRequest, SendReply, and RouteAbort function calls, see the Appendix 
on page 63.

Input
String RouteRequestID

The request ID received from the router by using the GetRequest function.
String sResult

The execution result of the request (treatment). OK indicates successful 
execution of the request.

String Data

The response from the IVR script. Depends on the treatment type.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

General-Purpose Functions

GetReply

This function retrieves the reply for a previously sent request.

Input
Number Request ID

The request ID received from a previously submitted request.
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Output
Number Result

If 1, the function succeeded.
If 0, the function failed.
If -1, a timeout occurred, and the GetReply function must be called later for 
the required Request ID.

String Reply

Request-specific information. For the exact values of each Reply string, see 
the “Output” section in the description of each function.

GetErrorCode

This function requests additional information about a previously requested 
function call that was not successful and that returned an error. GetErrorCode 
must be submitted immediately after the function call that failed.

Input

None

Output
Number Result

Table 5 lists the possible Result values.

Table 5: Result Values

Number Result Description

0 NOERROR The previously requested function call did 
not generate an error.

-5 CONNCLOSED The connection to the IVR Server is closed.

-7 BADARGS One or more arguments set for the previously 
requested function call are not valid.

-9 UNSUPPORTED The previously requested function call is not 
supported.

-11 TIMEOUT The previously requested function call timed 
out, but at the time when it was called, it was 
still in progress at the server.

-12 REQEXPIRED The previously requested function call has 
expired. Discontinue attempts to complete 
that function.
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GetVersion

This function prints the string to either the IVR Driver log or the log of IVR 
Server.

Input
String Service

The name of the service for which the version number is requested.
If this argument is null or a single space, the IVR Library version is 
returned.
If this argument is the name of the IVR, the IVR Driver version is returned.
If this argument is anything else, the IVR Server version is returned.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

String Version

The version of the Genesys product with the name Service.

ToLog

This function prints the string either to the d2is log or the log of another 
Genesys product.

Input
String PrintString

The string that is printed to the log.
String Service

If this argument is the name of the IVR, the function prints the string to the 
IVR Server log.

-1000 REQFAILURE The previously requested function call has 
failed at the server.

-2000 CANTFINDCHANNEL There has not been a previous request on this 
IVR channel. The channel cannot be found.

Table 5: Result Values (Continued) 

Number Result Description
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If this argument is any other value, or if it is empty, the function prints the 
string to the IVR Driver log.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

Statistical Functions

StatPeek

This function requests that Stat Server provide information about a predefined 
statistic. The parameters of the statistic are defined in the configuration 
environment.

Note: The supported statistics (which must be configured in the IVR Server) 
are CurrNumberWaitingCalls and ExpectedWaitTime. For more 
information, see the section about IVR Server options in the IVR 
Interface Option 7.5 IVR Server System Administrator’s Guide.

Input
String StatName

The name of the requested statistic, which must be defined in the 
configuration environment using Configuration Manager.

Output
Number Result

If 1, the request succeeded.
If 0, the request failed.

String StatInfo

The data value of the requested statistic.
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Customer Test Package
This appendix provides information about the Customer Test Package (CTP). 
It contains the following sections:

Introduction, page 63
Configuring and Using the Customer Test Package, page 63
CTP Voice Menu, page 65

Introduction
The IVR Driver includes a CTP that contains an Interactive Voice Response 
(IVR) application and a corresponding voice prompt database. The IVR 
application is a complete application that you can install on a vendor-provided 
IVR, and use to test and better understand the integration with Genesys 
Framework 7.5.

Configuring and Using the Customer 
Test Package

After installing the CTP, complete the following steps to configure and run the 
application:
1. Configure the CTP application to run over one or more IVR channels, by 

associating channels with a CTP application profile:
a. In the WVR for AIX Welcome window, select Configuration > Pack 

Configuration > Change > Channel IDs. The Channel Identification 
dialog box appears.

b. Enter values in the Area Code and Telephone Number boxes.
c. Click OK.
d. Select the Pack 1 check box.
e. Select File > Save, and then File > Close.
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2. Create an application profile, which associates the specified area code and 
phone number with the CTP application:
a. In the WVR for AIX Welcome window, select Configuration > 

Application Profiles. The Application Profiles dialog box appears.
b. Select File > New. The Application Profile (unnamed) dialog box 

appears.
c. In the Name box, enter CTP.
d. Click State Table and select d2is_ctp.
e. Click Ok, and then select File > Save. The Enter Data dialog box 

appears.
f. Enter the same concatenated string of area code and telephone number 

that you entered in Step 1, and then click Ok. You are returned to the 
Application Profile (unnamed) dialog box, which is now renamed 
Application Profile (<your concatenated string>).

g. Select File > Close. You are returned to the Application Profiles 
dialog box.

h. Select File > Close.
3. Verify that the IVR is active:

a. In the WVR for AIX Welcome window, select Operations > System 
Monitor. The System Monitor dialog box appears.

b. Verify that the Trunk Status value is In Service. If it is not, change it 
to In Service by selecting Enable and then clicking Ok.

c. Click In Service and select Channels In Service. The IVR is now 
active and ready to take calls.

4. If you are using the IVR-Behind-Switch configuration, start the T-Server.
5. Start the TServer_IVR application.
6. Start the IVR Driver.
7. Using a telephone set, dial the Directory Number (DN) associated with the 

IVR channel to activate the CTP and test the integration of IVR Interface 
Option 7.5 with the Genesys Framework software.

8. Follow the voice menu prompts to run the CTP. For more information, see 
“CTP Voice Menu” on page 65.

9. To learn how to invoke the Genesys IVR Interface Option 7.5 functions, 
follow the script example within the application.

10. To learn how to code the IVR Driver function calls, review the CTP State 
Tables in the WVR for AIX development environment.
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CTP Voice Menu
Table 6 lists the voice menu options available in the CTP.

Table 6: CTP Voice Menu Options

Option Key

Main Menu 

Open the User Data Menu Press 1

Open the Information Menu Press 2

Open the Transfer Menu Press 3

Open the Call Data Transfer Menu Press 4

Open the Router Instruction Menu Press 5

Open the Statistics Menu Press 6

Quit Press 0

User Data Menu 

Attach data Press 1

Get attached data Press 2

Delete a key-value pair Press 3

Remove all attached data Press 4

Attach a list of user-data pairs Press 5

Print a string to a log Press 6

Return to the Main Menu Press 0

Information Menu 

Get the Last Event Name Press 1

Get the PBX Call ID Press 2

Get the T-Server Connection ID Press 3

Get the DNIS Press 4

Get the ANI Press 5

Go to the Called call information Press 6
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Go to the Calling call information Press 7

Get the Version of the IVR Driver Press 8

Return to the Main Menu Press 0

Called Information Menu 

Get the called DN Press 1

Get the called ACD queue Press 2

Get the called Trunk Press 3

Return to the Information Menu Press 0

Calling Information Menu 

Get the calling DN Press 1

Get the calling ACD queue Press 2

Get the calling Trunk Press 3

Return to the Information Menu Press 0

Transfer Menu 

Transfer using the IVR Press 1

Transfer using T-Server Press 2

Initiate a transfer Press 3

Complete a transfer Press 4

Retrieve an original call Press 5

Initiate a conference Press 6

Complete a conference Press 7

Perform a single-step conference Press 8

Return to the Main Menu Press 0

Table 6: CTP Voice Menu Options (Continued) 

Option Key
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Call Data Transfer Menu 

Perform an indirect Call Data Transfer Press 1

Perform a direct Call Data Transfer with no tag Press 2

Perform a direct Call Data Transfer with a tag generated by the 
caller

Press 3

Perform a direct Call Data Transfer with a tag generated by the 
Call Data Transfer Layer

Press 4

Return to the Main Menu Press 0

Transfer Methods Menu 

Perform a transfer by IVR Press 1

Perform a transfer by T-Server Press 2

Cancel the Call Data Transfer request Press 0

Router Instruction Menu 

Perform a RouteStart, GetRequest, SendReply sequence Press 1

Perform a RouteRequest Press 2

Return to the Main Menu Press 0

Statistics Menu 

Perform a StatPeek Press 1

Return to the Main Menu Press 0

Table 6: CTP Voice Menu Options (Continued) 

Option Key
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