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Preface 
This preface is an introduction to the Exigen Workflow Administrator’s Guide, Part 3: Utilities. 

The following topics are described in this section: 

• Audience 

• Related Information 

• Typographic Conventions 

Audience 
This guide is intended for system administrators. The system administrator is often referred to as the 
administrator. 

This guide assumes basic computer knowledge for performing Windows® operations. It also assumes 
a familiarity with Open DataBase Connectivity (ODBC) and basic experience working with structured 
query language (SQL) and databases. 

Related Information 
The following table lists guides that provide related information about Exigen Workflow: 

Related documentation 
Title Description 
Exigen Workflow 
User’s Guide 

Describes how to operate Exigen Workflow. 

Exigen Workflow 
Administrator’s 
Guides I-III 

Defines the main concepts underlying Exigen Workflow and describes how to 
create projects and set up, manage, and monitor the system. 

Exigen Workflow 
Installation Guide 

Describes how to install Exigen Workflow. 

Exigen Workflow 
Web User's Guide 

Describes how to use the Exigen Workflow Internet solution. 
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Typographic Conventions 
The following styles and conventions are used in this guide: 

Typographic styles and conventions 
Convention Description 
Bold • Represents user interface items such as check boxes, command buttons, dialog 

boxes, drop-down list values, field names, menu commands, menus, option 
buttons, perspectives, tabs, tooltip labels, tree elements, views, and windows. 

• Represents keys, such as F9 or CTRL+A. 
• Represents a term the first time it is defined. 

Courier Represents file and directory names, code, system messages, and command-line 
commands.  

Courier Bold Represents emphasized text in code.  
Select File > Save 
As 

Represents a command to perform, such as opening the File menu and selecting Save 
As.  

Italic • Represents any information to be entered in a field.  
• Represents documentation titles.  

<  > Represents placeholder values to be substituted with user specific values.  
Hyperlink Represents a hyperlink. Clicking on this field takes you to the identified place in 

this guide. 
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Chapter 1: Introduction 
This section introduces the utility applications available in Exigen Workflow. The following topics are 
described in this section: 

• Overview 

• Exigen Workflow Utilities 

Overview 
Exigen Workflow utilities perform maintenance procedures within Exigen Workflow applications and 
throughout the database. Some utilities are designed to create electronic stamps and templates used in 
specific workflow applications. 

Administration-level users use utilities to maintain database integrity. To ensure database integrity, 
access to utilities is assigned through the Levels feature during system setup, as described in the 
Exigen Workflow Administrator's Guide, Part 1: Design and Configuration, Chapter 4: Setting Up 
Exigen Workflow. 

Exigen Workflow Utilities 
Each utility is designed to perform a different database maintenance function, as described in the 
following table: 

Exigen Workflow utilities 
Utility Icon Description 

Check Document 
Utility  

Checks the integrity of the images in the system. If corrupt images are 
located, they can be sent to a specific queue and user for handling. This 
allows implementing multiple corrections rather than waiting for end user 
notifications concerning specific problems. 

Clear Cache Utility 
 

Clears specific cache directories filled during the commit process or moves 
cache content to an optical or other archive storage medium. 

Empty Folders 
Maintenance Utility  

Creates a file listing all folders to which no documents are assigned. This 
allows the administrator to delete these folders and free up space in the 
database. 

FTS Maintenance 
 

Configures FTS settings in projects. It defines stopwords and the algorithm for 
splitting extracted text into words, and detects documents that are not 
correctly processed. 

Orphan Utility 
 

Locates discrepancies between the database and the actual files. When run, 
it lists image files without matching database records in the document table. 
These files can be routed to a specific queue, and then reviewed and 
processed. 
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Exigen Workflow utilities 
Utility Icon Description 

Stamp Management 
 

Creates and maintains electronic rubber stamps to be applied to document 
images. Stamps are created either by scanning a document with a stamp on it 
or by loading a TIFF or other image file containing the stamp to use. 

Template 
Management Utility  

Creates and maintains form templates to be used for Form Overlay and Form 
Optical Character Recognition processing. Data is either overlaid or extracted 
from specific form templates, depending on which process is used. 

Transfer Utility 
 

Defines the images to transfer from one medium to another. When the new 
storage location is configured, all selected documents are transferred. 

E-Capture Definition 
Utility  

Defines individual forms for recognition and information extraction. These 
forms are created as PDF or PCL files. 

Publisher Packager 

 

Packages a collection of Exigen Workflow folders, subfolders, and documents 
into one directory that can be copied onto a CD. The folders, subfolders, and 
folders can be viewed remotely without being connected to the Exigen 
Workflow system. 
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Chapter 2: Check Document Utility 

This section explains how to search a set of documents to locate image files that are corrupt or not 
located where the database pointers indicate. This section also explains how to verify that the page 
counters are synchronized. 

The following topics are described in this section: 

• Overview 

• Using the Check Document Utility 

• Configuring the Distribution of Affected Documents 

• Defining the Search Criteria 

• Check Document Utility Menus and Buttons 

Overview 
Check Document Utility is used to perform an integrity check on document files. Check Document 
Utility must be run prior to shredding the original paper documents because rescanning is sometimes 
necessary and cannot be performed after shredding. 

Three types of checks are performed during the Check Document Utility process: 

1. An internal check on the document files ensures that they are not corrupted. If the file is corrupted 
and cannot be recovered, it can be deleted and the pages can be rescanned into the system. 

2. This check ensures that the document files are located where the database pointers indicate them 
to be. If the document file is not located where the pointers indicate, it is necessary to search for the 
document record. If the file is found, it is moved to the proper location. If the document file is not 
found, the pages must be rescanned. 

3. This check ensures that the number of pages found in the document corresponds to the number of 
pages indicated in the database for that document record. 

An optional check can be performed to determine if quick tiles were created for a specific group of 
documents. 

Using the Check Document Utility 
To use Check Document Utility, perform the following steps: 

1. To open the Check Document Utility window, in the Exigen Workflow Explorer window, select 
the Utilities folder and double-click Check Document Utility. 

 
The Check Document Utility window appears. 
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Figure 1: Exigen Workflow Check Document Utility window 

The Workflow Project field lists all Exigen Workflow projects registered in the database. The 
Workflow field lists all workflow applications assigned to the selected project. 

2. In the Workflow Project field, select a project to check. 

3. In the Workflow field, select a workflow to check.  

4. To proceed, click Go. 
Another Check Document Utility window appears. 

5. If you do not want to check a project or workflow, click Exit.  
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Figure 2: Check Document Utility window 

All fields are empty initially. Before searching for corrupted documents you must configure where the 
affected documents are sent. 

Configuring the Distribution of Affected Documents 
The Distribution Setup window is used to define the queue where affected documents are routed. It is 
also used to determine the image file destination and the resulting operation. To configure the 
distribution of affected documents, perform the following steps: 

1. To open the Distribution Setup window, in the Utility window, click Distribution Setup. 
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The Distribution Setup window appears. 

 

Figure 3: Distribution Setup window 

2. In the Send to Node list box, select the node, or queue, where you want to route the database 
records.  
The records are sent to the current user. 

3. In Damaged Document Repair Options, select the actions to be taken to repair the documents. 

4. To locate the directory where you want to send the affected documents, click the browse button 

.  
The system places the three-character Project ID after the selected directory string. If the 
subdirectory does not already exist, the system asks for permission to create it.  

5. To automatically create the subdirectory, click Yes. 
6. To use the salvage directory, click No. 

If you select No, you must manually create the directory. 

The Salvage Directory must be specified to use one of the check box options listed in the following 
table:  

Salvage Directory options 
Option Description 

Create Empty Doc. 
Content for Rescan 

Deletes the affected DMS files but retains the database information. The 
document number and all related data are retained so that the documents can 
be rescanned without changing the document number. 

Route Content to Copies the affected files to the salvage directory. 
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Salvage Directory options 
Option Description 
Salvage Directory 

Fix Doc. Content, for 
TIFF Only 

If the header information is corrupted, repairs the document file by treating it 
as a TIFF file and searching for specific characters within the document. 
Once it is re-created in TIFF format, the file is converted back into a DMS file 
so that it can be viewed. 

Remove Damaged Doc 
Content 

Deletes the affected DMS file from its current location. 

 

7. Select an action and click OK. 

Defining the Search Criteria 
Once you configure where the affected documents are sent, you must determine which documents you 
want to check. The Parameter List section of the Distribution Setup window is used to define the 
search criteria. To define the search criteria, perform the following steps: 

1. To select whether to check documents residing in the current workflow or archived documents, in 
the Workflow Environment list box, select Workflow or Archived. 

2. To search for affected documents within a specific range of document numbers, in the Document 
RSN From field, enter the first number. 

3. To begin with the first document number in the database, click Find.  
4. To search in a range, in the Document RSN To field, enter the last number of the range.  

5. To retrieve the last document number in the database, click Find. 
6. To specify a date option for searching the database, select one of the following Search by Process 

options:  
Search by Process options 
Option Description 

Scan Uses the document creation date as the search parameter. 

Modify Uses the document modification date as the search parameter. 

Commit Uses the document commitment date as the search parameter. 
 

7. To define the date range, enter the beginning date in the Processed Date From field and the 
ending date in the Processed Date To field.  
The default values for each field are the current date. 

8. To check whether Quick Tiles or thumbnail views of each image page were created during 
scanning, select the Check “Quick Tile” check box. 

9. To define document storage, select one of the following Device from options:  
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Device from options 
Option Description 

Optical Searches on optical storage devices only. 

Server Searches on server storage devices only. 

Magnetic Searches on magnetic storage devices only. 

Any Devices Searches on all storage devices. 
 

The Check Document Utility window displays the specified settings. 

 

Figure 4: Filled out Check Document Utility window 
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10. To search for corrupted documents, click Start . 
During processing, the Total Records field displays the number of records processed, and the 
Records Verified field displays the number of verified records.  

The Processed Doc RSN field displays the number of the document currently being processed. 
The Detected Problems field displays the number of affected image files found. 

If the selected range of documents is large, such as specified document RSNs or Processed Dates, 
the checking process can be lengthy. 

11. To stop the process, click Stop . 

When the checking process is completed, the Check Document Utility window displays a list of 
problematic documents. 
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Figure 5: List of corrupted documents 

All buttons except Start are enabled. For information on these buttons, see Check Document Utility 
Menus and Buttons. 

The results table at the bottom of the window displays any document that meets the search criteria and 
is corrupted. If no documents appear in the table, the utility has not detected any problems. The 
following table describes the columns in the results table: 

Results table 
Column Description 

Project ID Project where the document is located. 

WFL ID ID of the workflow where the document is located. 
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Results table 
Column Description 

Node ID Node where the document is located. 

Parcel ID ID of the parcel to which the document is assigned. 

Batch Num. Batch number to which the document is assigned. 

Folder RSN Number of the folder to which the document is assigned. 

Document RSN Number of the affected document. 

LOC Location of the document: 
• M: Magnetic 
• O: Optical 
• S: Server 

Pages Number of pages in the document. 

Status Current status of the document: 
• DMS: records in the database exist, and the document file is present, but the file is 

corrupted.  
• ORP: an orphan document where the records in the database exist, but the document 

file is not found, for example, if the file was deleted manually outside Exigen Workflow 
without updating the database records. 

• PGS: number of pages actually present in the document file does not match the number 
of pages stored in the database. 

• Sent: document is sent to the designated queue. 
• Tile: Quick Tiles for the image were created. 

 

To work with corrupted documents, perform the following steps: 

1. To view an individual document, highlight it and click Display.  
If the image is viewable, it appears in the Image Viewer on the right side of the window. If not, an 
error message appears that describes the problem. 

2. To create and view a report listing the affected documents, click Report.  
3. In the Problem Docs - Save File window, enter the name of the report file and click Save. 

The Centura Report Builder window displays the affected documents in report form. 

4. To send one or more documents to the queue assigned in the Distribution Configuration window, 
select the documents and click Send.  

5. To highlight multiple documents for sending, use click and drag, or the CTRL key.  

6. To send all the documents, select Select All and click Send.  
The records remain in the list and appear in the specific queue for the current user ID. 

7. To clear the list, click Clear. 

Check Document Utility Menus and Buttons 
The following table describes the Check Document Utility window buttons and menu functions: 
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Check Document Utility window buttons and menu functions 
Button Shortcut key Menu 

command 
Description 

 

 Check > Start Start 
Checks for corrupted documents. 

 

 Check > Stop Stop 
Stops the checking process. 

 

 Check > 
Distribution 
Setup 

Distribution Setup 
Opens the Distribution Configuration window used to 
determine where and how the affected document records are 
distributed. 

 

CTRL+S Document > 
Send 

Send Document 
Sends all selected documents to the repair queue. 

 

CTRL+R Document > 
Report 

Report 
Saves the list of affected documents, which can be displayed 
and printed via the Centura Report Builder. 

 

CTRL+D Document > 
Display 

Display Document 
Displays the selected image file in the Image Viewer on the 
right side of the window. 

 

 Check > Clear Clear Entries 
Clears all entries in the results portion of the window. 

 

F1 Help > Context 
Help 

Context Help 
Opens the help section. 

 CTRL+F1 Help > Help 
Topics 

Help Topics 
Displays a list of available help topics. 

  Help > About 
Exigen 
Workflow 
System 

About Exigen Workflow System 
Displays copyright and release information regarding Exigen 
Workflow. 

 

F12 Document > 
Exit 

Exit the System 
Closes the Check Document Utility window.  
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Chapter 3: Clear Cache Utility 
This section describes Clear Cache Utility and how to use it. The following topics are described in this 
section: 

• Overview 

• Using the Clear Cache Utility Window 

• Clear Cache Utility Menus and Buttons 

Overview 
Clear Cache Utility is used to identify documents that are modified after being moved to a storage 
medium via the Commit process. Since the committed document cannot be changed, the modified file 
is stored in the Cache directory. The documents found in the Cache directory were edited using the Edit 
Tools feature in the Image Viewer in the Retrieve object. 

Once identified, the modified image files can be moved back into the workflow for further review or 
discarded. They can also be moved to the Commit queue to be recommitted when the pointers in the 
database are changed to reflect the new location of the document. Regardless of the action, the original 
image file remains in the same location on the storage medium. 

Using the Clear Cache Utility Window 
To use Clear Cache Utility, perform the following steps: 

1. To clear the cache directories, in the Exigen Workflow Explorer window, select the Utilities folder 
and double-click Clear Cache Utility.  

 
The Clear Cache Utility window appears. 
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Figure 6: Clear Cache Utility window 

2. Select the Exigen Workflow project and workflow to clear and click Go. 
The Clear Cache Utility window appears. 
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Figure 7: Clear Cache Utility window 

The Cache Directory list box displays all the cache directories configured for the current project 
and workflow. 

3. To view all modified files, perform the following steps: 
1. In the Cache Directory list box, select a directory to view. 

The Device list box displays all devices where committed documents are stored.  

2. In the Device list box, select a directory to compare against the cache.  
Note: This information is based on the configurations setup in the Config portion of the Administrator 

application.  

3. In the Extension list, select an extension. 
The Extension list box contains the available file extensions in the project. In addition to the 
DMS extension that is the standard Exigen Workflow image file extension, all the extensions 
associated with the Task setup in the database are listed. 

4. Click Start. 
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The utility compares all committed documents and lists all modified ones in the table. 

 

Figure 8: Modified documents 

The following fields are displayed while the process is running: 

Clear Cache, processed data fields  
Field Description 

Processed Doc 
RSN 

Number of the currently processed document. 

 

Records verified Number of documents verified in the selected cache directory. 

Detected for 
Recommit  

Number of altered documents found to recommit. 
 

File Name Name of file being processed. 

Total to Verify Number of altered documents found in the selected cache directory. 
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The table lists all modified files found. The following table describes the columns contained in the 
results table:  

Results table columns 
Column Description 

Document 
RSN 

Internal document number. 

Pages Number of pages in the document. 

Modified on Last time the document file was modified. 

Status Current document status: 
• DOC: record exists in the document table. 
• DEL: record was discarded from the cache directory. 
• Sent: record was sent to a queue. 

4. To send documents to a specific node, proceed as follows: 
• In the Send to Node list box, select the workflow node to which to route the modified document 

files. 
• Select documents that must be sent to the node.  
• Click Send.  
The document status changed to Sent in the document list. 

The documents must be routed either to a specific node and user for further review, or to the 
Commit node to be recommitted to an optical storage device. 

5. To view a document, click Display.  
The selected document is opened in the Image Viewer.  

6. To remove a document from the cache directory, in the list, select the document record and click 

Delete . 
Depending on the configuration, the Delete button may be disabled. 

If document versioning is not used, the status of the Delete button is controlled by the following 
section in Configuration Browser: 
ClearCacheOptions/EnableDelete 

If this section is defined in the system and its value is set to y, Y, or 1, the Delete button is enabled. 
Otherwise, the Delete button is disabled. 

If document versioning is used, the Delete button is always disabled. 

If a document is deleted, the document status is changed to Del in the document list. 

7. To clear the document list, click Clear. 

Clear Cache Utility Menus and Buttons 
The following table describes the Clear Cache Utility window buttons and menu functions: 
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Clear Cache Utility window buttons and menu functions 
Button Shortcut key Menu 

command 
Description 

 

 Clear > Start Start 
Compares cache documents to stored 
documents. 

 

 Clear > Stop Stop 
Stops the comparing process. 

 

 Document > 
Send 

Send Document 
Sends all selected documents to the assigned 
node. 

 

 Clear > Delete Delete  
Deletes the selected files from the cache 
directory. 

 

 Document > 
Display 

Display Document 
Displays the selected image file in the Image 
Viewer on the right side of the window. 

 

 Clear > Clear Clear  
Clears all entries in the results portion of the 
window. 

 

F1 Help > Context 
Help 

Context Help 
Opens the help section. 

 CTRL+F1 Help > Help 
Topics 

Help Topics 
Displays a list of available help topics. 

  Help > About 
Exigen 
Workflow 

About Exigen Workflow 
Displays copyright and release information 
regarding Exigen Workflow. 

 

F12 Document > 
Exit 

Exit the System 
Closes the Clear Cache Utility window.  
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Chapter 4: Empty Folders Maintenance Utility 
This section explains how Empty Folders Maintenance Utility works. The following topics are described 
in this section: 

• Overview 

• Using the Empty Folders Maintenance Window 

• Empty Folders Maintenance Utility Menus and Buttons 

Overview 
Empty Folders Maintenance Utility is used to identify the folders in the database that do not have 
assigned documents. If an empty folder is found, the utility offers you the option to either keep or delete 
the folder records. Deletion is recommended to optimize the database space on the server. 

Using the Empty Folders Maintenance Window 
To start processing the empty folders in your database, perform the following steps: 

1. In the Exigen Workflow Explorer window, select the Utilities folder and double-click Empty 
Folders Maintenance. 

 
The Empty Folders Maintenance Utility window appears. 
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Figure 9: Empty Folders Maintenance Utility window 

The Report Date is set to the current date by default and cannot be changed. 

2. To remove empty folders from the system, select the Delete Empty Folder check box. 
If this box is not selected, the records must be deleted manually. 

3. In the Project ID list box, select the project you want to check for empty folders.  
The project name appears in the Project field.  

4. In the Folder Field check box, select the field you want to view in the results file. 
The value in the Result File field is generated by the utility and reflects the path where the Exigen 
Workflow executables reside. The Result File field also includes a datafile name of DOC plus the 
current month and day followed by a DAT extension.  

5. To change the value in the Result File field, click the browse button . 
The Folder From and To fields are associated with the folder numbers in the current project and 
can be changed if required. If your project contains a large number of folders, only a few must be 
processed at a time so that the results file does not become too large. 

6. To begin processing, click Start or select File > Start.  
The Current folder being processed appears in red. When all the defined folders are checked, the 
following buttons are enabled: 

• Close 
• Start 
• Read File 

7. To view the list of all empty folders, click Read File or select File > Read File.  



Administrator's Guide, Part 3: Utilities Chapter 4: Empty Folders Maintenance Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 28 of 145 

Notepad opens with a list of the field values for all folders meeting the empty folder criteria.  

8. To close the Empty Folders Maintenance window, click Close. 

Empty Folders Maintenance Utility Menus and Buttons 
The following table describes the Empty Folders Maintenance Utility window buttons and menu 
functions: 

Empty Folders Maintenance Utility window buttons and menu functions 
Button Shortcut key Menu command Description 

 

 File > Start Start 
Identifies empty folders. 

 

F4 File > Read File Read File 
Opens the list of all empty folders. 

 

F1 Help > Context 
Help 

Help 
Opens the help section. 

 CTRL+F1 Help > Help 
Topics 

Help Topics 
Displays a list of available help topics. 

  Help > About 
Exigen Workflow 

About Exigen Workflow 
Displays copyright and release information regarding Exigen 
Workflow. 

 

F12 File > Exit Exit Application 
Closes the Empty Folders Maintenance window.  
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Chapter 5: Full Text Search Maintenance Utility 
This section explains how to configure FTS Preprocessor. This section also describes how to define 
indexing DLL files that FTS Server uses to create the FTS Index. 

The following topics are described in this section: 

• Overview 

• Using the FTS Maintenance Utility Window 

• Maintaining the Stopwords List 

• Configuring Full Text Search 

• Viewing Erroneous Documents 

• FTS Maintenance Utility Menus and Buttons 

Overview 
The FTS Index is created by adding all words in text files, except stopwords, to the list. The stopwords 
are configured using FTS Maintenance Utility. For more information on stopwords, see Maintaining the 
Stopwords List. 

The FTS Index is created by FTS Server, which uses a predefined structure of extracting and 
configuring words from documents. The predefined structure is defined in an indexing DLL file.  

One or more indexing DLL files can be set. The FTS Index can contain one or several indexes. If 
several indexes are set, a user can select an index to use when retrieving documents. 

FTS Maintenance Utility allows you to set the indexing DLL file or files. Indexing DLL files are designed 
according to customer needs. For more information on DLL files, see Configuring Full Text Search. 

When running FTS Preprocessor and FTS Server, document corruption or other errors may occur. All 
erroneous documents can be viewed and reindexed in FTS Maintenance Utility. For more information 
on corrupted files, see Viewing Erroneous Documents. 

Using the FTS Maintenance Utility Window 
To configure and maintain the list of keywords, perform the following steps: 

In the Exigen Workflow Explorer window, select the Utilities folder and double-click FTS 
Maintenance. 

 

The FTS Maintenance window appears. 
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Figure 10: Full Text Search Maintenance window 

The Full Text Search Maintenance window contains the following features: 

• menu and button bars as described in FTS Maintenance Utility Menus and Buttons 

• table containing the following existing projects in the system: 
 

FTS Maintenance window, existing projects 
Column Description 

Project ID Project IDs in the system. 

Project 
Name 

Project names in the system. 

Database Database where the projects reside. 

FTS Flag indicating that the project is set up to use FTS service. 

Maintaining the Stopwords List  
To maintain the stopwords list, perform the following steps: 

1. In the FTS Maintenance window, click Stopword Maintenance. 
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The Stopword Maintenance window appears. 

 
Figure 11: Stopword Maintenance window 

The Stopword list displays existing project stopwords. The Word list contains all words in the 
existing index. If a word repeats in all documents, it is useful to move the word to the Stopword list 
to narrow the search results. Stopwords are not case sensitive. 

2. To add the words selected in the Word list to the Stopword list, click Add Selected. 
3. To view words in the list, in the field above the appropriate list, enter the first letters of a word and 

click Show List. 
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If nothing is entered in the field before clicking Show List, all words of the list are displayed.  

Not all words in a list are displayed at once because displaying a large number of words can slow 
performance.   

The following actions can be performed with stopwords: 

Stopword Maintenance window buttons 
Button Description 

  

New Stopword 
Adds a new stopword to the list. 

  

Edit Stopword 
Opens the selected stopword for editing. 

  

Delete Stopword 
Deletes the selected stopword. 

You can also import and export stopwords. Stopword lists are saved as text files with an .swf file 
extension. To exchange stopword lists between projects, importing and exporting stopwords is 
useful.  

4. To import stopwords, click Import Stopwords.  
The Choose Import File window opens. 

5. Select a file to import, and click Open.  
The Info message appears containing information about how many stopwords were imported. If the 
imported stopword file contains the same words as the list, no stopwords are exported. 

6. To export stopwords in the list, click Export Stopwords. 
7. To export stopwords, locate the directory and file. 

8. Select one of the following export options: 
Export options 
Option Description 
All stopwords All stopwords in the project.   
Stopwords in 
the list 

Stopwords in the Stopword list in the Stopword Maintenance window. 

9. Click Export.  
The confirmation window appears after a successful export. 

10. When all necessary changes are made, click Close. 
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Configuring Full Text Search 
Before running FTS Server to create the FTS index, the indexes used for each project that uses the full 
text search must be defined. 

Full text search indexes are defined in specific DLL files named full text search plug-ins. 

To configure full text search for a project, perform the following steps: 

1. In the FTS Maintenance window, select a project. 

2. Click Setup. 

 

Figure 12: Full Text Search Setup window 

The window lists all indexes added to the project. The following table describes Full Text Search 
Setup window index parameters: 
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Full Text Search Setup window index parameters 
Parameter Description 
Active Flag that shows whether the indexing DLL file is active. If set, the index is created when 

running FTS Preprocessor and FTS Servers. It is useful to have several indexing DLL files 
set for the project, but they are not required to be used simultaneously. 

Default Index is used as the default index. 
The default index defines the algorithm for identifying words in text in the Image Viewer. 
A default index must be specified to ensure that FTS functions correctly. 

Status Shows whether the indexing plug-in file is loaded successfully. 
Name Index name. 
Description Index description. 

3. To maintain the parameters, click the buttons in the toolbar or select the appropriate commands as 
described in the following table: 
Full Text Search Setup window buttons and menu functions 
Button Shortcut 

key 
Menu 
command 

Description 

 

 Index > Add Opens a dialog for adding a new indexing DLL file to create a 
new index. If there are several indexes in one DLL file, the one 
that is most appropriate for the project can be selected. 

 

 Index > 
Modify 

Opens the Modify Index dialog. The following fields and options 
can be modified: 

Name Description 
Name Index name. 
Description Index description. 
Active DLL indexing file is active. 
Set as default Index is used as the default. 

  

 

 Index > 
Configure 

Configures the selected index as described in Configuring an 
Index. 

 

 Index > 
Delete 

Deletes the selected index. It is not possible to delete an active 
index. 

 F1 Help > 
Context Help 

Opens the help section. 

 CTRL+F1 Help > Help 
Topics 

Displays a list of available help topics. 

  Help > About 
Exigen 
Workflow 

Displays copyright and release information regarding Exigen 
Workflow. 

 

F12 File > Exit Closes the FTS Setup window. 

When all indexes are set, FTS Server can be run to create indexes. 
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Configuring an Index 
Exigen Workflow supports the following full text search indexes: 

Full text search indexes 
Index Plug-in file Description 
Delimiter index d32_ftx.dll Creates a list of words using the defined delimiters to separate 

the words. 
Alphabet index d32_ftx.dll Creates a list of words consisting only of the defined alphabet. 
Telephone index d32_ftxa.dll Creates a list of telephone numbers with defined formats. 

The following topics describe how to configure each of the full text search indexes: 

• Configuring a Delimiter Index 

• Configuring an Alphabet Index 

• Configuring a Telephone Index 

Configuring a Delimiter Index 
To configure a delimiter index, perform the following steps: 

1. In the FTS Setup window, select the delimiter index and click Configure. 
The Index Configuration window appears. 

 
Figure 13: Configuring a delimiter index 

2. Enter the required symbols in the following fields: 
Index Configuration window fields 
Name Description 

Delimiters Characters recognized as the end of the current word and the beginning of the next 
one. They are not considered part of the word during the OCR process. The default 
setting does not recognize punctuation marks or mathematical characters as part of 
the word. 

Soft delimiters Characters not excluded from a word, for example, re-created. If a hyphen is used, all 
possible words are added to the index. For example, re-created adds the following 
words to the index: re-created, re, and created. 
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3. To accept the changes, click OK. 

Configuring an Alphabet Index 
To configure an alphabet index, perform the following steps: 

1. In the FTS Setup window, select the alphabet index and click Configure. 
The Index Configuration window appears. 

 
Figure 14: Configuring an alphabet index 

2. Enter the required symbols in the following fields: 
Index Configuration window fields 
Name Description 

Soft delimiters Characters not excluded from a word, for example, re-created. If a hyphen is used, all 
possible words are added to the index. For example, re-created adds the following 
words to the index: re-created, re, and created. 

Alphabet Set of recognized characters. Words built from characters not defined in this field are 
not added to the FTS index. 

3. To accept the changes, click OK. 

Configuring a Telephone Index 
To configure a telephone index, perform the following steps: 

1. In the FTS Setup window, select the telephone index and click Configure. 
The Index Options window appears. 
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Figure 15: Configuring a telephone index 

The Index Options window displays all supported telephone number, country code, and extension 
formats. 

2. Navigate through the tree and define telephone number formats to be recognized by FTS Server by 
selecting the appropriate check boxes. 

3. To accept the changes, click OK. 

Viewing Erroneous Documents 
The erroneous documents list displays documents from the FTS Server that could not be indexed. It is 
not possible to use the standard error handling mechanism, workflow routing rules, for these 
documents because the FTS Server does not obtain work from the workflow, but operates in the 
background. 

To view the erroneous documents list, perform the following steps: 

1. In the FTS Maintenance Utility window, click Erroneous Documents.  

 
The Erroneous documents window appears. 
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Figure 16: Erroneous documents window 

The window lists all documents that failed indexing because they are corrupted or because other 
errors occurred. 

The erroneous documents list does not display FTS Preprocessor errors. 

The following table describes the columns displayed in the Erroneous documents window: 

Erroneous documents window 
Column Description 

Batch Document batch number. 

Parcel Document parcel number. 

Document Document number assigned to the record. 

Page(s) Number of pages in the document. 

Index Name Index name. 

Description Index description. 

Error Code Error code that caused the indexing failure. There are two error code types:  
• If the file cannot be loaded, usually the file is missing. 
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Erroneous documents window 
Column Description 

• The memory is low. 
Additional 
Info 

Brief description of why the document failed indexing. 

2. To update the list, click Refresh.  
3. Select documents you want to re-index, or use Select All.  
4. To resend the documents to the FTS Server, click Reindex Selected Documents. 

FTS Maintenance Utility Menus and Buttons 
This section describes the buttons and menu commands in the following windows: 

• FTS Maintenance Window 

• Erroneous Documents Window 

FTS Maintenance Window 
The following table describes the FTS Maintenance window buttons and menu functions: 
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FTS Maintenance window buttons and menu functions 
Button Shortcut key Menu 

command 
Description 

 

 File > Setup Setup 
Opens the FTS Setup window used to set indexes. 

 

 File > 
Stopwords 

Stopword Maintenance 
Opens the Stopword Maintenance window used to 
maintain the list of stopwords. 

 

 File > 
Erroneous 
Documents 

Erroneous Documents 
Opens the Erroneous Documents window and 
displays the list of documents that could not be 
indexed. 

 

F1 Help > Context 
Help 

Context Help 
Opens the help section. 

 CTRL+F1 Help > Help 
Topics 

Help Topics 
Displays a list of available help topics. 

  Help > About 
Exigen 
Workflow 

About Exigen Workflow 
Displays copyright and release information regarding 
Exigen Workflow. 

 

F12 File > Exit Exit Application 
Closes the FTS Maintenance window.  

 

Erroneous Documents Window 
The following table describes the Erroneous Documents window buttons and menu functions: 
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Erroneous Documents window buttons and menu functions 
Button Shortcut key Description 

 

F5 Refresh List 
Updates the list of erroneous documents.  

 

 Select All Documents 
Selects all documents in the list. 

 

 Reindex Selected Documents 
Sends selected documents for reindexing. 

 

F1 Help 
Opens the help section for this application. 

 

F12 Exit 
Closes the Erroneous Documents window. 
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Chapter 6: Orphan Utility 
This section explains how to search for image files with no corresponding database records. The 
following topics are described in this section: 

• Overview 

• Using the Orphan Utility Window 

• Orphan Utility Menus and Buttons 

Overview 
Orphan Utility is used to locate discrepancies between the image directories and the database. 
Orphan Utility lists DMS image files that do not have matching database records in the document table. 
Only valid DMS image files having a file name consisting of eight digits and the .DMS extension are 
displayed. These files can be routed to a specific queue where parcel records are generated for them 
and they can be reviewed and processed. 

Using the Orphan Utility Window 
To start Orphan Utility, in the Exigen Workflow Explorer window, select the Utilities folder and 
double-click Orphan Utility.  

 

The File Orphan Utility window appears. 
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Figure 17: File Orphan Utility window 

The Workflow Project list displays all projects registered in the database. The Workflow list displays 
all workflow applications assigned to the selected project. 

To use Orphan Utility, perform the following steps: 

1. In the Workflow Project list, select a project to check. 

2. In the Workflow list, select an application. 

3. To start the check, click Go. 
The Orphan Utility window appears. 

4. To cancel the check, click Exit. 
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Figure 18: Orphan Utility window 

The Orphan Utility window contains the following options and features: 

• Menu and button bars are described in Orphan Utility Menus and Buttons.  

• The Send To Node combo box displays all nodes in the selected workflow. 

• The selected project and workflow are displayed below the button bar. 

• The search path specifies the directory that is tested.  

• A table displays retrieved document attributes and process information. 

To check the image files in the selected project and workflow, perform the following steps: 

1. In the Send To Node combo box, select the node where you want to send the orphan files.  

2. To specify the directory to be checked for orphan files, click the browse button to the right of the 
Search Path field.  

3. Click Start. 
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The verification process begins. 

 

Figure 19: Orphan Utility window with processed data 

The following fields are displayed while the process is running: 

Orphan Utility, processed data fields  
Field Description 

Processed DOC 
RSN 

Last document number processed. 

Records Verified Total number of verified records. 

Detected 
Problems 

Number of orphaned files. 

File Name Name of file being processed. 

Total to Verify Number of files in the search path directory. 
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When the utility verifies the database records for the image files in the search path, image files without 
corresponding database records are displayed in the results table. Only valid DMS image files having a 
file name consisting of eight digits and the .DMS extension are displayed. The following are examples 
of valid DMS image file names: 

• 00030006.DMS 

• 00000127.DMS 

The results table displays the following information: 

Results table 
Column name Description 

Document RSN Document number. 

User ID User ID of the person who scanned the document. 

Creation Date Document creation date. 

Pages Number of pages in the document. 

Status Document status. The status of all image files located by this utility is ORP. 

Because the image files do not have database records associated with them, you must use the Send 
function to send them to a specific node. Once the Send function is started, parcel and document 
records are created in the database for these image files. This allows the recipient to view and route 
them accordingly.  

To work with Orphan Utility, perform the following steps: 

1. To send documents, click Send.  
2. To send all documents, select Select All and click Send.  

The orphan records remain in the window. When the send process is complete, the status changes 
to Send.  

3. To stop the process at any time during the send process, click Stop. 
4. To view an image file, highlight the records and click Display.  
5. To produce a report listing all records in the results window, click Report.  

The Centura Report Builder application opens. 
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Figure 20: CENTURA Report Builder window 

6. To reset the Orphan Utility window, click Clear. 



Administrator's Guide, Part 3: Utilities Chapter 6: Orphan Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 48 of 145 

Orphan Utility Menus and Buttons 
The following table describes the Orphan Utility window button and menu functions: 

Orphan Utility window buttons and menu functions 
Button Shortcut key Menu 

command 
Description 

 

 Orphan > Start Start 
Starts the Orphan Utility process. 

 

 Orphan > Stop Stop  
Stops the Orphan Utility process. 

 

CTRL+S Document > 
Send 

Send Document 
Sends all selected documents to the assigned node. 

 

CTRL+D Document > 
Display 

Display Document 
Displays the selected image file in the Image Viewer on 
the right side of the window. 

 

CTRL+R Document > 
Report 

Report 
Saves the list of orphan documents in a report that can 
be displayed and printed via the Centura Report Builder.

 

 Orphan > Clear Clear  
Clears all entries in the results portion of the window. 

 

F1 Help > Context 
Help 

Context Help 
Opens the help section. 

 CTRL+F1 Help > Help 
Topics 

Help Topics 
Displays a list of available help topics. 

  Help > About 
Exigen 
Workflow 

About Exigen Workflow 
Displays copyright and release information regarding 
Exigen Workflow. 

 

F12 Document > 
Exit 

Exit 
Closes the Orphan Utility window. 
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Chapter 7: Stamp Management Utility 
This section explains how to create electronic stamps in Exigen Workflow. The following topics are 
described in this section: 

• Overview 

• Using the Stamp Management Window 

• Creating or Modifying Stamps 

• Stamp Management Utility Menus and Buttons 

Overview 
Exigen Workflow supports an electronic stamp tool. 

Stamp Management Utility is used to create and maintain electronic stamps to overlay onto 
documents. The following table describes methods for creating stamps: 

Stamp creation methods 
Name Description 

Scanning Document is scanned and an area to be used as a stamp is selected. 

Loading from 
existing file 

File in DMS or TIFF format is opened and the area to be used as a stamp is 
specified. 

Only monochrome images can be used to define stamps. 

Note: Exigen Workflow supports the most efficient type of compression for TIFF files, CCITT Group4 
compression. Using TIFF files that are compressed in a different way leads to undesirable results. 

After the electronic stamps are created, the administrator grants permission for the user to apply the 
stamps by selecting Administrator > System Setup > Stamps. The user can apply electronic stamps 
to documents by selecting Image Viewer > Stamp. For more information on Image Viewer, see the 
Exigen Workflow User's Guide, Chapter 11: Image Viewer. 

Using the Stamp Management Window 
To create or modify electronic stamps, perform the following steps: 

1. In the Exigen Workflow Explorer window, select the Utilities folder and double-click Stamp 
Management. 

 
The Stamp Management window appears. 
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Figure 21: Stamp Management Utility window 

The Stamp Management window contains the following information: 

• menu and button bars as described in Stamp Management Utility Menus and Buttons. 
• table containing data of the existing stamps in the system: 

 

Stamp Management, existing stamp data 
Column Description 

Stamp 
Description 

Names of existing stamps in the system. 

Created on Date the stamp was created. 

Created by User who created the stamp. 

Stamp Color Color to be used for the stamp. 

Resolution (DPI) Resolution with which the stamp was scanned. 

• Buttons at the lower left are used for the following tasks:  
• create 
• modify 
• delete  

• The selected stamp is displayed on the right.  
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• The Scan Engine field displays the scanning device used to create a stamp. 

2. To remove a stamp from the system, select it and click Delete Stamp . 

3. To modify an existing stamp, select the stamp and click Modify Stamp .  

4. To add a new stamp to the system, click New Stamp .  
The Image Viewer appears on the right and the Create/Modify Stamp window appears on the left. 

 

Figure 22: Create/Modify Stamp window 
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Creating or Modifying Stamps 
To create a stamp, perform the following steps: 

1. To set up the scanner, click Setup and Enhance. 
2. Click Scan-F3 or press F3. 
3. To create a stamp from an existing DMS file, click Load DMS.  
4. To create the stamp from a TIFF image file, click Load Document. 

Regardless of its origin, the image file appears in the Image Viewer. 

When you move the pointer over the image, it changes into the OCR tool:  

 
To use the Try to print from native application feature, a specialized printer driver that is used for 
conversion into TIFF format must be installed. 

The NED Image Printer installation is available in the install directory under the Exigen Workflow 
root directory. 

5. If the documents are one of the following file types, select the Try to convert using native 
application check box:  
• DOC 
• RTF 
• XLS 
• PDF 
Selecting this check box enables the native application such as Word for DOC and RTF and Excel 
for XLS to convert documents to DMS format. 

The Driver button is enabled.  

6. To open the Driver Setup window for selecting and configuring the print driver, click Driver.  
An appropriate printer driver must be installed, such as one of the following: 

• Informatik Image Driver  
• NED Image Printer  

NED Image Printer is a base driver. The NED Image Printer driver port name length cannot 
exceed five characters. 

Note:  NED Image printer has to be installed before printing Office and PDF files. 

7. To configure the print driver, click Properties to export appropriate types of images such as A4, 
monochrome, or color TIFF. 
If you are using an NED printer driver, observe the following restrictions:  

• Do not select a print quality of 100x100 dpi for color images. 
• Ensure sufficient free hard drive space is available when printing color documents, for example, 

up to 10 MB per page for a resolution of 200x200 dpi.  
• Ensure Excel files are printed only at a DPI resolution of 600x600. 
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8. To select the area to use for the stamp, position the pointer at the top-left corner of the area you 
want to use for the stamp, click and drag to the lower right, and release the mouse button.  
The selected area is displayed in the lower part of the Create/Modify Stamp window.  

9. In the Stamp Description field, enter the name of the stamp. 

10. In the Stamp Color list box, select the color for the stamp. 

11. To see how the stamp looks when applied, click Test.  
The stamp appears in the top-left corner of the image. 

12. To complete the stamp, click Apply or press F8.  
13. To create another stamp, click Next Stamp.  
14. To close the Create/Modify Stamp window, click Close - Esc. 

Stamp Management Utility Menus and Buttons 
The following table describes the Stamp Management Utility window button and menu functions: 
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Stamp Management Utility window buttons and menu functions 
Button Shortcut key Menu command Description 

 

 File > New 
Stamp 

New Stamp 
Opens the Create/Modify Stamp window to 
create a new stamp. 

 

 File > Modify 
Stamp 

Modify Stamp 
Opens the Create/Modify Stamp window to 
modify the selected stamp. 

 

 File > Delete 
Stamp 

Delete Stamp 
Deletes the selected stamp. 

  File > Delete All Delete All Stamps 
Deletes all stamps. 

  File > Optimize  Optimize Stamp Storage 
Removes all traces of deleted objects from the 
DMS file. 

  File > Recovery Recovery Stamp Storage 
Performs recovery operations. 
This option is used if your last session was 
interrupted, for example, your computer was 
rebooted without first closing the application. This 
operation removes changes made in that session 
while preserving information entered previously. 

  Scan > Select 
Scan Engine 

Select Scan Engine 
A scan device is selected from the list of available 
ones. 

 

F1 Help > Context 
Help 

Context Help 
Opens the help section. 

 CTRL+F1 Help > Help 
Topics 

Help Topics 
Displays a list of available help topics. 

  Help > About 
Exigen 
Workflow 

About Exigen Workflow 
Displays copyright and release information 
regarding Exigen Workflow. 

 

F12 File > Exit Exit 
Closes the Create/Modify Stamp window. 
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Chapter 8: Template Management Utility 
This section explains how to create Forms Overlay and Forms Optical Character Recognition 
templates. These templates are used to display and populate database information based on the types 
of documents being scanned into the system. This section also describes how to assign document 
templates to projects. 

The following topics are described in this section: 

• Overview 

• Using the Template Management Utility Window 

• Creating a Template 

• Defining OCR and Overlay Zones 

• Assigning a Document Template to a Project 

• Template Management Utility Menus and Buttons 

Overview 
Template Management Utility is used for the following tasks: 

• Creating templates for Forms Overlay processing. Forms Overlay defines zones on a template 
where data is placed. Data imported from a text or by other means into the database is overlaid 
onto an existing template when the Image Viewer is launched. To end users it appears as if the 
document they are viewing was originally scanned into the system. 

• Creating templates for Forms Optical Character Recognition (OCR) processing. Forms Optical 
Character Recognition, or Forms OCR, defines zones on a template where data is extracted. This 
data is used to populate database fields depending on the zone data and Forms OCR Server 
configuration. 

• Assigning document templates to projects. Document templates are draft documents that can be 
applied when a user processes a task using an external application. 

Using the Template Management Utility Window 
Template Management Utility is used to capture template files and define the zones to be overlaid or 
extracted. Templates can either be scanned in as new DMS files, or attached as existing DMS or other 
types of image files. 

The following topics are described in this section: 

• Opening Template Management Utility 

• Using the General Tab 

• Using the Detail Tab 
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Opening Template Management Utility 
To open Template Management Utility, in the Exigen Workflow Explorer window, select the Utilities 
folder and double-click Template Management Utility.  

 

The Template Management Utility window appears. 

 

Figure 23: Template Management Utility window with General tab 
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The Template Management Utility window contains the following tabs:  

• General 

• Detail 

• Where Used  

Only the General and Detail tabs apply to Forms OCR Processing. The Where Used tab is used to 
view the projects in which the selected template appears. 

Menu commands and buttons are described in Template Management Utility Menus and Buttons. 

Using the General Tab 
The General tab lists all form templates that are created in the database. The list can be modified. 

The list of form templates contains the following information:  

Template Management Utility window, General tab, list of form templates 
Column Description 

Form ID Internal identification number generated when the template was created. 

Form Name Name given to the template when it was created. The name can be up to 32 characters long 
and must clearly identify the form it is used for. 

Form Type Form type. They are either OCR or Overlay template. 

Created on Template creation date. 

Created by Person who created the template. 

Template File Path to the actual template DMS file. Each template file is named TEMPLATE.### with ### 
representing the Form ID with leading zeros to create a three character file extension. 

To use the General tab, perform the following steps: 

1. To modify an existing template, in the list, highlight it and click Modify.  
The Form Template Maintenance window appears. 

2. In the Form Template Maintenance window, modify template zones and their attributes. 

3. To remove the selected template from the system, click Delete.  
4. To create a new form template, click New.  

For information on creating a new template, see Creating a Template.  

5. To assign the Default Template Location, click Browse and select a location 

 .  

If the location is not configured, a corresponding message appears.  

6. To save the selected template path in the visi.ini file in the Exigen Workflow System directory, 
click Yes. 
All subsequent templates created are located in this directory. 
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7. Ensure that the template directory location is set in Administrator Utilities in the following location: 
Workflow Tools > Administrator > System Setup > Locations Setup 

8. To find a desired template in the form list, in the Form Name field, enter all or a portion of the form 
name and click Find.  
All forms that meet the search criteria are displayed. The Found field displays the total number of 
form records matching the search criteria.  

9. To display all forms, click Refresh.  
10. To change the sort order of the list, select the desired sort key from the Sort By list box.  

The default sort order is by Form ID value.  

11. To display a specific form and the zones assigned in the template, highlight the record and click 
Display. 

Using the Detail Tab 
To use the Detail tab, perform the following steps: 

1. To view zone details about a specific template, highlight the template and select the Detail tab.  
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Figure 24: Template Management Utility window with Detail tab 

The selected form name is displayed at the top of the window. The table displays the following data: 

Template Management Utility window, Detail tab 
Column Description 

Page Zone page number. 

Zone ID Zone internal identification number. 

Zone Name Zone name. 
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Template Management Utility window, Detail tab 
Column Description 

Zone Data 
Type 

Zone data type. 

 

2. To view the entire template and all zones, click Show All.  
All zones in the template are displayed.  

3. To view a specific zone, highlight the zone record in the table and click Display.  
The specified zone is displayed. 

Creating a Template 
The following topics are described in this section: 

• Creating a New Form Template 

• Scanning a New Form 

• Creating a New Form from the Existing File 

• Saving Zones to a File 

Creating a New Form Template 
To create a new form template, perform the following steps: 

1. Select the General tab. 

2. In the Template Management Utility window, click New .  
The Form Template Maintenance window appears with the Preparation tab displayed. 
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Figure 25: Form Template Maintenance window with Preparation tab 

The Preparation tab is used to scan in a new DMS file or retrieve an existing one that is used to create 
the new template. 

When the window is launched, a default template name is applied. The name consists of the word 
Template followed by the numeric form ID and cannot be changed until the image file is scanned or 
loaded. 
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Scanning a New Form 
To create a form template from a newly scanned image, perform the following steps: 

1. Click Select Engine and select the appropriate scan engine from the list.  

2. Click Setup.  
The available settings depend on which scan engine is selected.  

3. After you configure and save the scanner settings, in the Scan Config list box, select the necessary 
configuration from the predefined settings.  

4. To use the Try to print from native application feature, ensure a specialized printer driver that is 
used for conversion into TIFF format is installed. 
NED Image Printer installation is available in the install directory in the Exigen Workflow root 
directory.   

5. If your documents are one of the following file types, select the Try to print from native 
application check box: 
• DOC 
• RTF 
• XLS 
• PDF 
Selecting this check box enables the native application such as MS Word for DOC and RTF and 
MS Excel for XLS to convert documents to DMS format.  

The Driver button is enabled. 

6. To open the Driver Setup window for selecting and configuring the print driver, click Driver.  
An appropriate printer driver must be installed, such as one of the following: 

• Informatik Image Driver  
• NED Image Printer  

NED Image Printer is a base driver. The NED Image Printer driver port name cannot exceed 5 
characters. 

7. To configure the print driver, click Properties to export appropriate types of images such as A4, 
monochrome, or color TIFF. 
If you are using an NED printer driver, observe the following restrictions: 

• Do not select a print quality of 100x100 dpi for color images. 
• Ensure sufficient hard drive space is available when printing color documents, for example, up 

to 10 MB per page for a resolution of 200x200 dpi.  
• Ensure Excel files are printed only at a DPI resolution of 600x600. 

 
8. To perform additional scanning enhancements, click Enhance. 

Note: Setup and Enhance are enabled only if a scanner is connected to the system. Enhance features work 
only with a Kofax driver version and a scanner that supports the enhance functionality.  

The Scan Position list box is used to notify the system where the new page appears in the 
selected document.  

9. To place the new page at the end, in the list, select Append.  
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10. To place the new page before an existing page, scroll through the document until the existing page 
is displayed in the viewer and in the list, select Before. 

11. To place a page after an existing page, scroll through the document until the existing page is 
displayed and in the list, select After.  

12. To replace an existing page, scroll through the document until the existing page is displayed and in 
the list, select Replace. 

13. In the Scan From list box, select Feeder or Flat Bed, depending on the type of feeder you are 
using.  

14. To begin scanning, click Scan-F3 or press F3.  
15. When all pages are scanned, in the Form Name field, change the form name.  

The name must reflect the purpose of the form to facilitate selection of the template during the 
Forms OCR or ERM Server configuration process.  

16. To copy a page within the scanned form, display the page in the Image Viewer and click Copy 
Page.  
The page is pasted into the form at the position specified in the Scan Position field. 

17. To remove a page, display the page and click Del Page. 

Before you create zones for the template, it is a good idea to clean the scanned document by removing 
scanning defects. Cleaning the document is done by using filters and other enhancement tools to 
ensure zones are clearly defined.  

To clean the document, perform the following steps:  

1. To use the Filter service, in the Image Viewer, select the Filter check box.  
This check box is located to the right of the Magnify check box.  

2. Open the Edit Tools window and click Filters.  

For information on Image Viewer, see the Exigen Workflow User's Guide, Chapter 11: Image Viewer. 

Creating a New Form from the Existing File 
To create a form template from an existing file, perform the following steps:  

1. Click Attach. 

Note: Only VCET Engine supported file types can be used. 

The Image - Attach File window appears. 
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2. Locate the desired file and click Open.  

The selected file appears in the Image Viewer.  

Note: As a result of VCET conversion, DOC files appear black and white. 

Saving Zones to a File 
To save zones set up on a template to a file, perform the following steps: 

1. Click Save Page Zones.  
The Save Page Zone Template window appears. It allows a file with the extension .pzn to be 
saved in the selected directory.  

2. To assign saved zones to a new template, click Load Page Zones.  
3. Select the zone file you want to apply to the new template and click Open. 

Defining OCR and Overlay Zones 
To enable the Form Overlay Definition or Form OCR Definition tab, select one of the following 
options from the Form Type list box: 

• OVERLAY  

• FORM OCR   

The following topics are described in this section: 
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• Form Overlay Definition 

• Defining Form OCR 

Form Overlay Definition 
The Form Overlay Definition tab is used to configure the location and appearance of the database 
information that is overlaid onto the form. 

The Form Overlay Definition window appears with the template displayed on the right side of the 
window in the Image Viewer. 
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Figure 26: Form Template Maintenance window with Form Overlay Definition tab 

This section describes how to add a zone to a template using the following procedures: 

• Defining a Zone 

• Modifying and Deleting a Zone 

• Testing and Saving a Zone 
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Defining a Zone 

To define a zone, proceed as follows: 

1. Click New.  
The cursor changes to the Zone tool.  

2. Position the new cursor at the top left corner of the area being defined as the zone.  

3. Click and drag to the lower right corner of the area.  
A box appears while the cursor is dragged. 

4. When the zone is completely outlined, release the mouse button. 
The Zone ID is generated when a new zone is added to the template. 

Modifying and Deleting a Zone 

To modify or delete a zone, proceed as follows: 

1. To modify an existing zone, in the Zone ID list box, select the appropriate zone and click Modify. 
2. To delete an existing zone, in the Zone ID list box, select the appropriate zone and click Delete. 
3. In the Zone Name field, enter a descriptive title for the current zone. 

This name is used during the ERM Server setup to define the database fields used to populate this 
zone.  

4. To specify how the data is displayed when overlaid, make appropriate selections in the following list 
boxes: 
• Size 
• Font Name 
• Weight 
Different fonts appear in different sizes. 

5. Before saving a template, test all fonts. 

6. In the Rotate list box, select the angle of rotation for the overlaid text.  
The following options are available: 

• 0 
• 90 
• 180 
• 270 
The Text Color list box is used to define the color in which the overlaid text appears.  

Unless you are using a color printer, the text is printed in black. 

The Justify list box is used to specify the placement of a zone around selected text. The Justify list 
box setting must be specified before the zone is drawn. 

7. To specify the placement of a zone around selected text, select one of the following options in the 
Justify list box: 
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Justify list box 
Option Description 

None Zone remains at its original position. 

Left Justify Zone is positioned so that the selected text is justified left. 

Right Justify Zone is positioned so that the selected text is justified right. 

By Example Zone is resized to match the selected text exactly. 

8. To assign additional formatting to alter the overlaid text appearance, select any of the following 
formatting options: 
Additional formatting options 
Check box Description 

Italic Displays the text in italics. 

Underline Underlines the text. 

Border Creates a frame around the text. 

Opaque Overlays any background information within the zone. 

9. To move the zone in the desired direction, click the following buttons:  
• Up 
• Left 
• Right 
• Down  

10. To increase or decrease zone height, click Size + and Size–.  
11. To increase or decrease zone width, click >Size< and <Size>. 

The Zone Coordinates values display the left, right, top, and bottom coordinates in pixels of the 
zone.  

The zone length, number of rows, and height are displayed. This information is generated when the 
zone is set up, and can be changed.  

12. To update the zone coordinates, click Set. 

Testing and Saving a Zone 

To test and save a zone, proceed as follows: 

1. To use the test area to test the settings for the zone, enter a sample of the database information in 
the test area and click Test.  
The text appears in the Image Viewer in the current zone. You can verify that the proper font size, 
name, and weight are used as well as any additional attributes you assigned.  

2. To save the settings for a zone, click Save.  
3. When all zones are set up, to save all changes in the template, click Apply. 
4. To display all zones in the current template, click Show.  
5. To cancel the current changes, click Undo. 
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Defining Form OCR 
The Form OCR Definition tab is also used to assign zones to a template. Rather than overlaying data 
from the database, the text is later extracted from the form and used to populate specified database 
fields. 

The Form OCR Definition window displays the template on the right side of the window in the Image 
Viewer. 

 

Figure 27: Form Template Maintenance window with Form OCR Definition 
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When creating a form template, it is necessary to create a signature zone. A signature zone is used in 
the Form OCR Server setup to identify the incoming form. This zone must be defined with the ID 
number 1 and the zone name signature. For more information on Form OCR Server, see the Exigen 
Workflow Administrator's Guide, Part 2: Business Component Reference, Chapter 5: Form OCR 
Server. 

This section describes how to add a signature zone to a template using the following procedures: 

• Defining a Signature Zone 

• Modifying or Deleting a Signature Zone 

Defining a Signature Zone 

To define a signature zone, proceed as follows: 

1. Click New. 
The cursor changes to the Zone tool. 

2. Position the new cursor at the top left corner of the area you are defining as the zone.  

3. Click and drag to the lower right corner of the area.  
A box appears while the cursor is dragged. 

4. Once the zone is completely outlined, release the mouse button. 

Note: As scaling is a complex process, it is recommended that the zone borders on the template be larger 
than the actual zone. 

When creating zones for Form OCR Processing, it is important to allow for deskewing and 
differences in potential print sizes for the incoming forms. Consider these factors when creating 
each zone and allow space on all sides to ensure that the zone is captured properly each time.  

The Zone ID is generated by the system when a new zone is added to the template.  

Modifying or Deleting a Signature Zone 

To modify or delete a signature zone, proceed as follows: 

1. In the zone list, select a zone ID and click the appropriate button. 

2. To name the zone, in the Zone Name field, enter a descriptive title.  
This name is used during OCR server setup to define the database fields that are populated by the 
extracted data. 

3. In the Mask field, enter the mask for the anticipated value for the zone. 
It is recommended that a generic mask is used rather than specific characters for all zones except 
the signature zone. If the signature zone is a specific word, such as INVOICE for invoice forms, use 
the exact value to ensure a proper match. 

The following characters are used to create generic masks: 
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Generic mask characters 
Symbol Meaning 
X or x Any character in the case entered. 
! Any character. 
A or a Alpha characters in the case entered. 
A Alpha characters, uppercase. 
9 Digits 0 to 9. 
N or n Alphanumeric characters in the case 

entered. 
N Alphanumeric characters, uppercase. 
[x] Check box. 
!!!! !!! Bar code. 

The Justify list box is used to specify the placement of a zone around selected text. The Justify list 
box setting must be specified before the zone is drawn. 

4. To specify the placement of a zone around selected text, in the Justify list box, select one of the 
following options: 
Justify list box options 
Option Description 

None Zone remains at its original position. 

Left Justify Zone is positioned so that the selected text is justified left. 

Right Justify Zone is positioned so that the selected text is justified right. 

By Example Zone is resized to match the selected text exactly. 

5. To move the current zone, click the following buttons: 
• Up 
• Left 
• Right 
• Down  

6. To increase or decrease zone height, click Size + and Size –. 
7. To increase or decrease zone width, click >Size< and <Size>. 
8. To check whether the line removal settings are correct, click Test.  

The zone text appears in the Test window with the lines removed according to the settings.  

The Zone Coordinates values display the left, right, top, and bottom coordinates in pixels of the 
zone. The zone length, number of rows, and height are also displayed. This information is 
generated when the zone is set up and can be changed. 

Note: Test is disabled if Image Enhancement Engine is not installed. 

9. To save the zone coordinates, click Set.  
10. To remove scanning defects from the zone area, in the Line Removal Detection section, enter 

appropriate values as described in the following table:  
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Line Removal Detection section 
Name Description 

Min. Horizontal (Pix) Minimum size, in pixels, of horizontal lines to be deleted. This value must be large 
enough to ensure that horizontal lines such as the horizontal portions of the letter T 
are not removed. 

Min. Vertical (Pix) Minimum size, in pixels, of vertical lines to be deleted. This value must be large 
enough to ensure that vertical lines such as the vertical portions of the letter H are 
not removed. 

The cleaning is applied just before Forms OCR Processing to achieve an accurate result. Changes 
are not saved in the document. 

11. If the selected mask is a check box, enter values as follows: 
• In the Min. Horizontal (Pix) and Min. Vertical (Pix) fields, enter 30. 
• Use the Erase edit tool to clear the area defined as the zone. Ensure the area defined as the 

zone is blank. 
12. To apply permanent horizontal and vertical line removal within each zone created, use the 

Highlight edit tool to highlight the line to be removed.  

 
13. Click Modify edit tool and double-click the highlighted area.  

 
The Object Settings window appears. 

 

Figure 28: Object Settings window 

The Location and Size section displays the coordinates for the line.  

14. To obtain the value for the Horiz. Line Removal setting, subtract the value in the Right field from 
the value in the Left field.  
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15. To obtain the value for the Vert. Line Removal setting, subtract the value in the Bottom field from 
the value in the Top field.  

16. To perform line removal for the zone, enter these values in the appropriate fields. 

17. To save settings for a zone, click Save.  
18. When all zones are set up, to save all the changes made in the template, click Apply. 
19. To display all zones existing in the current template, click Show.  
20. To cancel the current changes, click Undo. 

Assigning a Document Template to a Project 
Document templates are draft documents created in an external application such as Word or Excel. 
Document templates are applied when a user processes a task using an external application. 

Note: This feature is not available in standard Exigen Workflow client/server and Web applications. It is 
supported by programmable extensions only, and is available via application programming interfaces 
(APIs). For information on how to acquire this feature, contact Exigen Support Services. 

For more information on setting up document templates for tasks, see the Exigen Workflow 
Administrator's Guide, Part 1: Design and Configuration, Chapter 4: Setting Up Exigen Workflow, 
Setting Up Document Templates for Tasks. 

Template Management Utility is used to assign document templates to a project. 

To assign a document template to a project, proceed as follows: 

1. Ensure that the document template is saved on the computer where Exigen Workflow is installed. 

2. Open Template Management Utility as described in Opening Template Management Utility. 
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Figure 29: Opening Template Management Utility 

3. In the Project list box, select the project. 

4. Click New . 
The Form Template Maintenance window appears with most controls disabled. This window is 
used to assign document templates to projects. This window appears only when a project is 
selected in the Template Management Utility window. If a project is selected, the Form Overlay 
Definition and Form OCR Definition tabs are disabled. 
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Figure 30: Assigning a document template to a project 

5. In the Form Name box, enter a name for the template, for example, INVOICE. 

6. To select the document template, click Attach. 
The Select Template window appears. 

7. In the Files of Type box, select the task, for example, Pre_Inv (*.doc). 
A task can be selected only if tasks are defined for the project. 
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8. Select the template file. 

9. Click Open. 
10. To view the template, click Show. 
11. To copy the template to the default template location, click Apply. 

If a file with the same name exists in the default template directory, an error message appears. 

If file with the same name does not exist in the default template directory, a confirmation window 
appears. 

12. To save the template, click Yes. 
13. To close the Form Template Maintenance window, click Close. 

The Template Management Utility window appears with the new document template in the list. 

Template Management Utility Menus and Buttons 
This section describes Template Management Utility menus and buttons. 

The following topics are described in this section: 

• Form Manager Window 

• Form Template Maintenance Window  

Form Manager Window  
The following table describes the Form Manager window button and menu functions: 
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Form Manager window buttons and menu functions 
Button Menu command Shortcut key  Description 

 

File >  
New 

 New Form 
Opens the Form Template Maintenance window 
to create a new form template. 

 
 

File >  
Modify 

 Modify Form 
Opens the Form Template Maintenance window 
to modify the selected form template. 

 

File > 
Delete 

 Delete Form 
Deletes the selected form template from the 
system. 

 

File >  
Save 
Configuration 

 Save Configuration 
Saves the configuration of the Form Manager 
window. 

 File >  
Delete All 

 Delete All Forms 
Deletes all form templates listed from the system. 

 Storage > 
Optimize 
Template Storage 

 Optimize Template Storage 
Compresses all template files to optimize the 
storage space. 

 Storage >  
Recover Template 
Storage 

 Recover Template Storage 
Recovers any template files that cannot be 
opened due to invalid closing or shutdown 
procedures run the last time the template was 
accessed.  

 Scan > Select 
Scan Engine 

 Select Scan Engine 
Opens a dialog box to select the scanning device 
to be used. 

 

Help > Context 
Help 

F1 Help 
Opens the help section. 

 Help > Help 
Topics 

CTRL+F1 Help Topics 
Displays a list of available help topics. 

 Help > About 
Exigen Workflow 

 About Exigen Workflow 
Displays copyright and release information 
regarding Exigen Workflow. 

 

File >  
Exit 

 Exit 
Closes the Form Manager window.  

 

  Find Specific Form 
Queries the list for form names matching the 
search criteria entered in the field of the same 
name. 
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  Refresh  

Refreshes the form list. 

 

  Display Template 
Displays the selected template in the Image 
Viewer on the right side of the window.  

Form Template Maintenance Window 
This section describes Form Template Maintenance window menus and buttons.  

The following topics are described in this section: 

• Preparation Tab 

• Form Overlay Definition Tab 

• Form OCR Definition Tab 

Preparation Tab 

The appearance of the Preparation tab differs depending on whether a project is selected in the 
Template Management Utility window: 

• If no project is selected, the Preparation tab displays the buttons required for creating form 
templates. 

• If a project is selected, the Preparation tab displays the buttons required to assign document 
templates to projects. 

The following topics are described in this section: 

• Preparation Tab for Form Templates 

• Preparation Tab for Document Templates 

Preparation Tab for Form Templates 

The following table describes the buttons in the Form Template Maintenance window Preparation tab 
when it is used to create form templates: 

Form Template Maintenance window, Preparation tab buttons for form template creation 
Button Description 

 

Scan 
Begins the scanning process.  
F3 is the shortcut for this button. 

 

Restart 
Deletes any scanned or loaded image associated with the current form template, 
allowing another image to be inserted. This feature works with the add and modify 
template functions. 
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Form Template Maintenance window, Preparation tab buttons for form template creation 
Button Description 

 

Attach Image 
Opens the Image-Attach File window to use existing DMS files to create templates. 

 

Copy Page 
Copies the page displayed either at the end or after the current page. 

 

Delete Page 
Deletes the page displayed. 

 

Save Page Zones 
Saves the zones assigned to a page in a file format.  

 

Load Page Zones 
Loads previously saved page zones onto new form templates.  

 
Select Engine 
Selects the engine to be used for scanning. 

Setup Setup 
Opens the Setup window to adjust the scanner settings.  

Enhance Enhance 
Opens the Enhance window to improve the image quality. 

Apply Apply 
Applies all changes made to the current form template. 

Undo Undo 
Reverses the last modification made. 

 
 

Driver 
Opens the Driver Setup window for selecting the needed driver.  

Help Help 
Opens help. 

Close Close 
Closes the Form Template Maintenance window without saving modifications in the 
current form template. 
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Preparation Tab for Document Templates 

The following table describes the buttons in the Form Template Maintenance window Preparation tab 
when it is used to assign document templates to a project: 

Form Template Maintenance window, Preparation tab buttons for document templates 
Button Description 

 

Show 
Displays a document template. 
This button is enabled only if a document template is selected. 

 

Attach 
Selects a document template. 

Apply Apply 
Copies the document template to the default template location. 

Help Help 
Opens help. 

Close Close 
Closes the Form Template Maintenance window. 

Form Overlay Definition Tab 

The following table describes the Form Template Maintenance window Form Overlay Definition tab 
button and menu functions: 

Form Overlay Definition tab buttons 
Button Description 

 

New 
Changes the mouse into the zone tool to add a new zone to the template. 

 

Modify 
Modifies the selected zone. 

 

Delete 
Deletes the selected zone. 

 

Undo 
Undoes the last change to the selected zone. 

 

Test 
Checks the size, location and other attributes of the selected zone before saving it. 

 

Save 
Saves all attributes for the current zone. 

 

Show All 
Displays all zones for the current template in the Image Viewer.  
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Form OCR Definition Tab 

The following table describes the Form Template Maintenance window Form OCR Definition tab 
button and menu functions: 

Form OCR Definition tab buttons 
Button Description 

 

New 
Changes the mouse into the Zone tool to add a new zone to the template. 

 

Modify 
Modifies the selected zone. 

 

Delete 
Deletes the selected zone. 

 

Undo 
Undoes the last change to the selected zone. 

 

Test 
Checks the size, location, and other attributes of the selected zone before saving it. 

 

Save 
Saves all attributes for the current zone. 

 

Show All 
Displays all zones for the current template in the Image Viewer.  
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Chapter 9: Transfer Utility 
This section explains how to use Transfer Utility.  

The following topics are described in this section: 

• Overview 

• Preparing to Transfer Documents 

• Transferring Documents 

• Transfer Utility Menus and Buttons 

Overview 
Transfer Utility is used to move image files from one physical location to another, for example, from a 
raid unit to a server. The process includes changing the database pointers for each document file 
moved. 

Preparing to Transfer Documents 
To prepare to transfer documents, perform the following steps: 

1. Review the documents to be transferred. 
The documents must be displayed. 

2. If you are planning to transfer data to optical storage, ensure that the optical configurations are 
specified. 
For more information on optical configurations, see the Exigen Workflow Administrator's Guide, Part 
1: Design and Configuration, Chapter 4: Setting Up Exigen Workflow. 

Transferring Documents 
The following topics are included in this section: 

• Initiating Document Transfer 

• Using the Transfer Utility Window 

• Identifying the Files to Be Transferred 

• Running Transfer Server 

Initiating Document Transfer 
To begin transferring documents, perform the following steps: 
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1. In the Exigen Workflow Explorer window, select the Utilities folder, and double-click Transfer 
Utility.  
The Workflow Transfer Utility window appears.  

2. In the Workflow Transfer Utility window, select the project and workflow. 
The Transfer window appears. For more information on transfers, see Using the Transfer Utility 
Window.  

3. Identify the documents to be transferred. 
This can be done using the Control file or by entering a direct database query, as described in 
Identifying the Files to Be Transferred.  

4. Select the Select Data from and Transfer Data to types.  

5. To start the transfer process, click Transfer. 

Using the Transfer Utility Window 
To use the Transfer Utility window, perform the following steps: 

1. To open Transfer Utility, in the Exigen Workflow Explorer window, select the Utilities folder and 
double-click Transfer Utility.  

 
The Workflow Transfer Utility window appears. 

 

Figure 31: Exigen Workflow Transfer Utility window 

2. In the Workflow Project field, select the project to transfer. 
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3. In the Workflow field, select the workflow to transfer. 

4. Click Go. 

The main Transfer Utility window appears. 

 

Figure 32: Transfer Utility window 
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For information on menus and buttons in the Transfer Utility window, see Transfer Utility Menus and 
Buttons. 

The Transfer Utility window contains the following fields and tables: 

Transfer Utility window 
Field Description 

Status and 
processing field 

Transfer Utility status and processing messages. 

Control File Path to the text file containing a field value for each document record. 

Number of 
Loaded Records 

Number of records that are selected for transfer. 

Currently 
Processed 

Number of records processed by the transfer. 

Search Level List box that displays the tables used for the search criteria. Searches can be performed in 
either the Folder or Document table. 

Search Field List box that displays all fields existing in the table, which is selected in the Search Level. 
The table and the field must be selected. 

Exigen 
Workflow 
Environment 

Exigen Workflow environment. The following options are available: 
• Archive for transferring documents that are already committed 
• Workflow for selecting documents in the active workflow 

Select Data from Storage medium of the documents to be transferred. The following options are available: 
• Optical 
• Server 
• Magnetic 
• Any Devices 
If a specific device is selected, only those documents residing on the device and meeting 
the search criteria are transferred. 

Transfer Data to Target storage medium. The following options are available: 
• Optical: Enables the Setup button and is used to perform Optical Volume Maintenance. 

For more information on how to configure optical volumes, see the Exigen Workflow 
Administrator's Guide, Part 1: Design and Configuration, Chapter 4: Setting Up Exigen 
Workflow. 

• Magnetic: Enables the Select Target Directory dialog box and is used to map the 
target location. 

• Merge: Combines all segments into a DMS file if you commit documents to Optical with 
the Partial option and have a DMS file presented in chunks with the extension DMS, 
001, 002.  

• Trash prompts if you want to save the documents to a specific directory. NO deletes the 
documents. YES opens the Select Trash Directory dialog box. The path to the trash 
directory must be selected, and OK must be clicked. 

Release 
Previous 
Location 

Instructs the system to move the files from the source medium to the target. If it is cleared, 
the files are copied. 

Create “Quick 
Tile” 

Creates thumbnail views of the documents. If thumbnail views do not exist, the option must 
be selected.  

Change Changes resolution of the image files during the transfer process. The following options are 
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Transfer Utility window 
Field Description 
Resolution available: 

• 100 
• 150 
• 200 DPI  
• None 
None is selected to retain the current DPI setting. 

Decreasing the resolution also decreases the image file size, and you cannot increase it 
later. The image quality is decreased permanently. 

5. Select the settings and click Start Transfer. 

Identifying the Files to Be Transferred 
You can identify the documents for performing a transfer in the following ways: 

• Using the Control File 

• Performing a Direct Query 

Using the Control File 

The control file is a flat file that contains a field value for each document record. This field value must 
correspond with the Search Level and Search Field selections. 

For example, if one of the folder fields in your project is Tax ID, or A_TAX_ID, and you want to transfer 
accounts with a specific tax ID, you can generate a flat file named taxid.txt that contains all tax IDs 
and can be used as a control file. 

To use the control file, perform the following steps: 

1. To register the control file, click Load Control File. 

 
2. To locate the path to the taxid.txt file, browse the directories.  

The taxid.txt file contains account numbers that are part of the folder table. 

3. In the Search level field, select Folder. 
4. In the Search field, select A_TAX_ID. 

Once the text file and search criteria are selected, the values listed in the control file are displayed 
in the table located in the middle-left of the window. Each record found is listed. 
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Figure 33: Transfer Utility window with control file 

Performing a Direct Query 

If you do not want to use a control file, you can perform a direct query on the database. To perform a 
direct query on the database, perform the following steps: 

1. Select the level and field to query.  
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2. Click Query.  
The Add/Modify Search Content window appears. 

 

Figure 34: Add/Modify Search Content 

3. To define the search criteria, make appropriate entries in the Search Content field. 
For the preceding example, if the folder table also contained a Tax ID, or A_TAX_ID, with a valid 
value, the following search string is used for folders: 

WHERE A_TAX_ID = ‘C7737’.  

4. To execute the query, click OK.  
The records located are displayed in the Search Content table in the middle-left of the window. 

5. To alter the records, click one of the following options:  
• Add 
• Modify 
• Delete 

6. If Add or Modify is selected, enter a new value or change the existing value, and click OK.  
7. To delete a record, select the record and click Delete. 
8. To highlight all records in the list, select the Select All Search Content check box.  

The table at the bottom displays the documents found for the records listed. These documents are 
transferred when you click Start Transfer as described in Running Transfer Server. 

9. Select individual records using standard Windows selection options. 

Running Transfer Server 
After you select the records to be transferred, and locate and configure the source and target medium 
locations, you can begin the transfer process. To run Transfer Server, perform the following steps:  

1. Click Start Transfer. 
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Figure 35: Run Transfer window 

2. To stop the transfer of documents at any time during the process, click Stop Process.  
3. If you transfer in error, to return the transferred files to the source, click Undo. 

When the transfer is completed, a message appears. 
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Figure 36: Transfer completed 

4. To change the control file or perform another database query for additional documents, click Delete 

the content . 
5. To confirm the choice, click Yes.  

Clicking Delete the content releases the selected control file and resets all query information.  
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6. Modify the query criteria as described in Performing a Direct Query. 
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Transfer Utility Menus and Buttons 
The following table describes the Transfer Utility window buttons and menu functions: 

Transfer Utility window buttons and menu functions 
Button Menu command Shortcut key  Description 

 

  Load Control File 
Loads the control file. 

 File > Refresh 
Document List 

 
F5 

Refresh Document List 
Refreshes the document list. 

 File > 
Check Folder 

 
CTRL+C 

Check Folder 
Checks search result documents to determine 
whether the selected folder exists. 
The command is enabled only if a search is 
conducted by FLD_RSN field in the DOCUMENT 
table. 

 File > Save 
Control File 

 
CTRL+F 

Save Control File 
Saves the control file. 

   Control List 
Opens the File dialog box to select the control list file 
to be used for the transfer.  

 

File > Delete 
Search Content 

 
CTRL+DEL 

Delete Search Content 
Clears the Search Content window and all related 
queries. 
Deletes the values in the Search Content column. 

 

File > Exit F12 Exit 
Closes the main Transfer Utility window. 

 

Transfer > 
Setup… 

 
 

Setup… 
Opens the Optical Disk Volumes Maintenance 
window, which is used to configure the optical drives 
for storage.  

 

Transfer > Start 
Transfer 

 
CTRL+T 

Start Transfer 
Starts document transfer. 

 

Transfer > Stop 
Transfer 

 
CTRL+S 

Stop Transfer 
Stops document transfer. 

 

  Undo Transfer 
Returns selected transferred documents to the 
original storage medium.  

 

View > Display 
Image 

 
CTRL+L 

Display 
Displays the selected document in the Image Viewer. 
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Transfer Utility window buttons and menu functions 
Button Menu command Shortcut key  Description 
 View > Show 

Original 
CTRL+O Show Original 

Displays the original version of the selected 
document. 

 View > Show 
Versions 

CTRL+V Show Versions 
Displays a list of all versions of the selected 
document. The current version is displayed at the 
bottom of the list. 

 

Help > Context 
Help 

F1 Context Help 
Opens the help section. 

 Help > Help 
Topics  

CTRL+F1 Help Topics 
Displays a list of available help topics. 

 Help > 
About Exigen 
Workflow 

 About Exigen Workflow 
Displays copyright and release information regarding 
Exigen Workflow. 
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Chapter 10: E-Capture Definition Utility 
This section describes how to use E-Capture Definition Utility. The following topics are described in this 
section: 

• Overview 

• Getting Started 

• Registering a Form 

• Modifying a Registered Form 

• Deleting a Registered Form 

• Mapping a Form 

• Testing Form Definitions 

• Exporting and Importing Templates 

Overview 
The definition utility module of Exigen E-Capture prepares form templates for recognition and data 
extraction. 

Tasks performed using E-Capture Definition Utility include the following: 

• registering individual form templates and assigning necessary attributes 

• mapping form templates, which includes selecting areas on a template of the electronic document 
that contain the information you want to recognize and extract 

• testing form maps for accuracy 

• specifying if and how E-Capture Server processes and verifies extracted information 

Getting Started  
Before using E-Capture Definition Utility, you must set up the E-Capture environment using Exigen E-
Capture Administrator. These procedures are described in the Exigen Workflow Administrator's Guide, 
Part 1: Design and Configuration. 

E-Capture Definition Utility requires Adobe Acrobat Reader for displaying PDF files. 

The following topics are described in this section: 

• Starting E-Capture Definition Utility 

• E-Capture Definition Utility Tools 

• Searching Registered Forms 
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Starting E-Capture Definition Utility 
To start E-Capture Definition Utility, perform the following steps: 

1. In the Exigen Workflow Explorer window, select Administration Tools > Utilities. 

2. Double-click the E-Capture Definition Utility icon . 
The E-Capture Definition Utility window appears. 

 

Figure 37: E-Capture Definition Utility window 

The records in the E-Capture Definition Utility window display the names of registered forms and a 
number of other attributes. These attributes are described in the following table: 
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E-Capture Definition Utility window attributes 
Attribute Description 
Form Name Form template name. The name must be descriptive so that the form is easy to 

recognize. Form names must be unique.  
Signature Unique code that distinguishes a form, usually located in its bottom or upper corner. 

The signature must only be on the first page of a form, and often includes the form 
number and edition date. However, not all forms have a signature, and some 
multipage forms have a signature on each page. The signature can be used as the 
form name if only one type of software was used to produce the form. 

Keywords List of words used to identify the first page of a form. At least one keyword selection is 
mandatory. Keywords are useful because sometimes the signature does not provide 
the specificity required to differentiate between forms, such as multipage forms that 
have signatures on each page, and forms that refer to a signature in the actual form 
content. Only keywords from the first page of the template form are selected. 

Category 
Name 

Category associated with the form. Categories are set up using E-Capture 
Administrator.  

Form Type Form type associated with the form. Form types are set up using E-Capture 
Administrator. 

Output Output group associated with the form. Output groups are set up using E-Capture 
Administrator.  

Company 
Name 

Company to which the form is assigned. Companies are set up using E-Capture 
Administrator.  

Vendor Name Software used to create the form. If you handle one form that is produced using 
different software types, each version of the form must be mapped. Vendors are set 
up using E-Capture Administrator. 

First Page If other forms are not in the file that contains the template, the number 1 appears by 
default. Otherwise, the number of the first page of the template form is selected within 
the file.   

Last Page If other forms are not in the file that contains the template, the total number of pages 
in the template appears. Otherwise, the number of the last page of the template form 
within the file is selected. 

File Name Full file path of the source template file. 
Description Additional optional comments that help administer and maintain a form template. 
St. Top Numerical value of the top coordinate of the horizontal strip that contains the form’s 

signature. If the form does not have a signature, this number represents the top 
coordinate of a strip containing keywords. In this case, all keywords must be located 
within the strip specified here. The strip feature is useful in preventing recognition 
errors caused by signatures contained within the content of other forms. 

St. Bottom Numerical value of the bottom coordinate of the horizontal strip that contains the 
form’s signature. If the form does not have a signature, this number represents the 
bottom coordinate of a strip containing all keywords. 

Orientation Orientation of the form template: Landscape or Portrait. 
Multipage Ind Multipage indicator. This is described in Multipage Indicator. 

E-Capture Definition Utility Tools 
The following table describes the buttons and menu commands in the E-Capture Definition Utility 
window: 



Administrator's Guide, Part 3: Utilities Chapter 10: E-Capture Definition Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 97 of 145 

 

E-Capture Definition Utility window buttons and menu functions 
Button Menu command Shortcut key Description 

 

File > New F2 Adds a form. 

 

File > Open  F3 Opens an existing form for modification. 

 

File > Delete F5 Deletes a form. 

 

Form > Detail F6 Maps a form. 

 

Form > Test F7 Tests a form. 

 

File > Save 
Configuration 

 Saves the size and position of the current window for the 
next time when the window is opened. 

 

Help > Index F1 Opens help. 

 

File > Exit F12 Closes the application. 

 File > Save As F4 Renames an existing form. 

Searching Registered Forms 
A search for registered forms by full name or partial name can be performed using the E-Capture 
Definition Utility window. 

 
Figure 38: Searching for a form 

The following topics are described in this section: 

• Searching by Exact Name 

• Searching by Partial Name 



Administrator's Guide, Part 3: Utilities Chapter 10: E-Capture Definition Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 98 of 145 

Searching by Exact Name 

To search the list of registered forms by exact name, perform the following steps: 

1. In the Form Name field, enter the exact name.  

2. Click Search.  
If the form is found, its record appears in the table. If no match is found, the table does not show 
any records. 

3. To clear the search and return to the complete list of form records, click Reset. 

Searching by Partial Name 

To search the table of registered forms by partial name, perform the following steps: 

1. In the Form Name field, enter the partial name, replacing the unknown portion with the % symbol 

2. Click Search.  
Records of forms containing the character string you entered are displayed. If no matches are 
found, the table does not show any records. 

3. To clear the search and return to the complete list of form records, click Reset. 

Registering a Form 
The following topics are described in this section: 

• Opening the Add Form Window 

• Viewing the Form Text and Template Source File 

• Assigning Attributes 

Opening the Add Form Window 
To open the Add Form window to register a form, perform the following steps: 

1. In the E-Capture Definition Utility window, click Add. 

 
The Add Form window appears. 
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Figure 39: Add Form window 

2. To define form attributes, enter values in the following tabs: 
• General 
• Signature 
• Tables 

Viewing the Form Text and Template Source File 
E-Capture’s built-in text recognition capability reads the text of the following file types:  

• PDF 

• PCL 

The text of the source template file appears in the Document Text field. 
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The panel at the bottom of the Add Form window contains tools for navigating through both the 
document text and original template source file. 

 
Figure 40: Viewing document text and source template file 

Viewing the Form Text 

To view the form text, use either of the following methods: 

• In the Go To Page field, enter the number of the page and click Go To Page. 

• To view the pages of the form, use the scroll bars and standard arrow buttons. 

 
Figure 41: Labeled buttons of navigation panel 

Viewing the Source File 

To view the original form template’s source file, click Display Image. 

If the form template is a PDF file, the Adobe Acrobat Reader is launched. Otherwise, the Exigen 
Workflow Image Viewer is launched to display an image of a PCL file. 

Assigning Attributes 

The following topics are described in this section: 

• Assigning Form Attributes in the General Tab 

• Selecting Keywords and a Signature 

• Selecting Keywords 

• Modifying and Deleting Keywords 

• Multipage Indicator 

• Selecting a Signature 



Administrator's Guide, Part 3: Utilities Chapter 10: E-Capture Definition Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 101 of 145 

• Verifying Coordinates of the Selected Text 

• Modifying and Deleting a Signature 

• Rules for Selecting a Signature 

Assigning Form Attributes in the General Tab 

The General tab is used to perform the following actions: 

• specify general form attributes 

• define a strip border 

• view the form text and source template file 

 
Figure 42: General tab 
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The procedures that can be performed using the General tab are described in this section. 

To assign form attributes in the General tab, perform the following steps:  

1. In the Form Name field, enter a unique name for the form.  

2. To browse for a template file, click the browse button next to the Sample File field. 

 
The Open File window appears. 

 
Figure 43: Selecting template file 

3. To select the file type, in the Open File window, select a value in the Files of type list box 
You can only open files with the following extensions. 

• .pcl  
• .pdf 

4. Select the source template file and click Open.  
The file name appears in the Sample File field. 

5. In the Output list box, select the output group to which to assign the form. 

6. In the Category list box, select the category to which to assign the form. 

7. In the Company list box, select the company to which to assign the form. 

8. In the Form Vendor list box, select the software vendor of the form. 

9. In the Form Type list box, select the form type.  

10. In the Orientation list box, select Portrait or Landscape. 
11. In the Pages in Form panel, if you know the exact number of pages in the form, select the Fixed 

radio button. If you do not know the exact number of pages in the form, select Variable.  
12. In the Page Number panel, enter the number of the first and last pages shown on the form 

template.  
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Note: You cannot modify the Page Number panel later. 

13. To scan the full form page for keywords and a signature using E-Capture Server, in the Strip 
Border panel, leave Entire Page selected. To select a strip border, clear the Entire Page check 
box. 
The box is selected by default. 

In the St. Top and St. Bottom fields of the Strip Border panel, use the signature tab to determine 
these coordinates, and enter the number of the top and bottom coordinates of the strip that contains 
the signature or keywords of the form. 

Selecting Keywords and a Signature  

To select a signature and keywords for the form template, in the Signature tab of the Add Form 
window, enter values in the fields.  
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Figure 44: Signature tab 

The Form Name field displays the name you entered in the General tab. The text of the named form 
appears to the right in the Document Text area. 

Selecting Keywords 

Keywords are used to recognize the first page of a form. You can select any number of keywords or 
keyword phrases. Review the following list of rules for selecting keywords. 

• You must select at least one keyword. If the signature is sufficient to identify the form, use it as a 
keyword and select No in the Signature Exists panel. 
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• Keyword phrases must not contain commas. 

• You cannot select part of a word as a keyword. 

• Select all keywords from the first page of the form only. 

• A keyword phrase can contain any number of words, but no commas.  

• Each word inside a keyword phrase is used as a separate keyword. Word order and selection order 
are not relevant. 

• If the form does not have a signature, ensure that all keywords are located within the coordinates of 
the strip border you defined on the General tab. 

• The set of keywords and signature for each registered form of a given vendor must ensure correct 
recognition of the form. This means that the set of keywords and signature for any registered form 
must not be identical to or a subset of another set of keywords and signature for a form belonging to 
the same vendor. 

To select a keyword or keyword phrase, perform the following steps: 

1. In the Document Text area, highlight the keyword. 

 
Figure 45: Selecting keywords 

2. To save your selection, in the Keywords panel, click Set. 
The captured keyword or keyword phrase appears in the box. 
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Figure 46: Using Keyword panel to apply keyword selection 

Modifying and Deleting Keywords 

To prevent spelling errors, text cannot be typed into the Keywords box. Instead, you must delete and 
reselect the keyword or keyword phrase.  

To delete your selections, perform the following steps:  

1. In the Document Text area, highlight the keyword or keyword phrase. 

2. In the Keywords panel, click Delete. 
The selected word or phrase is removed from the Keywords field. If you select a word that appears 
within a keyword phrase, the entire phrase is removed. 

3. To delete all keywords, click Clear. 

Multipage Indicator 

A multipage indicator is text that E-Capture Server uses to differentiate between multipage forms. 
You can use the signature, for example, if it is listed on each page of the form. The most common 
multipage indicators are Page and of to indicate Page X of XX. 

If a MASTER or SLAVE form is assigned to the template, the multipage indicator feature cannot be 
used, and the Multipage Indicator field must be empty. 

To use this feature, in the Pages in Form panel, select the Variable radio button. 

Selecting a Multipage Indicator 

To select a multipage indicator, perform the following steps: 

1. In the Document Text area, highlight a multipage indicator from the second page of the form.  
Your selection must indicate that the form has multiple pages.  

2. In the Multipage Indicator panel, click Set.  
The selection appears in the field. 
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Figure 47: Selecting a multipage indicator for forms with more than one page 

3. To delete the selection, click Clear. 

Rules for Selecting a Multipage Indicator 

Review the following rules for selecting a multipage indicator: 

• A multipage indicator selection cannot contain commas. 

• The total length of the selection cannot exceed 20 characters. 

Selecting a Signature 

Signatures often use a standard and identifiable format. For example, signatures may contain the date 
and edition number of the form. If signatures on your forms share a standard, you can use the signature 
as a means of validation. You can prepare custom scripts to implement the validation. 

Selecting a signature is similar to selecting a keyword. To select a signature, perform the following 
steps: 

1. In the Signature Exists panel, select the correct option, as described in the following table: 
Signature Exists options 
Name Description 

Every Page Every Page is selected if the signature appears on each page of a multipage form. 

First Page 
Only 

First Page Only is selected if the signature appears on the first page of a form. 

No No is selected if the form does not have a signature. 

No is selected by default. 

 

Figure 48: Selecting the correct option in the Signature Exists panel 

2. In the Page Listing Exists panel, select Yes only if the following conditions apply: 
• The source template file is paginated.  
• A multipage indicator is selected.  
• The number of pages in the form varies, for instance, if you selected Variable in the Pages in 

Form panel in the General tab. 
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Figure 49: Selecting a pagination option 

3. If you select Fixed in the Pages in Form panel in the General tab, in the Pages Listing Exists 
panel, select No.  

4. In the Document Text area, highlight the signature. 

 

Figure 50: Highlighting the template file's signature 

5. In the Signature panel, click Set.  

 

 

Figure 51: Using the Signature panel to apply signature selection 

The captured signature appears in the Signature field. 
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Verifying Coordinates of the Selected Text 

To verify the coordinates of the selected text, in the Signature tab, click Select. 

The coordinates of the selected text appear in the Left, Bottom, Right, and Top fields. 

This information is used when the strip border is selected for the signature or keywords in the General 
tab. 

Modifying and Deleting a Signature 

To prevent spelling errors, text cannot be typed into the Signature field. To modify or delete a selected 
signature, perform the following steps: 

1. In the Signature panel, click Clear. 
The selected signature is removed. 

2. To select a new signature, follow the steps for selecting a signature as described in Selecting a 
Signature. 

Rules for Selecting a Signature 

Review the following list of rules for selecting a signature: 

• The signature cannot contain commas. 

• The total length of the signature cannot exceed 20 characters 

• The signature field can contain only one selection. 
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Modifying a Registered Form 

To modify the general attributes, signature, keywords, and virtual calculation tables of a registered 
form, perform the following steps: 

1. In the E-Capture Definition Utility window, select the form to modify. 

2. Double-click the form, or click Modify. 

 
The Edit Form window appears. 
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Figure 52: Modifying a registered form using the General tab 

3. To modify form attributes, use the General and Signature tabs as described in Registering a Form.  
In the General Tab, you can modify all attributes except the following: 

• form name 
• source file path 
• output group assigned to the form 
• numbers of the first and last pages of the form template 

4. To save the changes, click OK. 
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Deleting a Registered Form 
To delete a registered form, perform the following steps: 

1. In the Registered Form window, select the form you want to delete. 

2. Click Delete. 

 
A confirmation window appears. 

3. To delete the form, click Yes. 
4. To cancel your request, click No.  

Mapping a Form 
The following topics are described in this section: 

• Map Form Tool 

• Mapping a Field 

• Modifying a Mapped Field 

• Deleting a Mapped Field 

Map Form Tool 
The Map Form tool is used to select locations containing information you want to capture, and to 
specify how you want this information entered in an Exigen Workflow database. 

To map a form, perform the following steps: 

1. In the E-Capture Definition Utility window, select the form you want to map. 

2. In the toolbar, click Map Form.  

 
The Form Definition Details window appears. 
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Figure 53: Mapping form with Line(s) tab 

The Form Definition Details window displays the name of the form in the Form Name field. The 
Document Text area displays the text of the form template.  

3. To view the document text, use the navigation panel located under the Document Text area.  

4. To view the original template PDF or PCL source file, click Display Image. 
5. To add, modify, and delete mapped fields, use the Form Definition Details interface.  

These procedures are described in the following sections. 
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6. To save the form map, click Apply. 

Mapping a Field 
The following topics are described in this section: 

• Selecting an Output Field 

• Selecting Text for Capture 

• Additional Settings 

Selecting an Output Field 

E-Capture Administrator is used to define output fields.  

To select an output field, perform the following steps: 

1. In the Form Definition Details window, click Add. 

 
The Output Fields window appears. 

 

Figure 54: Selecting an output field 
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The Output Fields window displays all fields assigned to the output group named in the title bar. 
Each record also displays the E-Capture field type, workflow field type and workflow field name 
associated with the field. If a SLAVE template is used, the registered folder, subfolder, and 
document fields are not displayed. 

2. Select an output field. 
You can also search for an output field by exact name or partial name. 

3. To search for the field name, perform the following steps: 
1. In the Field Name field, enter the exact name or a character string, replacing the unknown 

portion of the name with %. 
2. Click Search.  

Records of fields containing the name or character string are displayed. If no matches are 
found, the table does not show any records. 

3. To clear the search and return to the complete list of output fields, click Reset. 
4. Click OK. 

The name of the field you selected appears in the Form Definition Detail window in the Output 
Field.  
The Form Status field displays the following message: 

Adding a new field. 

Selecting Text for Capture 

E-Capture Definition Utility is used to select lines and boxes of text for capture from the Document 
Text Area.  
To select individual words or a phrase contained in one line of text, use the Line(s) tab.  

If you select multiple lines of text using the Line(s) tab, the top leftmost and the bottom rightmost words 
define the text coordinates. This can lead to a conflict between the right and left coordinates in cases 
where the text area in the question is not completely filled. To resolve this problem, use the Box(es) tab 
to select the text. 

To select text using the Line(s) tab, perform the following steps: 

1. In the Form Definition Details window, select the Line(s) tab. 
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Figure 55: Selecting text with the Line(s) tab 

The selected output field appears in Output Field. 

2. In the Document Text area, highlight the text you want to assign to the selected field. 
The selection can be a single word, several words, or several rows of text, but cannot contain 
commas. 

3. Click Select.  
The text appears in the Selected Area text field of the Line(s) tab. The Field’s Page # field 
displays the page number on which the selected text is located. 

The numerical coordinates of the selected area appear in the Left, Bottom, Right, and Top fields. 

4. If necessary, to extend the selection area, change the numerical coordinates manually.  

5. To save your selection, click Apply.  
The field name appears in the Output Field Name table.  

6. To delete the selection, click Clear All.  
To select text using the Box(es) tab, perform the following steps: 

1. In the Form Definition Details window, select the Box(es) tab. 
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Figure 56: Selecting text with the Box(es) tab 

2. Highlight the word at the far left of the rectangle zone in the Document Text area. 
For example, to select the box, highlight TEST. 

3. To apply the selection, click Left.  
The selected word and its coordinate appear in the Contents and Coordinate panels. 

4. Highlight the word at the top of the rectangle zone, for example, TEST.  
5. To apply the selection, click Top. 
6. Highlight the word at the far right of the rectangle zone, for example, 23356.  
7. To apply the selection, click Right. 
8. Highlight the word at the bottom of the rectangle zone, for example, 23356. 
9. To apply the selection, click Bottom.  
10. To cancel your selection, click Clear Boxes.  

Additional Settings  

E-Capture Server processes and verifies the data in each mapped field according to default settings. 
The default procedures can be changed using the following tabs: 

• Properties 

• Validate 

Properties 
The Properties tab is used to modify default procedures regarding error messages and temporary data 
storage. 
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Figure 57: Selecting processing options with the Properties tab 

To use the Properties tab, perform the following steps: 

1. To send an error diagnosis to Exigen Workflow if the mapped field does not contain data using E-
Capture Server, select Mandatory. 
A custom script can be used to handle this problem. 

2. To place extracted data into the Temporary Storage table using E-Capture Server, select Place in 
Temporary Storage. 
While in the Temporary Storage table, the data is available to other applications. 

Validate  

The Validate tab is used to have E-Capture Server validate and transform the data contained in the 
field. 

Examples of simple transformations include changing case and date format. Custom scripts are used to 
handle these and all other validation and transformation requirements. 
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Figure 58: Selecting processing options with the Validate tab 

Selecting either box instructs E-Capture to execute custom scripts prepared to validate and transform 
data. If no script is used and the Transform option is selected, by default, E-Capture Server deletes 
dashes and blanks from the corresponding extracted text. 

By default, both boxes are cleared. 

E-Capture Administrator is used to register and assign scripts. 

Modifying a Mapped Field 
To modify a mapped field, perform the following steps: 

1. In the Form Definition Details window, in the list of mapped fields, select the field to modify.  

2. Click Modify. 

 
The name of the field you selected appears in Output Field.  
The Form Status field displays the following message: 

Modifying the Field. 

3. To select text and specify handling instructions, use the following tabs: 
• Line(s) 
• Box(es) 
• Properties 
• Validate 
For information on using these tabs, see Selecting Text for Capture and Additional Settings. 

4. To save the changes, click Apply. 



Administrator's Guide, Part 3: Utilities Chapter 10: E-Capture Definition Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 120 of 145 

Deleting a Mapped Field 
To delete a mapped field, perform the following steps: 

1. In the Form Definition Details window, in the list of mapped fields, select the field to delete.  

2. Click Delete. 

 
The field is removed from the list of mapped fields. 

Testing Form Definitions 
Testing a form definition verifies whether the fields you mapped captured the correct data. For example, 
testing the form definitions verifies if the selected keywords provide the required information, or if you 
overlooked information that must be mapped. 

To test a form definition, perform the following steps: 

1. In the E-Capture Definition Utility window, select the form you want to test. 

2. Click Test Form. 

 
The Verify Input window opens. 
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Figure 59: Testing form definition 

The Test File field displays the name and path of the form template. If a signature exists, the 
Signature field displays it. The Keywords field displays all selected keywords. 

3. To verify the named form against itself, click Verify.  
4. To verify the form against another form, perform the following steps: 

1. In the Verify Selected Form Against panel, select Other Form. 
2. To browse for an alternative file, click the browse button next to the Test File field. 

 
The Open File window appears. 
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Figure 60: Browsing for an alternative testing template 

3. Select a file and click Open. 
The path and name of the file appear in the Test File field. 

4. To test the form, click Verify.  
Information appears in the Verify Input window. 
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Figure 61: Sample test results 

The Verify Input window displays the following information: 

• form name 
• output group 
• number of the page on which keywords are located 
• names of each mapped field 
• extracted data 
• number of the page on which the field is located 

5. To view the selected form template, click Display. 
6. To return to the E-Capture Definition Utility window, click Close. 
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Exporting and Importing Templates 
E-Capture templates can be imported and exported. This makes it possible to use a template in another 
environment. 

An environment is defined by one or more of the following factors: 

• network 

• computer 

• Windows version 

• Exigen Workflow project 

A template can be imported into an environment that already has registered E-Capture templates. The 
import procedure checks the integrity of the existing templates and the imported templates.  

The import procedure checks E-Capture environment variables that are specified manually in the E-
Capture Administrator. The environment variables in the export environment are compared with those 
in the import environment. 

The following topics are included in this section: 

• Exporting Templates 

• Importing Templates 

Exporting Templates 
To export templates, proceed as follows: 

1. In the E-Capture Definition Utility window, select File > Export. 
The Export Templates Setup window appears. 
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Figure 62: Exporting template setup 

2. In the Project name list box, select the Exigen Workflow project containing the E-Capture 
templates to be exported. 
If only one E-Capture project is available, it is displayed and selected by default. 

3. In the Output name list box, select the output from which the templates are exported. 
For example, if the templates are assigned Invoice output, Invoice must be selected. 

All templates from the specified project and with the specified output are displayed in the 
Templates box. 

4. In the Templates box, select one or more templates to export. 

5. To export all templates, select All Templates. 
6. In the Text Editor section, specify the text editor used to edit the exported templates. 

The following text editor options are available: 

• Notepad 
• WordPad 
An existing text editor can be changed before exporting templates. 

7. To continue the export process, click Next. 
The Export Template Data window appears. 
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Figure 63: Exporting template data 

8. To select an existing path and file name for exporting data, next to the Export file path field, click 
the browse button. 

9. To specify a new file for exporting data, in the Export file path field, enter the path and file name. 
The file for exported data must have a .dat extension. If several templates are exported, all data is 
exported to a single .dat file. 

10. In the Note field, enter an optional note. 

11. To view the template data to be exported, click Read File. 
12. To start export, click Start Export. 

The template files are exported. 

13. To close the window, click Close. 

Importing Templates 
During the template import process, the following actions occur: 

• The Import Template Data window is used to import template-related data. 

• The user moves the templates to the new location. 

To import templates, proceed as follows: 
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1. In the E-Capture Definition Utility window, select File > Import. 
The Import Template Data window appears. 

 
Figure 64: Importing template data 

2. To select the path and file name from which template data is imported, click the browse button next 
to the Import file path field. 
The file must have the .dat extension. 

3. In the Target project name field, select the target project for template import. 

4. In the Target output field, select the destination output for the imported template. 

5. To select the directory for the templates, click the browse button next to the Template directory 
field. 
The directory is the location to which the user physically moves the templates. 

6. Move the templates to the selected directory. 

7. To view the import data, click Data. 
8. To view a description of possible problems that occurred during export, click Log File. 
9. To import information related to the templates, click Start Import. 
10. To close the window, click Close.  

The templates are imported. 
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Chapter 11: Publisher Packager Utility 
This section describes the Exigen Publisher system and explains how to use its components. The 
following topics are described in this section: 

• Exigen Publisher System Overview 

• Using Exigen Publisher Packager 

Exigen Publisher System Overview 
Exigen Publisher is a subsystem of Exigen Workflow used to create a collection of documents that is 
viewable remotely without being connected to the Exigen Workflow system database. Exigen Publisher 
allows you to gather documents from the Exigen Workflow database into one data collection and to 
copy them to a CD where they can be viewed from a machine that is not connected to Exigen 
Workflow. 

Exigen Publisher consists of the following components: 

• Exigen Publisher Collector 

• Exigen Publisher Packager 

• Exigen Publisher Cabinet 

The following diagram shows how the components in the system work together. 

 
Figure 65: Process of data publishing with Exigen Publisher 
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Exigen Publisher Collector  
Exigen Publisher Collector assembles documents from an Exigen Workflow project into one 
collection. Each data collection consists of image files, folders, subfolders, and document records 
collected within the existing Exigen Workflow database. Exigen Publisher Collector is run from the 
Exigen Workflow Retrieve object.  

Exigen Publisher Packager 
After a collection of folder, subfolder, and document records and images is created, the Exigen 
Publisher Packager application is run to package the data collection together with the Exigen Workflow 
system files into one directory, which can be written onto a CD. The CD also includes Exigen Publisher 
Cabinet. 

Exigen Publisher Cabinet 
Exigen Publisher Cabinet is used to view the data collection that was packaged onto the CD without 
being connected to the Exigen Workflow system. 

Exigen Publisher components must be installed. If Exigen Publisher is not installed, perform the 
following steps: 

1. Insert the Exigen Workflow installation CD and run setup.exe. 

2. In the Exigen Workflow Setup window, select Upgrade and Modify.  
3. In the Select Components window, under Workflow Optional Components, select Publisher. 

Using Exigen Publisher Packager 
This section describes how to use the Exigen Publisher Packager. The following topics are described in 
this section: 

• Overview 

• Preliminaries for Packaging 

• Packaging Steps 

• CD Contents 

Overview 
Exigen Publisher Packager is used during the second stage in the file distribution process of Exigen 
Workflow Publisher. The following actions occur in this stage: 

1. The collection of files to be exported is defined. 

2. The collection is packaged and copied to a CD.  

The packaged data consists of the following contents: 
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• folder 

• subfolder 

• document indexing data 

• corresponding image files 

• Exigen Publisher Cabinet application 

Exigen E-Forms documents cannot be viewed in Exigen Publisher Cabinet. 

Preliminaries for Packaging 
Before running Exigen Publisher Packager, create a collection of document records and images using 
Exigen Publisher Collector. For more information about Exigen Publisher Collector, see the Exigen 
Workflow User’s Guide, Chapter 10: Exigen Publisher Collector. 

Packaging Steps  
To open the Exigen Publisher Packager utility, in Exigen Workflow Explorer, in the Utilities folder, 
double-click Publisher Packager.  

 

Exigen Publisher Packager consists of the following steps: 

• Step 1. Creating a CD Export Directory 

• Step 2. Creating a Copy Directory 

• Step 3. Finishing the Export Process 

Step 1. Creating a CD Export Directory 

When Exigen Publisher Packager is launched, the Create CD Export Directory: Step 1 of 3 window 
appears. 
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Figure 66: Creating CD Export Directory: Step 1 of 3 

The CD Export Directory window contains the following fields: 

Create CD Export Directory window fields 
Field Description 
Export Directory Destination directory where the data is published before it is copied onto a CD. The 

collection is saved in a new directory with a unique name, which includes the packaging 
date and time. 

Disk Capacity and 
Available Space 

Fields that display the disk capacity and available space according to the specified 
destination. 

Available 
collections 

Field that displays the Exigen Workflow projects with collections available for copying. 

Selected 
collections 

Field that displays the collections selected for copying onto the CD. 

To work with collections, perform the following steps: 

1. To add collections to the directory, select the collections you want to copy onto the CD and click 
Add.  
The selected collections are disabled in the Available collections list. 

2. To remove a collection from the Selected collections list, click Remove. 
3. To merge several collections into one, select them in the Selected collections list and click Merge.  

A new window appears, prompting you to enter a name for the merged collection. 
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4. To find a collection, click Filter.  
The Filter window appears. 

 

Figure 67: Filter window 

In this window, you can specify a collection or multiple collections that appear in the Available 
collections field. 

5. To display a particular collection, enter the collection’s name in the Name field and click Set. 

Note: Use the “%” symbol in the Name field to represent one symbol or several symbols in the name of 
collections to be displayed. The “%” symbol is used to display a range of collections with a similar name 
pattern. 

6. To display collections of a particular user, in the User dropdown list, select the user and click Set. 
The Name and User fields can be used simultaneously. 

7. To empty both fields, click Clear. 
8. To exit the Filter window without filtering, click Close. 
9. When all required collections are in the Selected list, click Next. 
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Step 2. Creating a Copy Directory 

The Create Copy Directory: Step 2 of 3 window appears. 

 

Figure 68: Creating Copy Directory: Step 2 of 3 

The following check boxes are used to set conditions for the packaging process: 

Creating Copy Directory, Step 2, options 
Option Description 

PDF Exigen Publisher Cabinet User’s Guide in PDF format is copied onto the CD. 

HTML Exigen Publisher Cabinet User’s Guide in HTML format is copied onto the CD. 

Display messages 
about invalid files 

Error messages that occur while processing the files are displayed. 

Remove overlays Image overlay documents are not packaged in the repository. 

To set conditions for the packaging process, perform the following steps: 

1. In the Create Copy Directory window, select the appropriate options. 

2. In the Password field, enter the password that is used later when opening Exigen Publisher 
Cabinet. 
The Current Info field displays information about the current status, for example, a warning that the 
selected directory is not empty. 

3. When all the fields in this step are complete, to begin copying the packaged data, click Next.  
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The application starts packaging the files and displays the current operation in the Current Info 
window. 

If the Display messages about invalid files check box is selected in the Setup window, a 
message window is displayed when a problem occurs. 

 

Figure 69: Processing Files error message window 

The full name of the missing file is displayed in the Cannot locate the following file field.  

The Processing Files window also displays the Folder RSN and Document RSN. These are 
internal numbers assigned to each folder, document, batch, parcel record, and other records in the 
Exigen Workflow database. 

4. If the Processing Files window appears, in the Would You Like To section, select either of the 
following options: 
• To end the search and continue the copy process, Skip file and continue.  
• To end the copy process, Stop processing. 

5. When the packaging process is complete, to proceed to the third step, click Next. 

Step 3. Finishing the Export Process 

During the final step, it is possible to make manual changes to the copy directory that was created in 
step 2. 

As the packaged data is created, the Export Finish: Step 3 of 3 window appears. 
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Figure 70: Export Finish: Step 3 of 3 

The Total CD Volume field indicates the number of megabytes that are used on the CD for the current 
collection.  

The Transfer File Types window displays the actual image file types in the collection. In the previous 
example, only DMS files were copied. The following file types can be included:  

• DOC 

• TXT 

• XLS 

• any other file type used within the Exigen Workflow system 

If the Delete origin collection(s) check box is selected, the packaged collection is deleted from the 
Exigen Workflow database after it is packaged. 

To make manual changes to the packaged files, perform the following steps: 

1. Click Advanced.  
The Manual Changes window appears. 



Administrator's Guide, Part 3: Utilities Chapter 11: Publisher Packager Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 136 of 145 

 

Figure 71: Manual Changes window 

2. Specify the files to add to or delete from the final package.  
In this window, you can remove or add files. The Folder drop-down list contains paths to the export 
directory and its subdirectories. A list of files appears in the Files table when a directory is selected.  

3. To remove a file, select the file and click Remove.  
4. To complete the process, click Close. 
5. To add a file, perform the following steps: 

1. Click Add.  
The Find File dialog box appears. 

2. Select the file to be added. 
3. In the Folder drop-down list, specify the directory where the file is to be added.  
4. Select one of the options listed in the following table: 

Add file directory, folder dropdown options 
Option Description 

Etdm Exigen Workflow ERM data files and respective templates. 

Ftx Files required to perform Full Text Search. 

Image All image files in the collection. 

Info All information files, such as message.txt, associated with the 
collection. 



Administrator's Guide, Part 3: Utilities Chapter 11: Publisher Packager Utility 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates.  All rights reserved.   
Exigen Workflow 5.6 Page 137 of 145 

Add file directory, folder dropdown options 
Option Description 

Task Files that are not processed internally by Exigen Workflow, such as Word 
and Excel files. 

Xml Reference files in XML format. These files are used internally and contain 
essential information for opening images. 

The last six directories reside in the root directory specified in step 1 of the package-creation 
process. 

5. To complete the process, click Close. 
The Total Volume value indicates the total size of the files to be copied onto the CD. This value 
changes as files are added to or deleted from the export directory. 

6. If system files, folders, or documents could not be copied into the export directory, to view the 
information, click Log Info. 
The Missing Files window appears. 

 

Figure 72: Missing Files window 

The Missing Runtime Files section lists any files that are necessary to run Exigen Workflow from 
the CD but could not be copied. 

The Missing Document Files section lists the folder numbers and document numbers for any 
documents that could not be copied. 
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7. To open the packlog.txt file in Notepad, click Print.  
This file can be printed.  

8. To exit the Missing Files window, click Close.  
9. To complete the packaging process, click Finish. 

CD Contents 
The export directory contains the following contents: 

Folders    Files 

ETDM autorun.inf d32_enh.dll d32_sms.dll 

Image cabinet.dec d32_eti.dll d32_tifs.dll 

Info cabinet.exe d32_etv.dll d32_view.dll 

Task cabinet.hlp d32_etz.dll d32_word.dll 

Xml d32_bar.dll d32_gbvw.dll d32_xls.dll 

 d32_base.dll d32_gui.dll Exigen 
Publisher 
Cabinet User 
Guide.pdf 

 d32_clr.dll d32_mnr.dll mfc42.dll 

 d32_comp.dll d32_ocr.dll msvcrt.dll 

 d32_conv.dll d32_prfx.dll msvcrtd.dll 

 d32_dlm.dll d32_rus.dll redirect.ini 

 d32_dsp.dll d32_serv.dll sm.dll 

The contents of the export directory can be copied onto a CD or be distributed by other means, such as 
email. 
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Chapter 12: Migration Utility 
This section describes how to migrate document versions from the XML based versioning mechanism 
to the database based versioning mechanism using Migration Utility. 

The following topics are described in this section: 

• Migration Utility Overview 

• Migrating Document Versions 

Migration Utility Overview 
Migration Utility is an application that converts existing XML based document versions used in 
previous Exigen Workflow versions to the new database based document version format. 

Migration Utility must be used only when XML based document versions are already present in the 
system and Exigen Workflow is upgraded to use the new versioning mechanism. 

Migrating Document Versions 
To migrate document versions using Migration Utility, proceed as follows: 

1. In the <Exigen Workflow installation directory>\SYSTEM directory, launch the 
utilvers.exe file. 
The Exigen Workflow login window appears. 

2. Enter the user name and password. 

3. Click Connect. 
The Migration Utility window appears with the Start tab displayed. 
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Figure 73: Selecting the project 

4. In the Project list box, select the project in which document versions must be converted. 

5. Click Next. 
The Setup tab is displayed. 

 
Figure 74: Selecting documents to convert 
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The Number of documents field displays the number of documents in the selected project that 
contain versions that must be migrated. The Imported versions field displays the number of 
versions that are already converted in the project. 

6. To refresh the Number of documents and Imported versions fields, click Refresh. 
7. In the Documents to convert box, select one of the following options as appropriate: 

Document version conversion options 
Option Description 
All documents Converts all document versions in the project. 
Documents that have 
RSN greater than 

Converts all document versions for which the document identifier is greater than 
the document identifier specified in the field. 
This option is useful in cases when the conversion process is interrupted. When 
Migration Utility is launched again, the document identifier of the last processed 
document is automatically entered in the field. 

8. Click Next. 
The Import tab is displayed. 

 
Figure 75: Viewing the conversion progress 

9. To convert document versions in the selected project, click Next. 
Migration Utility converts document versions. The progress of the conversion is displayed in the 
Import tab. 

When all documents are processed, the Finish tab is displayed. 
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Figure 76: Finishing the migration 

If the list in the Finish tab is empty, it means that all documents are processed successfully. If any 
errors are encountered during the conversion, the document identifier of the defective documents 
and corresponding error messages are displayed in the Finish tab. 

10. To convert documents in another project, click Next. 
11. To exit Migration Utility, click Finish. 
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alphabet indexes 
configuring, 36 

C 
cache directories 
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Check Document Utility, 8, 10 

defining search criteria, 14 
definition, 10 
menus and buttons, 18 
specifying distribution settings, 12 
using, 10 

Clear Cache Utility, 8, 20 
definition, 20 
menus and buttons, 24 
using, 20 

control file 
definition, 86 
using, 86 

coordinates 
verifying, 109 

D 
databases 

identifying discrepancies between databases and 
image directories, 42 

maintaining integrity, 8 
performing direct queries, 87 

delimiter indexes 
configuring, 35 

directories 
identifying discrepancies between image directories 

and databases, 42 
DMS images 

valid file names, 46 
document templates 

assigning to projects, 73 
definition, 73 

document versions, 139 
documents 

checking for corrupted, 10 
checking for quick tiles, 10 
checking integrity, 10 
checking locations, 10 
checking number of pages, 10 
cleaning, 63 
configuring distribution, 12 
initiating transfer, 82 
locating documents that are committed and modified, 

20 
preparing to transfer, 82 
removing scan defects, 63 
specifying documents to be checked, 14 

transferring to a different physical location, 82 
viewing erroneous, 37 
viewing remotely, 128 
working with corrupted, 18 

E 
E-Capture Definition Utility, 9 

assigning attributes, 100 
definition, 94 
deleting forms, 112 
deleting mapped fields, 120 
exporting templates, 124 
importing templates, 124 
mapping fields, 114 
mapping forms, 112 
menus and buttons, 96 
modifying forms, 110 
modifying mapped fields, 119 
preliminary steps, 94 
registering forms, 98 
selecting text for capture, 115 
specifying default settings, 117 
starting, 95 
tasks, 94 
testing form definitions, 120 
viewing form texts, 100 
viewing source files, 100 

E-Capture Server 
specifying default settings, 117 
validating and transforming data, 118 

electronic stamps 
creating and maintaining, 49 

Empty Folders Maintenance Utility, 8, 26 
definition, 26 
menus and buttons, 28 
using, 26 

error handling, 117 
Exigen E-Capture Definition Utility. See E-Capture 

Definition Utility 
Exigen Publisher 

definition, 128 
system overview, 128 

Exigen Publisher Packager Utility. See Exigen Publisher 
Exigen Workflow 

related information, 6 
Exigen Workflow utilities 

overview, 8 

F 
fields 

deleting mapped, 120 
mapping, 114 
modifying mapped, 119 

folders 
identifying folders without documents, 26 
processing empty folders, 26 
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form templates 
assigning attributes, 101 
assigning zones, 69 
configuring location and appearance of overlay 

information, 65 
creating, 60 
creating from existing files, 63 
creating from scanned images, 62 
deleting keywords, 106 
modifying keywords, 106 
preparing, 94 
selecting keywords, 103 
selecting signatures, 103, 107 
viewing attributes, 95 
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assigning attributes, 101 
deleting, 112 
deleting keywords, 106 
mapping, 112 
modifying, 110 
modifying keywords, 106 
modifying signatures, 109 
registering, 98 
searching, 97 
selecting keywords, 103 
selecting signatures, 103, 107 
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configuring a full text search, 33 
configuring and maintaining keywords, 29 
configuring indexes, 35 
definition, 29 
menus and buttons, 39 
viewing erroneous documents, 37 

FTS Server 
viewing erroneous documents, 37 

full text search 
configuring, 33 

full text search indexes, 33 
Full Text Search Maintenance Utility, 8. See FTS 

Maintenance Utility 

G 
guide 

audience, 6 
related information, 6 
typographic conventions, 7 

I 
image files 

transferring to a different physical location, 82 
indexes 

configuring for full text search, 35 

K 
keywords 

configuring and maintaining, 29 
deleting, 106 

modifying, 106 
selecting, 104 

M 
Migration Utility, 139 
multipage indicators 

definition, 106 
selecting, 106 

O 
OCR, 55 
Optical Character Recognition. See OCR 
Orphan Utility, 8, 42 

definition, 42 
menus and buttons, 48 
using, 42 

output fields, 114 

P 
printing 

from a native application, 62 
Publisher Cabinet 

definition, 129 
Publisher Collector 

definition, 129 
Publisher Packager 

CD contents, 138 
creating a CD export directory, 130 
creating a copy directory, 133 
definition, 129 
export directory, 138 
finishing the export process, 134 
packaging steps, 130 
preliminary steps, 130 

Publisher Packager Utility, 9. See Exigen Publisher 

Q 
queries 

performing direct, 87 

R 
registered forms 

searching, 97 

S 
scanning defects 

removing, 63 
search 

output fields, 115 
signature zones 

definition, 70 
signatures 

deleting, 109 
modifying, 109 
selecting, 107 

Stamp Management Utility, 9, 49 
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menus and buttons, 53 
using, 49 

stamps 
creating, 52 
managing, 49 
viewing information, 50 

stopwords list 
maintaining, 30 

T 
telephone indexes 

configuring, 36 
template forms 

deleting, 112 
mapping, 112 
modifying, 110 

Template Management Utility, 9, 55 
assigning document templates to projects, 73 
assigning zones to templates, 69 
configuring location and appearance of overlay 

information, 65 
creating a form template from an existing file, 63 
creating a template, 60 
defining OCR and overlay zones, 64 
definition, 55 
menus and buttons, 76 
saving zones to a file, 64 
scanning a new form, 62 
using, 55 

templates 
assigning to projects, 55 

creating, 55 
exporting, 124 
importing, 126 

Transfer Server 
running, 88 

Transfer Utility, 9, 82 
definition, 82 
identifying files for transfer, 86 
menus and buttons, 92 
opening, 83 
preparing to transfer documents, 82 
running Transfer Server, 88 
using, 82 

typographic conventions, 7 

U 
utilities 

definition, 8 

V 
versions, 139 

Z 
zones 

adding to templates, 66, 70 
defining OCR, 64 
defining overlay, 64 
saving to a file, 64 
signature, 70 
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